Você está na página 1de 6

ESCUELA POLITÉCNICA NACIONAL

INGENIERÍA MECÁNICA
NOMBRE: DENNIS TOMALO GUACHAMIN GRUPO: 3 ASIGNATURA:
FECHA: 10/05/2017
1. Diseñar un algoritmo que visualice y sume la serie de números 3, 6, 9,12..., 99 (del 3 al 99
en múltiplos de 3).
Pseudocodigo:
Proceso sin_titulo
A<-3
B<-6
Mientras B<=99
A<-A+B
B<-B+3
Escribir B-3,"------->",A
FinMientras
Escribir "LA SUMA DE LOS MULTIPLOS DE 3 DESDE 3 A 99= ",A
FinProceso

Pseudocódigo
Diagrama de flujo

El programa consiste en un programa el cual tiene un valor inicial 3 que se lo denomino A


y un segundo llamado B que corresponde a un valor de 6, lo que el programa hace es
realizar una suma entre el primero y segundo A+B y ese resultado es la nueva variable A,
mientras que cada resultado se le va agregando a la variable B el valor de 3 y así nos
entrega la suma menores a 100 peor múltiplos de 3

2. Escribir un algoritmo para calcular y visualizar el perímetro y el área de un círculo de


radio dado.
Pseudocodigo:
Proceso sin_titulo
Repetir
Escribir "CÁLCULO DE ÁREA Y PERÍMETRO DE UN CIRCULO"
Escribir "INGRESAR RADIO"
Leer RADIO
P<-3.14159265
A<-2*P*RADIO
Escribir "EL PERIMETRO ES= ",A
B<-P*RADIO*RADIO
Escribir "EL ÁREA ES= ",B
Escribir "DESEA INGRESAR MÁS VALORES? S/N"
Leer PREGUNTA
Hasta Que PREGUNTA="N"
FinProceso

Pseudocódigo

Diagrama de flujo
El programa no es tan complicado ya que solo nos pide ingresar un valor al radio y este
nos calculará la superficie y el perímetro, esto gracias a las constantes ingresadas como P
que representa al número de Pi, cabe recalcar que el programa nos da la opción de realizar
una nueva medida y volver a repetir hasta que tengamos como respuesta la letra N

3. Dividir un número entero por otro, escribiendo un mensaje donde pida al usuario ingresar
nuevamente el denominador en caso de que sea 0.
Pseudocodigo:
Proceso sin_titulo
Repetir
Escribir "CÁLCULO DE DIVISIONES"
Escribir "INGRESAR NUMERADOR"
Leer NUMERADOR
Escribir "INGRESAR DENOMINADOR"
Leer DENOMINADOR
Si DENOMINADOR <>0 Entonces
A<-NUMERADOR/DENOMINADOR
Escribir "EL RESULTADO ES= ",A
Sino
Repetir
Escribir "INGRESE OTRO VALOR DISTINTO DE
CERO"
Leer VALOR
Hasta Que VALOR<>0
B<-NUMERADOR/VALOR
Escribir "EL RESULTADO ES= ",B
Fin Si
Escribir "DESEA INGRESAR OTRO VALOR? S/N"
Leer PREGUNTA
Hasta Que PREGUNTA="N"
FinProceso

Pseudocódigo

El programa nos permite calcular cualquier tipo de división, en el inicio el programa nos pide que
ingresemos valores al numerador y al divisor y este realiza la operación de la división, pero este
programa tiene una restricción ya que si el valor del denominador es 0 entonces el programa nos
pedirá que ingresemos un nuevo valor distinta de 0 ya que la división para 0 no esta definida, al
igual que en el programa anterior este nos muestra la opción de seguir calculando hasta que la
respuesta sea N.
Diagrama de flujo