Você está na página 1de 5

Lista 01 – Estruturas de Repetição

Enquanto

1. Faça um programa que conte de 1 a 10 usando o laço enquanto.


Algoritmo " Lista01_questao01"
Var
cont: inteiro
Inicio
cont <- 0
enquanto cont <= 10 faca
cont <- cont + 1
escreval(cont)
fimenquanto
Fimalgoritmo

2. Escrever um algoritmo que gera e escreve os números ímpares entre 100 e 200 usando o
enquanto.
Algoritmo "Lista01_questao02"
Var
cont: inteiro
Inicio
cont <- 100
enquanto cont < 200 faca
se cont mod 2 = 1 entao
escreval(cont)
fimse
cont <- cont + 1
fimenquanto
Fimalgoritmo

3. Faça um algoritmo que escreva na tela os números de um número inicial a um número


final. Os números inicial e final devem ser informados pelo usuário. Use a estrutura de
repetição enquanto.
Algoritmo "Lista01_questao03"
Var
numeroI, numeroF: inteiro
Inicio
escreval("Digite um numero inicial")
leia(numeroI)
Escreval("Digite um numero final")
leia(NumeroF)

// testando se o número final é maior que o inicial


se numeroF <= numeroI entao
repita
Escreval("O numero final deve ser MAIOR que o número inicial. Por favor, Tente
novamente.")
leia(NumeroF)
ate numeroF > numeroI
fimse

// escrevendo os números entre o número inicial e final


enquanto numeroI <= numeroF faca
escreval(numeroI)
numeroI <- numeroI + 1
fimenquanto
Fimalgoritmo

4. Escrever um algoritmo que imprima a tabuada de multiplicação de um número informado


pelo usuário.
Algoritmo "Lista01_questao04"
Var
num, cont, resposta: inteiro
Inicio
cont <- 0
escreval("Digite um numero.")
leia(num)
enquanto cont <= 10 faca
resposta <- num * cont
escreval(num," x ",cont," = ",resposta)
cont <- cont + 1
fimenquanto
Fimalgoritmo

Repita
5. Faça um programa em que o usuário digite diversos números positivos. Se digitar um
número negativo o programa termina.
Algoritmo "Lista01_questao05"
var
num: inteiro
inicio
repita
Escreval("Digite um numero maior que zero. (Caso digite um néumro negativo, o
programa será encerrado).")
leia(num)
ate num < 0
fimalgoritmo

6. Escreva um programa que lê o sexo de uma pessoa. O sexo deverá ser com o tipo de dado
caractere o programa deverá aceitar apenas os valores “M” ou “F”.
Algoritmo "Lista01_questao06"
var
sexo: caracter
inicio
repita
escreval("Digite o sexo (M ou F): ")
leia(sexo)
ate ((sexo = "M") ou (sexo = "F"))
escreval("Sexo informado é:", sexo)
fimalgoritmo

7. Escreva um programa que leia dois valores reais. Ambos valores deverão ser lidos até que
o usuário digite um número no intervalo de 1 a 100. Apresentar a soma dos dois valores
lidos.
Algoritmo "Lista01_questao07"
var
num1, num2: real
inicio
repita
escreval("Digite dois valores reais: ")
leia(num1)
leia(num2)
escreval(num1, " + ", num2, " = ", num1 + num2)
ate ((num1 >= 1) e (num1 <= 100) ou (num2 >=1) e (num2 <= 100))
fimalgoritmo

8. Faça um programa em que o usuário digite 2 valores e se a soma deles for maior que 15 o
programa encerra, caso contrário, repete.
Algoritmo "Lista01_questao08"
var
num1, num2, total: inteiro
inicio
repita
escreval("Digite o 1º valor:")
leia(num1)
escreval("Digite o 2º valor:")
leia(num2)
total <- num1 + num2
escreval("soma do 1º valor coom o 2º valor é: ", total)
ate total > 15
fimalgoritmo

9. Faça um programa que peça ao usuário para digitar a melhor escola de Bacabal. O
programa só termina se ele digitar IFMA.
Algoritmo "Lista01_questao09"
Var
escola:caracter
Inicio
repita
escreval("Qual melhor escola de Bacabal:")
leia(escola)
escreval("Resposta errada. Tente novamente :P ")
ate (escola = "IFMA")
Fimalgoritmo
Para
10. Faça um programa que escreva de 50 a 100.
Algoritmo "Lista01_questao10"
var
i: inteiro
inicio
para i de 50 ate 100 faca
escreval(i)
fimpara
fimalgoritmo

11. Faça um programa que escreva de 30 a 50 contando de 2 em 2.


Algoritmo "Lista01_questao11"
var
i:inteiro
inicio
para i de 30 ate 50 passo 2 faca
escreval(i)
fimpara
fimalgoritmo

12. Faça um programa que escreva de 80 a 40, em ordem decrescente de 5 em 5.


Algoritmo "Lista01_questao12"
var
i: inteiro
inicio
para i de 80 ate 40 passo -5 faca
escreval(i)
fimpara
fimalgoritmo

13. Escreva um programa que, lido um número, calcule e informe o seu fatorial. Ex.: 5!= 5 * 4 *
3 * 2 * 1 = 120.
Algoritmo "Lista01_questao13"
var
n,i,fatorial: inteiro
inicio
escreval("Digite um número:")
leia(n)
fatorial <- n
para i de n ate 2 passo -1 faca
fatorial <- fatorial * (i - 1)
fimpara
escreval("O fatorial de ",n," é :", fatorial)
fimalgoritmo

Acumuladores
14. Escrever um programa de computador que leia 10 números inteiros e, ao final, apresente a
soma de todos os números lidos;
Algoritmo "Lista01_questao14"
var
i, soma, num: inteiro
inicio
soma <- 0
para i de 1 ate 10 faca
escreval("Digite um numero")
leia(num)
soma <- soma + num
fimpara
escreva("O valor da soma é: ", soma)
fimalgoritmo

15. Faça o mesmo que antes, porém, ao invés de ler 10 números, o programa deverá ler e
somar números até que o valor digitado seja zero ( 0 ).
Algoritmo "Lista01_questao15"
var
i, soma, num: inteiro
inicio
num <- 1
soma <- 0
enquanto num <> 0 faca
escreval("Digite um numero:")
leia(num)
soma <- soma + num
fimenquanto
escreval("O resultado da soma dos numeros digitados é: ", soma)
fimalgoritmo

Você também pode gostar