Você está na página 1de 29

2017

LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO

SEMANA 1

Introdução a Programação: conceitos básicos; construção de algoritmos: o fluxogramas e


pseudocódigos

ALGORITMO

Mas o que é Algoritmo? É simplesmente uma “receita” para executarmos uma tarefa ou
resolver algum problema. E como toda receita, um algoritmo também deve ser finito. Se
seguirmos uma receita de bolo corretamente, conseguiremos fazer o bolo. A computação
utiliza muito esse recurso, então se você pretende aprender programação, obviamente
deve saber o que é algoritmo.

Exemplos:

Imagine a seguinte situação:

Situação: Dirigir até uma lanchonete e almoçar.

O que é preciso fazer para realizá-la?

 1º Passo: Saia de casa.


 2º Passo: Entre no carro.
 3 º Passo: Se a garagem estiver aberta, saia. Senão, abra-a e saia.
 4 º Passo: Dirija até o local desejado.
 5º Passo: Se chegou, estacione o carro. Senão, continue até chegar e
estacionar.
 6 º Passo: Se estacionou, retire a chave da ignição e saia do carro.
 7 º Passo: Tranque o carro e dirija-se à lanchonete.
 8 º Passo: Se a lanchonete estiver aberta, entre e dirija-se ao caixa.
Senão, volte para o carro. Procure outra lanchonete aberta, entre e
dirija-se ao caixa.
 9º Passo: Faça o pedido e efetue o pagamento.
 10º Passo: Aguarde.
 11º Passo: Se o número de seu pedido for chamado, dirija-se ao caixa e
pegue sua refeição. Senão, aguarde ser chamado e pegue-a.
 12 º Passo: Procure um lugar para sentar e coma.
 13 º Passo: Se estiver satisfeito, jogue o resto na lixeira. Senão, faça
outro pedido e coma.
 14º Passo: Saia da lanchonete e dirija-se ao carro.
 15 º Passo: Entre, ponha o sinto de segurança e vá para casa.

Você conseguiu almoçar?

Viu como você usa algoritmos na sua vida? Agora pense desde quando você
acorda até quando você volta a dormir. Quantas tarefas necessitam de suas
decisões? Com certeza muitas. Lógico que não paramos para ver a vida
detalhadamente, mas quando percebemos que o que fazemos faz parte de um
grande algoritmo de decisões, escolhas, entendemos como funciona um
algoritmo computacional.
LÓGICA DE PROGRAMAÇÃO

Abaixo estão listados alguns passos importantes para a escrita de um algoritmo


computacional:

 Preste atenção à ordem lógica da execução das tarefas;


 Lembre-se de que ele deve ter um início e fim;
 Ele deve ser completo;
 Deve ter um alto nível de detalhes;
 Cada tarefa é uma instrução, assim, defina-a bem.

Agora faremos juntos alguns algoritmos.

Fazer café
LÓGICA DE PROGRAMAÇÃO

Semana 2

Fazer suco de laranja

Atividade para casa:

Elaborar algoritmo para tomar banho

Entendemos então que :


LÓGICA DE PROGRAMAÇÃO

Algoritmo exemplo

Elaborar um algoritmo que permita ler dois números e somá-los


LÓGICA DE PROGRAMAÇÃO

Bom entendendo que o pseudocódigo será os passos que seu programa irá executar ou as
tarefas que irá fazer, assim usaremos um apoio para auxiliá-los neste entendimento. Este
apoio será o programa VisuaG.

O VisuAlg é um programa que interpreta uma linguagem de programação bem


semelhante aos pseudocódigos utilizados para aprender Lógica de Programação, a
representação que chamamos de Português Estruturado ou “Portugol”.
A linguagem do VisuAlg permite apenas um comando por linha,não é preciso colocar
ponto e vírgula no final das frases.
Todas as palavras-chave do VisuAlg foram implementadas sem acentos, cedilha, etc.
Portanto, o tipo de dados lógico é definido como logico, o comando se..então..senão é
definido como se..entao..senao, e assim por diante. O VisuAlg também não distingue
maiúsculas e minúsculas no reconhecimento de palavras-chave e nomes de variáveis.
Ou seja, para o programa, “ABC” é o mesmo que “abc”.

Formato Código e Inclusão de Comentários

O formato básico do nosso pseudocódigo é o seguinte:


LÓGICA DE PROGRAMAÇÃO

algoritmo "semnome"

// Função :

// Autor :

// Data :

// Seção de Declarações

inicio

// Seção de Comandos

Fimalgoritmo

A primeira linha é composta pela palavra-chave algoritmo seguida do seu nome


delimitado por aspas duplas. Este nome será usado como título nas janelas de leitura
de dados. A seção que se segue é a de declaração de variáveis, que termina com a
linha que contém a palavra-chave inicio. Deste ponto em diante está a seção de
comandos, que continua até a linha em que se encontre a palavra-chave fimalgoritmo.
Esta última linha marca o final do pseudocódigo: todo texto existente a partir dela é
ignorado pelo interpretador.
O VisuAlg permite a inclusão de comentários: qualquer texto precedido de "//" é
ignorado, até se atingir o final da sua linha. Por este motivo, os comentários não se
estendem por mais de uma linha: quando se deseja escrever comentários mais longos,
que ocupem várias linhas, cada uma delas deverá começar por "//".

Comandos de Saída de Dados

escreva (<lista-de-expressões>)
Escreve o conteúdo de cada uma das expressões que compõem <lista-de-expressões>.
As expressões dentro desta lista devem estar separadas por vírgulas; depois de serem
avaliadas, seus resultados são impressos na ordem indicada.
É possível especificar o número de espaços no qual se deseja escrever um determinado
valor. Por exemplo, o comando escreva(x:5) escreve o valor da variável x em 5 espaços,
alinhado-o à direita. Para variáveis reais, pode-se também especificar o número de
casas fracionárias que serão exibidas. Por exemplo, considerando y como uma variável
real, o comando escreva(y:6:2)escreve seu valor em 6 espaços colocando 2 casas
decimais.

escreval (<lista-de-expressões>).
Idem ao anterior, com a única diferença que pula uma linha em seguida.
LÓGICA DE PROGRAMAÇÃO

Comando de Entrada de Dados


leia (<lista-de-variáveis>)
Recebe valores digitados pelos usuário, atribuindo-os às variáveis cujos nomes estão
em <lista-de-variáveis> (é respeitada a ordem especificada nesta lista).

Veja no exemplo abaixo o resultado:


algoritmo "exemplo 1"
var x: inteiro;
inicio
leia (x)
escreva (x)
fimalgoritmo

O comando de leitura acima irá exibir uma janela como a que se vê ao lado, com a
mensagem padrão: "Entre com o valor de <nome-de-variável>"
Se você clicar em Cancelar ou teclar Esc durante a leitura de dados, o programa será
imediatamente interrompido.

Bom, como você percebeu para ser efetuado o calculo é lido um dado pelo computador. Este
dado possui características diferentes que são lidos pelo computador.
LÓGICA DE PROGRAMAÇÃO

Semana3
LÓGICA DE PROGRAMAÇÃO

IMPORTANTE
LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO
LÓGICA DE PROGRAMAÇÃO

Alguns exemplos: sem variáveis


Faça um algoritmo que exiba seu nome na tela

algoritmo "algoritmo1"

// Função :

// Autor :

// Data : 7/15/2010

// Seção de Declarações

var

inicio

escreva("Meu nome é Raquel:" )

// Seção de Comandos

Fimalgoritmo

Faça um algoritmo que exiba uma saudação na tela e na linha em seguida escreva a data
de hoje.

algoritmo "algoritmo2"

// Função :

// Autor :

// Data : 7/15/2010

// Seção de Declarações

var

inicio

escreval("Bom dia")

escreva("Hoje é dia 15/07/2010:")

// Seção de Comandos

Fimalgoritmo
LÓGICA DE PROGRAMAÇÃO

Exemplo com variáveis

algoritmo "algoritmo3"

// Função :

// Autor :

// Data : 7/15/2010

// Seção de Declarações

var

x:inteiro

inicio

// Seção de Comandos

escreva("Entre com um valor para x:")

leia(x)

escreva("O valor de x e",x)

fimalgoritmo

Atividades em sala
Faça um algoritmo que solicite o nome e a idade de uma pessoa e exiba a tela.

Faça um algoritmo que solicite ao usuário o preço de um produto, sua quantidade e exiba
o total a pagar por este produto.

Faça um algoritmo que solicite ao usuário dois números inteiros e exiba o valor do
produtos destes dois numeros.

Treinando

1) Faça um algoritmo que solicite o nome e a idade de uma pessoa e exiba seu nome e
quantos dias ela viveu.

2) Faça um algoritmo que solicite dois números e exiba sua soma

3) Faça um algoritmo que solicite o numero de filhos de um funcionário e exiba o valor do


salário família. Sabe-se que para cada filho é pago 23,40.

4) Faça um algoritmo que receba as duas notas de um aluno e exiba sua média.
LÓGICA DE PROGRAMAÇÃO

5) Faça um algoritmo que solicite o nome, idade e sexo(F ou M) e exiba estes dados na
tela.

6) Faça um algoritmo que solicite um número, e exiba o resto da divisão deste numero por

7) Faça um algoritmo que solicite dois valores inteiros (A e B) para o usuário e efetue a
troca entre as variáveis .

8)Faça um algoritmo que solicite a quantidade de pães e de leite e exiba o total a pagar.
Considere que cada pão custa 0,40 e que o leite custe 2,00.

9)Faça um algoritmo que solicite o valor da temperatura em Celsius e efetue a conversão


para fahrenheit, para efetuar a conversão considere a seguinte fórmula:

Tf=(9*Tc+160)/5

10) Faça um algoritmo que solicite o saldo atual de uma conta, o valor de débitos , o valor
de créditos e exiba o saldo final.

Extra
1-Faça um algoritmo que receba um número, calcule e imprima o seu sucessor e o seu
antecessor;

2. O Preço de um automóvel é calculado pela soma do preço de fábrica, mais o preço dos
impostos (45% do preço de fábrica), mais o percentual dos vendedores (28% do preço de fábrica).
Faça um algoritmo que imprima o nome do automóvel e seu preço final.

3. Elabore um algoritmo que faça a leitura de dois números reais e calcule as operações de soma,
subtração, divisão e multiplicação a partir dos valores lidos e mostre os resultados;

4. Faça um algoritmo que receba 4 números calcule e imprima a soma e a média dos números
lidos;
5. Faça um algoritmo que receba o salário mínimo atual e o valor do salário de um funcionário.
Calcule e mostre a quantidade de salários mínimos que este funcionário recebe.

6. Elabore um algoritmo que receba o valor de um produto e o seu percentual de desconto.


Calcule e mostre o preço do produto após o desconto.

7. Desenvolva um algoritmo que receba os valores dos catetos de um triangulo, calcule e mostre
o valor da hipotenusa (hipotenusa = raiz quadrada (cateto1+ cateto2).

8. Faça um algoritmo que receba o número de horas trabalhadas e o valor do salário mínimo.
Calcule e mostre o salário a receber seguindo as regras abaixo:

a. A hora trabalhada vale a metade do salário mínimo;

b. O salário bruto equivale ao número de horas trabalhadas multiplicado pelo valor da hora
trabalhada

c. O imposto equivale a 3% do salário bruto;


LÓGICA DE PROGRAMAÇÃO

d. O salário a receber equivale ao salário bruto menos o imposto.

9. João recebeu seu salário e precisa pagar duas contas que não foram pagas, como as contas
estão atrasadas, João terá que pagar 2% de multa sobre cada conta. Desenvolva um algoritmo
que calcule e mostre quanto restará do pagamento de João.
LÓGICA DE PROGRAMAÇÃO

1. Faça um algoritmo que receba um numero e se este numero for maior que 10 exiba a
mensagem “Numero digitado maior que 10”

algoritmo "algoritmo11"

// Função :

// Autor :

// Data : 7/15/2010

// Seção de Declarações

var

numero:inteiro

inicio

escreva("Entre com um numero:")

leia (numero)

se (numero >10 ) entao

escreva ("O numero digitado é maior que 10")

// Seção de Comandos

fimse

fimalgoritmo

2. Faça um algoritmo que receba um número e se ele for par exibir a mensagem “Número
par”.

algoritmo "algoritmo13"

// Função :

// Autor :

// Data : 7/15/2010

// Seção de Declarações

var

numero:inteiro

inicio

escreva("Entre com um numero:")

leia (numero)
LÓGICA DE PROGRAMAÇÃO

se (numero%2=0) entao

escreva ("Numero par" )

// Seção de Comandos

fimse

fimalgoritmo
Exercícios -

1) Faça um algoritmo que receba a idade de uma pessoa e se a idade for maior de 18 exibir
a mensagem “Você e maior de idade”

2) Faça um algoritmo que receba um numero inteiro, se este numero for maior que 50
exibir a terça parte dele. (numero/3).

3)Faça um programa que solicite um numero e se este numero estiver entre 20 e 90 exibir
a mensagem “ Este numero é menor que 90” . Dica utilize o operador E.

4) Faça um programa que receba um numero e exiba a mensagem para saber se ele é
impar. Dica: utilize o operador NÃO.

5) Faça um algoritmo que receba dois números e exiba o valor do maior entre eles.
LÓGICA DE PROGRAMAÇÃO

Exemplos

Faça um algoritmo que receba dois números se ambos forem maior que 10 calcule e
mostre sua soma senão exiba a multiplicação entre eles.

algoritmo "algoritmo14"

// Função :

// Autor :

// Data : 7/15/2010
LÓGICA DE PROGRAMAÇÃO

// Seção de Declarações

var

n1,n2,soma,mult:inteiro

inicio

escreva("Entre com um numero:")

leia (n1)

escreva("Entre com um numero:")

leia (n2)

se (n1>10) e (n2>10) entao

soma<-(n1+n2)

escreva ( "A soma entre os numeros e", soma)

senao

mult<-(n1*n2)

escreva ( "A multiplicação entre os numeros e", mult)

fimse

fimalgoritmo

Faça um algoritmo que receba um numero e exiba uma mensagem para saber se ele é
positivo, negativo ou nulo.

algoritmo "algoritmo15"

// Função :

// Autor :

// Data : 7/15/2010

// Seção de Declarações

var

n1:inteiro

inicio

escreva("Entre com um numero:")

leia (n1)

se (n1>0) entao
LÓGICA DE PROGRAMAÇÃO

escreva ( "O numero ", n1, " é maior que 0" )

senao

se (n1<0) entao

escreva ( "O numero ", n1, " é menor que 0" )

senao

escreva ( "o numero é nulo")

fimse

fimse

fimalgoritmo