Você está na página 1de 4

UNIVERSIDADE ESTADUAL DO CEARÁ - UECE

UNIVERSIDADE ABERTA DO BRASIL – UAB


CURSO DE LICENCIATURA EM COMPUTAÇÃO

Disciplina: Algoritmos e Programação

ATIVIDADE PRÁTICA
Unidades abordadas: 1 e 2
Pontuação máxima permitida: 20 pontos (acrescidos na média final das atividades)

1. Faça o algoritmo que, dadas três dimensões (A, B e C), faça o seguinte:

a) Verifique se as três dimensões formam um triângulo. Caso não formem,


apresentar uma mensagem para o usuário.

Obs.: Três dimensões conseguem formar um triângulo, quando cada uma


dessas dimensões, individualmente, for menor que a soma das outras
duas dimensões.

b) Caso as dimensões formem um triângulo, apresentar qual tipo de


triângulo elas formam. Sabe-se que:

o Triângulo do tipo equilátero – possui os três lados iguais;

o Triângulo do tipo isósceles – possui dois lados iguais;

o Triângulo do tipo escaleno – possui os três lados diferentes.

Resposta

algoritmo "Triângulo_Isaac"

var a,b,c : real

inicio

escreval("Digite o primeiro número")

leia(a)

escreval("Digite o segundo número")


leia(b)

escreval("Digite o terceiro número")

leia(c)

se (a<b+c) e (b<a+c) e (c<a+b) entao

se (a=b) e (a=c) entao

escreval("Estas medidas podem formar um triângulo EQUILÁTERO")

senao

se (a<>b) e (a<>c) e (b<>c) entao

escreval("Estas medidas podem formar um triângulo ESCALENO")

senao

escreval("Estas medidas podem formar um triângulo ISÓSCELES")

fimse

fimse

senao

escreval("Estas medidas não podem formar um triângulo")

fimse

Fimalgoritmo

2. Faça o algoritmo para calcular e apresentar o valor a ser pago pelo período de
estacionamento do automóvel (PAG). O usuário entra com os seguintes dados:
hora (HE) e minuto (ME) de entrada, hora (HS) e minuto (MS) de saída. Sabe-
se que esse estacionamento cobra hora cheia, ou seja, se passar um minuto,
ele cobra a hora inteira. O valor cobrado pelo estacionamento é:

o R$ 5,00 para uma hora de estacionamento;

o R$ 8,00 para duas horas de estacionamento


o R$ 2,00 por hora adicional (acima de duas horas).

Resposta

algoritmo "Estacionamento_Isaac"

var he, me, hs, ms: inteiro

var pag, t, tmod, tpag: real

inicio

escreval("escreva a hora de entrada")

leia (he)

escreval("escreva o minuto de entrada")

leia (me)

escreval("escreva a hora de saída")

leia (hs)

escreval("escreva o minuto de saída")

leia (ms)

t <- (hs*60+ms-(he*60+me)) DIV (60)

tmod<- (hs*60+ms-(he*60+me)) mod (60)

se (tmod <> 0) entao

tpag<-t+1

senao

tpag<-t

fimse

escolha tpag
caso 1

pag<-5

caso 2

pag<-8

outrocaso

pag<- (tpag-2)*2+8

fimescolha

escreval(" O valor pago deve ser de: ",pag)

fimalgoritmo

3. Faça um algoritmo que leia um vetor de inteiros de 10 posições:

A) Informe se existe algum número repetido e que número é esse

B) Informe quantos números menores do que 0 existem no vetor

C) Informe a soma de todos os números do vetor

D) Imprima o vetor em ordem inversa

E) Ordene o vetor de menor para o maior número

Você também pode gostar