Você está na página 1de 16

SETTINGAN

NAMA INTERFACE WAN INTERNET-1

SETTINGAN DARI ISP SATUAN


DOWNLOAD DARI ISP 40 M
UPLUAD DARI ISP 16 M

SETTINGAN DOWNLOAD SATUAN


HOTSPOT&CLIEN RUMAHAN DOWNLOAD 30 M
USER HOTSPOT DOWN 30 M
CLIEN RUMAHAN DOWN 30 M

SETTINGAN UPLUAD SATUAN


HOTSPOT&CLIEN RUMAHAN UPLUAD 8 M
USER HOTSPOT UP 8 M
CLIEN RUMAHAN UP 8 M

SETTINGAN GAME OTOMATIS DI KALKULASI DARI ISP SATUAN


1.SELAIN PORT UMUM RINGAN GAME ONLINE DOWN 10 M
2.SELAIN PORT UMUM RINGAN GAME ONLINE UP 8 M
3.PAKET ICMP 10 M
IP LOCAL

WAJIB 192 168 60 0/24


192 168 61 0/24
192 168 71 0/24
192 168 51 0/24
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
/ip firewall mangle
add action=mark-connection chain=prerouting comment="port umum" dst-port=\
21,22,23,81,88,5050,843,182,8777,1935,53,8000-8081,443,80 in-interface=\
!INTERNET-1 new-connection-mark="PORT UMUM" passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting dst-port=\
67,5228,35915,39397,110,5060,6666,3478,66,53 in-interface=!INTERNET-1 \
new-connection-mark="PORT UMUM" passthrough=yes protocol=tcp
add action=mark-connection chain=prerouting connection-state="" dst-port=\
67,5228,35915,39397,110,5060,6666,3478,66,53 in-interface=!INTERNET-1 \
new-connection-mark="PORT UMUM" passthrough=yes protocol=udp
add action=mark-connection chain=prerouting dst-port=\
21,22,23,81,88,5050,843,182,8777,1935,53,8000-8081,443,80 in-interface=\
!INTERNET-1 new-connection-mark="PORT UMUM" passthrough=yes protocol=udp
add action=add-dst-to-address-list address-list="IP GAME ONLINE" \
address-list-timeout=1s chain=prerouting comment=\
"port selain umum ringan(game)" connection-mark="!PORT UMUM" \
dst-address-list="!IP LOCAL" in-interface=!INTERNET-1 protocol=tcp
add action=add-dst-to-address-list address-list="IP GAME ONLINE" \
address-list-timeout=1s chain=prerouting connection-mark="!PORT UMUM" \
dst-address-list="!IP LOCAL" in-interface=!INTERNET-1 protocol=udp
add action=mark-connection chain=prerouting dst-address-list="IP GAME ONLINE" \
in-interface=!INTERNET-1 new-connection-mark="PORT SELAIN PORT UMUM ( GAME )" \
passthrough=yes
add action=mark-packet chain=forward connection-mark=\
"PORT SELAIN PORT UMUM ( GAME )" in-interface=INTERNET-1 new-packet-mark=\
"PORT SELAIN PORT UMUM(GAME) DOWN" passthrough=yes
add action=mark-packet chain=forward connection-mark=\
"PORT SELAIN PORT UMUM ( GAME )" new-packet-mark=\
"PORT SELAIN PORT UMUM(GAME) UPLUAD" out-interface=INTERNET-1 passthrough=yes
add action=mark-connection chain=prerouting comment=icmp new-connection-mark=\
ICMP passthrough=yes protocol=icmp
add action=mark-packet chain=forward connection-mark=ICMP new-packet-mark=\
"ICMP DOWN" passthrough=yes
add action=add-dst-to-address-list address-list="IP BUKAN PORT UMUM" \
address-list-timeout=1s chain=prerouting comment="selain umum(berat)" \
connection-mark="!PORT UMUM" connection-rate=200k-100M dst-address-list=\
"!IP LOCAL" in-interface=!INTERNET-1
add action=mark-connection chain=prerouting dst-address-list=\
"IP BUKAN PORT UMUM" in-interface=!INTERNET-1 new-connection-mark=BERAT \
passthrough=yes

/queue tree
add max-limit=30M name="7.HOTSPOT&CLIEN RUMAHAN DOWNLOAD" parent=global
add max-limit=8M name="8.HOTSPOT&CLIEN RUMAHAN UPLUAD" parent=global
add max-limit=10M name="1.SELAIN PORT UMUM RINGAN GAME ONLINE DOWN" \
packet-mark="PORT SELAIN PORT UMUM(GAME) DOWN" parent=global priority=1 \
queue=pcq-download-default
add max-limit=8M name="2.SELAIN PORT UMUM RINGAN GAME ONLINE UP" \
packet-mark="PORT SELAIN PORT UMUM(GAME) UPLUAD" parent=global priority=1 \
queue=pcq-upload-default
add max-limit=30M name="1.USER HOTSPOT DOWN" parent=\
"7.HOTSPOT&CLIEN RUMAHAN DOWNLOAD" queue=pcq-download-default
add max-limit=8M name="1.USER HOTSPOT UP" parent=\
"8.HOTSPOT&CLIEN RUMAHAN UPLUAD" queue=pcq-upload-default
add max-limit=10M name="3.PAKET ICMP" packet-mark="ICMP DOWN" parent=global \
priority=1 queue=pcq-download-default

add max-limit=30M name="2.CLIEN RUMAHAN DOWN" parent=\


"7.HOTSPOT&CLIEN RUMAHAN DOWNLOAD" queue=pcq-download-default
add max-limit=8M name="2.CLIEN RUMAHAN UP" parent=\
"8.HOTSPOT&CLIEN RUMAHAN UPLUAD" queue=pcq-upload-default

/system scheduler
add name=deluser-startup on-event="/ip firewall mangle remove [find where comm\
ent=\"user_hotspot\"]\r\
\n/queu tree remove [find where comment=\"user_hotspot\"]" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-time=startup

/ip firewall address-list


add address=192.168.60.0/24 list="IP LOCAL"
add address=192.168.61.0/24 list="IP LOCAL"
add address=192.168.71.0/24 list="IP LOCAL"
add address=192.168.51.0/24 list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
add address=... list="IP LOCAL"
SETTINGAN PROFIL HOTSPOT
DOWNLOAD PER USER 800K
UPLUAD PER USER 800K
:local datetime [/system clock get date];
:local timedate [/system clock get time];
[/ip firewall mangle add action=mark-packet chain=forward comment=user_hotspot connection-mark=\ "!PORT SELAIN PORT U
[/ip firewall mangle add action=mark-packet chain=forward comment=user_hotspot connection-mark=\ "!PORT SELAIN PORT U
[/queue tree add max-limit=800K name=("$user-hotspot"." ->down "."$address") comment="user_hotspot" packet-mark=("pa
[/queue tree add max-limit=800K name=("$user-hotspot"." ->upluad "."$address") comment="user_hotspot" packet-mark=("p

/queue tree remove [find packet-mark=("paket-down"."$address")] ;


/queue tree remove [find packet-mark=("paket-up"."$address")] ;
/ip firewall mangle remove [find where new-packet-mark=("paket-down"."$address")]
/ip firewall mangle remove [find where new-packet-mark=("paket-up"."$address")]
\ "!PORT SELAIN PORT UMUM ( GAME )" dst-address="$address" in-interface=\ INTERNET-1 new-packet-mark=("paket-down"."$address")
\ "!PORT SELAIN PORT UMUM ( GAME )" new-packet-mark=("paket-up"."$address") out-interface=\ INTERNET-1 packet-mark="!ICMP DOW
spot" packet-mark=("paket-down"."$address") parent="1.USER HOTSPOT DOWN"];
otspot" packet-mark=("paket-up"."$address") parent="1.USER HOTSPOT UP"];
paket-down"."$address") packet-mark="!ICMP DOWN" \ passthrough=yes];
packet-mark="!ICMP DOWN" passthrough=yes src-address=\ "$address"];
NO NAMA CLIEN IP DOWN UP
1 PA-UDIN 192.168.61.8 2M 900K
2 UDIN 192.168.61.9 3M 1M
3 EDOT 192.168.71.31 1M 750K
4 ROBY 192.168.61.6 1M 750K
5 YENI 192.168.61.7 1M 750K

Nama clien tidak boleh pakai spasi


gantikan spasi dengan format berikut ini :
_ dan -
/ip firewall mangle
add action=mark-packet chain=forward comment=PA-UDINDOWN connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" dst-address=192.168.61.8 in-interface=\
INTERNET-1 new-packet-mark=PA-UDINDOWN packet-mark="!ICMP DOWN" \
passthrough=yes
add action=mark-packet chain=forward comment=PA-UDINUP connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" new-packet-mark=PA-UDINUP out-interface=\
INTERNET-1 packet-mark="!ICMP DOWN" passthrough=yes src-address=\
192.168.61.8

/queue tree
add max-limit=2M name=PA-UDINDOWN packet-mark=PA-UDINDOWN parent="2.CLIEN RUMAHAN DOWN" \
queue=pcq-download-default
add max-limit=900K name=PA-UDINUP packet-mark=PA-UDINUP parent="2.CLIEN RUMAHAN UP" queue=\
pcq-upload-default

/ip firewall mangle


add action=mark-packet chain=forward comment=UDINDOWN connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" dst-address=192.168.61.9 in-interface=\
INTERNET-1 new-packet-mark=UDINDOWN packet-mark="!ICMP DOWN" \
passthrough=yes
add action=mark-packet chain=forward comment=UDINUP connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" new-packet-mark=UDINUP out-interface=\
INTERNET-1 packet-mark="!ICMP DOWN" passthrough=yes src-address=\
192.168.61.9

/queue tree
add max-limit=3M name=UDINDOWN packet-mark=UDINDOWN parent="2.CLIEN RUMAHAN DOWN" \
queue=pcq-download-default
add max-limit=1M name=UDINUP packet-mark=UDINUP parent="2.CLIEN RUMAHAN UP" queue=\
pcq-upload-default

/ip firewall mangle


add action=mark-packet chain=forward comment=EDOTDOWN connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" dst-address=192.168.71.31 in-interface=\
INTERNET-1 new-packet-mark=EDOTDOWN packet-mark="!ICMP DOWN" \
passthrough=yes
add action=mark-packet chain=forward comment=EDOTUP connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" new-packet-mark=EDOTUP out-interface=\
INTERNET-1 packet-mark="!ICMP DOWN" passthrough=yes src-address=\
192.168.71.31

/queue tree
add max-limit=1M name=EDOTDOWN packet-mark=EDOTDOWN parent="2.CLIEN RUMAHAN DOWN" \
queue=pcq-download-default
add max-limit=750K name=EDOTUP packet-mark=EDOTUP parent="2.CLIEN RUMAHAN UP" queue=\
pcq-upload-default
/ip firewall mangle
add action=mark-packet chain=forward comment=ROBYDOWN connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" dst-address=192.168.61.6 in-interface=\
INTERNET-1 new-packet-mark=ROBYDOWN packet-mark="!ICMP DOWN" \
passthrough=yes
add action=mark-packet chain=forward comment=ROBYUP connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" new-packet-mark=ROBYUP out-interface=\
INTERNET-1 packet-mark="!ICMP DOWN" passthrough=yes src-address=\
192.168.61.6

/queue tree
add max-limit=1M name=ROBYDOWN packet-mark=ROBYDOWN parent="2.CLIEN RUMAHAN DOWN" \
queue=pcq-download-default
add max-limit=750K name=ROBYUP packet-mark=ROBYUP parent="2.CLIEN RUMAHAN UP" queue=\
pcq-upload-default

/ip firewall mangle


add action=mark-packet chain=forward comment=YENIDOWN connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" dst-address=192.168.61.7 in-interface=\
INTERNET-1 new-packet-mark=YENIDOWN packet-mark="!ICMP DOWN" \
passthrough=yes
add action=mark-packet chain=forward comment=YENIUP connection-mark=\
"!PORT SELAIN PORT UMUM ( GAME )" new-packet-mark=YENIUP out-interface=\
INTERNET-1 packet-mark="!ICMP DOWN" passthrough=yes src-address=\
192.168.61.7

/queue tree
add max-limit=1M name=YENIDOWN packet-mark=YENIDOWN parent="2.CLIEN RUMAHAN DOWN" \
queue=pcq-download-default
add max-limit=750K name=YENIUP packet-mark=YENIUP parent="2.CLIEN RUMAHAN UP" queue=\
pcq-upload-default
1

3
4