Você está na página 1de 73

VWEERAFR

RD Press

Switches 3Com, H3C e HPN Serie-A

Diego Dias
R D PR E SS

Guia Básico para Configuração de


Switches

 RD Press
Rotadefault.com.br
Comutadores.com.br

Autor: Diego Dias


Revisão: Roger Sales
Ricardo Amaral
Luiz Santos
Índice
Introdução aos Switches Ethernet ................................................................................... 7
Switches...........................................................................................8
Protocolo ARP.................................................................................9
Domínio de Broadcast...................................................................12
Switching.......................................................................................12
Administração do Comware... ....................................................................................... 14
Método de Gerenciamento............................................................14
CLI - Níveis de Privilégio...............................................................15
Menus (view) ........... ....................................................................16
Criando um usuário........................................................................17
Ajuda nos comandos CLI ..............................................................19
Comandos Display "chave" ...........................................................20
Interfaces ................. .................................................................... 21
Como funciona a auto-negociação..... ..........................................22
Display this.....................................................................................22
Zerar contadores............................................................................22
Comandos para o sistema de arquivos..........................................23
Efetuando a atualização do Switch via TFTP. ...............................24
Boat-loader.....................................................................................26
Bootrom..........................................................................................26
Reset da Configuração.. ................................................................27
Display version...............................................................................27
Configuração de VLANs............................................................................................... .29
Configurando VLANs...................................... ...............................30
Configurando Trunk .......................................................................36
Configurando a VLAN Nativa ........................................................ 37
Configurando a porta Híbrida .........................................................38
Estudo de caso 1.......................................................................................... 40
GVRP, aprendizado dinâmico de VLANs ...................................................................... 42
Configurando o GVRP ...................................................................45
Configurando o GVRP no modo Fixed .......................................... 48
Configurando o GVRP no modo Forbidden.....................................48
Estudo de caso 2.......................................................................................... 50
Roteamento entre VLANs ............................................................................................. 52
Configurando a Interface VLAN ...................... ...............................56
Rota estatica............ ...................................................................... 60
Port link-mode route............... ........................................................60
Interface Null 0...................... ......................................................... 61
Estudo de caso 3.......................................................................................... 62
Apêndice A ................................................................................................................... 64
Quem deve ler esse livro?
Esse livro pode ser utilizado por técnicos ou administradores de
Switches Ethernet da 3Com, H3C e HPN Serie-A, familiarizados ou
não com a configuração de VLANs e a comunicação entre as
redes.

O ebook tambem servirá para administradores com formação


Cisco que desejam por necessidade profissional gerenciar um
ambiente com diversos vendors.

Apesar do Título do livro ser Guia Básico para Configuração de


Switches o conteúdo abordado no ebook poderá ser relacionado
com materiais de Certificação de Nível Intermediário como HP ASE
Network Infrastructure e CCNP da Cisco. Mas o foco não será para
exames de certificação e sim para comandos e cenários no dia-a-
dia de um administrador de Redes.

Agrego nesse material as experiencias como adminsitrador de


redes de pequeno e médio porte até a administração de Data
Centers.

O Livro inclui estudos de caso para refletirmos em topologias


similares a cenários reais, trabalhando de forma progressiva desde
a criação de VLANs, Interfaces de Acesso, Trunk até o
Roteamento entre VLANs e rotas para o Roteador de Internet.
Agradecimentos
A atividade de escrever um ebook foi muito prazerosa e ao mesmo
tempo muito cansativa. Apesar de não conseguir exemplificar
nesse material tudo o que gostaria, sinto-me feliz por tê-lo
concluído.

Gostaria de agradecer aos meus amigos do Rota Default: Roger


Sales e Ricardo Amaral, pela amizade e companherismo.

Gostaria de agradecer também ao colaborador indireto do Rota


Default, Luiz Santos, pela propaganda boca-a-boca e sua ultra-
sinceridade! Aos amigos da Ziva, ao “mestre” Denis Albuquerque
por todos os anos de trabalho e aos amigos da HP.

Para finalizar, quero agradecer a minha Mãe, quero agradecer a


minha companheira (muito paciente) Millena Mota e louvar a Deus
pela vida, energia e paz nessa Nova Vida!
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM Capítulo

1
Introdução aos Switches
Ethernet
Este capítulo é uma breve introdução da evolução dos hubs para os
switches ethernet.

U ma rede de computadores consiste em dois ou mais dispositivos


interligados entre si de modo a compartilhar recursos físicos e
lógicos por um padrão de endereçamento lógico para
comunicação. Para ocorrer a comunicação de equipamentos em uma rede,
utilizamos equipamentos que proveem uma quantidade de portas para
acesso aos computadores, servidores e etc.

No inicio do padrão Ethernet para comunicação das redes locais, adotou-


se a utilização de HUBs para a conexão de diversos equipamentos - como
computadores e impressoras.

A função de um HUB é repetir o sinal recebido por uma porta para todas
as outras portas com dispositivos conectados, não utilizando nenhum filtro
ou inteligência no encaminhamento de informações.

Conforme o crescimento de uma rede local, a arquitetura do HUB


ocasiona colisões de quadros, resultando em uma comunicação lenta entre
os equipamentos de rede. Na terminologia da Ethernet, uma colisão
ocorre quando dois dispositivos tentam “falar” ao mesmo tempo.

O protocolo CSMA/CD (Carrier Sense Multiple Access with Collision Detection)


permite que os dispositivos comuniquem-se no meio, sem perda de
informações, possibilitando as máquinas escutarem o meio físico antes de
iniciar a comunicação, coordenando assim o controle para não ocorrer
colisões. Se houver colisão, é encaminhado um sinal de alerta para os
dispositivos esperarem um tempo aleatório antes de iniciar a comunicação

7
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

novamente. Colisões serão consideradas um problema, erro de


transmissão, após ocorrem 16 vezes consecutivas, resultando em um
timeout para a comunicação.

A comunicação entre os dispositivos proporcionada por HUBs é


denominada como um domínio de colisão por permitir em toda a sua
extensão, colisão na comunicação entre os computadores, limitando a
escalabilidade de equipamentos na LAN, possibilitando apenas um único
dispositivo comunicar em determinado momento em toda a rede.

Os HUBs também não possuem inteligência para identificação de loops


físicos na rede dificultando a detecção de problemas, impossibilitando
também a utilização de métodos de disponibilidade, como a redundância
de cabos, etc.

Uma das coisas mais interessantes para administradores de rede é a detecção de


tempestades de broadcast ocasionada por HUB’s inseridos sem o consentimento da
equipe de TI. Em varias situações só conseguimos descobrir o problema, após
desconectarmos os UpLinks (conexão com outros Switches); um a um.

Switches
O desenvolvimento de novos dispositivos tornou-se necessário para
melhora de desempelho, como por exemplo, MAU's, Bridges e Switches.

Os Switches Ethernet trouxeram a capacidade de encaminhamento de


“pacotes” (entenda-se quadros/frames) baseado no endereço MAC de cada
dispositivo; ao invés de encaminhar o sinal para todas as portas, a
informação é encaminhada somente para o dispositivo correto.

O aprendizado de endereços MAC é feito de maneira dinâmica otimizando


o consumo do link, tornando cada porta como um domínio de colisão; ao
invés de todas as portas como o HUB faz.

8
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo 1-1 Visualizando a tabela MAC de um Switch HP Serie-A

[Switch] display mac-address


MAC ADDR VLAN ID STATE PORT INDEX AGING TIME(s)

00e0-fc17-a7d6 1 Learned Ethernet1/0/2 AGING


00e0-fc5e-b1fb 1 Learned Ethernet1/0/2 AGING
00e0-fc55-f124 1 Learned Ethernet1/0/4 AGING

Um Switch possui grande vantagem pela utilização de processadores, RAM


e ASICS para rápido encaminhamento dos quadros.

Exemplo 1-2 Posição de um Switch no modelo de referência OSI

Conforme Exemplo 1-2, o termo Switch L2, Layer 2 ou de Camada 2,


atribui a função do Switch em apenas utilizar o endereço MAC para
encaminhamento de quadros.

Protocolo ARP

Mas o leitor pode questionar: Se os Switches efetuam a leitura de endereços


MAC para encaminhamento de quadros, como é feita a leitura da
comunicação entre máquinas que utilizam o endereço IP?

9
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Com a utilização do protocolo IP para conexão entre hosts em uma LAN,


o Switch fará a leitura do protocolo ARP para armazenamento e
encaminhamento baseado no endereço MAC de cada equipamento ao
invés do endereço lógico de rede (endereço IP).

O Protocolo ARP é utilizado na comunicação entre dispositivos em uma


Rede Ethernet da mesma subrede IPv4. A principal função do ARP é a
tradução de endereço IP em endereço MAC:

1. emissor encaminha em broadcast (ffff-ffff-ffff ) um pacote ARP contendo


o próprio endereço MAC e endereço IP, além do endereço IP de destino
do outro host, esperando assim uma resposta com um endereço MAC
respectivo.

Exemplo 1-3 Solicitação de requisição ARP(1) e resposta ARP(2)

2. Após a resposta da requisição ARP, o mapeamento IP vinculado ao MAC


é armazenado em cache por alguns minutos. Se houver uma nova
comunicação com o IP mapeado na tabela ARP, o dispositivo deverá
consultar o mapeamento em cache; e não encaminhará uma mensagem em
Broadcast solicitando novamente o endereço MAC. Após o timeout do
endereço, uma nova consulta é encaminhada à rede.

10
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo 1-4 Visualizando a tabela ARP no Switch

[system] display arp

Type: S-Static D-Dynamic


IP Address MAC Address VLAN ID Port Name / AL ID Aging Type

192.168.39.52 001b-b96d-2858 4 GigabitEthernet1/0/2 13 D


192.168.38.49 001f-d0fb-7e59 4 GigabitEthernet1/0/3 14 D
192.168.39.251 001b-b96d-1671 4 GigabitEthernet1/0/2 15 D

Exemplo 1-5 Visualizando a tabela ARP em uma máquina com Windows7

C:\Users\comutadores>arp –a

interface: 192.168.1.100 --- 0x13


Internet Address Physical Address Type
192.168.1.1 00-25-9c-8d-a8-f6 dynamic
192.168.1.20 00-21-6a-99-dc-22 dynamic
192.168.1.23 00-21-6a-99-dc-01 dynamic
192.168.1.255 ff-ff-ff-ff-ff-ff static
224.0.0.22 01-00-5e-00-00-16 static
224.0.0.252 01-00-5e-00-00-fc static
239.255.255.250 01-00-5e-7f-ff-fa static
255.255.255.255 ff-ff-ff-ff-ff-ff static

A principal vantagem do ARP é a facilidade do mapeamento dinâmico de


endereços de hardware (MAC) para endereços de rede (IP).

Os dispositivos só exibirão a tabela ARP da sub-rede que


pertence!

O processo de Switching (comutação) na camada de enlace do modelo OSI


é capaz de encaminhar “pacotes” baseado apenas no endrereço MAC,
incrementado largura de banda e densidade de portas para a rede.

A tabela MAC e a tabela ARP podem ser consultadas na necessidade de


identificar em qual Switch e/ou porta está conectado cada equipamento.
Em diversos cenários já utilizei a consulta ARP para identificar o endereço MAC de
um Servidor problemático forçando o Switch a pingar o endereço IP para rastrear a
11
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

porta que o equipamento “está” conectado, corrigindo assim um problema de negociação


de Velocidade e Duplex.

Dominio de Broadcast

Para comunicação entre computadores, os mesmos devem estar


configurados na mesma subrede para troca de mensagens unicast e
broadcast para a resolução de endereços. Os dispositivos agrupados nessa
subrede e conectados ao Switch farão parte do mesmo domínio de
Broadcast, incluindo cenários com diversos Switches conectados a rede.
Esse cenário é necessário a comunicação de diversos protocolos em redes
com endereçamento IPv4.

Conforme ocorre o crescimento da rede, é possível filtrar as mensagens


trocadas entre os dispositivos com a criação de VLANs, que permitem a
divisão dos dominios de Broadcast e a comunicação unicast entre os
equipamentos. No capitulo 3 abordaremos a utilização de VLANs em uma
rede.

Se houver algum problema de comunicação entre equipamentos dispersos


na Rede da empresa dentro da mesma VLAN, verifique se a conexão entre
os Switches está permitindo a passagem das mensagens dessa VLAN -
fazendo a extensão do dominio de Broadcast.

As melhores práticas sugerem a criação de uma subrede para


cada VLAN.

Para a comunicação entre as VLANs será necessário a utilização de um


Roteador ou um Switch escolhido como Core com capacidade “L3” para
Roteamento dessas redes.No capitulo 6 abordaremos o Roteamento entre
VLANs em uma rede.

Switching

Em sua função básica, um Switch deverá apenas ler e armazenar as


informações de Camada Enlace para encaminhar os “pacotes” em baixa
latência, separar cada porta em um único dominio de colisão e cada VLAN
em um domino de Broadcast; mas em sua evolução, foram atribuídas

12
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

diversas funções como encaminhamento baseado em informações da


camada de Rede, Transporte e Aplicação.

A utilização de features como Spanning-Tree (802.1d, 802.1w e 802.1s),


Link-Aggregation (802.3ad) permitiram a construção de topologias com
alta-disponibilidade contra queda de enlaces com a utilização de caminhos
redundantes e o empilhamento com as features proprietárias da
3Com/H3C/HP (XRN, IRF e IRFv2) acrescentando maior inteligência
aos dispositivos.

Nesse volume focaremos nas funções principais de Comutação da Camada


2 e 3.

Espero que apreciem o material...

Uma boa leitura a todos!

13
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM
Capítulo

2
Administração do Comware
Administração do Comware torna-se bastante simples após o
aprendizado de algumas dicas que facilitam o trabalho e a configuração
dos Switches.

A ntes de iniciarmos os tópicos sobre configuração de VLANs, Trunk


e Roteamento usaremos esse capitulo para familiarização da
linguagem utilizada no Sistema Operacional Comware, atualmente
na versão 5, para configuração de portas, gerenciamento, administração de
usuários, atualização de sistema operacional entre outros.

Métodos de Gerenciamento

Existem 3 tipos de formas para configuração e administração dos Switches


HPN ( SNMP, GUI e CLI ):

SNMP
O protocolo SNMP é um protocolo da camada de aplicação, que permite
que dispositivos de rede como Firewall, Roteadores, Switches , etc,
troquem informações gerenciais com Servidores NMS (gerencia e
monitoração).
GUI
O acesso e a administração pelo modo GUI (Graphical User Interface) são
permitidos pela utilização de navegadores de Internet (Firefox, Explorer,
etc) ou pelo software de Gerenciamento IMC.

CLI
O acesso via CLI (Command Line Interface – modo texto) é permitido via
porta AUX (console), TELNET e SSH. O acesso por console é efetuado
por um cabo com uma ponta com o cabo DB9 Fêmea a outra ponta em RJ
45. É geralmente chamado de acesso físico pelo fato de não precisar de
endereço IP configurado nos dispositivos para comunicação. Esse tipo de

14
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

acesso é geralmente utilizado nas primeiras configurações e em situações


em que o Switch não esteja respondendo devido algum problema.
Para comunicação por TELNET e SSH, é necessária a configuração de ao
menos um endereço IP no Switch. A Principal diferença entre o TELNET
e o SSH é a maneira como as informações trafegam na rede. No caso do
TELNET as informações são transmitidas em texto puro, já o SSH utiliza
modo seguro transportando os dados criptografados .

Podemos utilizar os programas Hyperterminal (somente para console),


Putty e etc para acesso via CLI.

Os exemplos utilizados nesse livro serão baseados no modo CLI.

CLI – Níveis de privilégio

Os Switches 3Com/H3C e HPN possuem alguns níveis de hierarquia para


permissão de acesso. Os comandos são classificados em quatro níveis que
permitem o monitoramento do nível de acesso ao sistema e administração
do Switch:

Visit: Nível 0. Os comandos neste nível incluem ferramentas de


diagnóstico de rede como PING, TRACERT, TELNET, etc. Não é
permitido salvar ou alterar a configuração.

Monitoring: Nível 1. Os comandos neste nível incluem os comandos de


diagnostico de rede, display, debugging, etc. Não é permitido salvar ou
alterar a configuração.

System: Nível 2.Os comandos neste nível incluem comandos de


configuração e os comandos de Nível 0 e 1.

Management: Nível 3. Os comandos neste nível incluem comandos de


configuração e comandos que desempenham um papel de apoio de
serviços. Comandos neste nível incluem o arquivo de comandos do sistema
de arquivos, os comandos FTP, comandos TFTP, XModem, comandos de
gerenciamento de usuários e nível de definição.

15
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo 1-1 Tabela com os niveis de privilégio

Tipo Nível Privilégio

Visit 0 Comandos executados neste nível são para diagnostico de rede e


não podem ser salvos. Incluem Telnet, Ping e Traceroute.

Monitor 1 Comandos executados neste nível tem como objetivo principal


diagnosticar falhas na rede e não podem ser salvos no arquivo de
configuração. Incluem Display e Debugging
System 2 Comandos executados neste nível são usados para configuração de
serviços nas camadas de rede e roteamento e poderão ser salvos no
arquivo de configuração
Manager 3 Idem ao anterior acrescido dos comandos para manutenção do
sistema como criação de usuários, FTP/TFTP/Xmodem download

Menus (views)

Ao efetuarmos o acesso via Telnet ou console no Switch e após passar pelo


processo de autenticação cairemos por default na view user-view que é o
primeiro nível de acesso no Switch, permitindo a execução de comandos
display que permitem a visualização de configurações, estatísticas, debug e
troubleshooting. É indicado no prompt pelo nome do Switch entre os
sinais de maior e menor como <Switch>. O termo “view” poderá ser
comparado com o termo “menu”.

O menu de configuração do Comware é chamado system view, separando


o nome do Switch por colchetes, por exemplo, [Switch].

Para acessar o menu system-view digite o comando system-view no


modo user-view

Exemplo 1-2 Acessando o modo system-view

<Switch> system-view
[Switch]
! Acessando o modo system-view a partir do modo user-view
[Switch]quit
<Switch>
! Retornando para o modo user-view

16
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo 1-3 Diagrama com as views

Criando um usuário

Os Switches 3Com/H3C e HPN Serie-A vêm de fábrica com alguns


usuários “default” no arquivo de configuração:

Usuário admin, com a senha em branco, nível de permissão 3


Usuário manager, com a senha manager, nível de permissão 2
Usuário monitor, com a senha monitor, nível de permissão 1

As melhores práticas sugerem a criação de um novo usuário para cada


funcionário da equipe de TI que administrará os Switches, com seus níveis
de permissão diferenciados e a remoção dos usuários default ou a utilização
de um servidor de autenticação. Para criação de um usuário, devemos
efetuar os seguintes comandos no modo system-view:

Exemplo 1-4 Criando um usuário com o nome diego

<Switch>system
[Switch]
[Switch]local-user diego
! Criação do usuário diego
[Switch-luser-diego]password cipher d13go
! Criação da senha cifrada d13go
[Switch-luser-diego]service-type ssh telnet terminal
! Tipo de conexão permitida para o usuário como SSH, TELNET e

17
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

CONSOLE
[Switch-luser-diego]authorization-attribute level 3
! Nível de acesso do usuário

Após criarmos o usuário, configuramos o nível de acesso e quais serviços


poderão ser utilizados, como por exemplo acesso TELNET e Console, é
necessário a configuração da interface de acesso VTY para utilizar a base
de usuários local.

A interface VTY refere-se ao acesso virtual (TELNET e SSH). Para esse


tipo de acesso é necessário a configuração de endereço IP. A interface
AUX refere-se ao acesso via cabo Console, sendo necessária apenas a
configuração de cada equipamento no software cliente.

Exemplo 1-5 Exemplo dos parâmetros no software cliente para conexão via Console

A velocidade de Bits por segundo geralmente varia entre 9600 e


19200 para os dispositivos HPN

18
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo 1-6 Exemplo de configuração para acesso Telnet e Console utilizando a base de usuários
local.

[Switch]telnet server enable


!Habilitando o serviço Telnet

[Switch]user-interface vty 0 4
!Acessando a interface vty 0 e 4
[Switch-ui-vty0-4]authentication-mode password
! Configurando o modo de autenticação utilizando a base de
usuários
[Switch-ui-vty0-4]quit

[Switch]user-interface aux 0
! Acessando a interface aux 0 (console)
[switch-ui-aux0]authentication-mode scheme
[switch-ui-aux0]quit

A configuração authentication-mode scheme no user-interface vty 0 4


e user-interface aux 0 permite a utilização da base de usuários local na
falta de utilização de um servidor RADIUS para autenticação.

O modo de conexão por console poderá ser identificado como AUX, o


acesso Telnet e SSH é administrado como VTY.

Gerencia de usuários

Para visualizar todos os usuários conectados ao dispositivo e identificar o


acesso, digite o comando display users.

Exemplo 1-7 Visualizando os usuários conectados com o comando display users.

[Switch] display users


UI Delay Type Ipaddress Username Userlevel
VTY 0 00:00:00 TEL 192.168.0.208 admin 3
AUX 0 00:00:00 admin 3
VTY 1 00:06:08 TEL 192.168.0.3 monitor 1

Ajuda nos comandos CLI

Para obter ajuda durante a visualização é possível utilizar as dicas abaixo:

19
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

 Para obter ajuda online, utilize o caracter ? para obter a lista de todos os
comandos possíveis para a view onde se encontra.

 Para obter os parâmetros possíveis em um comando, utilize o caractere ? a


frente do comando. Por exemplo:
<Switch>display ?

 Para obter a lista de possíveis comandos iniciados por uma sequência de


caracteres, tecle ? logo após o mesmo. Por exemplo:
<Switch>p?

 É possível completar um comando ou parâmetro automaticamente, utilize


a tecla <tab>

 Caso não tenha outro comando ou parâmetro com a mesma identificação


inicial, o mesmo será completado.

 Durante a apresentação de múltiplas telas, use:


<barra de espaço> para apresentar a próxima pagina

<ENTER> para apresentar a próxima linha

Comandos display “chave”

O comando display current-configuration exibe a configuração atual que


está na memória volátil do dispositivo e em execução.

O comando display saved-configuration exibe a configuração salva na


memória Flash e que será solicitada quando o dispositivo for iniciado.

O comando display mac-address mostra a tabela com o mapeamento de


endereços MAC e portas do switch.

O comando display arp exibe a tabela contendo o mapeamento de


endereço IP, MAC, porta e VLAN do dispositivo.

20
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Os Switches 3Com/H3C/HPN incluem filtros para comandos display


com a inclusão de pipes “|” seguindos pela sintaxe begin ou include, etc,
como por exemplo:

display current-configuration | begin vlan

O comando display interface exibe o status das portas, contadores de


tráfego, erros e etc.

Interfaces

As portas Ethernet 10/100BASE-T suportam MDI/MDI-X auto-sensing.


Elas podem operar em half-duplex, full-duplex e auto-negotiation e
negociar com outros dispositivos para determinar velocidade e modo de
operação.

As portas GigabitEthernet 10/100/1000BASE-T suportam MDI/MDI-X


auto-sensing, e operam em 1000 Mbps full duplex, 100 Mbps half/full
duplex e 10 Mbps half/full duplex, além de trabalharem com auto-
negociação.

As portas Gigabit GBIC & SFP operam em 1000Mbps full duplex mode
que pode ser configurado como full (full-duplex) e auto (auto-negotiation)
e a velocidade pode ser configurada como 1000 (1000Mbps) e auto (auto-
negotiation).

As portas 10Gigabit Ethernet operam em 10000Mbps full-duplex. O modo


duplex pode ser configurado como full (full-duplex) e auto (auto-
negotiation)e a velocidade pode ser configurada como 10000 (10000Mbps)
e auto (auto-negotiation).

Como funciona a auto-negociação?

A auto-negociação é uma protocolo da Camada Física do modelo de


referência OSI, que permite que dois equipamentos de rede (Switches,
Roteadores e Servidores) negociem velocidade e duplex para escolha dinâmica
do melhor cenário para a comunicação de dados.

O padrão é bastante útil no dimensionamento de redes para a


compatibilidade entre as versões 10/100/1000Mb das interfaces.

21
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Apesar da instabilidade inicial do padrão (devido à incompatibilidade dos


fabricantes na adoção do modelo), as discussões da especificação da auto-
negociação foram eliminados pela versão de 1998 do IEEE 802.3. Em
1999, o protocolo de negociação foi significativamente ampliado por IEEE
802.3ab, que especificava o protocolo de GigabitEthernet, tornando
obrigatória a auto-negociação para 1000BASE-T.

A auto-negociação é utilizada por dispositivos com diferentes velocidades de


operação (como 10Mb e 1Gb) e diferentes modos de operação duplex
(Half-duplex e Full-duplex).

A incompatibilidade de duplex (duplex mismatch) ocorre quando um


dispositivo está em full-duplex e o outro está funcionando em half-duplex.
Por causa desse cenário um grande número de colisões irá ocorrer no lado
half-duplex. Uma segunda ressalva é que interfaces configuradas
manualmente não funcionam adequadamente com interfaces configuradas
como auto-negociação.

Problemas de duplex mismatch são comuns e difíceis de diagnosticar,


pois a rede continua a funcionar; e em testes básicos de troubleshooting,
reportam uma conexão ativa, mas a rede funciona com lentidão.

Display this

O comando display this exibe a configuração baseado na “view” de


acesso. Por exemplo, se estivemos aplicando a configuração em uma
interface GigabitEthernet, o comando display this exibirá as
configurações aplicadas na interface.

Exemplo 1-8 Exemplo do comando display this.

[Switch-GigabitEthernet1/0/12]display this
#
interface GigabitEthernet1/0/12
stp edged-port enable
broadcast-suppression PPS 3000
undo jumboframe enable
apply qos-profile default

Zerar contadores

Durante problemas de rede é possível visualizarmos os contadores de erros

22
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

nas interfaces com o comando display interfaces. Nos casos em que há a


necessidade de zerarmos os contadores para eliminarmos falsos positivos
podemos utilizar o comando reset counters interface no modo user-view

Comandos para o sistema de arquivos

No modo user-view é possível utilizar comandos para administração do


Switch.
Para visualizar os arquivos da memória flash digite o comando dir ou dir
/all. Os switches 3Com utilizam as principais extensões abaixo:

 .bin ou .app : é a imagem do Switch, o Sistema Operacional do dispositivo

 .cfg ou .def: são arquivos de texto contendo as configurações salvas

 .web: pacote para administração do Switch por HTTP

 .btm : arquivo do bootrom responsável pelo boot da Sistema Operacional

O comando mkdir permite a criação de diretórios, o comando cd permite


a movimentação pelos diretórios. O comando pwd exibe o diretório
corrente.

Utilize o comando delete para remover os arquivos, após a exclusão do


arquivo, o mesmo ficará na lixeira até efetuarmos a limpeza com o
comando reset recycle-bin.

O comando dir /all exibe quais arquivos estão na lixeira exibindo o nome
do arquivo entre colchetes( [ ] ). Para visualizar arquivos de texto, utilize a
opção more.

Utilize o comando rename para renomear o nome do arquivo.

Para salvar a configuração utilize o comando save. Ao salvamos a


configuração poderemos alterar o nome do arquivo (criando um novo
arquivo) e manter a configuração anterior para backup em caso de
problemas na nova configuração aplicada.

23
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Para isso o comando startup saved-configuration permite alterarmos o


arquivo que deverá ser utilizado no próximo boot do dispositivo e/ou a
configuração de backup no caso de problemas no arquivo principal.

Para visualizarmos o arquivo atual, o arquivo do próximo boot e o arquivo


de backup digite:
display startup.

Exemplo 1-9 Exemplo do comando display startup para visualizar os arquivos de configuração que
serão utilizados após o Switch reiniciar, incluindo o arquivo atual e o de backup.

<Switch> display startup


MainBoard:
Current startup saved-configuration file: flash:/ab.cfg
Next main startup saved-configuration file: flash:/ab.cfg
Next backup startup saved-configuration file: NULL

Efeatuando a atualização do Switch via TFTP

No modo user-view é possível efetuarmos a cópia de arquivos no sentido


Switch x Servidor (put) ou Servidor x Switch (get). O TFTP é o modo mais
utilizado para cópia de arquivos com o objetivo de atualização de extensões
como .bin, .app, .btm, .web,etc.

É necessário configurarmos ao menos um endereço IP no Switch, além de


validarmos comunicação por endereço IP entre o Servidor TFTP e o
Switch.A sintaxe para cópia de arquivos para o Switch é a seguinte:

Tftp [ip do servidor TFTP] get [nome do arquivo no servidor TFTP] [nome do
arquivo copiado no switch]

Outra opção para utilizarmos o comando TFTP é para o Backup de


configurações/arquivos no servidor TFTP. A sintaxe necessária para a
cópia de arquivos para o Servidor TFTP é a seguinte:

Tftp [ip do servidor TFTP] put [nome do arquivo no Switch] [nome do arquivo
copiado servidor TFTP]

Os softwares mais utilizados para Servidores TFTP para Windows são


Solarwinds TFTP Server,tftpd32 e etc.

24
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo 1-10 Exemplo do comando para cópia via TFTP

! Certifique se é possivel comunicar o Switch com o Servidor


TFTP

<Switch> tftp 10.1.1.2 put config.cfg


! Efetuando a cópia do arquivo de configuração no servidor
TFTP com o comando “put”
<Switch> tftp 10.1.1.2 get s7500e-cmw520-r6616p01.app
! Efetuando a cópia do arquivo s7500e-cmw520-r6616p01.app do
servidor TFTP para o Switch

Em caso de problemas na transferência de arquivos verifique:

 Se há espaço disponível na memória flash do Switch com o comando dir


no modo user-view .

 Verifique se o firewall da Máquina está bloqueando a transferência.

 Identifique se o serviço TFTP está ativo no computador.

 Verifique se a pasta de destino configurada no Servidor para coleta dos


arquivos está com o caminho correto no Software de TFTP

Após copiarmos os arquivos na memória flash do Switch será necessário


selecionar qual arquivo será utilizado para a próxima vez que o
equipamento iniciar.

Obs: para utilizarmos os arquivos copiados (.bin, .app, .cfg, etc) será
necessário reiniciar o Switch.

Durante o processo de boot, os arquivos necessários para o correto


funcionamento do Switch, como o Sistema Operacional e o arquivo de
Configuração, serão copiados na memória RAM e a partir daí estarão
prontos para o uso. Ao removermos ou formatarmos os arquivos da
memoria Flash durante o funcionamento do Switch, esta atividade não
afetará o funcionamento do equipamento, pois todos os arquivos
necessários estarão “carregados” na memória volatil. O problema ocorre ao

25
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

reiniciarmos o Switch, pois no processo de boot o Switch tentará copiar os


arquivos novamente da Flash e o Switch não “iniciará”.

Devemos nos atentar tambem as alterações na configuração. Lembrando


que a alterarmos a configuração de uma interface, endereço IP e etc,
estaremos alterando o arquivo da memoria RAM. Se não salvarmos a
configuração e reiniciarmos o Switch, o processo de boot iniciará com as
configurações salvas alteriormente a alteração, da memoria Flash.

O processo pode ser bem interessante quando não estamos confiantes de uma nova
configuração. Se algo errado acontecer, não salve a configuração, após o erro e reinicie o
Switch!!!

Boot-loader

O comando boot-loader define qual imagem será escolhida como


principal e a de backup na
inicialização do Switch.

Por Exemplo, após atualização por TFTP da imagem atual do Switch de


s4800g-cmw520-r2102p02.bin para s4800g-cmw520-r2202p15-s56.bin,
precisaremos informar ao equipamento qual versão do Sistema
Operacional iremos utilizar no próximo boot.

<Switch>boot-loader file S4800G-cmw520-r2202p15-s56.bin main

Bootrom

No documento de liberação de releases para alguns modelos de Switches


será solicitado o upgrade do bootrom .

<Switch>bootrom update file s4800g-btm_604.btm

Após efetuados os passos acima, reinicie o equipamento com o comando


reboot.

Antes de efetuar a atualização do Sistema do Switch, leia o


release da versão para identificar quais arquivos serão necessários
efetuar a atualização.

26
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Reset da configuração

Para apagar a configuração exibida no comando display save (que será


utilizada no próximo boot do dispositivo), aplique o comando reset
saved-configuration. Ao reiniciar o Switch e não houver configuração de
backup configurada, o equipamento iniciará sem configuração.
Reload, Reboot

Utilize o comando reboot para reiniciar o equipamento. Para a necessidade


de reiniciar o Switch em horários fora do expediente ou durante a aplicação
de comando que podem deixar o administrador sem a gerência do Switch,
é possível efetuar o agendamento do reload com o comando schedule
reboot.

Para cancelar o agendamento do reboot utilize a opção undo schedule


reboot.

Display version

O comando display version no modo user-view, permite identificarmos


informações valiosas
como a quantidade de tempo que o Switch está em funcionamento, versão
do Switch,
quantidade de memória, versão do bootrom, etc.

Exemplo 1-11 Exemplo do comando display version

<Switch> display version


3Com Corporation
Switch 5500G-EI Software Version 3Com OS V3.03.02s168p07
Copyright (c) 2004-2010 3Com Corporation and its licensors,
All rights reserved.
Switch 5500G-EI uptime is 3 weeks, 4 days, 2 hours, 21
minutes
Switch 5500G-EI 48-Port with 1 Processor
128M bytes SDRAM
16384K bytes Flash Memory
Config Register points to FLASH

<saída omitida>

27
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

28
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM
Capítulo

3
Configuração de VLANs
Administração de uma rede local com a utilização de VLANs permite
uma melhor administração para controle de dominios de broadcast,
segurança, QoS, entre outros.

E m uma Rede Ethernet, uma mensagem Broadcast encaminhada à


um Switch (como uma solicitação ARP para comunicação com o
Roteador ou uma solicitação DHCP), deverá ser direcionada para
todas as portas exceto a porta que recebeu o frame. Todos os dispositivos
dessa rede local participam do mesmo domínio de Broadcast.

Ao tirarmos um novo Switch da caixa em uma rede não configurada com VLANs e
“plugarmos” o equipamento na rede, todas as portas estariam disponíveis para funcionar
sem a mínima intervenção técnica.

Por default, a grande maioria dos Switches já vem de fabrica com todas as portas
configuradas na VLAN 1.

A utilização de VLANs (Virtual Local Area Network) permite que uma


rede física de uma empresa seja dividida em várias redes lógicas
segmentando os diversos departamentos e Serviços da Empresa como
Marketing , Administrativo, TI, Financeiro, Servidores, etc, em diferentes
redes.

A partir da utilização de VLANs, uma estação não é capaz de comunicar


com as estações que não são pertencentes a ela. Sendo mandatório que o
tráfego passe por um roteador ou Switch Multicamada.

Quando configurado corretamente, uma VLAN prove aumento no


desempenho da rede, limitando logicamente cada rede em um domínio de
broadcast, provendo segurança, controle de largura banda, etc.

29
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

A habilidade dos dispositivos em uma rede de se identificarem, como por


exemplo, com a utilização do Protocolo ARP, significa que os usuários que
abrigam dados sensíveis devam ser colocados em uma LAN separada do
usuário comum, limitando excessos como mensagens em broadcast.

Estes fatores tornam-se críticos para que os administradores da rede


controlem os limites da LAN.

As melhores práticas indicam a utilização de uma subrede por


VLAN.

A identificação de VLANs é efetuada por números. A VLAN default é


numerada com o valor 1.

Configurando VLANs

Os Switches 3Com, H3C e HP Serie-A suportam diferentes quantidades de


VLANs - baseado no modelo do equipamento- , os dispositivos de médio
e grande portam suportam a configuração de até 4096 VLANs.

Passo 1 Acesse o modo system-view


<Switch> system-view

Passo 2 Crie a VLAN com o numero do ID


[Switch] vlan vlan-id

Passo 3 (Opcional) Atribua um nome a VLAN


[Switch-vlan] name vlan-name

Passo 4 Saia do modo de configuração


[Switch-vlan] quit

O Exemplo3-1 exibe a configuração da VLAN 2 com o nome TI

Exemplo 3-1 Configurando VLAN

<Switch> system-view
[Switch] vlan 2
[Switch-vlan2] name TI
[Switch-vlan2] quit

30
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Para visualizar as VLANs criadas no Switch digite o commando display


vlan

Exemplo 3-2 Comando display vlan

[Switch]display vlan
Total 2 VLAN exist(s).
The following VLANs exist:
1(default), 2,

Para remover uma VLAN criada no Switch efetue os seguintes passos:

Passo 1 Acesse o modo system-view


<Switch> system-view

Passo 2 Remova a VLAN com o comando undo


[Switch] undo vlan vlan-id

Para adicionar uma porta a uma VLAN previamente criada efetue os


seguintes passos:

Passo 1 Acesse o modo system-view


<Switch> system-view

Passo 2 Acesse a porta/interface física que deseja atribuir a VLAN


[Switch] interface [ Ethernet | Gigabit | TenGigabit]
sub/subslot/port

Passo 3 Especifique a porta como Access e atribua a VLAN


[Switch-Ethernet] port link-type access
[Switch-Ethernet] port access vlan vlan-id

Passo 4 Saia do modo de configuração


[Switch-Ethernet] quit

A opção link-type atribui diretamente a relação da porta com a


VLAN:

Link-type access: a porta encaminhará os frames da VLAN como

31
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

untagged ( não alterando a estrutura do frame). A porta configurada como


Access poderá participar somente de uma VLAN. Esse é o
comportamento default de todas as portas.

O exemplo 3-3 exibe a configuração da VLAN 2 e a configuração das


portas como Access para a nova VLAN

Exemplo3-3 Configurando VLAN e atribuindo a porta

Exemplo3-3 a

<Switch> system-view
[Switch] vlan 2
[Switch-vlan2] name TI
[Switch-vlan2] quit

[Switch] interface gigabitethernet 1/0/1


[Switch-GigabitEthernet1/0/1] port link-type access
[Switch-GigabitEthernet1/0/1]port access vlan 2
[Switch-GigabitEthernet1/0/1] interface gigabitethernet 1/0/2
[Switch-GigabitEthernet1/0/2] port link-type access
[Switch-GigabitEthernet1/0/2] port access vlan 2
[Switch-GigabitEthernet1/0/2] quit

Para visualizar as portas configuradas na VLAN 2 digite display vlan 2

Exemplo3-4 Comando display vlan[ID da VLAN]

[Switch]display vlan 2
VLAN ID: 2
VLAN Type: static
Route Interface: not configured
Description: none
Name: TI
Tagged Ports: none
Untagged Ports:
GigabitEthernet1/0/1 GigabitEthernet1/0/2

32
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

É possível também configurar um range de portas para uma VLAN


conforme comando abaixo

Exemplo3-5 Configurando um range de portas para a VLAN 2

<Switch> system-view
[Switch] vlan 2
[Switch-vlan2] port gigabitethernet 1/0/1 to gigabitethernet
1/0/24

Para configurar uma interface para a VLAN 1 utilize o comando acima


atribuindo a interface física dentro da VLAN ou removendo a
configuração de VLAN conforme sintaxe abaixo:

Exemplo3-6 Configurando uma porta para a VLAN 1

[Switch] interface gigabitethernet 1/0/1


[Switch-GigabitEthernet1/0/1]undo port access vlan
! O commando undo port access vlan fará o vinculo da porta
Gigabit 1/0/1 com a VLAN 1

A utilização de VLANs não limita-se apenas a configuração local do


Switch, ela estende-se por todo a rede permitindo a distribuição geográfica
dos Switches para conexão de usuários, servidores e serviços.

Para estendermos esse limite de VLANs para vários Switches, faz-se


necessário a utilização do
protocolo 802.1Q. O protocolo permite a marcação (TAG) para frames
encaminhados para outros Switches. Ao receber o frame com a marcação
com o numero da VLAN o Switch receptor removerá a informação e
entregará a mensagem intacta ao host de destino.

O conceito de marcação de VLANs com a identificação do numero para


encaminhamento para outros Switches é chamado de Trunk. Em Switches
de outros fabricantes podemos ter o conceito de TAG (marcado) ou
UNTAGGED (sem marcação).

Se não utilizássemos uma interface configurada como Trunk e


precisássemos passar o tráfego da VLAN 1 e 2 para o outro Switch, seria

33
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

necessário a passagem de um cabo de cada VLAN para o outro dispositivo,


como no exemplo abaixo.

Exemplo3-7 Implementação com portas como acesso

Como a maioria dos Switches possui entre 24 e 48 portas a solução ficaria


inviável, inutilizando a maioria das portas para conexões entre os
dispositivos.

O protocolo IEEE 802.1Q permite utilizarmos apenas um cabo na


comunicação entre os Switches, marcando cada Frame (quadro) com o ID
de cada VLAN.

Exemplo3-8 Implementação com a porta configurada como Trunk

A marcação efetuada adiciona aos quadros Ethernet 4 bytes no frame


original e calculam um novo valor de checagem de erro para o campo FCS.

34
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo3-9 Quadro Ethernet Original e Quadro Ethernet com TAG

Dos valores contidos dentro do campo TAG o numero da VLAN é


adicionado ao campo VLAN id permitindo a identificação da VLAN entre
os Switches

Exemplo3-10 Campo TAG

Uma observação relevante é a utilização do campo Priority (também


dentro da TAG) para função de QoS em camada 2 para Ethernet, chamado
de 802.1p ou CoS (Class of Services), permitindo a diferenciação de classes
de serviços por Switches sem a necessidade de leitura do campo IP.

Muitas placas de rede para PC's e impressoras não são compatíveis com o
protocolo 802.1Q e ao receberem um frame com TAG, não
compreenderão a marcação de VLAN e descartarão a informação. Já
os Switches que receberem na interface Trunk um quadro com TAG, irão
remover o campo e entregar o ao destino sem a marcação (porta
configurada como acesso).

A regra é bem simples para a maioria dos casos (salvo exceções):

35
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

 Para comunicação entre Switches, configure as interfaces como


Trunk (Tagged)
 Para comunicação entre Switches e hosts, servidores, impressoras;
configure as interfaces como Access (untagged) com o ID da VLAN

Exemplo3-11 Marcação dos Quadros com o ID da VLAN no Link Trunk

1. O quadro é encaminhado pelo host sem marcação para a porta do Switch


configurada como Access na VLAN 2.
2. Após identificar o destino da mensagem o Switch encaminha o quadro
marcado para o próximo Switch com o ID da VLAN.
3. O Switch recebe o quadro marcado o Switch encaminha o quadro marcado
para o próximo Switch com o ID da VLAN.
4. Ao encaminhar o quadro para o host final, o Switch remove a marcação e
entrega o quadro gerado pelo host de origem.

Configurando Trunk

Os Switches 3Com, H3C e HP Serie-A permitem a atribuição de todas as


VLAN no link trunk, assim como, o filtro para especificas VLANs.

Link-type Trunk: a porta encaminhará os frames de cada VLAN


como tagged ( inserindo a marcação com o ID da VLAN na estrutura do
frame). A porta configurada como Trunk poderá encaminhar tráfego de

36
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

todas as VLANs. Por default a VLAN 1 é encaminhada sem TAG.

Passo 1 No modo system-view acesse a interface física que deseja


configurar
[Switch] interface [ Ethernet | Gigabit | TenGigabit]
sub/subslot/port

Passo 2 Especifique a porta como Trunk e atribua a(s) VLAN(s)


[Switch-Ethernet] port link-type trunk
[Switch-Ethernet] port trunk permit vlan {lista de vlans |
all}

Passo 3 Saia do modo de configuração


[Switch-Ethernet] quit
Exemplo3-12 Configurando o Trunk permitindo todas as VLANs

[SwitchA] interface gigabitethernet 1/0/1


[SwitchA-GigabitEthernet1/0/1] port link-type trunk
[SwitchA-GigabitEthernet1/0/1] port trunk permit vlan all
[SwitchA-GigabitEthernet1/0/2] quit
[Switch]

Configurando a VLAN nativa (PVID) na interfaceTrunk.

A VLAN nativa é considerada a VLAN não “tagueada” no link Trunk.


Por default , ao configurarmos a interface como Trunk, a VLAN nativa
(chamada de PVID da interface física) será a VLAN 1.

Quando a porta está configurada como Access o PVID será o proprio ID


da VLAN.

Exemplo3-13 Verificando o PVID da Interface

[SwitchA] display interface gigabitethernet 1/0/1


GigabitEthernet1/0/1 current state: UP
IP Packet Frame Type: PKTFMT_ETHNT_2, Hardware Address: 0000-
5612-0000
Description: GigabitEthernet1/0/1 Interface
Loopback is not set
Media type is not sure,Port hardware type is No connector
Unknown-speed mode, unknown-duplex mode
Link speed type is autonegotiation, link duplex type is

37
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

autonegotiation
Flow-control is not enabled
The Maximum Frame Length is 1536
Broadcast MAX-ratio: 100%
Unicast MAX-ratio: 100%
Multicast MAX-ratio: 100%
Allow jumbo frame to pass
PVID: 1
Mdi type: auto
Link delay is 0(sec)
Port link-type: trunk
VLAN passing : 2, 6-50, 100
VLAN permitted: 2, 6-50, 100
Trunk port encapsulation: IEEE 802.1q
<saída omitida>
Para alterar o PVID da VLAN de uma interface Trunk utilize o comando
port trunk pvid vlan [id da vlan]:

Exemplo3-14 Configurando a VLAN 200 como nativa na interface Trunk

[SwitchA] interface gigabitethernet 1/0/9


[SwitchA-GigabitEthernet1/0/9] port link-type trunk
[SwitchA-GigabitEthernet1/0/9] port trunk permit vlan all
[SwitchA-GigabitEthernet1/0/9] port trunk pvid vlan 200
[SwitchA-GigabitEthernet1/0/9] quit
[Switch]

Tenha bastante cuidado ao alterar a VLAN nativa do link Trunk e só use


em casos especificos para não direcionar o tráfego de uma VLAN para
outra incorretamente. Nesse caso é necessário manter a consistência da
configuração nas duas interfaces fisicas do Link.

Configurando a porta Híbrida (Hybrid)

Ao configurarmos uma interface como Hybrid, sua função será muito


semelhante a uma interface Trunk permitindo a interface encaminhar e
receber quadros com TAG de diversas VLANs.Uma porta Hybrid também
permite a configuração de diversas VLANs em uma interface como
Untagged.

A principal vantagem de utilizar a porta Hibrida é a possibilidade de


atribuir um dispositivo dinamicamente a uma VLAN baseando-se em

38
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

protocolos de Camada 3, endereços MAC, endereços IP, autenticação,


como citaremos nos próximos Capitulos.

Passo 1 No modo system-view acesse a interface física que deseja


configurar

[Switch] interface [ Ethernet | Gigabit | TenGigabit]


sub/subslot/port

Passo 2 Especifique a porta como Hybrid e atribua a(s) VLAN(s)


[Switch-Ethernet] port link-typehybrid
[Switch-Ethernet] port hybrid vlan {lista de vlans }{tagged
| untagged}

Passo 3 Saia do modo de configuração


[Switch-Ethernet] quit

39
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Estudo de Caso 1: Configurando VLANs, atribuindo as


portas de usuários e Uplinks como Trunk

O estudo de caso servirá como revisão para os principais temas discutidos


nesse capitulo:

Objetivos:
O Objetivo desse exercício é demonstrar a configuração dos Switches A, B
e C para comunicação das redes das VLANs 4 e 5, os usuários poderão
apenas comunicar com os usuários pertencentes a mesma VLAN.

A Interface dos usuários deverá ser configurada como Access com suas
respectivas VLANs e a comunicação entre os Switches deverão ocorrer
com a porta configurada como Trunk permitindo todas as VLANs.

A resolução do Estudo de Caso 1 estará no APENDICE A no final do livro.

Para a correta resolução do exercício, os Switches deverão conter os


outputs abaixo.

! Comandos display para o Switch A


[SwitchA]display port trunk
Interface PVID VLAN passing
GE1/0/1 1 1, 4-5,
GE1/0/2 1 1, 4-5,

40
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

! Comandos display para o Switch B


[SwitchB]display vlan 5
VLAN ID: 5
VLAN Type: static
Route Interface: not configured
Description: VLAN 0005
Name: VLAN 0005
Tagged Ports:
GigabitEthernet1/0/24
Untagged Ports:
GigabitEthernet1/0/2 GigabitEthernet1/0/3

[SwitchB]display vlan 4
VLAN ID: 4
VLAN Type: static
Route Interface: not configured
Description: VLAN 0004
Name: VLAN 0004
Tagged Ports:
GigabitEthernet1/0/24
Untagged Ports:
GigabitEthernet1/0/4 GigabitEthernet1/0/5

! Comandos display para o Switch C


[SwitchC]display vlan 4
VLAN ID: 4
VLAN Type: static
Route Interface: not configured
Description: VLAN 0004
Name: VLAN 0004
Tagged Ports:
GigabitEthernet1/0/24
Untagged Ports:
GigabitEthernet1/0/2 GigabitEthernet1/0/3

[SwitchC]display vlan 5
VLAN ID: 5
VLAN Type: static
Route Interface: not configured
Description: VLAN 0005
Name: VLAN 0005
Tagged Ports:
GigabitEthernet1/0/24
Untagged Ports:
GigabitEthernet1/0/4 GigabitEthernet1/0/5

41
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

42
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM
Capítulo

4
GVRP, aprendizado dinamico
de VLANs
O Protocolo GVRP torna-se auxiliar um elemento auxiliar para
grandes redes locais, com uma quantidade razaovél de VLANs que
precisam ser administrada em todo os Switches o protocolo é ferramenta
importante para manter a consistencia dos dominios de Broadcast por
todo o Campus.

E m uma rede tradicional, a segmentação das subredes com VLANs


permite aumento no desempenho da rede com a limitação do
domínio de broadcast, melhora nas políticas de segurança,
troubleshooting, Qualidade de Serviço (QoS), etc.

Apesar da utilização de VLANs resolver diversos problemas da camada de


Enlace, é necessário que a VLAN seja estendida fim-a-fim para ocorrer
comunicação entre duas máquinas na mesma rede local, em caso contrario
a mensagem não chegará ao destino.

Exemplo 4-1 Problemas de consistência de VLAN no Campus

43
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

1. O quadro é encaminhado pelo host sem marcação para a porta do Switch


configurada como Access na VLAN 2.
2. Após identificar o destino da mensagem, o Switch encaminha o quadro
marcado para o próximo Switch com o ID da VLAN.
3. O Switch recebe o quadro marcado, mas descarta a mensagem por não
possuir o ID da VLAN 2 em sua tabela (apenas a VLAN 1 está habilitada).

Conforme ocorre a expansão da rede torna-se complexo a administração


de todos os dispositivos para gerenciar e manter a consistência das VLANs
espalhadas pelo Campus.

De forma a aperfeiçoar o trabalho, o protocolo GVRP permite a


distribuição de informações das VLANs dinamicamente para os Switches.

GVRP significa GARP VLAN Registration Protocol, o protocolo


utiliza-se do mecanismo de propagação e registro do protocolo GARP
,registrando e removendo atributos, permitindo aos Switches a utilização
de VLANs aprendidas dinâmicamente. A sigla GARP significa Protocolo
de Registro de Atributos Genéricos (Generic Attribute Registration Protocol).

Todos os Switches com o serviço GVRP ativo podem receber a


informação de registro de VLANs de outros dispositivos e dinamicamente
efetuar a atualização da tabela de VLANs utilizando-se do link Trunk.

Então, ao habilitarmos o GVRP nos Switches e efetuarmos a configuração


de VLAN em um dos equipamentos, todos os Switches terão a nova
VLAN habilitada nas interfaces Trunk.

Para que as VLANs encaminhem os quadros para os destinos, todos os


Switches devem conter a mesma informação em suas respectivas base de
dados. O protocolo GVRP permite que dispositivos com suporte ao IEEE
802.1Q editem ou revoguem membros de uma VLAN.

Os Switches também são responsáveis por registrar e propagar os


membros de uma VLAN para todas as portas que participam da topologia.
Necessitando apenas que um Switch da rede seja configurado com as
VLANs e os demais dispositivos estariam com a sua base de VLANs em
conformidade.

44
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo 4-2 Propagação de VLANs via GVRP

A utilização do GVRP é bem simples e pode trabalhar resumidamente nos


3 seguintes modos:

 Normal: permite que o Switch envie e receba mensagens para aprendizado


de VLANs dinâmicas.

 Fixed: permite que o Switch envie mensagens GVRP com as VLANs


geradas localmente, mas o dispositivo não insere na tabela dinâmica as
VLANs anunciadas por outros Switches.

 Forbidden: permite que o Switch ignore as mensagens do protocolo.

Configurando o GVRP

Para a configurarmos o GVRP será necessário habilitar o protocolo


globalmente no Switch e atribuir quais interfaces Trunk irão compartilhar e
aceitar mensagens do protocolo.

Passo 1 No modo system-view habilite o GVRP


[Switch] gvrp

Passo 2 acesse a interface habilitada como Trunk


[Switch] interface [ Ethernet | Gigabit | TenGigabit]
sub/subslot/port
[Switch-Ethernet] port link-type trunk

45
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Passo 3 Habilite a interface para receber e encaminhar mensagens


GARP/GVRP
[Switch-Ethernet] gvrp

Ao habilitarmos o GVRP em uma interface Trunk, a porta terá o


comportamento do GVRP mode normal permitindo o envio e
recebimento de registro de VLANs.

O exemplo 2-3 exibe a configuração da VLAN 2, 3 e 4 no Switch A e a


configuração das portas dos Switches para aprendizado dinâmico das novas
VLANs

Exemplo4-3 Configurando os Switches para atribuição dinâmica de VLANs

Exemplo4-3 a

[SwitchA]gvrp
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type trunk
[SwitchA-GigabitEthernet1/0/1] port trunk permit vlan all
[SwitchA-GigabitEthernet1/0/1] gvrp
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] port link-type trunk
[SwitchA-GigabitEthernet1/0/2] port trunk permit vlan all
[SwitchA-GigabitEthernet1/0/2] gvrp
[SwitchA-GigabitEthernet1/0/2] quit

46
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

[SwitchA] vlan 2 to 4

[SwitchB]gvrp
[SwitchB] interface gigabitethernet 1/0/24
[SwitchB-GigabitEthernet1/0/24] port link-type trunk
[SwitchB-GigabitEthernet1/0/24] port trunk permit vlan all
[SwitchB-GigabitEthernet1/0/24] gvrp

[SwitchC]gvrp
[SwitchC] interface gigabitethernet 1/0/24
[SwitchC-GigabitEthernet1/0/24] port link-type trunk
[SwitchC-GigabitEthernet1/0/24] port trunk permit vlan all
[SwitchC-GigabitEthernet1/0/24] gvrp

Para visualizar as VLANs aprendidas dinamicamente nos Switches digite


display vlan dynamic

Exemplo4-4 Comando display vlan dynamic

[SwitchB]display vlan dynamic


Total 3 dynamic VLAN exist(s).
The following dynamic VLANs exist:
2-4

Ao atribuirmos uma interface física à VLAN aprendida dinamicamente,


essa VLAN entrará na tabela de VLANs estáticas e não poderá ser
removida de forma dinâmica.

Exemplo4-5 Configurando uma interface com a VLAN aprendida de forma dinâmica.

[SwitchB] interface gigabitethernet 1/0/19


[SwitchB-GigabitEthernet1/0/19] port link-type access
[SwitchB-GigabitEthernet1/0/19] port access vlan 3
Dynamic VLAN is configured, now changed to static!

[SwitchB]display vlan static


Total 2 static VLAN exist(s).
The following static VLANs exist:
1(default), 3

[SwitchB]display vlan dynamic


Total 2 dynamic VLAN exist(s).
The following dynamic VLANs exist:
2, 5

47
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Configurando o GVRP no modo Fixed

Ao habilitarmos o GVRP em um Switch da rede a configuração do modo


de funcionamento das portas define a maneira como o equipamento irá ou
não gerar ou aceitar as mensagens GVRP na rede.

Como citado anteriormente o modo padrão do protocolo (Normal)


permite o envio e o aprendizado dinâmico de VLANs.

A configuração da interface Trunk como fixed habilitará ao Switch


continuar gerando mensagens GVRP com atribuição/remoção de VLANs
dinâmicas, mas ignorará mensagens de registros encaminhada por outros
equipamentos .

Exemplo 4-6 Propagação de VLANs via GVRP e bloqueio pelo modo Fixed

Exemplo 4-7 Configurando a interface G1/0/24 no modo Fixed

[Switch]gvrp
[Switch] interface gigabitethernet 1/0/24
[Switch-GigabitEthernet1/0/24] port link-type trunk
[Switch-GigabitEthernet1/0/24] port trunk permit vlan all
[Switch-GigabitEthernet1/0/24] gvrp registration fixed

Configurando o GVRP no modo Forbidden

A configuração de uma porta no modo Forbidden não permitirá o registro


e a remoção de VLANs via GVRP, com exceção de informações da VLAN
1. Permitindo a transmissão de mensagens da VLAN 1.

48
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo 4-8 Configurando a interface G1/0/24 no modo Forbidden

[Switch]gvrp
[Switch] interface gigabitethernet 1/0/24
[Switch-GigabitEthernet1/0/24] port link-type trunk
[Switch-GigabitEthernet1/0/24] port trunk permit vlan all
[Switch-GigabitEthernet1/0/24] gvrp registration forbidden

Para retornarmos uma interface GVRP do modo forbidden ou fixed para


o modo normal será necessário digitarmos o comando gvrp registration
normal na respectiva interface

49
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Estudo de Caso 2: Configurando o registro de VLANs


dinamicamente para os novos Switches e VLANs da Rede
utilizando GVRP no modo Normal.

O estudo de caso servirá como revisão para os principais temas discutidos


nesse capitulo:

Objetivos:

O Objetivo desse exercício é permitir aos Switches da rede o aprendizado


dinâmico de novas VLANs, permitindo a distribuição dos usuários pelo
Campus e suas VLANs correspondentes e a atribuição das VLANs
existente no novo Switch D.

A resolução do Estudo de Caso 2 estará no APENDICE A no final do livro.

Para a correta resolução do exercício, os Switches deverão conter os


outputs abaixo.

[SwitchD]display port trunk


Interface PVID VLAN passing
GE1/0/24 1 1, 4-6,

[SwitchD]disp vlan dynamic


Total 2 dynamic VLAN exist(s).
The following dynamic VLANs exist:
4-5

50
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

[SwitchD]display vlan static


Total 3 static VLAN exist(s).
The following static VLANs exist:
1(default), 6

[SwitchC]display vlan dynamic


Total 1 dynamic VLAN exist(s).
The following dynamic VLANs exist:
6

[SwitchB]display vlan dynamic


Total 1 dynamic VLAN exist(s).
The following dynamic VLANs exist:
6

[SwitchA]display vlan static


Total 4 static VLAN exist(s).
The following static VLANs exist:
1(default), 4-6

51
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM
Capítulo

5
Roteamento entre VLANs
Nesse capitulo discutiremos a integração de VLANs com o roteamento de endereços IP
com a utilização de Switches (com capacidade de Roteamento) e entender também a
utilização do conceito de interfaces VLAN como Gateway nos Switches.

N os capítulos anteriores abordamos a divisão da rede em múltiplos


domínios de broadcast com a utilização de VLANs para resolver
diversos problemas de desempenho e segurança, restringido assim
naturalmente a comunicação entre redes diferentes pela separação lógica
dos equipamentos.

Logicamente com a utilização de VLANs cria-se um ambiente similar a


separação física de Switches para os dispositivos agrupados naquela
VLAN.

Exemplo 5-1 Restrição de comunicação por VLAN

Mesmo com a divisão da rede em diversos domínios de broadcast, o


objetivo final de uma rede local é permitir a comunicação entre todos os
equipamentos pertencentes ao Campus (domínio da empresa), salvo
algumas exceções.

52
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

A solução para a comunicação entre VLANs é a utilização de um


Roteador ou Switch Multicamanda para o roteamento das redes isolada por
VLANs. A função para roteamento entre VLANs em um Switch não
excluir a sua obrigatoriedade de dividir a rede em domínios de broadcast
separados.

Há alguns anos atrás utilizavamos Roteadores para efetuar o Roteamento


entre VLANs, designando uma interface física (porta) para cada VLAN; ou
utilizando apenas uma porta do Roteador com sub-interfaces para atuação
de gateway para cada VLAN, (fazendo a multiplexação da interface física
com a separação do trafego por tags 802.1q).

A desvantagem desse cenário é o trafego ir e voltar pelo mesmo cabo para comunicação
entre maquinas de diferentes redes na rede local!!!

Exemplo 5-2 Roteamento entre VLANs com a utilização de Roteador

O Roteamento entre VLANs é chamado de Inter-VLAN Routing

Os Switches reservados para a função de Roteamento entre VLANs


tambem são chamados de Switches de Camada 3, Switches L3, Switches
Core ou Switches Multicamada. Esses Switches possuem significativa
melhora no processo de Roteamento IP comparado a Roteadores
tradicionais, com o diferencial de efetuar o Roteamento em Hardware.

53
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

A construção de uma topologia de rede estruturada envolve a divisão dos


Switches na topologia em um desenho hieraquico de camadas que atribui a
funções de Core, Distribuição e Acesso aos Switches, limitando claramente
a função de cada equipamento na topologia.

A camada de Acesso providencia acesso aos usuarios, densidade de portas,


politicas simples de QoS , segurança e funções de camada 2.

Os Switches de Distribuição podem atribuir politicas de segurança mais


complexas como ACLs, restrição de banda e segmentação da rede em
Camada 3, Roteamento local (entre VLANs), dinamico com a utilização de
protocolos como RIP, OSPF e roteamento estático, além de incluir
politicas de QoS e redundancia na camada de Rede.

A camada Core, providencia velocidade para encaminhamento de tráfego e


inteligencia para comutação rápida de pacotes para quaisquer mudanças de
Roteamento na Rede utilizando protocolos de Roteamento dinamico. Em
ambientes mais complexos, faz adjacencia com Roteadores da WAN para
acesso a internet e/ou com filiais.

Em redes de pequeno e médio porte, a função da camada de Distribuição e


Core podem ser atribuida a uma unica camada Core, algumas
documentações citam essa camada como um “Nucleo Colapsado”.

Exemplo 5-3 Roteamento entre VLANs em uma Rede de pequeno e médio porte com Nucleo
Colapsado

Exemplo 5-3a Roteamento entre VLANs em uma Rede de utilizando Switches com funções de
Acesso, Distribuição e Core

54
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Quando múltiplas VLANs são configuradas em um Switch com capacidade


de rotear pacotes, o Roteamento é efetuado no próprio Switch com a
utilização de Interfaces VLAN que possuem função de Gateway para
aquela rede.

Uma Interface VLAN pode ser atribuída em algumas documentações


como SVI (Switch Virtual Interface) e Interface L3.

Ela é associada com o ID da VLAN para atribuir capacidade de


roteamento para a mesma.

Exemplo 5-4 Roteamento entre VLANs com a utilização de Switch

55
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Configurando a Interface VLAN

Para a configurarmos a Interface VLAN será mandatória a existência da


VLAN no Switch para mapeamento automático da Interface VLAN com a
VLAN.

Passo 1 No modo system-view com a VLAN já criada, crie a interface


VLAN de referência.
[Switch] interface vlan vlan-id

Passo 2 (Opcional) Atribua uma descrição para interface VLAN


[Switch-vlan-interfacex] ip address endereço-ip mascara

Passo 3 Digite o endereço IP da Interface VLAN


[Switch-vlan-interfacex] ip address endereço-ip mascara

Exemplo5-4 Configurando VLANs e Interface VLAN

[Switch] vlan 20
[Switch-vlan20] quit
[Switch] vlan 30
[Switch-vlan30] quit
[Switch] interface vlan 20
[Switch-vlan-interface20]ip add 192.168.1.1 255.255.255.0
[Switch-vlan-interface20]quit
[Switch] interface vlan 30
[Switch-vlan-interface10]ip add 10.8.0.1 255.255.255.0
[Switch-vlan-interface10]quit

Antes de efetuar o encaminhamento de qualquer pacote direcionado para a


interface VLAN para acesso a outras redes o Switch deverá consultar em
sua tabela de Roteamento se há entradas para o destino solicitado. Como
as interfaces VLAN estão diretamente conectadas ao Switch, o
Roteamento é feito automaticamente. Caso seja encaminhado um pacote
com o destino desconhecido pelo Switch, o mesmo será descartado.

Para visualização da tabela de Roteamento do Switch digite display ip


routing-table:

56
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo5-5 Verificando a tabela de roteamento com o comando display ip routing-table

[Switch] display ip routing-table


Routing Table: public net
Destination/Mask Protocol Pre Cost Nexthop Interface
127.0.0.0/8 DIRECT 0 0 127.0.0.1 InLoopBack0
127.0.0.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0
192.168.1.0/24 DIRECT 0 0 192.168.1.1 Vlan-Interface20
192.168.1.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0
10.8.0.0/24 DIRECT 0 0 10.8.0.1 Vlan-interface30
10.8.0.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0

Em cenários que seja necessário a utilização de mais de um endereço IP


para a interface VLAN, como em casos para correção de design da
topologia, podemos utilizar o comando sub ao fim do endereço IP, como
exemplo: ip address 10.99.1.1 255.255.255.0 sub

Exemplo5-6 Configurando a Interface VLAN com IP primário e secundario

[Switch] interface vlan 20


[Switch-vlan-interface20]ip add 192.168.1.1 255.255.255.0
[Switch-vlan-interface20]ip add 192.168.2.1 255.255.255.0 sub
[Switch-vlan-interface20] display this
!
interface Vlan-Interface 20
ip address 192.168.1.1 255.255.255.0
ip address 192.168.2.1 255.255.255.0 sub
!

É possível criar uma interface VLAN para uma VLAN para as seguintes
razões:

 Providenciar um gateway para uma VLAN para que o tráfego possa ser roteado.
 Providenciar conectividade em Camada 3 com o Switch.
 Suporte do dispositivo a protocolos de Camada 2 e 3.
 Monitoração e Gerencia do Switch utilizando Telnet, Ping, SSH, SNMP, ICMP

Rota Estática

A configuração de rota estática faz-se necessário para o acesso a outras


redes que não estão diretamente conectadas ao Switch Core/Roteador,

57
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

como por exemplo, outros Campus, Empresas ou a Internet.

Durante a solicitação de hosts para acessar outra Rede externa a LAN, o


Switch L3 efetua uma consulta na sua tabela de roteamento para verificar
se existe alguma rota para o destino solicitado. Se a rota existir o pacote
será encaminhado, senão, o pacote será descartado.

É possível verificar a tabela de roteamento do Switch com o


comando display ip routing-table.

Se a rota não estiver na tabela de roteamento é possível adicionar


estaticamente com o comando “ip route-static [rede de destino] [máscara da
rede de destino] [Gateway- próximo salto]”. O proximo salto é o equipamento
que possui a rede de destino em sua tabela de roteamento.

A rota “ip route-static 0.0.0.0 0.0.0.0 [Gateway próximo-salto]” é uma “rota


genérica” que informa que, se o Switch não possuir uma rota especifica
para o destino em sua tabela de roteamento, o pacote será encaminhado
para o próximo roteador.

No exemplo abaixo configuramos uma VLAN de trânsito para isolarmos


o Roteador do resto da Rede e incluiremos uma rota default para acesso a
internet apontando o endereço IP do Roteador.

Exemplo5-5 Inserindo uma VLAN de trânsido para Internet e a Rota Default para o Roteador.

58
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Exemplo5-5a Configurando a interface VLAN, rota default.

[Switch] vlan 100


[Switch-vlan100] quit
!Criando a VLAN 100
[Switch] interface vlan 100
[Switch-vlan-interface100] ip add 172.31.16.1 255.255.255.0
[Switch-vlan-interface100] quit
! Criando a Interface VLAN 100 e o endereço IP

[Switch] interface gigabitethernet 1/0/14


[Switch-GigabitEthernet1/0/14] port access vlan 100
[Switch-GigabitEthernet1/0/14] quit
!Configurando a interface Giga1/0/14 conectada ao Roteador de
Internet na VLAN 100

[Switch] ip route-static 0.0.0.0 0.0.0.0 172.31.16.2


! Criando uma rota Rota Default estática para o Roteador

[Switch] display ip routing-table


! Verificando a entrada estática na tabela de Roteamento
Routing Table: public net
Destination/Mask Protocol Pre Cost Nexthop Interface
0.0.0.0/0 Static 60 0 172.31.16.2 Vlan-Interface100
127.0.0.0/8 DIRECT 0 0 127.0.0.1 InLoopBack0
127.0.0.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0
192.168.1.0/24 DIRECT 0 0 192.168.1.1 Vlan-Interface20
192.168.1.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0
10.8.0.0/24 DIRECT 0 0 10.8.0.1 Vlan-interface30
10.8.0.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0
172.31.16.0/24 DIRECT 0 0 172.31.16.1 Vlan-interface30
172.31.16.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0

Uma VLAN de trânsito serve como boas práticas para não inserirmos o Roteador na
VLAN de usuários ou de Servidores (em nosso exemplo).

Mesmo que ocorra qualquer problemas em uma das VLANs, isso não afetará nosso
acesso para a Internet.

Já a Rota Default encaminhará pacotes com destino à redes que não possuam entradas
na tabela de roteamento para o Roteador ; sendo uma rota genérica para o Switch
resolver endereços não diretamente conectados e não conhecidos. A famosa frase: Eu não
conheço essa rede, mas eu sei quem conhece, o Roteador!!!!

59
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

VLAN de Gerenciamento

As melhores práticas indicam a criação de uma VLAN de gerenciamento


segregada da VLAN de usuário para acesso aos Switches, permitindo várias
políticas de Segurança e QoS se desejável para acesso ao dispositivo.

Nesse cenário criamos uma interface VLAN para os Switches de acesso,


mas a sua função será apenas para gerenciarmos os Switches.

Exemplo5-4 Exemplo de configuração de Interface VLAN em um Switch de camada 2 apenas


para gerenciamento

[Switch] vlan 40
[Switch-vlan40] description Gerenciamento
[Switch-vlan40] quit
[Switch] interface vlan 40
[Switch-vlan-interface40]ip add 192.168.4.30 255.255.255.0
[Switch-vlan-interface40]quit
[Switch] ip route-static 0.0.0.0 0.0.0.0 192.168.4.1

Para os Switches que não possuem capacidade de roteamento entre


VLANs (ou estão disponíveis como Switches de acesso), a configuração da
rota default (Gateway) permite o gerenciamento dos dispositivos por redes
diferentes ou de outro Campus.

Se quiséssemos encontrar um parelelo, essa situação cai no mesmo cenário da criação de


um gateway para um computador. O computador geralmente não faz roteamento mas
possui uma rota default para o gateway da rede, para acessar e ser acessado de outras
redes.

Port Link-mode Route

As últimas versões do Comware 5 para os Switches HP Serie-A trazem o


conceito de portas em modo Bridge e Route.

O modo Bridge (port link-mode bridge) trabalha da mesma maneira que


utilizamos em nossos Switches de acesso, com a configuração de VLAN e
atribuição do gateway das estações para o Switch Core ou Roteador.

60
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

O modo Route (port link-mode route) permite a atribuição de endereço


IP para porta física do Switch e não permite a atribuição de VLAN para
aquela interface. A porta não encaminhará BPDU's e ignorará as
mensagens STP recebidas.

Exemplo5-7 Configurando a Interface em modo route

interface GigabitEthernet4/0/1
port link-mode route
ip address 192.168.1.1 255.255.255.0
#
interface GigabitEthernet4/0/2
port link-mode bridge
port link-type access
port access vlan 2

Obs: Uma das vantagens do modo Route é poder trabalhar com mais facilidade com
ACL's, Roteamento, Route-Policy, Links em Ethernet e etc.

Interface Null 0

A Interface Null é uma interface lógica disponível em Switches e


Roteadores para manipulação em processos de Roteamento.

Configurando uma Rota Estática com o Gateway para NULL fará que os
pacotes direcionados para aquela Rede sejam descartados.

Exemplo5-8 Configurando uma rota para interface Null 0

ip route-static 192.168.1.0 255.255.255.0 Null 0


! Configurando a rota 192.168.1.0/24 para ser encaminhada
para Interface Null 0 (zero)

Em processos de Roteamento Dinâmico a Interface Null 0 poderá ser


utilizada para manipulação de Rotas como: sumarização, filtro, injeção de
prefixos, etc.

61
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Estudo de Caso 3: Configurando o Roteamento entre


VLANs.

O estudo de caso servirá como revisão para os principais temas discutidos


nesse capitulo:

Objetivos:

O Objetivo desse exercício é permitir ao Switches Core da rede a


comunicação das VLANs servindo como Gateway de cada rede, além da
configuração da rota estatica para acesso a Internet.

A resolução do Estudo de Caso 3 estará no APENDICE A no final do livro.

Para a correta resolução do exercício, os Switches deverão conter os


outputs abaixo.

62
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

[SwitchA] display ip routing-table


Routing Table: public net
Destination/Mask Protocol Pre Cost Nexthop Interface
0.0.0.0/0 Static 0 0 192.168.20.2 Vlan-interface40
127.0.0.0/8 DIRECT 0 0 127.0.0.1 InLoopBack0
127.0.0.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0
192.168.1.0/24 DIRECT 0 0 192.168.1.1 Vlan-interface4
192.168.1.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0
192.168.2.0/24 DIRECT 0 0 10.8.0.1 Vlan-interface5
192.168.2.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0
192.168.20.0/24 DIRECT 0 0 10.8.0.1 Vlan-interface40
192.168.20.1/32 DIRECT 0 0 127.0.0.1 InLoopBack0

63
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM
Apêndice

A
Resolução do “Estudo de
Caso” do Capítulo 3
Estudo de Caso 1: Configurando VLANs, atribuindo as portas de
usuários e Uplinks como Trunk

Para a completa execução do exercicio, o administrador deverá configurar


as VLANs em todos os Switches, além das interfaces responsáveis pela
comunicação entre eles - como port link-type trunk - com permissão para
todas as VLANs, estendendo assim cada dominio de Broadcast.

Cada usuário deverá ser configurado como porta de acesso (port link-type
access) em sua respectiva VLAN (máquinas de diferente VLANs não
deverão comunicar-se).

Switch A - Configuração de VLANs e Trunks

#
vlan 4
#
vlan 5
#
interface gigabitethernet 1/0/1
description SwitchB
port link-type trunk
port trunk permit vlan all
#
interface gigabitethernet 1/0/2
description SwitchC
port link-type trunk
port trunk permit vlan all
#

Switch B - Configuração de VLANs e Trunks

#
vlan 4

64
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

#
vlan 5
#
interface gigabitethernet 1/0/2
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/3
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/4
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/5
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/24
description SwitchA
port link-type trunk
port trunk permit vlan all
#

Switch C - Configuração de VLANs e Trunks

#
vlan 4
#
vlan 5
#
interface gigabitethernet 1/0/2
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/3
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/4
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/5
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/24
description SwitchA
port link-type trunk
port trunk permit vlan all
#

65
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Resolução do “Estudo de
Caso do” Capítulo 4
Estudo de Caso 2: Configurando o registro de VLANs
dinamicamente para os novos Switches e VLANs da Rede utilizando
GVRP no modo Normal.

Para a completa execução do exercicio, o administrador deverá configurar


o GVRP em todos os Switches. A troca de informação entre VLANs
deverá ocorrer entre as interfaces Trunk de ligação entre os Switches
configurado com o GVRP no modo Normal.

O Switch D aprenderá dinâmicamente as VLANs criadas nos outos


Switches do Campus. Ao criamos a VLAN 6, os demais Switches
aprenderão a nova VLAN do Switch D.

Cada usuário deverá ser configurado como porta de acesso (port link-type
access) em sua respectiva VLAN (máquinas de diferente VLANs não
deverão comunicar-se).

A configuração dos laborátorios 1,2 e 3 são sequenciais.


Switch D - Configuração de VLANs, Trunks e GVRP

#
gvrp
#
vlan 6
#
interface gigabitethernet 1/0/2
port link-type access
port access vlan 6
#
interface gigabitethernet 1/0/3
port link-type access
port access vlan 6
#
interface gigabitethernet 1/0/24
description SwitchA
port link-type trunk
port trunk permit vlan all
#

66
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Switch A - Configuração do GVRP

#
gvrp
#
vlan 4
#
vlan 5
#
interface gigabitethernet 1/0/1
description SwitchB
port link-type trunk
port trunk permit vlan all
gvrp
#
interface gigabitethernet 1/0/2
description SwitchC
port link-type trunk
port trunk permit vlan all
gvrp
#
interface gigabitethernet 1/0/3
description SwitchD
port link-type trunk
port trunk permit vlan all
gvrp
#

Switch B - Configuração do GVRP

#
gvrp
#
vlan 4
#
vlan 5
#
interface gigabitethernet 1/0/2
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/3
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/4
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/5
port link-type access
port access vlan 4

67
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

#
interface gigabitethernet 1/0/24
description SwitchA
port link-type trunk
port trunk permit vlan all
gvrp
#

Switch C - Configuração do GVRP

#
gvrp
#
vlan 4
#
vlan 5
interface gigabitethernet 1/0/2
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/3
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/4
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/5
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/24
description SwitchA
port link-type trunk
port trunk permit vlan all
gvrp
#

68
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Resolução do “Estudo de
Caso” do Capítulo 5
Estudo de Caso 3: Configurando o Roteamento entre
VLANs.

Para a completa execução do exercicio, o administrador efetuará a


configuração das Interfaces VLAN para cada VLAN no Switch A, eleito
como Switch Core em nossa topologia.

O Switch A, será o Gateway de cada VLAN e por ter as interfaces todas


diretamente conectadas, proverá o Roteamento entre VLAN por conhecer
todos os destinos na LAN.

Para acesso a Internet, criaremos uma VLAN ( ID 40 ) e a Interface


VLAN de Transito correspondente, para isolar o Roteador de Internet do
resto da Rede, além de criamos uma Rota Default estática para encaminhar
todo endereço de destino desconhecido no pacote IP, para o Roteador.

Todas as máquinas deverão comunicar entre si.

A configuração dos laborátorios 1,2 e 3 são sequenciais. (Não esqueça que algumas
VLANs foram aprendidas dinâmicamente via GVRP em nosso Laborátorio)
Switch A - Configuração de Roteamento

#
gvrp
#
vlan 4
#
vlan 5
#
vlan 40
#
interface gigabitethernet 1/0/1
description SwitchB
port link-type trunk
port trunk permit vlan all
gvrp
#

69
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

interface gigabitethernet 1/0/2


description SwitchC
port link-type trunk
port trunk permit vlan all
gvrp
#
interface gigabitethernet 1/0/3
description SwitchD
port link-type trunk
port trunk permit vlan all
gvrp
#
interface gigabitethernet 1/0/12
description Roteador_de_Internet
port link-type access
port access vlan 40
#
interface vlan-interface 4
ip address 192.168.1.1 255.255.255.0
#
interface vlan-interface 5
ip address 192.168.2.0 255.255.255.0
#
interface vlan-interface 6
ip address 192.168.3.1 255.255.255.0
#
interface vlan-interface 40
ip address 192.168.20.1 255.255.255.252
#
ip route-static 0.0.0.0 0.0.0.0 192.168.20.2
#

Switch D - Configuração de VLANs, Trunks e GVRP

#
gvrp
#
vlan 6
#
interface gigabitethernet 1/0/2
port link-type access
port access vlan 6
#
interface gigabitethernet 1/0/3
port link-type access
port access vlan 6
#
interface gigabitethernet 1/0/24
description SwitchA
port link-type trunk
port trunk permit vlan all
#

70
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

Switch B - Configuração do GVRP

#
gvrp
#
vlan 4
#
vlan 5
#
interface gigabitethernet 1/0/2
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/3
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/4
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/5
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/24
description SwitchA
port link-type trunk
port trunk permit vlan all
gvrp
#

Switch C - Configuração do GVRP

#
gvrp
#
vlan 4
#
vlan 5
interface gigabitethernet 1/0/2
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/3
port link-type access
port access vlan 4
#
interface gigabitethernet 1/0/4
port link-type access
port access vlan 5
#
interface gigabitethernet 1/0/5

71
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

port link-type access


port access vlan 5
#
interface gigabitethernet 1/0/24
description SwitchA
port link-type trunk
port trunk permit vlan all
gvrp
#

72
G U I A B Á S I C O P A R A C O N F I G U R A Ç Ã O D E S W I T C H E S
MUNIZ.FILHO@GMAIL.COM

73