Você está na página 1de 5

CENTRO DE CIÊNCIAS EXATAS E TECNOLÓGICAS

ENGENHARIA CIVIL

VLADER DANIEL SANTANA DE CAMPOS

LISTA DE EXECÍCIOS

Trabalho apresentado à Universidade Norte do Paraná -


UNOPAR, na disciplina Algoritmo e Lógica de
Programação no curso de Engenharia Civil.
Professor: Diony Almeida.

Londrina
2019
1.1
algoritmo
escreva "Olá este é o exercício 1"
fim_algoritmo

1.2
algoritmo
declare n1,n2,n3 literal id1,id2,id3 numerico
escreva "Digite o 1º Nome: "
leia n1
escreva "Digite a idade do 1º Nome: "
leia id1
escreva "Digite o 2º Nome: "
leia n2
escreva "Digite a idade do 2º Nome: "
leia id2
escreva "Digite o 3º Nome: "
leia n2
escreva "Digite a idade do 3º Nome: "
leia id3
escreva "1º Nome é : ",n1, ",Idade :",id1," ,2º Nome é : ",n2, " ,Idade :",id2, " ,3º Nome é : ",n3,
" ,Idade :",id3
fim_algoritmo

1.3
Programa {
funcao inicio() {
inteiro num ,result
escreva("Digite um número :")
leia(num)
result = num % 2
se (result == 0)
{
escreva(" É Par ")
}
senao
{
escreva ("É impar ")
}
}
}

1.4
algoritmo
declare n1,n2,n3, maior numerico
escreva "Digite o 1º número: "
leia n1
escreva "Digite o 2º número: "
leia n2
escreva "Digite o 3º número: "
leia n3
se n1 >=n2
entao maior <-n1
senao maior <-n2
se maior <= n3
entao maior <- n3
escreva "O maior número é :",maior
fim_algoritmo

1.5
algoritmo
declare n1,n2,n3 numerico
escreva "Digite o 1º número: "
leia n1
escreva "Digite o 2º número: "
leia n2
escreva "Digite o 3º número: "
leia n3
se n1 > n2 e n2 >= n3 entao
escreva n3,n2,n1,"L1"
senao
se n2 >= n1 e n2>n3 e n1>=n3 entao
escreva n3,n1,n2,"L2"
senao
se n2 > n1 e n2>=n3 e n1<=n3 entao
escreva n1,n3,n2,"L3"
senao
se n2>n1 e n2 <= n3 entao
escreva n1,n2,n3,"L4"
senao
se n2<n1 e n1<n3 entao
escreva n2,n1,n3,"L5"
senao
se n2<n3 e n3<=n1 entao
escreva n2,n3,n1,"L6"
senao
escreva n1,n2,n3,"L7"
fim_algoritmo

1.6
algoritmo
declare n1,soma numerico
soma <- 0
escreva "Digite números para soma : "
leia n1
enquanto soma <= 1024 faca
inicio
soma <- n1 + soma
escreva "Total : ", soma
leia n1
fim
escreva " Opa!!! Já utrapassou 1024 ",soma
fim_algoritmo

1.7
algoritmo
declare n1, n2 numerico
enquanto n1 < 50 faca
inicio
escreva "Digite um numero acima de 50 : "
leia n1
n2 <- n1
se n1 < 50
entao
escreva "Acima de 50, vamos tentar de novo !!! "
fim
enquanto n2 >= 0 faca
inicio
escreva n2
n2 <- n2 - 1
fim
fim_algoritmo

1.8
algoritmo
declare ficha [10] registro (nome literal dia, mes, ano numerico) x numerico
para x <-1 ate 10 faca passo 1
inicio
escreva "Digite nome : "
leia ficha[x].nome
escreva "Digite o dia de aniversario : "
leia ficha[x].dia
escreva "Digite o mês de aniversario : "
leia ficha[x].mes
escreva "Digite o ano de aniversario : "
leia ficha[x].ano
fim
para x <- 1 ate 10 faca passo 1
escreva "Nome : " ,ficha[x].nome," ,data de anivesário: ",ficha[x].dia,"/",ficha[x].mes,
"/",ficha[x].ano
fim_algoritmo