Você está na página 1de 4

Agrupamento de Escolas Joaquim de Araújo – Penafiel

Curso Profissional de Técnico de Gestão e Programação de Sistemas Informáticos

Ficha de Avaliação de Programação de Sistemas Informáticos – 10º F


MÓDULO 1 - Introdução à Programação e Algoritmia A

PROFESSOR: DURAÇÃO: 45’ Classificação:

 Nome: Nº: DATA:

Antes de iniciar o teste, lê com atenção todo o enunciado!

1. Classifica os dados abaixo de acordo com o seu tipo, assinalando com I os dados do tipo
inteiro, R os reais, C caracter e S para as strings:
a) “0,155” ( )
b) 1 ( )
c) ‘T’ ( )
d) 5,0 ( )

2. Para cada um dos nomes indicados abaixo indica os que não são opção para nomes de
variáveis, justificando a tua resposta:

a) “Valor”
_____________________________________________________________________
b) xVar
_____________________________________________________________________
c) Sala_12
_____________________________________________________________________
d) 123
_____________________________________________________________________
3. Indica o valor de cada uma das expressões seguintes:
a) (-1)^4 _________________________________________

b) 28+2*2^3 _______________________________________

c) 15 DIV 2 _______________________________________

d) 45 MOD 2 ____________________________________

4. Dá um exemplo de um operador aritmético e um operador relacional.


Aritmético ______________________________________________________
Relacional ______________________________________________________
5. Preenche a tabela de verdade:
A B AEB
F V
F F
V V
V F

6. Constrói o fluxograma e pseudocódig, utilizando o “Visualalg”, para a seguinte situação:


O algoritmo deve ler dois números reais e imprimir o maior.

2
7. Constrói o pseudocódigo para a seguinte situação:
O algoritmo deve ler duas notas de um aluno e calcular a sua nota final sabendo que o primeiro teste
vale 70% e o segundo 30%. Se a média for maior ou igual a 9,5 deverá escrever “Aprovado” e
“Reprovado” caso contrário.

8. Considera o seguinte algoritmo em pseudocódigo:

Algoritmo “divisivel”
Var
num: inteiro
resto1. resto2: real

Inicio
Escreva(“Introduza um número inteiro:”)
Leia(num);
resto1 num MOD 5;
resto2num MOD 7;

Se (resto1=0) E (resto2=0) entao


Escreva(“O nº: ”, num, “é divisível por 5 e 7”)
Senao
Escreva (“O nº: ”, num, “não é divisível por 5 e 7”)
FimSe
FimAlgoritmo

8.1 Indica uma instrução de input;

8.2 Indica uma instrução de output;

8.3 Indica uma instrução de processamento;

8.4 Indica uma expressão lógica ou booleana.

3
8.5 Faz a traçagem do algoritmo para cada um dos seguintes valores introduzidos para variável
num:
8.5.1 35
8.5.2 15

Você também pode gostar