Você está na página 1de 1

UnityPro 5.6.

4 p2_Use para resolver `Erro de An�lise do pacote� no `Android�

Se voc� baixou um "APP" para Android, e na hora de instalar recebe a mensagem:


"Erro de An�lise: H� um problema com a an�lise do pacote." � porque a vers�o do
"APP" � para Android superior ao seu!

Para resolver esse problema, basta editar o arquivo "AndroidManifest.xml" que vem
embutido em todos os App para Android. Mas, isso n�o � t�o simples, pois voc� ter�
que usar um programa espec�fico que possa descomprimir o App para poder acessar o
arquivo "AndroidManifest.xml" e poder edit�-lo e salv�-lo no mesmo local.

-- No Android, aconselha-se usar o "App Editor Pro" (� pago)


1. Instalar e executar o "App Editor Pro";
2. Selecionar um arquivo Apk> o .Apk que precisa de corre��o;
3. Escolher "Edi��o Completa"> esperar o carregamento;
4. Agora clique na op��o "Manifest" que fica l� embaixo no lado direito> espere o
carregamento;
5. Clique na terceira linha: <uses-sdk android:minSdkVersion="21".....
6. Aparecer� uma janela informando os dados desta linha, modifique apenas o n� da
coluna "android:minSdkVersion"; deixe o n� da coluna "android:targetSdkVersion"
como est�, ou mude para a �ltima vers�o, por exemplo, 23.
7. Nesse exemplo, o n�mero para a "minSdkVersion" do Android est� como 21 que se
refere ao Android 5.0; voc� ter� que editar e mudar para o n�mero da vers�o que se
refere ao seu Android, por exemplo:
>>> 9 para Android 2.3;
>>> 11 para Android 3.0;
>>> 14 para Android 4.0;
>>> 16 para Android 4.1;
>>> 17 para Android 4.2;
>>> 18 para Android 4.3;
>>> 19 para Android 4.4;
>>> 21 para Android 5.0;
>>> 22 para Android 5.1;
>>> 23 para Android 6.0;
>>> 24 para Android 7.0;
8. No meu caso, mudei 21 para 17, pois o meu Android � 4.2;
9. Clique em "Salvar";
10. Voltar� para a janela das Linhas da op��o "Manifest", Clique em "Salvar
novamente";
11. Aparecer� "Passo 1/4: Compor", aguarde a composi��o do arquivo.
12. No fim, mostrar�: "Sucesso! APK salvo como
/storage/emulated/0/ApkEditor/_xxx.apk (xxx.apk representa o nome do App que voc�
escolheu para a corre��o);
13. Clique em "Instalar";
14. Pronto, o App ser� instalado normalmente, sem apresentar o "Erro de An�lise: H�
um problema com a an�lise do pacote."

SE VOC� N�O QUER PAGAR PELO "App Editor Pro"; Poder� instalar o "App Editor
Parser", que tem as fun��es id�nticas ao "App Editor Pro", s� que n�o exibe a op��o
"Manifest";