Você está na página 1de 14

CCNPv7 ROUTE

Chapter 4 Lab 4-2, Controlling Routing Updates

nstru!tor "ersion

Topolog#

Ob$e!tives
 Filter routes using a distribute list and ACL.
 Filter routes using a distribute list and prefix list.
 Filter redistributed routes using a route map.
 Filter redistributed routes and set attributes using a route map.

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age 1 of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

%a!&ground
(n this scenario% &1 and &2 are running )(*&" +hile &2 and &$ are running multi#area ,-"F. &2 is the
,-"F autonomous sstem border router A-& consisting of areas 0% 10% and 20.
our tas3 is to control routing updates b u sing distribute lists% prefix lists and route maps.

Note' !his lab uses Cisco 141 routers +ith Cisco (,- &elease 15.2 +ith (" ase. 6epending on the router

or s+itch
from +hatmodel andin
is sho+n Cisco (,- -oft+are ersion% the commands aailable and output produced might ar
this lab.

Re(uired Resour!es
 $ routers Cisco (,- &elease 15.2 or comparable
 -erial and )thernet cables

)tep *' Con+igure loopba!&s and assign addresses

Note7 !he follo+ing t+o steps are not re8uired if ou are continuing from Lab 4#1.
a. Configure all loopbac3 interfaces on the three routers in the diagram. Configure the serial interfaces +ith
the (" addresses% bring them up% and set a 6C) cloc3 rate +here appropriate.
R1(config)# interface Loopback0
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)# exit
R1(config)#
R1(config)# interface Loopback48
R1(config-if)# ip address 192.168.48.1 255.255.255.0
R1(config-if)# exit
R1(config)#
R1(config)# interface Loopback49
R1(config-if)# ip address 192.168.49.1 255.255.255.0
R1(config-if)# exit
R1(config)#
R1(config)# interface Loopback50
R1(config-if)# ip address 192.168.50.1 255.255.255.0
R1(config-if)# exit
R1(config)#
R1(config)# interface Loopback51
R1(config-if)# ip address 192.168.51.1 255.255.255.0
R1(config-if)# exit
R1(config)#

R1(config)# interface
R1(config-if)# Loopback70
ip address 192.168.70.1 255.255.255.0
R1(config-if)# exit
R1(config)#
R1(config)# interface Serial0/0/0
R1(config-if)# ip address 172.16.12.1 255.255.255.0
R1(config-if)# clock rate 64000
R1(config-if)# bandwidt 64
R1(config-if)# no s!tdown

R2(config)# interface Loopback0


R2(config-if)# ip address 172.16.2.1 255.255.255.0

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age 2 of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

R2(config-if)# exit
R2(config)#
R2(config)# interface Loopback100
R2(config-if)# ip address 172.16.100.1 255.255.255.0
R2(config-if)# ip ospf network point"to"point
R2(config-if)# exit
R2(config)#
R2(config-if)# interface Serial0/0/0
R2(config-if)# bandwidt 64
R2(config-if)# ip address 172.16.12.2 255.255.255.0
R2(config-if)# no s!tdown
R2(config-if)# exit
R2(config)#
R2(config)# interface Serial0/0/1
R2(config-if)# bandwidt 64
R2(config-if)# ip address 172.16.2#.2 255.255.255.0
R2(config-if)# clock rate 64000
R2(config-if)# no s!tdown

R3(config)# interface Loopback0


R3(config-if)# ip address 172.16.#.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit
R3(config)#
R3(config)# interface loopback 8
R3(config-if)# ip address 192.168.8.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit
R3(config)#
R3(config)# interface loopback 9
R3(config-if)# ip address 192.168.9.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit
R3(config)#
R3(config)# interface loopback 10
R3(config-if)# ip address 192.168.10.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit
R3(config)#
R3(config)# interface loopback 11
R3(config-if)# ip address 192.168.11.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit
R3(config)#
R3(config)# interface Loopback20
R3(config-if)# ip address 192.168.20.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit
R3(config)#
R3(config)# interface Loopback25
R3(config-if)# ip address 192.168.25.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit
R3(config)#
R3(config)# interface Loopback#0
R3(config-if)# ip address 192.168.#0.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age $ of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

R3(config)#
R3(config)# interface Loopback#5
R3(config-if)# ip address 192.168.#5.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit
R3(config)#
R3(config)# interface Loopback40
R3(config-if)# ip address 192.168.40.1 255.255.255.0
R3(config-if)# ip ospf network point"to"point
R3(config-if)# exit
R3(config)#
R3(config)# interface Serial0/0/1
R3(config-if)# ip address 172.16.2#.# 255.255.255.0
R3(config-if)# bandwidt 64
R3(config-if)# no s!tdown

)tep 2' Con+igure Routing, )uari.ation, and Redistribution


(n this step% +e +ill configure )(*&" on &1 and &2% and ,-"F on &2 and &$.
a. ,n &1% create a supernet route summari9ing the loopbac3 4: and 4 net+ or3s and configure )(*&" in
autonomous sstem 1.
R1(config)# interface Serial0/0/0
R1(config-if)# ip s!$$ar%"address ei&rp 1 192.168.48.0 255.255.254.0
R1(config-if)# exit
R1(config)# ro!ter ei&rp 1
R1(config-router)# no a!to"s!$$ar%
R1(config-router)# network 172.16.0.0
R1(config-router)# network 192.168.0.0 0.0.255.255
R1(config-router)#

b. ,n &$% summari9e area 20 routes and configure ,-"F for area 0 and area 20.
R3(config)# ro!ter ospf 1
R3(config-router)# area 20 ran&e 192.168.8.0 255.255.252.0
R3(config-router)# network 172.16.0.0 0.0.255.255 area 0
R3(config-router)# network 192.168.0.0 0.0.255.255 area 0
R3(config-router)# network 192.168.8.0 0.0.#.255 area 20
R3(config-router)#

c. ,n &2% configure )(*&" and redistribute the ,-"F net+or3s into )(*&" A- 1. !hen configure ,-"F
and redistribute and summari9e the )(*&" net+or3s into ,-"F.
R2(config)# ro!ter ei&rp 1
R2(config-router)# no a!to"s!$$ar%
R2(config-router)# network 172.16.0.0
R2(config-router)# redistrib!te ospf 1 $etric 10000 100 255 1 1500
R2(config-router)# exit
R2(config)#
R2(config)# ro!ter ospf 1
R2(config-router)# network 172.16.2#.0 0.0.0.255 area 0
R2(config-router)# network 172.16.100.0 0.0.0.255 area 10
R2(config-router)# redistrib!te ei&rp 1 s!bnets
R2(config-router)# s!$$ar%"address 192.168.48.0 255.255.252.0
R2(config-router)# exit
R2(config)#

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age 4 of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

Jan 10 10:11:18.863: %DUAL--!"R$A!&: &'R-'* 1: !eig+,or 12.16.12.1


(eria/000) i u: ne a45acenc
R2(config)#
Jan 10 10:11:32.771: %9--ADJ$: roce 1 !,r 172.168.*0.1 on
eria/001 fro; LAD'! to 9ULL Loa4ing Done
R2(config)#

d. ;erif the )(*&" and ,-"F routing table entries on &2.


R2# sow ip ro!te ei&rp ' be&in (atewa%
atea of /at reort i not et

12.16.0.016 i aria,/ u,nette4 10 u,net 2 ;a<


D 12.16.1.02* =70*06*0000> ia 12.16.12.1 00:1*: eria/000
D 172.168.*8.023 =70*06*0000> ia 12.16.12.1 00:1*: eria/000
D 172.168.0.02* =70*06*0000> ia 12.16.12.1 00:1*: eria/000
D 172.168.1.02* =70*06*0000> ia 12.16.12.1 00:1*: eria/000
D 172.168.0.02* =70*06*0000> ia 12.16.12.1 00:1*: eria/000
R2#
R2# sow ip ro!te ospf ' be&in (atewa%
atea of /at reort i not et

12.16.0.016 i aria,/ u,nette4 10 u,net 2 ;a<


 12.16.3.02* =110163> ia 12.16.23.3 00:1:*1 eria/001
 'A 172.168.8.022 =110163> ia 12.16.23.3 00:1:*1 eria/001
 172.168.20.02* =110163> ia 12.16.23.3 00:1:*1 eria/001
 172.168.2.02* =110163> ia 12.16.23.3 00:1:*1 eria/001
 172.168.30.02* =110163> ia 12.16.23.3 00:1:*1 eria/001

 172.168.3.02* =110163> ia 12.16.23.3 00:1:*1 eria/001


 172.168.*0.02* =110163> ia 12.16.23.3 00:1:*1 eria/001
 172.168.*8.022 i a u;;ar 00:1:30 !u//0
R2#

As expected% &2 3no+s about the &1 routes including the summari9ed 12.1<:.4:.0/22 )(*&" route. &2
also 3no+s about the &$ ,-"F area 0 routes and the summari9ed area 20 routes.

e. ;erif the )(*&" routing table on &1.

R1# sow ip ro!te ei&rp ' be&in (atewa%


atea of /at reort i not et

12.16.0.016 i aria,/ u,nette4 8 u,net 2 ;a<


D 12.16.2.02* =70*06*0000> ia 12.16.12.2 00:11:*0 eria/000

D &?
D 12.16.3.02* =10*03600>
12.16.23.02* ia 12.16.12.2
=70*102*000> ia 12.16.12.2 00:11:*0
00:11:*0 eria/000
eria/000
D 12.16.100.02* =70*06*0000> ia 12.16.12.2 00:11:*0 eria/000
D &? 172.168.8.022 =10*03600> ia 12.16.12.2 00:11:*0 eria/000
D &? 172.168.20.02* =10*03600> ia 12.16.12.2 00:11:*0 eria/000
D &? 172.168.2.02* =10*03600> ia 12.16.12.2 00:11:*0 eria/000
D &? 172.168.30.02* =10*03600> ia 12.16.12.2 00:11:*0 eria/000
D &? 172.168.3.02* =10*03600> ia 12.16.12.2 00:11:*0 eria/000
D &? 172.168.*0.02* =10*03600> ia 12.16.12.2 00:11:*0 eria/000
D &? 172.168.*8.022 =10*03600> ia 12.16.12.2 00:11:38 eria/000
D 172.168.*8.023 i a u;;ar 00:11:*0 !u//0
R1#

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age 5 of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

&1 3no+s about the internal )(*&" routes and the external routes redistributed from the ,-"F routing
domain b &2. !he highlighted entr identifies the ,-"F 20 routes +hich +ill be filtered using a distribute
list and ACL in the next step.

f. ;erif the )(*&" routing table on &$.


R3# sow ip ro!te ospf ' be&in (atewa%
atea of /at reort i not et

12.16.0.016 i aria,/ u,nette4 8 u,net 2 ;a<


 &2 12.16.1.02* =11020> ia 12.16.23.2 00:22:*3 eria/001
 &2 12.16.2.02* =11020> ia 12.16.23.2 00:22:2 eria/001
 &2 12.16.12.02* =11020> ia 12.16.23.2 00:22:2 eria/001
 'A 12.16.100.02* =110163> ia 12.16.23.2 00:22:2 eria/001
 172.168.8.022 i a u;;ar 00:23:10 !u//0
 &2 172.168.*8.022 =11020> ia 12.16.23.2 00:22:*1 eria/001
 &2 172.168.0.02* =11020> ia 12.16.23.2 00:22:*2 eria/001
R3#

&$ 3no+s about the internal ,-"F routes and the external routes redistributed b &2 from the )(*&"
routing domain. !he highlighted entries identif the )(*&" routes +hich +ill be filtered using a d istribute
list and prefix list in another step.

g. ;erif that ou can ping across the serial lin3s +hen ou are finished. 'se the follo+ing !cl script to chec3
connectiit.

R3# tcls
foreac+ a44re @
12.16.1.1
172.168.*8.1
172.168.*7.1
172.168.0.1
172.168.1.1
172.168.0.1
12.16.12.1
12.16.12.2
12.16.2.1
12.16.100.1
12.16.23.2
12.16.23.3
12.16.3.1
172.168.8.1
172.168.7.1
172.168.10.1
172.168.11.1
172.168.20.1
172.168.2.1
172.168.30.1
172.168.3.1
172.168.*0.1
 @ ing Ba44re 

All pings should be successful. !roubleshoot if necessar.

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age < of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

)tep /' 0ilter redistributed routes using a distribute list and 1CL
&outes can be filtered using a ariet of techni8ues including7

istribute list and 1CL= A distribute list allo+s an access control lists ACLs to be applied to routing
updates.

 istribute list and pre+i3 list = A distribute list +ith a prefix list is an alternatie to ACLs designed to
filter routes. "refix lists are not exclusiel used +ith distribute lists but can also be u sed +ith route
maps and other commands.

Route aps= &oute maps are complex access lists that allo+ conditions to be tested against a
pac3et or route% and then actions ta3en to modif attributes of the pac3et or route.
(n this step% +e +ill use a distribute list and ACL to filter routes being adertised from &2 to &1. -pecificall%
+e +ill filter the ,-"F 20 routes i.e.% 12.1<:.:.0/22 from being adertised b &2 to &1.

a. ,n &1% erif the routing table entr for the 12.1<:.:.0/22 route.
R1# sow ip ro!te 192.168.8.0
Routing entr for 172.168.8.022 uernet
Cnon ia eigr 1 4itance 10 ;etric *03600 te eEterna/
Re4itri,uting ia eigr 1
Lat u4ate fro; 12.16.12.2 on eria/000 00:00:*3 ago
Routing Decritor "/oc<:
F 12.16.12.2 fro; 12.16.12.2 00:00:*3 ago ia eria/000
Route ;etric i *03600 traffic +are count i 1
Gota/ 4e/a i 21000 ;icroecon4 ;ini;u; ,an4i4t+ i 6* C,it
Re/ia,i/it 22 ;ini;u; HGU 100 ,te
Loa4ing 12 $o 1
R1#

b. Although a distribute list could be implemented on the receiing router% it is usuall best to filter routes
from the distributing router. !herefore on &2% create an ACL called O)P02-0LTER that denies the
12.1<:.:.0/22 route. !he ACL must also permit all other routes other+ise% no ,-"F routes +ould be
redistributed into )(*&".
R2(config)# ip access"list standard )S*+20"+,L-
R2(config-t4-nac/)# re$ark sed wit List to filter )S*+ 20 ro!tes
R2(config-t4-nac/)# den% 192.168.8.0 0.0.#.255
R2(config-t4-nac/)# per$it an%
R2(config-t4-nac/)# exit
R2(config)#

c. Configure a distribute list under the )(*&" process to filter routes propagated to &1 using the pr e#
configured ACL.
R2(config)# ro!ter ei&rp 1
R2(config-router)# distrib!te"list )S*+20"+,L- o!t ospf 1
R2(config-router)#

d. ,n &1% erif if the route is no+ missing from the &1 routing table.
R1# sow ip ro!te 192.168.8.0
% !etor< not in ta,/e
R1#
R1# sow ip ro!te ei&rp ' be&in (atewa%
atea of /at reort i not et

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age > of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

12.16.0.016 i aria,/ u,nette4 8 u,net 2 ;a<


D 12.16.2.02* =70*06*0000> ia 12.16.12.2 00:00:03 eria/000
D &? 12.16.3.02* =10*03600> ia 12.16.12.2 00:00:03 eria/000
D 12.16.23.02* =70*102*000> ia 12.16.12.2 00:00:03 eria/000
D 12.16.100.02* =70*06*0000> ia 12.16.12.2 00:00:03 eria/000
D &? 172.168.20.02* =10*03600> ia 12.16.12.2 00:00:03 eria/000
D &? 172.168.2.02* =10*03600> ia 12.16.12.2 00:00:03 eria/000
D &? 172.168.30.02* =10*03600> ia 12.16.12.2 00:00:03 eria/000
D &? 172.168.3.02* =10*03600> ia 12.16.12.2 00:00:03 eria/000
D &? 172.168.*0.02* =10*03600> ia 12.16.12.2 00:00:03 eria/000
D &? 172.168.*8.022 =10*03600> ia 12.16.12.2 00:00:03 eria/000
D 172.168.*8.023 i a u;;ar 00:00:03 !u//0
R1#

!he output confirms that the 12.1<:.:.0/22 route is no longer in the routing table of &1.

?ote that if additional router filtering +as re8uired% onl the ACL on &2 +ould need to be altered.

)tep 4' 0ilter redistributed routes using a distribute list and pre+i3 list
(n this step% a prefix list +ill be configured +ith a distribute list to filter &1 routes being adertised from &2 to
&$.
a. ,n &$% erif the routing table entr for the routes learned externall identified +ith the 0 )2 source entr.
R3# sow ip ro!te ospf ' incl!de ) 2
 &2 12.16.1.02* =11020> ia 12.16.23.2 00:10:12 eria/001
 &2 12.16.2.02* =11020> ia 12.16.23.2 00:10:12 eria/001
 &2 12.16.12.02* =11020> ia 12.16.23.2 00:10:12 eria/001
 &2 172.168.*8.022 =11020> ia 12.16.23.2 00:02:0 eria/001
 &2 172.168.0.02* =11020> ia 12.16.23.2 00:02:0 eria/001
R3#

-pecificall% the highlighted routes +ill be omitted from being adertised using a prefix list.
b. &2 +ill be conf igured +ith a prefix li st identifing +hich net+or3s to adertise to adertise to &$.
-pecificall% onl the 1>2.1<.0.0 net+or3s are permitted.
R2(config)# ip prefix"list ,(*"+,L- description sed wit List to filter
,(* ro!tes
R2(config)# ip prefix"list ,(*"+,L- per$it 172.16.0.0/16 le 24
R2(config)#

c. Configure a distribute list under the ,-"F process to filter routes propagated to &$ using the pre#
configured prefix list.
R2(config)# ro!ter ospf 1
R2(config-router)#
R2(config-router)# distrib!te"list prefix ,(*"+,L- o!t ei&rp 1

d. ,n &$% erif if the route is no+ missing from the &1 routing table.
R3# sow ip ro!te ospf ' incl!de ) 2
 &2 12.16.1.02* =11020> ia 12.16.23.2 00:13: eria/001
 &2 12.16.2.02* =11020> ia 12.16.23.2 00:13: eria/001
 &2 12.16.12.02* =11020> ia 12.16.23.2 00:13: eria/001
R3#

!he output confirms that onl the 1>2.1<.0.0/1< net+or3s are being adertised to &$.

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age : of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

)tep 5' 0ilter redistributed routes using a route ap


!he preceding t+o steps +ere simple examples of using a distribute list +ith an ACL and a prefix list. oth
methods basicall achieed the same result of filtering routes.
@o+eer% in large enterprise net+or3s% route filtering can be 8uite complex. !he ACLs can be er extensie
and therefore taxing on router resources. For this reason% prefix lists should be used instead of ACLs since
the are more efficient and less taxing on router resources than ACLs.

&oute maps can also be used to filter redistributed routes. A route map +or3s li3e an access list b ecause it
has multiple den and permit statements that are read in a se8uential order. @o+eer% route maps can match
and set specific attributes and therefore proide additional options and more flexibilit +hen redistributing
routes.
&oute maps are not ust for redistribution. !he are also commonl used for7
 Poli!#-based routing 6P%R= "& allo+s an administrator to define routing polic other than basic
destination#based routing using the routing table. !he route map is applied to an interface using the ip
poli!# route-ap interface configuration command.
 %8P=&oute maps are the primar tools for implementing *" polic and allo+s an administrator to
do path control and proide sophisticated manipulation of *" path attributes. !he route map is
applied using the *" neighbor router configuration command.
(n this step% +e +ill filter the &$ loopbac3 25 and $0 net+or3s from being redistributed into )(*&" on &2.
a. 6ispla the &1 routing table and erif that those t+o routes currentl appear there.
R1# sow ip ro!te ei&rp ' be&in (atewa%
atea of /at reort i not et

12.16.0.016 i aria,/ u,nette4 8 u,net 2 ;a<


D 12.16.2.02* =70*06*0000> ia 12.16.12.2 01:37:20 eria/000
D &? 12.16.3.02* =10*03600> ia 12.16.12.2 01:30:13 eria/000
D 12.16.23.02* =70*102*000> ia 12.16.12.2 01:37:20 eria/000
D 12.16.100.02* =70*06*0000> ia 12.16.12.2 01:37:20 eria/000
D &? 172.168.20.02* =10*03600> ia 12.16.12.2 01:30:13 eria/000
D &? 172.168.2.02* =10*03600> ia 12.16.12.2 01:30:13 eria/000
D &? 172.168.30.02* =10*03600> ia 12.16.12.2 01:30:13 eria/000
D &? 172.168.3.02* =10*03600> ia 12.16.12.2 01:30:13 eria/000
D &? 172.168.*0.02* =10*03600> ia 12.16.12.2 01:30:13 eria/000
D 172.168.*8.023 i a u;;ar 01:37:20 !u//0
R1#

b. !here are multiple +as to configure this filtering. (n this step% +e +ill configure an ACL that matches
these t+o net+or3. Configure the follo+ing named access list to identif the t+o routes to be filtered.
R2(config)# ip access"list standard #"3L
R2(config-t4-nac/)# re$ark 3L !sed wit te #"+,L- ro!te $ap
R2(config-t4-nac/)# per$it 192.168.25.0 0.0.0.255
R2(config-t4-nac/)# per$it 192.168.#0.0 0.0.0.255
R2(config-t4-nac/)# exit
R2(config)#

c. Configure a route map +ith a statement that denies based on a match +ith the named ACL. !hen add a
perit statement +ithout a at!h statement. !his acts as an explicit Bpermit all.
R2(config)# ro!te"$ap #"+,L- den% 10
R2(config-route-;a)# description  filters # )S*+ ro!tes

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age  of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

R2(config-route-;a)# $atc ip address #"3L


R2(config-route-;a)# exit
R2(config)# ro!te"$ap #"+,L- per$it 20
R2(config-route-;a)# description  per$its all oter # )S*+ ro!tes
R2(config-route-;a)# exit
R2(config)#

d. Appl this route map to )(*&" b reentering the redistribute command using the route-ap 3e+ord.
R2(config)# ro!ter ei&rp 1
R2(config-router)# redistrib!te ospf 1 ro!te"$ap #"+,L- $etric 64 100 255 1
1500
R2(config-router)#

e. ;erif that the t+o &$ net+or3s are filtered out in the &1 routing table.
R1# sow ip ro!te ei&rp ' be&in (atewa%
atea of /at reort i not et

12.16.0.016 i aria,/ u,nette4 8 u,net 2 ;a<


D 12.16.2.02* =70*06*0000> ia 12.16.12.2 00:02:20 eria/000
D &? 12.16.3.02* =10*03600> ia 12.16.12.2 00:02:0* eria/000
D 12.16.23.02* =70*102*000> ia 12.16.12.2 00:02:20 eria/000
D 12.16.100.02* =70*06*0000> ia 12.16.12.2 00:02:20 eria/000
D &? 172.168.20.02* =10*03600> ia 12.16.12.2 00:02:0* eria/000
D &? 172.168.3.02* =10*03600> ia 12.16.12.2 00:02:0* eria/000
D &? 172.168.*0.02* =10*03600> ia 12.16.12.2 00:02:0* eria/000
D 172.168.*8.023 i a u;;ar 00:02:31 !u//0
R1#

?otice that the12.1<:.25.0/24 and 12.1<:.$0.0/24 net+or3s are no longer in the routing table.
)tep 9' 0ilter redistributed routes and set attributes using a route ap
!he preceding step +as a simple example of using a route map to filter redistributed routes.
(n this step% +e +ill filter a route from &1 to change its metric and metric tpe.
a. ,n &$% erif the routing table entr for the routes learned externall identified +ith the 0 )2 source entr.
R3# sow ip ro!te ospf ' incl!de ) 2
 &2 12.16.1.02* =11020> ia 12.16.23.2 00:13: eria/001
 &2 12.16.2.02* =11020> ia 12.16.23.2 00:13: eria/001
 &2 12.16.12.02* =11020> ia 12.16.23.2 00:13: eria/001
R3#

!he 1>2.1<.12.0 route +ill be configured +ith additional attributes.

b. Configure a prefix list identifing the route to be filtered.

R2(config)# ip prefix"list 1"*L per$it 172.16.12.0/24


R2(config)#

c. Configure a route map matching the identified route in the prefix list and assign the metric cost of 25 and
change the metric tpe to )xternal !pe 1. !hen add a perit statement +ithout a at!h statement
acting as an explicit Bpermit all.
R2(config)# ro!te"$ap 1"+,L- per$it 10
R2(config-route-;a)# description  filters 172.16.12.0/24
R2(config-route-;a)# $atc ip address prefix"list 1"*L
R2(config-route-;a)# set $etric 25
R2(config-route-;a)# set $etric"t%pe t%pe"1

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age 10 of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

R2(config-route-;a)# exit
R2(config)# ro!te"$ap 1"+,L- per$it 20
R2(config-route-;a)# description  per$its all oter 1 )S*+ ro!tes
R2(config-route-;a)# exit
R2(config)#

d. Appl this route map to ,-"F b reentering the redistribute command using the route-ap 3e+ord.
R2(config)# ro!ter ospf 1
R2(config-router)# redistrib!te ei&rp 1 s!bnets ro!te"$ap 1"+,L-
R2(config-router)# exit
R2(config)#

e. ;erif that the t+o &$ net+or3s are filtered out in the &1 routing table.
R3# sow ip ro!te ospf ' be&in (atewa%
atea of /at reort i not et

12.16.0.016 i aria,/ u,nette4 8 u,net 2 ;a<


 &2 12.16.1.02* =11020> ia 12.16.23.2 00:02: eria/001
 &2 12.16.2.02* =11020> ia 12.16.23.2 00:02: eria/001
 &1 12.16.12.02* =11018> ia 12.16.23.2 00:02: eria/001
 'A 12.16.100.02* =110163> ia 12.16.23.2 00:02: eria/001
 172.168.8.022 i a u;;ar 00:02: !u//0
R3#

?otice that the1>2.1<.12.0/24 route is no+ a tpe 1 route a nd calculates the actual metric.

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age 11 of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

evi!e Con+igurations 6nstru!tor version

Router R*

+otna;e R1
I
interface Loo,ac<0
i a44re 12.16.1.1 2.2.2.0
I
interface Loo,ac<*8
i a44re 172.168.*8.1 2.2.2.0
I
interface Loo,ac<*7
i a44re 172.168.*7.1 2.2.2.0
I
interface Loo,ac<0
i a44re 172.168.0.1 2.2.2.0
I
interface Loo,ac<1
i a44re 172.168.1.1 2.2.2.0
I
interface Loo,ac<0
i a44re 172.168.0.1 2.2.2.0
I
interface eria/000
,an4i4t+ 6*
no i a44re
i u;;ar-a44re eigr 1 172.168.*8.0 2.2.2*.0
c/oc< rate 6*000
I
router eigr 1
netor< 12.16.0.0
netor< 172.168.0.0 0.0.2.2
I
en4

Router R2
+otna;e R2
I
interface Loo,ac<0
i a44re 12.16.2.1 2.2.2.0
I
interface Loo,ac<100
i a44re 12.16.100.1 2.2.2.0
i of netor< oint-to-oint
I
interface eria/001
,an4i4t+ 6*
i a44re 12.16.23.2 2.2.2.0
c/oc< rate 6*000
I
router eigr 1
4itri,ute-/it 920-9'LG&R out of 1
netor< 12.16.0.0
re4itri,ute of 1 ;etric 6* 100 2 1 100 route-;a R3-9'LG&R

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age 12 of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

I
router of 1
u;;ar-a44re 172.168.*8.0 2.2.22.0
re4itri,ute eigr 1 u,net route-;a R1-9'LG&R
netor< 12.16.23.0 0.0.0.2 area 0
netor< 12.16.100.0 0.0.0.2 area 10
4itri,ute-/it refiE &'R-9'LG&R out eigr 1
I
i acce-/it tan4ar4 920-9'LG&R
re;ar< Ue4 it+ 4itri,ute /it to fi/ter 9 20 route
4en 172.168.8.0 0.0.3.2
er;it an
I
i acce-/it tan4ar4 R3-AL
re;ar< AL ue4 it+ t+e R3-9'LG&R route ;a
er;it 172.168.2.0 0.0.0.2
er;it 172.168.30.0 0.0.0.2
I
I
i refiE-/it &'R-9'LG&R 4ecrition Ue4 it+ DLit to fi/ter &'R route
i refiE-/it &'R-9'LG&R e  er;it 12.16.0.016 /e 2*
I
i refiE-/it R1-L 4ecrition L ue4 it+ t+e R1-9'LG&R route ;a
i refiE-/it R1-L e  er;it 12.16.12.02*
I
route-;a R3-9'LG&R 4en 10
;atc+ i a44re R3-AL
I
route-;a R3-9'LG&R er;it 20
I
route-;a R1-9'LG&R er;it 10
4ecrition RH fi/ter 12.16.12.02*
;atc+ i a44re refiE-/it R1-L
et ;etric 2
et ;etric-te te-1
I
route-;a R1-9'LG&R er;it 20
4ecrition RH er;it a// ot+er R1 9 route
I
en4

Router R/
+otna;e R3
I
interface Loo,ac<0
i a44re 12.16.3.1 2.2.2.0
i of netor< oint-to-oint
I
interface Loo,ac<8
i a44re 172.168.8.1 2.2.2.0
i of netor< oint-to-oint
I
interface Loo,ac<7
i a44re 172.168.7.1 2.2.2.0

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age 1$ of 14
CCNPv7 ROUTE Lab 4#$% Controlling &outing 'pdates

i of netor< oint-to-oint


I
interface Loo,ac<10
i a44re 172.168.10.1 2.2.2.0
i of netor< oint-to-oint
I
interface Loo,ac<11
i a44re 172.168.11.1 2.2.2.0
i of netor< oint-to-oint
I
interface Loo,ac<20
i a44re 172.168.20.1 2.2.2.0
i of netor< oint-to-oint
I
interface Loo,ac<2
i a44re 172.168.2.1 2.2.2.0
i of netor< oint-to-oint
I
interface Loo,ac<30
i a44re 172.168.30.1 2.2.2.0
i of netor< oint-to-oint
I
interface Loo,ac<3
i a44re 172.168.3.1 2.2.2.0
i of netor< oint-to-oint
I
interface Loo,ac<*0
i a44re 172.168.*0.1 2.2.2.0
i of netor< oint-to-oint
I
interface eria/001
,an4i4t+ 6*
i a44re 12.16.23.3 2.2.2.0
I
router of 1
area 20 range 172.168.8.0 2.2.22.0
netor< 12.16.0.0 0.0.2.2 area 0
netor< 172.168.8.0 0.0.3.2 area 20
netor< 172.168.0.0 0.0.2.2 area 0
I
I
en4

© 2014 Cisco and/or its affiliates. All rights resered. !his document is Cisco "ublic. "age 14 of 14

Você também pode gostar