Você está na página 1de 47

©©

2010
2010
Cisco
Cisco
and/or
and/or
its its
affiliates.
affiliates.
AllAll
rights
rights
reserved.
reserved. Cisco Confidential 1
Junho/2011

• O objetivo deste workshop é descrever em linhas gerais a solução


adotada para o serviço VPN de Camada 2 ponto a ponto e
multiponto , explorando as configurações e os comandos básicos
de troubleshooting no switches da rede metro.

Workshop – L2L v1.0


• Objetivo

• Infraestrutura
– MPLS
– BGP
• QoS
• Serviços Lan to lan
• Conectando a Rede de Gerência
• Configurações de Gerência
Junho/2011

AL
• A Rede Metro é IM
dividida em vários GWD
clusters compostos por
SWCs e SWDs.
SWC SWD
• Os switches SWC e RC RA
OLT
SWD se conectam
entre si através de
IP/MPLS.

• Os clusters se
conectam na Rede IP SWC DSLAM
através dos SWCs que,
RC RA SWD
por sua vez, se
conectam nos
roteadores da Rede IP
denominados de SWT
Roteadores de
IM BRAS
Concentração (RC) ou
Roteadores de Acesso AL
802.1Q
(RA).
IP/MPLS

Workshop – L2L v1.0


• Objetivo
• Visão Geral da Rede Metro

– MPLS
– BGP
• QoS
• Serviços Lan to lan
• Conectando a Rede de Gerência
• Configurações de Gerência
Junho/2011

Túnel de Serviço (p2p)

Túnel de Infraestrutura (p2m) Túnel de Infraestrutura (p2m)

Rede Metro Intercluster Rede Metro

Fluxo

• Para o estabelecimento dos serviços lan to lan há necessidade de uma infra estrutura de rede, viabilizada
através do MPLS e BGP.

Workshop – L2L v1.0


• Objetivo
• Visão Geral da Rede Metro
• Infraestrutura

– BGP
• QoS
• Serviços Lan to lan
• Conectando a Rede de Gerência
• Configurações de Gerência
Junho/2011

SWD SWD
SWT SWT

Targeted
LDP

IP/MPLS

• As sessão LDP é estabelecida entre SWDs.

• As sessões LDP referidas são estabelecidas via conexão TCP (targeted ldp - porta TCP 646).

Workshop – L2L v1.0


Junho/2011

AL SWD
SWT
Targeted LDP

SWD
SWT

IP/MPLS

• As sessão LDP é estabelecida entre SWD e Intercluster.

• As sessões LDP referidas são estabelecidas via conexão TCP (targeted ldp - porta TCP 646).

Workshop – L2L v1.0


Junho/2011

Ponto a Ponto mpls ldp neighbor <ip SWD> password <pwd>

Multiponto mpls ldp neighbor <ip AL> password <pwd>

Workshop – L2L v1.0


Junho/2011

msv-swed2#show mpls ldp neighbor 200.207.194.38 det


Peer LDP Ident: 200.207.194.38:0; Local LDP Ident 200.207.194.10:0
TCP connection: 200.207.194.38.49641 - 200.207.194.10.646
Password: required, neighbor, in use
State: Oper; Msgs sent/rcvd: 79098/69256; Downstream; Last TIB rev sent 38026
Up time: 1w4d; UID: 62; Peer Id 2;
LDP discovery sources:
Targeted Hello 200.207.194.10 -> 200.207.194.38, active, passive;
holdtime: infinite, hello interval: 5000 ms
Addresses bound to peer LDP Ident:
200.207.193.178 200.207.194.38
Peer holdtime: 45000 ms; KA interval: 15000 ms; Peer state: estab
Clients: Dir Adj Client

• Autenticação do LDP, está em uso MD5.

• A distribuição de labels é compartilhada entre as interfaces.

• Tempo de duração da sessão LDP.

• Sessão direta TCP entre os SWDs (Targeted Hello)

Workshop – L2L v1.0


• Objetivo
• Visão Geral da Rede Metro
• Infraestrutura
– MPLS

• QoS
• Serviços Lan to lan
• Conectando a Rede de Gerência
• Configurações de Gerência
Junho/2011

• A estrutura do iBGP da rede Metro conta IM RC RC IM


com 2 refletores (SWCs) para rotas BGP, 1 2
sendo que ambos operam de maneira
redundante (Cluster Router Reflector).

• Os SWCs utilizam a tecnologia L3VPN


para a divulgação das rotas do serviço Cluster RRV
IPTV através de sessões MPeBGP com os
switches Imagenio SWC1 SWC2

• Troca de prefixos entre SWCs e Rede IP,


utilização do Inter-AS opção A para os
elementos de rede SWT, OLT, Dslams
Residenciais e Corporativos.

SWD1 SWD2

VRF
eBGP
iBGP

Workshop – L2L v1.0


Junho/2011

• Os roteadores SWD irão propagar suas AL AL


respectivas interfaces Loop0 no processo AS
BGP através do comando network. 10429

• Os domínios Metro Ethernet e


InterCluster fazem uso do mesmo AS AS 65XX
AS 65YY
(10429). Portanto, foi necessário utilizar
a funcionalidade denominada Local-AS
para viabilizar a conexão E-BGP na
SWC1 SWC2 SWC1 SWC2
interface AL-SWC.

• O estabelecimento das sessões BGP com


AS
a opção ipv4+labels permitiu a troca de 10429
prefixos e de labels necessários a
construção de um LSP entre o SWD-AL e
SWD-SWD intercluster, visando ao
transporte de aplicações MPLS L2VPN. SWD1 SWD2 SWD1 SWD2

eBGP
iBGP

Workshop – L2L v1.0


Junho/2011

• A solução do Inter-AS entre a rede InterCluster e a rede Metro requer a utilização da funcionalidade local-
as (fake-as) para esconder o fato dos domínios citados utilizarem o mesmo AS.

• Neste caso, a funcionalidade deve ser ativada nas duas pontas do pearing e-bgp, com as opções que
retiram o AS original do AS-PATH. Desta maneira o SWD observa o AS-PATH de um prefixo originado na
rede IC com apenas o 65000 e o AL observa o AS-PATH de um prefixo originado na rede METRO, em
exemplo, com apenas 64623.
Workshop – L2L v1.0
Junho/2011

• O identificador de AS será único para cada cluster e usará o range de ASes privados. (Tabela já definida
pela OPA).

• O protocolo BFD foi ativado nas sessões e-BGP entre a rede IC e a rede Metro, tendo em vista que o
sistema de transmissão destes enlaces é DWDM, salvo o caso de conexões entre equipamentos
colocalizados.

• A Rede IC não aplicará filtro na propagação de prefixos para rede Metro. Portanto, um determinado
cluster Metro Ethernet possuirá os prefixos dos outros clusteres.
Workshop – L2L v1.0
Junho/2011

Cluster RR

SWC1 SWC2
Ip loop0/32 ;

Ip loop0/32 ;
label

label
SWD1 SWD2

iBGP

• Na rede Metro Ethernet da Telesp as sessões iBGP ipv4 deverão ser ativadas dentro do cluster seguindo os
princípios arquiteturais definidos pelo serviço de consultoria METRO2008- Router Reflector VPNV4, ou
seja, SWCs operando como RR e SWDs com sessões iBGP para os refletores. Os SWDs enviarão mensagens
de update aos SWCs contendo: a NRLI e um Label para a sua interface loopback0.

Workshop – L2L v1.0


Junho/2011

AL AL

; label
Ip loop0/32

; label
Ip loop0/32
Cluster RR

SWC1 SWC2
Ip loop0/32

Ip loop0/32
; label

; label
SWD1 SWD2 eBGP
iBGP

• As sessões eBGP serão iniciadas nos SWCs e destinadas as interfaces físicas dos roteadores do intercluster
(AL). O principal objetivo deste pearing será a o envio dos prefixos+labels das interfaces loopback0 dos
SWDs e o recebimento dos prefixos+labels das loopbacks0 dos roteadores AL.

• A interface física de interconexão entre o SWC e o AL não é propagada no IGP da rede Metro Ethernet.
Para evitar problemas de conectividade, as mensagens de UPDATE recebidas do roteador AL têm o seu
next-hop alterado para a interface Loopback 0 do SWC receptor da mensagem.

Workshop – L2L v1.0


Junho/2011

• O SWD1 e o SWD3 irão sair respectivamente por SWC1 e SWC2, uma vez que irão decidir o NH para os
prefixos da rede InterCluster baseados na métrica do IGP.

• O SWD2 irá definir a sua saída para os prefixos da rede InterCluster baseado no router-id dos SWCs.
Portanto, foi dada a orientação que o menor router-id de um cluster Metro sempre seja o do SWC1.

Workshop – Backbone Intercluster v1.0


Junho/2011

• Os endereços ipv4 das Loopbacks0 dos SWDs devem ser marcados com a community que identifique sua
posição no anel.

• Os roteadores do InterCLuster fazem uso da community para atribuir um local-preference para o prefixo
da rede Metro e definem o NH com base no roteador que apresentar a maior local-preference.

Workshop – L2L v1.0


Junho/2011

msv-swed2#show ip bgp su
BGP router identifier 200.207.194.10, local AS number 27699
BGP table version is 517, main routing table version 517
10 network entries using 1210 bytes of memory
19 path entries using 988 bytes of memory
31/8 BGP path/bestpath attribute entries using 2356 bytes of memory
4 BGP rrinfo entries using 96 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
BGP using 5170 total bytes of memory
Dampening enabled. 0 history paths, 0 dampened paths
BGP activity 1445/1385 prefixes, 2804/2700 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd


200.207.194.8 4 27699 4803 3526 517 0 0 2d16h 9
200.207.194.50 4 27699 9119 8895 517 0 0 6d20h 9

• Síntese das sessões bgp por neighbor.

• Quantidade de prefixos recebidos por neighbor.

• Tempo da sessão BGP ativa por neighbor.

• Informação de consumo de memória das entradas especificas do BGP.

Workshop – L2L v1.0


Junho/2011

msv-swec2#show ip bgp su
BGP router identifier 200.207.194.50, local AS number 27699
BGP table version is 84, main routing table version 84
9 network entries using 1089 bytes of memory
16 path entries using 832 bytes of memory
BGP using 5201 total bytes of memory
Dampening enabled. 0 history paths, 0 dampened paths
BGP activity 176/70 prefixes, 213/100 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
200.207.194.8 4 27699 19817 19776 84 0 0 2w1d 7
200.207.194.10 4 27699 19721 19835 84 0 0 2w1d 1
200.207.194.71 4 27699 24051 19824 84 0 0 2w1d 1
200.207.237.201 4 65000 21873 19706 84 0 0 2w1d 7

• Síntese das sessões bgp por neighbor.

• Quantidade de prefixos recebidos por neighbor.

• Tempo da sessão BGP ativa por neighbor.

• Informação de consumo de memória das entradas especificas do BGP.

Workshop – L2L v1.0


Junho/2011

msv-swed2>sh ip bgp
BGP table version is 642, local router ID is 200.207.194.10
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


*> 200.207.194.10/32
0.0.0.0 0 32768 i
* i200.207.194.38/32
200.207.194.8 0 100 0 65000 65003 i
*>i 200.207.194.50 0 100 0 65000 65003 i
* i200.207.194.64/32
200.207.194.8 0 100 0 65000 i
*>i 200.207.194.50 0 100 0 65000 i

• Identificação do next-hop do prefixo recebido a partir do Switch de Concentração, para determinação do


caminho de saída de um LSP.

• Identificador >, indica que é o next-hop que esta foi instalado na tabela de roteamento.

• A partir do AS-PATH é possivel a identificação da origem do Cluster Metro que anuncia determinado
prefixo.

Workshop – L2L v1.0


Junho/2011

msv-swec2>show ip bgp
BGP table version is 164, local router ID is 200.207.194.50
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


r>i200.207.194.10/32
200.207.194.10 0 100 0i
* i200.207.194.38/32
200.207.194.8 0 100 0 65000 65003 i
*> 200.207.237.201 0 65000 65003 i
* i200.207.194.84/32
200.207.194.8 0 100 0 65000 65001 65000 i
*> 200.207.237.201 0 65000 65001 65000 i

• Identificação do next-hop do prefixo recebido a partir do Switch de Concentração, para determinação do


caminho de saída de um LSP.

• Identificador >, indica que é o next-hop que esta foi instalado na tabela de roteamento.

• A partir do AS-PATH é possivel a identificação da origem do Cluster Metro que anuncia determinado
prefixo.
Workshop – L2L v1.0
Junho/2011

msv-swec2>sh ip bgp label


Network Next Hop In label/Out label
200.207.194.3/32 200.207.194.8 43/139
200.207.237.201 43/21410
200.207.194.4/32 200.207.194.8 39/156
200.207.237.201 39/21411
200.207.194.10/32
200.207.194.10 23(from LDP)/imp-null
200.207.194.38/32
200.207.194.8 40/126
200.207.237.201 40/21413
200.207.194.84/32
200.207.194.8 38/157
200.207.237.201 38/21415

• A partir da existencia dos labels de transporte (entrada / saída) o caminho de um determinado LSP é
monitorado.

• Imp-Null , PHP (Penultimate Hop Popping) padrão nos equipamentos Cisco.

Workshop – L2L v1.0


Junho/2011

msv-swed2>sh ip bgp label


Network Next Hop In label/Out label
200.207.194.3/32 200.207.194.8 nolabel/139
200.207.194.50 nolabel/43
200.207.194.4/32 200.207.194.8 nolabel/156
200.207.194.50 nolabel/39
200.207.194.10/32
0.0.0.0 imp-null(from LDP)/nolabel
200.207.194.38/32
200.207.194.8 nolabel/126
200.207.194.50 nolabel/40
200.207.194.84/32
200.207.194.8 nolabel/157
200.207.194.50 nolabel/38

• A partir da existencia dos labels de transporte (entrada / saída) o caminho de um determinado LSP é
monitorado.

• Imp-Null , nolabel o prefixo foi gerado pelo próprio equipamento.

Workshop – L2L v1.0


• Objetivo
• Visão Geral da Rede Metro
• Infraestrutura
– MPLS
– BGP

• Serviços Lan to lan


• Conectando a Rede de Gerência
• Configurações de Gerência
Junho/2011

Arquitetura de QoS da rede Metro Ethernet

• A arquitetura de QoS da rede Metro Ethernet da Telesp trabalha com quatro classes de serviço (REALTIME,
VÍDEO, BUSINESS e BE) configuradas em interfaces do módulo WS-6704. Este módulo possui um sistema
de filas para transmissão do tipo 1p7q8t, onde o “p” é de priority queue, o “q”de queue (fila normal) e o
“t”de thereshold.

Workshop – L2L v1.0


Junho/2011

Marcações de QoS de SWT para rede Metro Ethernet

• O domínio SWT trabalhará com as seguintes aplicações pertinentes ao serviço Lan-to-Lan:

• Gerencia: tráfego de gerencia de dispositivos (SWTs).

• Dados: tráfego do serviço lan-to-lan ponto-a-ponto e multiponto.

• O SWD confia nas marcações de COS recebidas a partir do Switch Terminal.

• O Traffic Shapping é efetuado a partir dos SWTs.

Workshop – L2L v1.0


• Objetivo
• Visão Geral da Rede Metro
• Infraestrutura
– MPLS
– BGP
• QoS

• Conectando a Rede de Gerência


• Configurações de Gerência
Junho/2011

Cenário I

SWD SWD
SWT SWT
PW

Cluster A Cluster B
IP/MPLS

802.1Q
IP/MPLS

• Conexão do túnel de infra-estrutura entre SWDs.

• O túnel de infra-estrutura faz uso da tecnologia L2VPN-AToM.

Workshop – L2L v1.0


Junho/2011

P2P Cenário I
!
interface GigabitEthernet <S/P>
description <DESCRIPTION>
no switchport
mtu 1546
no ip address
logging event link-status
logging event bundle-status
logging event spanning-tree !
load-interval 30 interface GigabitEthernet <S/P>.<VLAN-ID>
carrier-delay msec 0 description <DESCRIPTION>
wrr-queue bandwidth 50 150 150 encapsulation dot1Q <VLAN-ID>
wrr-queue queue-limit 14 43 43 xconnect <IP-SWD-REMOTE> <PW-ID> encapsulation mpls
wrr-queue threshold 3 50 100 1 1 1 1 1 1 !
wrr-queue random-detect min-threshold 2 5 30 1 1 1 1 1 1
wrr-queue random-detect max-threshold 2 30 100 1 1 1 1 1 1
no wrr-queue random-detect 3
wrr-queue cos-map 2 1 1
wrr-queue cos-map 2 2 2
wrr-queue cos-map 3 1 4
wrr-queue cos-map 3 2 3
priority-queue cos-map 1 5 6 7
mls qos trust cos
flowcontrol send off
spanning-tree portfast trunk
spanning-tree bpdufilter enable
hold-queue 4096 in
!

Work Shop – L2L v1.0


Junho/2011

Cenário II

SWD SWD
SWT SWT
PW

Cluster A Cluster B
IP/MPLS

802.1Q
IP/MPLS

• Conexão do túnel de infra-estrutura entre SWDs

• O túnel de infra-estrutura faz uso da tecnologia L2VPN-AToM.

• Utilização do LAG, configuração channel mode ON.

Workshop – L2L v1.0


Junho/2011

P2P Cenário II
!
interface GigabitEthernet <S/P>
description <DESCRIPTION>
no switchport
mtu 1546 !
no ip address interface Port-channel<PO-ID>
logging event link-status description <DESCRIPTION>
logging event bundle-status mtu 1546
logging event spanning-tree no ip address
load-interval 30 logging event link-status
carrier-delay msec 0 logging event bundle-status
wrr-queue bandwidth 50 150 150 logging event spanning-tree
wrr-queue queue-limit 14 43 43 load-interval 30
wrr-queue threshold 3 50 100 1 1 1 1 1 1 carrier-delay msec 0
wrr-queue random-detect min-threshold 2 5 30 1 1 1 1 1 1 mls qos trust cos
wrr-queue random-detect max-threshold 2 30 100 1 1 1 1 1 1 flowcontrol send off
no wrr-queue random-detect 3 spanning-tree portfast trunk
wrr-queue cos-map 2 1 1 spanning-tree bpdufilter enable
wrr-queue cos-map 2 2 2 hold-queue 4096 in
wrr-queue cos-map 3 1 4 !
wrr-queue cos-map 3 2 3 !
priority-queue cos-map 1 5 6 7 interface Port-channel<PO-ID>.<VLAN-ID>
mls qos trust cos description <DESCRIPTION>
flowcontrol send off encapsulation dot1Q <VLAN-ID>
spanning-tree portfast trunk xconnect <IP-SWD-REMOTE> <PW-ID> encapsulation mpls
spanning-tree bpdufilter enable !
channel-group <PO-ID> mode on
hold-queue 4096 in
!

Work Shop – L2L v1.0


Junho/2011

Cenário I

AL BGP: sinalização e AL
descobrimento

Instância
VPLS

PW PW
SWD SWD
SWT SWT
PW-BKP

Cluster A Cluster B

802.1Q
IP/MPLS

• Conexão do túnel de infra-estrutura Ativo e Backup entre SWDs e AL.

• O túnel de infra-estrutura faz uso da tecnologia L2VPN-AToM.

Workshop – L2L v1.0


Junho/2011

P2M Cenário I
!
interface GigabitEthernet<S/P>
description <DESCRIPTION>
no switchport
mtu 1546
no ip address
logging event link-status
logging event bundle-status
logging event spanning-tree
load-interval 30
!
carrier-delay msec 0
interface GigabitEthernet <S/P>.<VLAN-ID>
wrr-queue bandwidth 50 150 150
description <DESCRIPTION>
wrr-queue queue-limit 14 43 43
encapsulation dot1Q <VLAN-ID>
wrr-queue threshold 3 50 100 1 1 1 1 1 1
xconnect <IP-AL-PRINCIPAL> <PW-ID> encapsulation mpls
wrr-queue random-detect min-threshold 2 5 30 1 1 1 1 1 1
backup peer <IP-AL-REDUNDANTE> <PW-ID+10K>
wrr-queue random-detect max-threshold 2 30 100 1 1 1 1 1 1
!
no wrr-queue random-detect 3
wrr-queue cos-map 2 1 1
wrr-queue cos-map 2 2 2
wrr-queue cos-map 3 1 4
wrr-queue cos-map 3 2 3
priority-queue cos-map 1 5 6 7
mls qos trust cos
flowcontrol send off
spanning-tree portfast trunk
spanning-tree bpdufilter enable
hold-queue 4096 in
!

Work Shop – L2L v1.0


Junho/2011

Cenário II

AL BGP: sinalização e AL
descobrimento

Instância
VPLS

PW PW
SWD SWD
SWT SWT
PW-BKP

Cluster A Cluster B

802.1Q
IP/MPLS
• Conexão do túnel de infra-estrutura Ativo e Backup entre SWDs e AL.

• O túnel de infra-estrutura faz uso da tecnologia L2VPN-AToM.

• Utilização do LAG, configuração channel mode ON.


Workshop – L2L v1.0
Junho/2011

P2M Cenário II
!
interface GigabitEthernet <S/P> !
description <DESCRIPTION> !
no switchport interface Port-channe <PO-ID>
mtu 1546 description <DESCRIPTION>
no ip address mtu 1546
logging event link-status no ip address
logging event bundle-status logging event link-status
logging event spanning-tree logging event bundle-status
load-interval 30 logging event spanning-tree
carrier-delay msec 0 load-interval 30
wrr-queue bandwidth 50 150 150 carrier-delay msec 0
wrr-queue queue-limit 14 43 43 mls qos trust cos
wrr-queue threshold 3 50 100 1 1 1 1 1 1 flowcontrol send off
wrr-queue random-detect min-threshold 2 5 30 1 1 1 1 1 1 spanning-tree portfast trunk
wrr-queue random-detect max-threshold 2 30 100 1 1 1 1 1 1 spanning-tree bpdufilter enable
no wrr-queue random-detect 3 hold-queue 4096 in
wrr-queue cos-map 2 1 1 !
wrr-queue cos-map 2 2 2 !
wrr-queue cos-map 3 1 4 interface Port-channel<PO-ID>.<VLAN-ID>
wrr-queue cos-map 3 2 3 description <DESCRIPTION>
priority-queue cos-map 1 5 6 7 encapsulation dot1Q <VLAN-ID>
mls qos trust cos xconnect <IP-AL-PRINCIPAL> <PW-ID> encapsulation mpls
flowcontrol send off backup peer <IP-AL-REDUNDANTE> <PW-ID+10K>
spanning-tree portfast trunk !
spanning-tree bpdufilter enable
channel-group <PO-ID> mode on
hold-queue 4096 in

Work Shop – L2L v1.0


Junho/2011

14 Bytes 4 Bytes 4 Bytes 4 Bytes

DOMÍNIO METRO ETHERNET Eth-II Label1 Label2 Label3 Dados

MPLS MTU = 1546 Bytes

FRAME MTU MAX = 1546 – 12= 1534 Bytes

Acesso Eth-II dot1Q Dados

• Payload Frame Ethernet entre SWD e SWT máximo = 1534, no adicionamento de funcionalidades
futuras, este valor será revisto.

Workshop – L2L v1.0


Junho/2011

msv-swed2#show mpls l2transport vc 2888 det


Local interface: Gi2/17.2888 up, line protocol up, Eth VLAN 2888 up
MPLS VC type is Eth VLAN, interworking type is Ethernet
Destination address: 200.207.194.65, VC ID: 2888, VC status: up
Output interface: Te7/4, imposed label stack {45 16092}
Next hop: 200.207.195.241
Create time: 2d04h, last status change time: 00:37:35
Signaling protocol: LDP, peer 200.207.194.65:0 up
Targeted Hello: 200.207.194.10(LDP Id) -> 200.207.194.65
MPLS VC labels: local 72, remote 16092
Group ID: local 0, remote 4
MTU: local 1546, remote 1546
Remote interface description: Access PW
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 98196998, send 38050474
byte totals: receive 150640198640, send 24009688748
packet drops: receive 0, send 0

• Sinalização Targeted LDP, entre os SWDs que não estão diretamente conectados.

• Atentar ao MTU local e remoto que devem ser iguais nos endpoints dos tuneis pois caso contrario o
pseudowire não é estabelecido.
Workshop – L2L v1.0
Junho/2011

msv-swed2#sh int port-channel 15


Port-channel15 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 0014.1bc4.4800 (bia 0014.1bc4.4800)
Description: lag Alcatel / Huawei p2m
MTU 1546 bytes, BW 2000000 Kbit, DLY 10 usec,
reliability 255/255, txload 0/255, rxload 0/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
Keepalive set (10 sec)
Carrier delay is 0 msec
Full-duplex, 1000Mb/s
input flow-control is off, output flow-control is off
Members in this channel: Gi2/15 Gi2/16
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 12306000 bits/sec, 1001 packets/sec
30 second output rate 12305000 bits/sec, 1000 packets/sec

• Atentar se o LAG esta operacional

• Atentar ao trafego de entrada e saida do LAG.

Workshop – L2L v1.0


Junho/2011

msv-swed2#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status


------------- -------------------------- --------------- ---------- ----------
Gi2/14.3611 Eth VLAN 3611 187.100.0.87 3611 DOWN
Gi2/14.3611 Eth VLAN 3611 187.100.0.88 13611 DOWN
Gi2/12.12 Eth VLAN 12 200.207.194.8 12 DOWN
Te7/1.41 Eth VLAN 41 200.207.194.8 41 DOWN
Gi2/11.187 Eth VLAN 187 200.207.194.8 187 DOWN
Gi2/11.239 Eth VLAN 239 200.207.194.8 239 DOWN
Gi2/13 Ethernet 200.207.194.8 888 DOWN
Po15.2889 Eth VLAN 2889 200.207.194.64 12889 DOWN
Po100.190 Eth VLAN 171 200.207.194.65 200 UP
Gi2/17.2888 Eth VLAN 2888 200.207.194.65 2888 UP
Po15.2889 Eth VLAN 2889 200.207.194.65 2889 UP
Gi2/21.2882 Eth VLAN 2882 200.207.194.84 2882 ADMIN DOWN
Po5.2886 Eth VLAN 2886 200.207.194.84 2886 DOWN
Gi6/2 Ethernet 200.207.194.205 1100 DOWN

• Sumario dos tuneis configurados no SWD.

Workshop – L2L v1.0


• Objetivo
• Visão Geral da Rede Metro
• Infraestrutura
– MPLS
– BGP
• QoS
• Serviços Lan to lan

• Configurações de Gerência
Junho/2011

Centro
de Gerência
Rede IP
AS 27699

RC4 RC5

VRF VRF
SubInterface SubInterface

SWC1 SWC2

IP/MPLS
AS 27699

SWD3 SWD2
VRF
SubInterface VRF
SubInterface

SWT SWT

• SubInterfaces de gerência especificas para cada SWT, endereçamento /30, divulgação das rotas de
gerencia dos SWTs é via roteamento estatico, faixa de Vlans utilizadas para gerencia 3561 a 3600 40 SWTs
por SWD.
Workshop – L2L 1.0
Junho/2011

SWD SWC
!
ip vrf V2524:GERENCIA-SWT !
rd 10429:2502 route-map EXPORT-GERENCIA-DSLAM-VPNIP permit 10
route-target export 10429:6309 set extcommunity rt 10429:6308 additive
route-target import 10429:6308 !
! ip vrf GERENCIA-DSLAM-VPNIP
! rd 27699:3
interface GigabitEthernet <S/P>.<VLAN-ID> export map EXPORT-GERENCIA-DSLAM-VPNIP
description <DESCRIPTION> route-target export 27699:3
encapsulation dot1Q <VLAN-ID> route-target import 27699:4
ip vrf forwarding V2524:GERENCIA-SWT route-target import 10429:6309
ip address <IP> <MASK> !
! !
! interface GigabitEthernet <S/P>.<VLAN-ID>
interface Port-channel<PO-ID>.<VLAN-ID> description <DESCRIPTION>
description <DESCRIPTION> encapsulation dot1Q <VLAN-ID>
encapsulation dot1Q <VLAN-ID> ip vrf forwarding GERENCIA-DSLAM-VPNIP
ip vrf forwarding V2524:GERENCIA-SWT ip address <IP> <MASK>
ip address <IP> <MASK> !
! !
router bgp 10429
!
address-family ipv4 vrf V2524:GERENCIA-SWT
no synchronization
redistribute connected
exit-address-family
!

Workshop – L2L v1.0


Junho/2011

Obrigado

Você também pode gostar