Você está na página 1de 64

INSTITUTO SUPERIOR POLITÉCNICO DE TECNOLOGIAS E CIÊNCIAS

Proposta de criação de uma rede


convergente para a empresa ZAP FIBRA

Nome: Idílio Casimiro


Nº de processo: 20140981

Engenharia Informática, 4º ano

Luanda, 2017
Índice

Introdução ...................................................................................................................... 3
Definição dos requisitos ................................................................................................ 4
Objectivo geral ........................................................................................................... 4
Objectivos específicos............................................................................................... 4
Ferramentas utilizadas ............................................................................................... 4
1. Configuração do MPLS VPN..................................................................................... 5
1.2 Habilitar o MPLS .................................................................................................... 6
1.3 Configuração das VRFs ....................................................................................... 7
1.4 Configuração do MP-BGP nos PE ...................................................................... 9
1.5 Configuração do OSPF entre o PE-CE ............................................................ 11
1.6 Configuração da redistribuição de rotas ....................................................... 12
2. Configuração do Tunel (VPN) ................................................................................ 13
3. Configuração de ACLs ........................................................................................... 15
4. Configuração do CME ............................................................................................ 16
5. Diagrama geral da rede ........................................................................................ 18
6. Anexos ....................................................................................................................... 20
6.1 Configuração R1 ................................................................................................ 20
6.2 Configuração R2 ................................................................................................ 26
6.3 Configuração R3 ................................................................................................ 32
6.4 Configuração R4 ................................................................................................ 37
6.5 Configuração R5 ................................................................................................ 42
6.6 Configuração R6 ................................................................................................ 48
6.7 Configuração SW01 (R7) ................................................................................... 54
6.7 Configuração SW02 (R8) ................................................................................... 59
Introdução
A ZAP é uma empresa pioneira no mercado angolano quando se trata de
fornecimento de serviços de internet e televisão por fibra óptica. A empresa
começou com a distribuição do serviço em 2015 contando na altura com um
Datacenter localizado no seu edifício sede, em Talatona.

Hoje tem no total três datacenters distribuídos ao longo da província de Luanda,


com previsão de expansão para as outras províncias do país dentro em breve.

Actualmente conta com mais de 20.000 clientes apenas no serviço de fibra, o


que representa uma difusão do serviço inimaginável e cada vez mais crescente,
visto ter quase apenas dois anos neste mercado.

“Este serviço veio revolucionar o mercado de oferta de TV e de Internet em


Angola. A partir de agora vai viver a melhor experiência de Televisão porque vai
poder ver do início os programas que já começaram, assistir a milhares de filmes
no maior Videoclube do país, aceder à programação até 7 dias para trás e
gravar 500 horas de conteúdos. A sua experiência de Internet irá permitir-lhe
navegar com as velocidades mais rápidas de sempre, ao melhor preço e com
a melhor qualidade” – afirma a equipa de marketing da empresa.
Definição dos requisitos

Após uma interação com a equipa de engenheiros da empresa ZAP, definiu-se


o escopo do projecto e os principais pontos a serem respeitados. Foram
analisados aspectos como abrangência da rede, número de computadores,
pontos de acesso, switchs, routers, terminais ou pontos wifi, dentre outros.

Objectivo geral

Apresentar uma proposta de rede convergente para a empresa ZAP FIBRA,


contemplando as soluções de dados e voz.

Objectivos específicos

 Comunicar adequadamente as províncias de Luanda e Benguela


 Por questões de segurança e eficácia da rede, a mesma deverá ser
dividida em vlans e regras de acesso para cada um dos serviços
suportados pelos sites (ACLs);
 Devera ser configurada uma VPN para 4 trabalhadores expatriados que
operam em Benguela;
 A configuração de telefonia devera ser feita entre os CALL MANAGER de
Luanda e Benguela para diminuir os custos de comunicação;

 Todas as impressoras de cada site deverão operar em vlans específicas;
 Deverá ser utilizada a tecnologia MPLS

Ferramentas utilizadas

Numa fase inicial de apresentação de proposta, foi necessário simular o


ambiente de rede que se pretende implementar, para tal foi utilizado o GNS3,
VirtualBox, Imagens do Windows XP para as máquinas virtuais, e o Cisco IP
comunicator para simular os telefones.
1. Configuração do MPLS VPN

Para a comunicação entre os dois sites é necessária a configuração do protocolo


MPLS, segundo os critérios estabelecidos para a criação da rede convergente em
questão. Para o MPLS necessitamos de dois Core Routers que terão a função de
analizar as tags colocadas para identificar cada rede e mais dos PEs (Provider
Edges) Routers, que terão a ligação directa com os clientes e serão responsáveis
por colocar as tags.

A topologia de rede a ser configurada será:

Para a implementação total vamos utilizar, portanto:

 P (Provider routers) - routers do ISP que não conectam-se a clientes


nenhuns e são responsáveis por “executar/correr” o mpls
 PE (provider edge) – routers que conectam aos clientes e que têm
configurados a VPN
 CE (customer edge) – routers dos clientes e que conectam aos PE routers
 MP-BGP na adjacência dos provedores e que deverá ser configurado nos
PEs routers

Como protocolo de roteamento, utilizar-se-á o OSPF, tanto internamente,


dentro da rede do provedor, quanto do lado do cliente.

Existem 5 tarefas básicas a cumprir para que tenhamos o MPLS VPN a funcionar na
sua totalidade:

1. Habilitar o MPLS no backbone dos provedores


2. Criar VRFs e associa-las as interfaces correspondentes
3. Configurar MP-BGP entre os PE routers
4. Configurar o OSPF entre os PE routers e os clientes associados (CE routers)
5. Habilitar a redistribuição de rotas entre a rede dos clientes (sites) e o
backbone do provedor

1.2 Habilitar o MPLS

Primeiramente precisamos de habilitar o MPLS entre todos os links do backbone do


provedor com o comando mpls ip. Há que se ter em atenção que o MPLS não deve
ser habilitado em nenhuma das interfaces ligadas aos clientes. Os CE não dever
executar o MPLS, apenas o IP deve ser configurado neles e o LDP deve ser habilitado
automaticamente como label de redistribuição padrão.

Podemos verificar o estado das interfaces de mpls com o comando show mpls
interfaces.

PE01(config)# interface f0/0

PE01(config-if)# mpls ip

PE01(config-if)# interface f0/1

PE01(config-if)# mpls ip

PE01(config-if)# do show mpls interfaces

Interface IP Tunnel Operational

FastEthernet0/0 Yes (ldp) No Yes

FastEthernet0/1 Yes (ldp) No Yes

PE02(config)# interface f0/0

PE02(config-if)# mpls ip

PE02(config-if)# interface f0/1

PE02(config-if)# mpls ip

PE02(config-if)# do show mpls interfaces

Interface IP Tunnel Operational

FastEthernet0/0 Yes (ldp) No Yes


FastEthernet0/1 Yes (ldp) No Yes

As adjacências entre os routers podem ser verificadas com o comando show mpls
ldp neighbor

PE01#sh mpls ldp neighbor

Peer LDP Ident: 4.4.4.4:0; Local LDP Ident 5.5.5.5:0

TCP connection: 4.4.4.4.646 - 5.5.5.5.54874

State: Oper; Msgs sent/rcvd: 117/118; Downstream

Up time: 01:33:18

LDP discovery sources:

FastEthernet0/1, Src IP addr: 10.10.10.10

Addresses bound to peer LDP Ident:

10.10.10.14 4.4.4.4 10.10.10.10

Peer LDP Ident: 3.3.3.3:0; Local LDP Ident 5.5.5.5:0

TCP connection: 3.3.3.3.646 - 5.5.5.5.38958

State: Oper; Msgs sent/rcvd: 116/116; Downstream

Up time: 01:33:18

LDP discovery sources:

FastEthernet0/0, Src IP addr: 10.10.10.2

Addresses bound to peer LDP Ident:

10.10.10.2 3.3.3.3 10.10.10.5

PE01#

1.3 Configuração das VRFs

O nosso próximo passo é criar as vfrs para os clientes nos nossos PE routers e associa-
las as interfaces que vão conectar directamente aos CEs. É necessário associar um
RD (routers distinguisher) a cada vrf para identificar univocamente os prefixos que
pertencem a determinada vrf e um RT (router target) para especificar como as rotas
devem ser importadas e exportadas da vrf.
Vamos usar o RD para cada vrf no formato <ASN>:<customer number>. Para
questões de simplicidade, utilizar-se-á o mesmo ASN para o RT (quer para
importação, quer para exportação).

A configuração das VRFs deve ser feita nos dos PE routers.

PE01(config)# ip vrf LUANDA

PE01(config-vrf)# rd 65000:1

PE01(config-vrf)# route-target both 65000:1

PE02(config)# ip vrf BENGUELA

PE02(config-vrf)# rd 65000:1

PE02(config-vrf)# route-target both 65000:1

O comando route-target both é utilizado com atalho para dois comando: route-
target import e route-target export, que aparecem separadamente na
configuração do router.

Agora precisamos de aplicar as vrfs para as interfaces correspondentes e reaplicar


os IPs a tais interfaces (aplicar uma vrf à uma interface faz com que
automaticamente tal interface perca o seu IP).

PE01(config)# interface s1/0

PE1(config-if)# ip vrf forwarding LUANDA

% Interface FastEthernet0/0 IP address 172.16.0.1 removed due to enabling VRF Custom


er_A

PE1(config-if)# ip address 172.16.0.1 255.255.255.252

PE1# show ip vrf interfaces

Interface IP-Address VRF Protocol

Se1/0 172.16.0.1 LUANDA up

PE2(config)# interface s1/0

PE2(config-if)# ip vrf forwarding BENGUELA

% Interface FastEthernet0/0 IP address 172.16.0.5 removed due to enabling VRF Custom


er_A
PE2(config-if)# ip address 172.16.0.5 255.255.255.252

PE2# show ip vrf interfaces

Interface IP-Address VRF Protocol

Se1/0 172.16.0.5 BENGUELA up

1.4 Configuração do MP-BGP nos PE

De forma a dar a conhecer aos PEs quais as vrfs que cada um possui, é necessário
configurar o BGP em cada um deles. O MP-BGP é ligeiramente diferente do bgp
padrão, pois ele suporta várias versões do protocolo IP (IPv4 e IPv6) dentro de uma
adjacência bgp. Ele também trabalha com rotas VPN que são maiores que as rotas
normais por causa dos 64 bits do RD (configurado na vrf).

O MP-BGP é configurado apenas nos PEs; os core routers preocupam-se apenas em


encaminhar o tráfego do MPLS e gerenciar as tags. De forma complementar os CEs
não têm conhecimento de nenhuma rota fora da vrf à que estes se encontram
associados.

Configuração do MP-BGP

PE1(config)# router bgp 65000

PE1(config-router)# neighbor 6.6.6.6 remote-as 65000

PE1(config-router)# neighbor 6.6.6.6 update-source loopback 0

PE1(config-router)# address-family vpnv4

PE1(config-router-af)# neighbor 6.6.6.6 activate

PE2(config)# router bgp 65000

PE2(config-router)# neighbor 5.5.5.5 remote-as 65000

PE2(config-router)# neighbor 5.5.5.5 update-source loopback 0

PE2(config-router)# address-family vpnv4

PE2(config-router-af)# neighbor 5.5.5.5 activate


Para confirmar as configurações a nível de BGP em cada PE executamos o
comando show running-config | section router bgp

PE01#show running-config | section router bgp

router bgp 65000

no synchronization

bgp log-neighbor-changes

neighbor 6.6.6.6 remote-as 65000

neighbor 6.6.6.6 update-source Loopback0

no auto-summary

address-family vpnv4

neighbor 6.6.6.6 activate

neighbor 6.6.6.6 send-community extended

exit-address-family

address-family ipv4 vrf LUANDA

redistribute ospf 2 vrf LUANDA

no synchronization

exit-address-family

PE01#

Para verificar que o BGP está configurado correctamente entre os dois PEs
executamos o comando show bgp vpn4 unicast all summary

PE01#show bgp vpnv4 unicast all summary

BGP router identifier 5.5.5.5, local AS number 65000

BGP table version is 13, main routing table version 13

6 network entries using 840 bytes of memory

6 path entries using 408 bytes of memory

5/4 BGP path/bestpath attribute entries using 620 bytes of memory


2 BGP extended community entries using 80 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory

BGP using 1980 total bytes of memory

BGP activity 6/0 prefixes, 6/0 paths, scan interval 15 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

6.6.6.6 4 65000 70 70 13 0 0 01:03:31 3

1.5 Configuração do OSPF entre o PE-CE

Após a configuração do MP-BGP é necessário que configuremos um protocolo para


reteamento com os clientes associados ou ligados aos PEs. Para isto vamos utilizar o
OSPF.

PE1(config)# router ospf 2 vrf LUANDA

PE1(config-router)# router-id 172.16.0.1

PE1(config-router)# interface s1/0

PE2(config)# router ospf 2 vrf BENGUELA

PE2(config-router)# router-id 172.16.0.5

PE2(config-router)# interface s1/0

Após isto já conseguimos ver as rotas associadas a cada vrf

PE01#sh ip route vrf LUANDA

Routing Table: LUANDA

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2


i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 2 subnets

B 172.16.0.4 [200/0] via 6.6.6.6, 01:17:46

C 172.16.0.0 is directly connected, Serial1/0

172.21.0.0/24 is subnetted, 2 subnets

B 172.21.1.0 [200/74] via 6.6.6.6, 01:17:46

B 172.21.0.0 [200/74] via 6.6.6.6, 01:17:46

172.20.0.0/24 is subnetted, 2 subnets

O 172.20.0.0 [110/74] via 172.16.0.2, 01:19:16, Serial1/0

O 172.20.1.0 [110/74] via 172.16.0.2, 01:19:16, Serial1/0

PE01#

1.6 Configuração da redistribuição de rotas

Até ao momento já temos o nosso backbone com MPLS em funcionamento, o BGP


entre os PEs configurados e as VRFs também. O próximo passo é fazer a
redistribuição de rotas do lado do cliente dentro do BGP que está a ser executado
nos PEs.

PE1(config)# router bgp 65000

PE1(config-router)# address-family ipv4 vrf LUANDA

PE1(config-router-af)# redistribute ospf 2

PE2(config-router)# address-family ipv4 vrf BENGUELA

PE2(config-router-af)# redistribute ospf 2


Isto habilita a redistribuição das rotas dentro do OSPF no BGP transportando o
tráfego pela rede do provedor entre os dois sites.

PE01#sh ip bgp vpnv4 vrf LUANDA

BGP table version is 13, local router ID is 5.5.5.5

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

Route Distinguisher: 65000:1 (default for vrf LUANDA)

*> 172.16.0.0/30 0.0.0.0 0 32768 ?

*>i172.16.0.4/30 6.6.6.6 0 100 0?

*> 172.20.0.0/24 172.16.0.2 74 32768 ?

*> 172.20.1.0/24 172.16.0.2 74 32768 ?

*>i172.21.0.0/24 6.6.6.6 74 100 0?

*>i172.21.1.0/24 6.6.6.6 74 100 0?

PE01#

2. Configuração do Tunel (VPN)


Para além da VPN configurada para o uso no MPLS, foi adicionada mais uma,
especificamente, um túnel para acesso directo das máquinas do SITE de
Benguela para o Site de Luanda, cumprindo-se desta forma, mais um dos
requisitos para a implementação da rede convergente.

Abaixo vemos a configuração do túnel VPN:

CR001_LUANDA#sh interfaces tunnel 0

Tunnel0 is up, line protocol is up

Hardware is Tunnel

Internet address is 10.0.0.1/30


MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive set (10 sec), retries 3

Tunnel source 172.16.0.2 (Serial1/0), destination 172.16.0.6

Tunnel protocol/transport GRE/IP

Key disabled, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255

Fast tunneling enabled

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input 01:53:56, output 00:00:07, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 11

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

685 packets input, 32880 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

686 packets output, 32928 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

CR001_LUANDA#

CR001_BENGUELA#sh int tun 0

Tunnel0 is up, line protocol is up

Hardware is Tunnel

Internet address is 10.0.0.2/30

MTU 1514 bytes, BW 9 Kbit/sec, DLY 500000 usec,

reliability 255/255, txload 1/255, rxload 1/255


Encapsulation TUNNEL, loopback not set

Keepalive set (10 sec), retries 3

Tunnel source 172.16.0.6 (Serial1/0), destination 172.16.0.2

Tunnel protocol/transport GRE/IP

Key disabled, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255

Fast tunneling enabled

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input 01:55:30, output 00:00:09, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 11

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

695 packets input, 33360 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

695 packets output, 33360 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

CR001_BENGUELA#

3. Configuração de ACLs
Como forma de manter-se a segurança da rede e demonstrar a aplicação
das ACLs no projecto em questão, decidiu-se “barrar o acesso” da máquina
com ip 172.20.0.10 para o servidor de HTTPs por meio de uma ACL extendida.

CR001_BENGUELA#sh access-lists

Extended IP access list 100

10 deny tcp host 172.20.0.10 eq www host 172.16.0.6


20 permit ip any any (5004 matches)

CR001_BENGUELA#

4. Configuração do CME
Como pré-requisito para o estabelecimento da comunicação entre os dois
sites, pediu-se também que fosse implementado um telefone IP em cada site,
permitindo desta forma que quem estivesse no site de Luanda pudesse
efectuar chamadas para Benguela e vice-versa.

Por questões de simplicidade, decidiu-se utilizar o router de Luanda para


efectuar o serviço de cal manager express, sendo que todos os telefones
registam-se neste.

Primeiramente foi necessário definir uma pool de DHCP para que os IPs
pudessem ser atribuídos de maneira dinâmica aos telefones.

no ip dhcp use vrf connected

ip dhcp excluded-address 172.20.0.1 172.20.0.9

ip dhcp excluded-address 172.20.1.1 172.20.1.9

ip dhcp pool VOZ

network 172.20.0.0 255.255.255.0

default-router 172.20.0.1

dns-server 172.20.0.1

option 150 ip 172.20.0.1

ip dhcp pool Dados

network 172.20.1.0 255.255.255.0

default-router 172.20.1.1

dns-server 172.20.1.1

A seguir, habilitou-se o serviço de telefonia e registou-se os macs dos telefones:

telephony-service
max-ephones 5

max-dn 5

ip source-address 172.20.0.1 port 2000

max-conferences 8 gain -6

transfer-system full-consult

ephone-dn 1

number 100

description Recepcao-Luanda

name Recepcao-Luanda

ephone-dn 2

number 200

description Recepcao-Benguela

name Recepcao-Benguela

ephone 1

device-security-mode none

mac-address 0800.2726.B813

button 1:1

ephone 2

device-security-mode none

mac-address 0800.27A6.2A55

button 1:2

!
5. Diagrama geral da rede
6. Anexos
6.1 Configuração R1

CR001_LUANDA#sh run

Building configuration...

Current configuration : 2653 bytes

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname CR001_LUANDA

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 172.20.0.1 172.20.0.9

ip dhcp excluded-address 172.20.1.1 172.20.1.9

ip dhcp pool VOZ


network 172.20.0.0 255.255.255.0

default-router 172.20.0.1

dns-server 172.20.0.1

option 150 ip 172.20.0.1

ip dhcp pool Dados

network 172.20.1.0 255.255.255.0

default-router 172.20.1.1

dns-server 172.20.1.1

no ip domain lookup

multilink bundle-name authenticated

!
!

archive

log config

hidekeys

ip tcp synwait-time 5

interface Tunnel0

ip address 10.0.0.1 255.255.255.252

keepalive 10 3

tunnel source Serial1/0

tunnel destination 172.16.0.6

interface FastEthernet0/0

no ip address

duplex auto

speed auto

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 172.20.0.1 255.255.255.0

!
interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 172.20.1.1 255.255.255.0

interface Serial0/0

no ip address

shutdown

clock rate 2000000

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

no ip address

shutdown

clock rate 2000000

interface Serial1/0

ip address 172.16.0.2 255.255.255.252

serial restart-delay 0

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

interface Serial1/2

no ip address
shutdown

serial restart-delay 0

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

router ospf 2

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0

network 172.20.1.0 0.0.0.255 area 0

network 172.20.0.0 0.0.255.255 area 0

ip forward-protocol nd

no ip http server

no ip http secure-server

no cdp log mismatch duplex

control-plane

!
!

telephony-service

max-ephones 5

max-dn 5

ip source-address 172.20.0.1 port 2000

max-conferences 8 gain -6

transfer-system full-consult

ephone-dn 1

number 100

description Recepcao-Luanda

name Recepcao-Luanda

ephone-dn 2

number 200

description Recepcao-Benguela

name Recepcao-Benguela

ephone 1

device-security-mode none

mac-address 0800.2726.B813

button 1:1
!

ephone 2

device-security-mode none

mac-address 0800.27A6.2A55

button 1:2

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

end

6.2 Configuração R2

CR001_BENGUELA#sh run

Building configuration...

Current configuration : 2264 bytes

!
version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname CR001_BENGUELA

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 172.21.0.1 172.21.0.9

ip dhcp excluded-address 172.21.1.1 172.21.1.9

ip dhcp pool VOZ

network 172.21.0.0 255.255.255.0

default-router 172.21.0.1

dns-server 172.21.0.1

option 150 ip 172.20.0.1

ip dhcp pool DADOS

network 172.21.1.0 255.255.255.0

default-router 172.21.1.1

dns-server 172.21.1.1
!

no ip domain lookup

multilink bundle-name authenticated

archive

log config

hidekeys

!
!

ip tcp synwait-time 5

interface Tunnel0

ip address 10.0.0.2 255.255.255.252

keepalive 10 3

tunnel source Serial1/0

tunnel destination 172.16.0.2

interface FastEthernet0/0

no ip address

duplex auto

speed auto

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 172.21.0.1 255.255.255.0

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 172.21.1.1 255.255.255.0

interface Serial0/0

no ip address

shutdown

clock rate 2000000

!
interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

no ip address

shutdown

clock rate 2000000

interface Serial1/0

ip address 172.16.0.6 255.255.255.252

ip access-group 100 in

serial restart-delay 0

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!
router ospf 2

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0

network 172.21.0.0 0.0.255.255 area 0

ip forward-protocol nd

ip http server

no ip http secure-server

access-list 100 deny tcp host 172.20.0.10 eq www host 172.16.0.6

access-list 100 permit ip any any

no cdp log mismatch duplex

control-plane

!
line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

end

CR001_BENGUELA#

6.3 Configuração R3
version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname P001

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5
no ip icmp rate-limit unreachable

ip cef

no ip domain lookup

multilink bundle-name authenticated

archive
log config

hidekeys

ip tcp synwait-time 5

interface Loopback0

ip address 3.3.3.3 255.255.255.255

interface FastEthernet0/0

ip address 10.10.10.2 255.255.255.252

duplex auto

speed auto

mpls ip

interface Serial0/0

no ip address

shutdown

clock rate 2000000

interface FastEthernet0/1

ip address 10.10.10.5 255.255.255.252

duplex auto

speed auto

mpls ip

!
interface Serial0/1

no ip address

shutdown

clock rate 2000000

interface Serial1/0

no ip address

shutdown

serial restart-delay 0

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

router ospf 1

log-adjacency-changes

network 3.3.3.3 0.0.0.0 area 0

network 10.10.10.0 0.0.0.255 area 0

ip forward-protocol nd
!

no ip http server

no ip http secure-server

no cdp log mismatch duplex

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous
line vty 0 4

login

end

6.4 Configuração R4

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname R4

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable


ip cef

no ip domain lookup

multilink bundle-name authenticated

archive

log config
hidekeys

ip tcp synwait-time 5

interface Loopback0

ip address 4.4.4.4 255.255.255.255

interface FastEthernet0/0

ip address 10.10.10.14 255.255.255.252

duplex auto

speed auto

mpls ip

interface Serial0/0

no ip address

shutdown

clock rate 2000000

interface FastEthernet0/1

ip address 10.10.10.10 255.255.255.252

duplex auto

speed auto

mpls ip

interface Serial0/1
no ip address

shutdown

clock rate 2000000

interface Serial1/0

no ip address

shutdown

serial restart-delay 0

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

router ospf 1

log-adjacency-changes

network 4.4.4.4 0.0.0.0 area 0

network 10.10.10.0 0.0.0.255 area 0

ip forward-protocol nd

!
!

no ip http server

no ip http secure-server

no cdp log mismatch duplex

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4
login

end

6.5 Configuração R5

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname PE01

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable


ip cef

ip vrf LUANDA

rd 65000:1

route-target export 65000:1

route-target import 65000:1

no ip domain lookup

multilink bundle-name authenticated

!
!

archive

log config

hidekeys

ip tcp synwait-time 5

interface Loopback0

ip address 5.5.5.5 255.255.255.255

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.252

duplex auto

speed auto

mpls ip

interface Serial0/0

no ip address

shutdown

clock rate 2000000

interface FastEthernet0/1

ip address 10.10.10.9 255.255.255.252


duplex auto

speed auto

mpls ip

interface Serial0/1

no ip address

shutdown

clock rate 2000000

interface Serial1/0

ip vrf forwarding LUANDA

ip address 172.16.0.1 255.255.255.252

ip ospf 2 area 0

serial restart-delay 0

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

router ospf 2 vrf LUANDA


log-adjacency-changes

redistribute bgp 65000 subnets

router ospf 1

log-adjacency-changes

network 5.5.5.5 0.0.0.0 area 0

network 10.10.10.0 0.0.0.255 area 0

router bgp 65000

no synchronization

bgp log-neighbor-changes

neighbor 6.6.6.6 remote-as 65000

neighbor 6.6.6.6 update-source Loopback0

no auto-summary

address-family vpnv4

neighbor 6.6.6.6 activate

neighbor 6.6.6.6 send-community extended

exit-address-family

address-family ipv4 vrf LUANDA

redistribute ospf 2 vrf LUANDA

no synchronization

exit-address-family

ip forward-protocol nd

no ip http server

no ip http secure-server

!
no cdp log mismatch duplex

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

end
6.6 Configuração R6

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname PE002

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

!
!

ip vrf BENGUELA

rd 65000:1

route-target export 65000:1

route-target import 65000:1

no ip domain lookup

multilink bundle-name authenticated

archive
log config

hidekeys

ip tcp synwait-time 5

interface Loopback0

ip address 6.6.6.6 255.255.255.255

interface FastEthernet0/0

ip address 10.10.10.13 255.255.255.252

duplex auto

speed auto

mpls ip

interface Serial0/0

no ip address

shutdown

clock rate 2000000

interface FastEthernet0/1

ip address 10.10.10.6 255.255.255.252

duplex auto

speed auto

mpls ip

!
interface Serial0/1

no ip address

shutdown

clock rate 2000000

interface Serial1/0

ip vrf forwarding BENGUELA

ip address 172.16.0.5 255.255.255.252

ip ospf 2 area 0

serial restart-delay 0

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

router ospf 2 vrf BENGUELA

router-id 172.16.0.5

log-adjacency-changes

redistribute bgp 65000 subnets

!
router ospf 1

router-id 6.6.6.6

log-adjacency-changes

network 6.6.6.6 0.0.0.0 area 0

network 10.10.10.0 0.0.0.255 area 0

router bgp 65000

no synchronization

bgp log-neighbor-changes

neighbor 5.5.5.5 remote-as 65000

neighbor 5.5.5.5 update-source Loopback0

no auto-summary

address-family vpnv4

neighbor 5.5.5.5 activate

neighbor 5.5.5.5 send-community extended

exit-address-family

address-family ipv4 vrf BENGUELA

redistribute ospf 2 vrf BENGUELA

no synchronization

exit-address-family

ip forward-protocol nd

no ip http server

no ip http secure-server

no cdp log mismatch duplex

!
!

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

end
6.7 Configuração SW01 (R7)

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname SW_LUANDA

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

no ip domain lookup

multilink bundle-name authenticated

!
!

archive

log config

hidekeys

ip tcp synwait-time 5

interface FastEthernet0/0
no ip address

shutdown

duplex auto

speed auto

interface Serial0/0

no ip address

shutdown

clock rate 2000000

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

no ip address

shutdown

clock rate 2000000

interface FastEthernet1/0

interface FastEthernet1/1

switchport access vlan 10

interface FastEthernet1/2

switchport access vlan 20

interface FastEthernet1/3

!
interface FastEthernet1/4

interface FastEthernet1/5

interface FastEthernet1/6

interface FastEthernet1/7

interface FastEthernet1/8

interface FastEthernet1/9

interface FastEthernet1/10

interface FastEthernet1/11

interface FastEthernet1/12

interface FastEthernet1/13

interface FastEthernet1/14

interface FastEthernet1/15

switchport mode trunk

interface Vlan1

no ip address

ip forward-protocol nd

!
no ip http server

no ip http secure-server

no cdp log mismatch duplex

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login
!

end

6.7 Configuração SW02 (R8)

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname SW_BENGUELA

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

!
no ip domain lookup

multilink bundle-name authenticated

archive

log config

hidekeys

!
ip tcp synwait-time 5

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

interface Serial0/0

no ip address

shutdown

clock rate 2000000

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

no ip address

shutdown

clock rate 2000000

interface FastEthernet1/0

interface FastEthernet1/1

switchport access vlan 10


!

interface FastEthernet1/2

switchport access vlan 20

interface FastEthernet1/3

interface FastEthernet1/4

interface FastEthernet1/5

interface FastEthernet1/6

interface FastEthernet1/7

interface FastEthernet1/8

interface FastEthernet1/9

interface FastEthernet1/10

interface FastEthernet1/11

interface FastEthernet1/12

interface FastEthernet1/13

interface FastEthernet1/14

interface FastEthernet1/15

switchport mode trunk

!
interface Vlan1

no ip address

ip forward-protocol nd

no ip http server

no ip http secure-server

no cdp log mismatch duplex

control-plane

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous
line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

end