Você está na página 1de 3

Disciplina: Introdução a Programação

Aula 4: Comandos de entrada e saída

Atividade

1) Leia os enunciados a seguir e crie os algoritmos que solucionam os problemas propostos.


a) Exiba o quadrado e o cubo de um número inteiro qualquer informado pelo usuário.
b) Receba a quantidade de dias que uma pessoa já viveu e informe quantos anos ela tem.
Desconsidere os anos bissextos.
c) Sabendo que o dono de uma loja aplica 20% sobre o valor de compra de um produto, informe o
valor sugerido para venda com base no valor pago na compra do produto.
Gabarito comentado

a)
programa
{
funcao inicio()
{
inteiro num, quadrado, cubo
escreva("Informe um número qualquer: ")
leia(num)
quadrado = num * num
cubo = num * num * num
escreva(num, " ao quadrado é: ", quadrado)
escreva(num, " ao cubo é: ", cubo)
}
}

  Se você escreveu o algoritmo como no exemplo, percebeu, quando executou, que as linhas que exibem o
quadrado e o cubo do número mostram as mensagens na mesma linha. Para que cada resultado fique em uma
linha, e a leitura deles seja facilitada, inclua “\n” ao final da linha que mostra o quadrado do número:

  escreva(num, " ao quadrado é: ", quadrado, "\n")


 
Essa formatação fará com que o algoritmo exiba a mensagem e quebre a linha antes de executar o próximo
comando.

  b)
programa
{
funcao inicio()
{
real dias, anos
escreva("Quantos dias você já viveu? ")
leia(dias)
anos = dias / 365
escreva("Você já viveu ", anos, " anos.")
}
}

  c. programa
{
funcao inicio()
{
real preCompra, preVenda
escreva("Preço de compra do produto: R$ ")
leia(preCompra)
preVenda = preCompra + (preCompra * 20/100)
escreva("Preço sugerido para venda R$ ", preVenda)
}
}

Atividade

2) Com base nos algoritmos escritos na atividade anterior, escreva os programas em C++. Abaixo estão os
enunciados.
Disciplina: Introdução a Programação

Aula 4: Comandos de entrada e saída

a) Exiba o quadrado e o cubo de um número inteiro qualquer informado pelo usuário.

b) Receba a quantidade de dias que uma pessoa já viveu e informe quantos anos ela tem. Desconsidere os
anos bissextos.

c) Sabendo que o dono de uma loja aplica 20% sobre o valor de compra de um produto, informe o valor
sugerido para venda com base no valor de compra do produto.

Gabarito comentado

a)
#include < iostream >
using namespace std;
int main()
{
int num, quadrado, cubo;
cout << "Informe um número qualquer: ";
cin >> num;
quadrado = num * num;
cubo = num * num * num;
cout << num << "ao quadrado é: " << quadrado;
cout << num << "ao cubo é: " << cubo;
}

    b)
#include < iostream >
using namespace std;
int main()
{
float dias, anos;
cout << "Quantos dias você já viveu? ";
cin >> dias;
anos = dias / 365;
cout << "Você já viveu " << anos << "anos.";
}
  c)
#include < iostream >
using namespace std;
int main()
{
float preCompra, preVenda;
cout << "Preço de compra do produto: R$ ";
cin >> preCompra;
preVenda = preCompra + (preCompra * 20/100);
cout << "Preço sugerido para venda R$ " << preVenda;
}

Atividade

Observe o algoritmo a seguir:

programa
{
inclua biblioteca Matematica --> mat
funcao inicio()
Disciplina: Introdução a Programação

Aula 4: Comandos de entrada e saída

{
real qtdeDin, valComb, qtdeLitros
escreva("Quanto custa o litro do combustível? R$ ")
leia(valComb)
escreva("Quantos reais você tem? R$ ")
leia(qtdeDin)
qtdeLitros=qtdeDin/valComb
escreva("Com R$ ", qtdeDin, " você consegue abastecer ",
mat.arredondar(qtdeLitros,2)," litros de combustível.")
}
}
Sabendo que o valor do litro do combustível é R$ 3,90 e que você dispõe de R$ 200,00 para abastecer, qual
mensagem seria exibida pelo computador na linha 12?

Gabarito comentado

O computador exibiria a mensagem "Com R$ 200.00 você consegue abastecer 51.28 litros de combustível."
Lembre-se de que o separador de casas decimais é o ponto e não a vírgula! .