Você está na página 1de 6

Exercício 1: Iterativo

programa
{
funcao inicio()
{
inteiro num, soma = 0, i = 0
escreva("Informe um número inteiro: ")
leia(num)
para (i=1;i<=num;i++)
{
soma = soma + i
}
escreva("A soma dos números inteiros até o número informado é ",soma)
}
}
Exercício 1: Recursivo

programa
{

funcao inicio()
{
inteiro num
escreva("Informe um número: ")
leia(num)
escreva("A soma dos números inteiros até o número informado é ",
soma(num))
}

funcao inteiro soma(inteiro num)


{
se (num == 0)
{
retorne 0
}
senao
{
retorne(num + soma(num - 1))
}
}
}
Exercício 2: Iterativo

programa
{
funcao inicio()
{
inteiro num, fat, i = 0
escreva("Informe um número inteiro: ")
leia(num)
se (num == 0) //Caso o número informado seja 0 o fatorial é 1
{
fat = 1
}
senao
{
fat = num
}
para (i=num-2;i>=1;i=i-2) // Subtrai de 2 em 2
{
fat = fat * i
}
escreva("O fatorial duplo do número informado é ",fat) }

}
Exercício 2: Recursivo

programa
{

funcao inicio()
{
inteiro num
escreva("Informe um número: ")
leia(num)
escreva("O fatorial duplo do número informado é ", fatorial(num)) //
Chamada externa
}

funcao inteiro fatorial(inteiro num)


{
inteiro fat = 1
se (num > 1)
{
fat = num * fatorial(num - 2) // Chamada
recursiva, subtraindo de 2 em 2
}
retorne fat
}
}
Exercício 3: Iterativo

programa
{
funcao inicio()
{
inteiro i, fib = 0, f1 = 0, f2 = 1, num
escreva("Informe o n termo da sequencia Fibonacci: ") // Termo desejado
leia(num)
se (num == 1)
{
fib = 0
}
senao
se (num == 2)
{
fib = 1
}
senao
{
para(i=1;i<num-1;i++) // Estrutura de soma dos
termos n-1 e n-2
{
fib = f1 + f2
f1 = f2
f2 = fib
}
}
escreva("O valor do termo procurado é ", fib)
}
}
Exercício 3: Recursivo

programa
{
funcao inicio()
{
inteiro num
escreva("Informe o n termo da sequencia de Fibonacci: ")
leia(num)
escreva("O termo solicitado é ", fibonacci(num))
}

funcao inteiro fibonacci(inteiro num)


{
inteiro fib = 0
se (num == 1)
{
fib = 0
}
senao
se (num == 2)
{
fib = 1
}
senao
{
fib = fibonacci(num - 2) + fibonacci(num - 1) // Chamada Recursiva
}
retorne fib
}
}
Exercício 4: Iterativo

programa
{
funcao inicio()
{
inteiro i, tetra = 0, t1 = 0, t2 = 0, t3 = 0, t4 = 1, num
escreva("Informe o n termo da sequencia Tetranacci: ") leia(num)

se ((num > 0) e (num <= 3))


{
tetra = 0
}
senao
se (num == 4))
{
tetra = 1
}
senao
{
para(i=3;i<num-1;i++)
{
tetra = t1 + t2 + t3 + t4
t1 = t2
t2 = t3
t3 = t4
t4 = tetra
}
}
escreva("O valor do termo procurado é ", tetra)
}
}
Exercício 4: Recursivo

programa
{
funcao inicio()
{
inteiro num
escreva("Informe o n termo da sequência Tetranacci: ") leia(num)
escreva("O termo solicitado é ", tetranacci(num))
}

funcao inteiro tetranacci(inteiro num)


{
inteiro tetra = 0
se ((num > 0) e (num < 4))
{
tetra = 0
}
senao
se (num == 4)
{
tetra = 1
}
senao
{
tetra = tetranacci(num - 4) + tetranacci(num - 3) + tetranacci(num - 2) +
tetranacci(num - 1) // Chamada Recursiva }
retorne tetra
}
}

Você também pode gostar