Você está na página 1de 33

ITEL AR

CCNA Exploration
Protocolos e Conceitos de Roteamento

Capítulo 2: Roteamento Estático

Sebastião L. Q. António
CCNA Instrutor
Sebastiaokinanga@hotmail.com
Função do roteador

O roteador é um computador com uma finalidade especial que desempenha um papel fundamental no
funcionamento de qualquer rede de dados. Os roteadores são os principais responsáveis por interconectar redes:

 Determinando o melhor caminho para enviar pacotes


 Encaminhando pacotes para o destino

A tabela de roteamento do roteador é usada para localizar a melhor correspondência entre o IP de destino de um
pacote e um endereço de rede na tabela de roteamento.
Topologia peview

Todos os roteadores desse exemplo são Cisco 1841. Um roteador Cisco 1841 tem as seguintes interfaces:
 Duas interfaces FastEthernet: FastEthernet 0/0 e FastEthernet 0/1
 Duas interfaces seriais: Serial 0/0/0 e Serial0/0/1
Conexões
Examinar as interfaces do roteador

O comando show ip interface


brief pode ser usado para ver uma
porção das informações de
interface em um formato
resumido.

O comando show interfaces


mostra o status e dá uma
descrição detalhada de todas
as interfaces no roteador.

R1#show interfaces fastethernet 0/0


FastEthernet0/0 is administratively down, line protocol is down

O comando show running-config exibe o arquivo de configuração atual usado pelo roteador.

R1#show running-config
<parte da saída do comando omitida>
interface FastEthernet0/0
no ip address
shutdown
<parte da saída do comando omitida>
Como configurar uma interface Ethernet

R1(config)#interface fastethernet 0/0


R1(config-if)#ip address 172.16.3.1 255.255.255.0
R1(config-if)#no shutdown

A seguinte mensagem retorna do IOS:

*Mar 1 01:16:08.212: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up


*Mar 1 01:16:09.214: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Nota: Embora habilitada com no shutdown, uma interface Ethernet não permanecerá em funcionamento, ou activa, a
menos que esteja recebendo um sinal de operadora de outro dispositivo (switch, hub, PC ou outro roteador).

O IOS costuma enviar mensagens não solicitadas semelhantes às mensagens changed state to up recém abordadas.
Às vezes, essas mensagens ocorrerão quando você estiver digitando um comando, como ao configurar uma descrição
para a interface.

Para manter a saída não solicitada separada da sua entrada, acesse o modo de configuração de linha da porta de
console e adicione o comando logging synchronous. Você verá que as mensagens retornadas pelo IOS não interferem
mais na sua digitação.
Verificando a interface Ethernet

Um roteador não pode ter várias interfaces pertences à mesma sub-rede IP. Cada interface deve pertencer a uma
sub-rede separada.

EXEMPLO: Um roteador não pode ter sua interface FastEthernet 0/0 configurada como o endereço e a máscara
172.16.3.1/24 e sua interface FastEthernet 0/1 configurada como 172.16.3.2/24.
R1(config-if)#int fa0/1
R1(config-if)#ip address 172.16.3.2 255.255.255.0
172.16.3.0 overlaps with FastEthernet0/0
R1(config-if)#
Configurar e verificar uma interface serial

R1(config)#interface serial 0/0/0


R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#no shutdown

Ainda há mais um comando que precisamos inserir, o comando clock rate,


no roteador com o cabo DCE. O comando clock rate definirá o sinal de
clock do link.

Os clock rates disponíveis, em bits por segundo, são:


1200, 2400, 9600, 19200, 38400, 56000, 64000, 72000,
125000, 148000, 500000, 800000, 1000000, 1300000,
2000000 e 4000000.
Cabo
R1(config)#interface serial 0/0/0 Console
R1(config-if)#clock rate 64000
As interfaces seriais exigem um sinal de clock para controlar o timing
da comunicação. Cabo
Cabo
V.35
UTP
Se um cabo for conectado entre os dois roteadores, você poderá usar o
comando show controllers para determinar que extremidade do cabo está
acoplada a essa interface (DCE ou DTE).
Nota: Se a interface de um roteador com um cabo DTE for configurada com o comando clock rate, o IOS
desconsiderará o comando, não havendo nenhum efeito colateral.
O que há na tabela de roteamento?

C 172.16.3.0 is directly connected, FastEthernet0/0

O C no início de cada rota indica que se trata de uma rede conectada diretamente. Em outras palavras, R1 tem uma
interface que pertence a essa rede. O significado de C é definido na lista de códigos na parte superior da tabela de
roteamento.

A máscara de sub-rede /24 dessa rota é exibida na linha acima da rota real.

172.16.0.0/24 is subnetted, 1 subnets


C 172.16.3.0 is directly connected, FastEthernet0/0
Tabela de roteamento, conceitos

A principal finalidade de uma tabela de roteamento é fornecer ao roteador caminhos para redes de destino diferentes.

A tabela de roteamento consiste em uma lista de endereços de rede "conhecidos“ ou seja, os endereços conectados
diretamente, configurados estaticamente e aprendidos dinamicamente.

O comando de depuração debug ip routing nos permitirá ver qualquer alteração feita pelo roteador ao adicionar ou
remover rotas. Você poderá desabilitá-lo usando o comando undebug ip routing ou o comando undebug all.

Para alterar o endereço ip em uma interface, desligue a interface e à seguir use o comando no ip address
Redes conectadas directamente

Quando um roteador só tem suas interfaces configuradas e a tabela de roteamento contém as redes diretamente conectadas, mas
nenhuma outra, apenas os dispositivos nessas redes diretamente conectadas são alcançáveis.

 R1 pode se comunicar com qualquer dispositivo nas redes 172.16.3.0/24 e 172.16.2.0/24.


 R2 pode se comunicar com qualquer dispositivo nas redes 172.16.1.0/24, 172.16.2.0/24 e 192.168.1.0/24.
 R3 pode se comunicar com qualquer dispositivo nas redes 192.168.1.0/24 e 192.168.2.0/24.

Enquanto não configurarmos as rotas, pacotes com destinos a redes que não fazem parte da tabela de roteamento não serão
alcançados
Pings sem sucesso
Pings com sucesso
CDP – Cisco Discovery Protocol

CDP é uma ferramenta que reúne informações usada por administradores de rede para obter informações sobre dispositivos Cisco
conectados directamente.

A maioria dos dispositivos de rede, por definição, não funciona isolada. Um dispositivo Cisco normalmente tem outros
dispositivos Cisco como seus vizinhos na rede.

Vizinhos de Camada 3 Vizinhos de Camada 2

Na Camada 3, os protocolos de roteamento O CDP só funciona na Camada 2. Por isso, os vizinhos CDP são
consideram os vizinhos dispositivos que dispositivos Cisco conectados directa e fisicamente e que
compartilham o mesmo espaço de endereço da rede. compartilham o mesmo vínculo de dados. Na figura, o
administrador de rede fez o login em S3. S3 só receberá anúncios
CDP de S1, S2 e R2.

Os switches não são vizinhos dos roteadores na Camada 3, porque


funcionam na Camada 2. No entanto, os switches são vizinhos de
Camada 2 de seus roteadores conectados directamente.
CDP - Cisco Discovery Protocol
CDP pode ser usado como uma ferramenta de detecção de rede, ajudando a criar uma topologia lógica de uma rede quando não houver
essa documentação ou faltar detalhes.

Quando um dispositivo Cisco é inicializado, o CDP é inicializado por padrão e automaticamente detecta dispositivos Cisco vizinhos que
executam CDP, independentemente do protocolo ou dos conjuntos de aplicações de protocolo que estejam executando. CDP troca
informações dos dispositivos de hardware e de software com seus vizinhos de CDP conectados directamente.

CDP fornece as seguintes informações sobre cada dispositivo CDP vizinho:


 Identificadores de dispositivo – Por exemplo, o nome de host configurado de um switch
 Lista de endereços – suporte até um endereço da camada de rede para cada protocolo
 Lista de recursos – por exemplo, se esse dispositivo é um roteador ou um switch
 Plataforma – a plataforma de hardware do dispositivo; por exemplo, um roteador série Cisco 72000
Mais comandos CDP

CDP pode ser um risco à segurança.


Em situações de detecção de rede, saber o endereço IP do vizinho CDP costuma ser toda a informação necessária à execução
de telnet no dispositivo. Com uma sessão Telnet estabelecida, as informações podem ser obtidas sobre os dispositivos Cisco
conectados directamente de um vizinho.
Que tipo de roteamento usar?

Um roteador pode aprender redes remotas de duas formas:


 Manualmente, a partir de rotas estáticas configuradas
 Automaticamente, a partir de um protocolo de roteamento dinâmico

Rotas estáticas

Rotas usadas no roteamento de uma rede para uma rede stub. Rede stub é uma rede acessada por uma única rota. Na figura
vemos que qualquer rede conectada a R1 só teria uma forma de alcançar outros destinos, independentemente de serem redes
conectadas a R2 ou destinos além de R2. Portanto, a rede 172.16.3.0 é uma rede stub e R1 é um roteador stub.

Executar um protocolo de roteamento entre R1 e R2 é um


desperdício de recursos porque R1 só tem uma saída para enviar
tráfego que não seja local. Por isso, as rotas estáticas são
configuradas tendo em vista a conectividade com redes remotas
que não estejam directamente conectadas a um roteador.
Configurar rotas estáticas

Nota: O parâmetro ip-address costuma ser conhecido como o endereço IP do "próximo salto" do roteador. O
endereço IP do próximo salto do roteador costuma ser usado nesse parâmetro. No entanto, o parâmetro ip-address
pode ser qualquer endereço IP, desde que possa ser resolvido na tabela de roteamento. Isso está além do escopo
desse curso, mas nós adicionamos esse ponto para manter a precisão técnica.
Verificar as rotas estáticas na Tabela de roteamento

Primeiro, habilite debug ip routing para que o IOS exiba uma mensagem quando a nova rota é adicionada à tabela de
roteamento.

Examinemos esta saída do comando:

 S - Código da tabela de roteamento para rota estática


 172.16.1.0 - Endereço de rede da rota
 /24 - Máscara de sub-rede da rota; ela é exibida na linha anterior, conhecida como a rota primária e abordada no Capítulo 8
 [1/0] - Distância administrativa e métrica da rota estática (explicada em um capítulo posterior)
 via 172.16.2.2 - Endereço IP do roteador do próximo salto, o endereço IP da interface Serial 0/0/0 de R2
Adicionar rotas para mais redes remotas

É importante gravar sempre as configurações na NVRAM:


R1#copy running-config startup-config

As novas entradas na tabela de roteamento podem ser verificadas usando o comando show ip route ou show
running-config
Princípios da Tabela de Roteamento e Rotas

Apresentaremos três princípios da tabela de roteamento,


conforme a descrição de Alex Zinin em seu livro, Cisco IP
Routing.

Alex Zinin é o novo (CTO - Chief Technology Officer ) das


Tecnologias de Informação, Cisco para Ásia Pacífica e Japão..

Alex Zinin Trabalhará  para consumidores de Provedores de


serviço Cisco nas áreas de (IP NGN -Internet Protocol Next-
Generation Networks), vídeo, móveis e centro de dados.

Zinin tem 20 anos de experiência em Redes IP, Roteamento e


Tecnologias de Comutação. Ele é também inventor de algumas
patentes e escreveu este livro 'Cisco IP Routing: Packet
Forwarding and Intra-domain Routing Protocols', publicado por
Addison-Wesley.
Princípios da Tabela de Roteamento de Alex Zinin
Como resolver a rota?

 Pelo endereço do próximo salto - Toda rota que só referencia um endereço IP do próximo salto, deve ter o
endereço IP do próximo salto resolvido usando outra rota na tabela de roteamento que tenha uma interface de
saída.

Normalmente, essas rotas são resolvidas para


rotas na tabela de roteamento que são redes
directamente conectadas.

 Pela interface de saída - a maioria das rotas estáticas pode ser configurada com uma interface de saída, o que
permite à tabela de roteamento resolver a interface de saída em uma única pesquisa, e não duas.

Quando se desliga uma interface a rota


desaparece na tabela de roteamento.

Nota: A rota estática exibe a rota como


conectada directamente. É importante
compreender que isso não significa que essa
rota é uma rede conectada directamente ou
uma rota conectada directamente. Essa rota
continua sendo uma rota estática.
Rotas estáticas com interfaces Ethernet

Sendo o link de rede entre R1 e R2 um link Ethernet e que a interface F0/1 de


R1 esteja conectada à essa rede, como mostrado na figura. Uma rota estática,
usando um endereço IP do próximo salto para a rede 192.168.2.0/24, pode ser
definido usando o comando:

R1(config)#ip route 192.168.2.0 255.255.255.0 172.16.2.2

Configurando uma interface Ethernet", o pacote IP deve ser encapsulado em um quadro Ethernet com um endereço MAC de
destino Ethernet. Se o pacote precisar ser enviado para um roteador do próximo salto, o endereço MAC de destino será o endereço
da interface Ethernet do roteador do próximo salto.

Enviando uma solicitação ARP

Se essa entrada MAC não estiver na tabela ARP, R1 enviará uma solicitação ARP pela interface FastEthernet 0/1. O broadcast de
Camada 2 está solicitando que, se algum dispositivo tiver o endereço IP 172.16.2.2, que responda com seu endereço MAC.
Rotas estáticas e interfaces de saída Ethernet

Para configurar uma rota estática com uma interface de saída Ethernet, use o
seguinte comando:
R1(config)#ip route 192.168.2.0 255.255.255.0 fastethernet 0/1

Dependendo da topologia e das configurações em outros


roteadores, essa rota estática talvez funcione ou não. Não
entraremos em detalhes aqui, mas é recomendável que,
quando a interface de saída for uma rede Ethernet, que
você não use apenas a interface de saída na rota estática.

A diferença entre uma rede Ethernet e uma rede serial ponto-a-ponto é que na rede ponto-a-ponto tem apenas um outro
dispositivo nessa rede – o roteador na outra extremidade do link. Com redes Ethernet, talvez haja muitos dispositivos diferentes
compartilhando a mesma rede multiacesso, inclusive hosts e até mesmo vários roteadores. Designando apenas a interface de
saída Ethernet na rota estática, o roteador não terá informações suficientes para determinar qual é o dispositivo do próximo salto.

Existe alguma forma de configurar uma rota estática em uma rede Ethernet para que ela não possa usar a pesquisa recursiva do endereço
IP do próximo salto, configurando a rota estática incluindo a interface de saída e o endereço IP do próximo salto.

R1(config)#ip route 192.168.2.0 255.255.255.0 fastethernet 0/1 172.16.2.2

A entrada da tabela de roteamento dessa rota seria:


Nota: Para obter mais informações sobre os problemas que
S 192.168.2.0/24 [1/0] via 172.16.2.2 FastEthernet0/1 podem ocorrer com rotas estáticas que só usam uma interface
Ethernet ou FastEthernet de saída, leia o livro Cisco IP Routing,
de Alex Zinin.
Remover e Verificar rotas estáticas

Para excluir uma rota estática, adicione no na frente do comando ip route, seguido pelo resto da rota estática a ser
removida.

Sempre que alterações forem feitas em rotas estáticas – ou em outros aspectos da rede – verifique se as alterações
entraram em vigor e se produziram os resultados desejados.

Use os comandos: show ip route, show running-config.

O teste final é rotear pacotes da origem para o destino. Usando o comando ping, podemos testar se os pacotes de
cada roteador estão alcançando seu destino e se o caminho de retorno também está funcionando corretamente.
Sumarizando rotas estáticas
Criar tabelas de roteamento menores torna o processo de pesquisa na tabela de roteamento mais eficiente, porque há menos rotas
a serem pesquisadas. Em muitos casos, uma única rota estática pode ser usada para representar dúzias, centenas ou até mesmo
milhares de rotas.

Várias rotas estáticas podem ser sumarizadas em uma única rota estática caso:
 As redes de destino possam ser sumarizadas em um único endereço de rede e
 As várias rotas estáticas usem a mesma interface de saída ou o endereço IP do próximo salto

Em seguida, configurar a rota estática de sumarização:

R3(config)#ip route 172.16.0.0 255.255.252.0 serial0/0/1


Rota estática padrão
É possível que o endereço IP de destino de um pacote corresponda a várias rotas na tabela de roteamento. Por exemplo, e se nós
tivéssemos as duas rotas estáticas a seguir na tabela de roteamento:
172.16.0.0/24 is subnetted, 3 subnets
S 172.16.1.0 is directly connected, Serial0/0/0 and
S 172.16.0.0/16 is directly connected, Serial0/0/1
Se o destino de um pacote for172.16.1.10, esse endereço corresponde a ambas as rotas. A tabela de roteamento usará a correspondência mais
específica. Como 24 bits correspondem à rota 172.16.1.0/24, e apenas 16 bits da rota 172.16.0.0/16 são correspondentes, a rota estática com a
correspondência mais longa do 24º bit será usada. Em seguida, o pacote será encapsulado em um quadro de Camada 2 e enviado pela interface
Serial 0/0/0. A máscara de sub-rede na entrada da rota é o que determina quantos bits devem corresponder ao endereço IP de destino do pacote
para essa rota para que haja uma correspondência.

Uma rota estática padrão é uma rota que corresponderá a todos os pacotes. São usadas rotas estáticas padrão:

 Quando nenhuma outra rota na tabela de roteamento corresponde ao endereço IP de destino. Em outras palavras, quando não houver
uma correspondência mais específica. Um uso comum é ao conectar o roteador de borda de uma empresa à rede ISP.
 Quando um roteador só tem um outro roteador ao qual está conectado. Essa condição é conhecida como um roteador stub.

Router(config)#ip route 0.0.0.0 0.0.0.0 [exit-interface | ip-address ]


O endereço de rede 0.0.0.0 0.0.0.0 e a máscara são chamados de rota "quad-zero".

Verifique a alteração feita na tabela de roteamento usando o


comando show ip route.

S* 0.0.0.0/0 is directly connected, Serial0/0/0

É a chamada rota candidata padrão


Resolução de problemas com rotas estáticas

As redes estão sujeitas a muitas forças diferentes que podem fazer com que seu status mude muito:
 Há falha em uma interface.
 Uma operadora descarta uma conexão.
 Há links saturados.
 Um administrador insere uma configuração errada.
Resumo