Você está na página 1de 5

Turma Técnico em Informática – INFMA20.

Exercícios
1. ( FCC - 2019 - SEFAZ-BA) Na
D) incorreto, pois está faltando uma
programação de um software, deseja-
comparação para verificar se c é menor
se calcular a média aritmética entre os
do que b e a.
dois valores maiores em um universo
de três números armazenados nas E) Incorreto, pois não pode haver uma
variáveis que suportam números reais comparação se dentro da outra.
a, b e c. A média será armazenada na
variável r, que também suporta 2. (CESP – 2010 - TRT) Considerando-
números reais. Para isso, se propôs o se a estrutura de controle apresentada
seguinte trecho de algoritmo. a seguir, é correto afirmar que o aluno
será reprovado se obtiver nota inferior a
7 e mais de 20 faltas .

Se nota >= 7 e faltas < = 20 Então

Escreva (“Aluno aprovado”)


senão se nota <= 5 e falta <= 20
O trecho mostrado está:
Escreva (“Aluno em recuperação”)

A) correto para o problema proposto. Senão

Escreva (“Aluno reprovado”)


B) incorreto, pois no lugar de senão se
(b<c) deve ser colocado senão se (b<a A afirmação está
E b<c).
Certo ( ) Errado ( )

C) incorreto, pois deve ser usado se 3. (Prof. Arthur Gonçalves/Turma


(a<b OU a<c) no lugar de se (a<b E Técnico em Informática/Esamaz Tec
a<c). - 2019) Analise o algoritmo a baixo:

“Descobri que, quanto mais eu estudo, mais sorte eu pareço ter nas
provas”
Var: a, b, c: inteiro

Algoritmo maior e menor valor literal Inicio


4. (Prof. Arthur Gonçalves/Turma
a = 100, b = 90 c=80
Técnico em Informática/Esamaz Tec
Se a >= b e a >= c Então - 2019) Um algoritmo possui estrutura
condicional simples quando precisamos
a é maior
decidir pela execução de apenas um
Senão Se b >= a e b >= c Então trecho de código, caso seja necessário

b é maior decidir por 2 trechos de código o


algoritmo passa a ter estrutura
senão
condicional composta e por sua vez,
c é maior caso seja necessário decidir por mais
de
fim se
2 trechos de códigos, temos uma
Fim estrutura de condição múltipla. Já em
algoritmos que possuem estruturas de
Assinale a alternativa CORRETA:
repetição, podemos afirmar que se não
A) O algoritmo possui estrutura de sabemos a quantidade de vezes que
condição simples. um determinado de trecho de código irá

B) O algoritmo possui estrutura de rodar, temos uma estrutura de

condição composta. repetição indefinida por outro lado,


quando temos a estrutura de petição
C) O algoritmo possui estrutura
definida é porque
de condição múltipla.
sabemos até quando um determinado
D) O algoritmo possui estrutura trecho de código será executado.
de repetição indefinida.
Está afirmação está completamente:
E) O algoritmo possui estrutura de
Certo ( ) Errado ( )
repetição definida.
5. (Prof. Arthur Gonçalves/Turma
Técnico em Informática/Esamaz Tec
- 2019) Os algoritmos possuem
comandos de entrada e de saída. O
comando de entrada é representado
por Leia e o comando de saída é
representado por escreva
“Descobri que, quanto mais eu estudo, mais sorte eu pareço ter nas
provas”
Está afirmação está completamente: ESCOLHA <variável de verificação>

Certo ( ) Errado ( ) CASO <valor1> FAÇA

6. (Prof. Arthur Gonçalves/Turma "instruções a serem executadas caso


Técnico em Informática/Esamaz Tec <variável de verificação> = <valor1>"
- 2019) Em algoritmo, quando nos
CASO <valor2> FAÇA
referimos a palavra atribuir, como por
exemplo, é atribuído x a variável erro) "instruções a serem executadas caso
significa dizer que estamos dando <variável de verificação> = <valor2>"
nome a uma variável.
CASO <valor3> FAÇA
Certo ( ) Errado ( )
"instruções a serem executadas caso
7. (Prof. Arthur Gonçalves/Turma <variável de verificação> = <valor3>"
Técnico em Informática/Esamaz Tec
FIM-ESCOLHA
- 2019) A estrutura a baixo é
classificada como uma estrutura de Está afirmação está completamente:
repetição definida.
Certo ( ) Errado ( )
ENQUANTO <expressão
9. (Prof. Arthur Gonçalves/Turma
booleana> FAÇA
Técnico em Informática/Esamaz Tec
<instruções executadas enquanto a - 2019) Analise o Algoritmo a baixo:
expressão booleana resultar em Algoritmo maior e menor valor literal
VERDADEIRO> Var: a, b, c: inteiro
Inicio
FIM-ENQUANTO
a = 100, b = 90 c=80
Está afirmação está completamente: Se a >= b e a >= c Então

Certo ( ) Errado ( ) a é maior


Senão Se b >= a e b >= c Então
8. (Prof. Arthur Gonçalves/Turma
b é maior
Técnico em Informática/Esamaz Tec
senão
- 2019) A estrutura a baixo é
c é maior
classificada como uma estrutura de
fim se
condição múltipla. Fim algoritmo

“Descobri que, quanto mais eu estudo, mais sorte eu pareço ter nas
provas”
3 –Enroscar lâmpada.
É correto afirmar que o resultado desse
4 –Senão se verificar se a lâmpada
algoritmo é:
está queimada Então
A) A é maior 5 –Trocar lâmpada.

B) 100 Senão
6 –Verificar instalação elétrica.
C) 90
Fim-Se
D) B é maior Fim

E) 80 É correto afirmar que se a lâmpada


estiver enroscada, então:
10. (Prof. Arthur Gonçalves/Turma
Técnico em Informática/Esamaz Tec A) É preciso trocar a lâmpada
- 2019) Analise o Algoritmo a
B) verifique a instalação elétrica
baixo: AlgoritmoLigar luz
Inicio C) Com toda a certeza a luz liga

1 –Lâmpada não liga. D) verifico se a lâmpada está queimada


2 –A lâmpada está enroscada? e troco ou verifico a instalação elétrica.
Se a lâmpada não está enroscada
E) Processa a Celpa e seus estagiários
Então

“Descobri que, quanto mais eu estudo, mais sorte eu pareço ter nas
provas”