Você está na página 1de 14

Manual novo ICTI Manager e Instalador Unificado ImPacta

1. Instalador Unificado Impacta


1.1. Sobre
O Instalador Unificado ImPacta foi criado com o objetivo de facilitar a
instalação dos aplicativos necessários para programar as centrais ImPacta,
tendo como foco as centrais que não possuam placa ICIP. As versões contidas
neste instalador serão baseadas na Tabela de Compatibilidade Centrais ImPacta
(exceto Programadores Java). É recomendado a utilização deste instalador em
conjunto com o novo ICTI Manager (também presente no pacote de instalação)
para garantir que a compatibilidade entre versão do PABX, Programador Web e
navegador sejam satisfeitas. Os detalhes sobre as novidades no ICTI Manager
serão abordados no capítulo 2.

1.2. Vantagens
Dentre as vantagens que o uso do instalador oferece, pode-se citar:
 As principais versões estáveis do Programador Web, lançadas ao longo
do tempo, estarão reunidas em um único arquivo de instalação, para
que não haja necessidade de busca e download individual. Útil em caso
de instalação em computador novo ou que necessitou de reinstalação
do Windows.
 Este instalador contém também a nova versão do ICTI Manager.
Portanto, como os aplicativos recomendados estarão instalados, será
possível executá-los automaticamente através do ICTI Manager.

O ICTI Manager também continuará sendo disponibilizado de forma


avulsa, mesmo a partir da nova versão.

1.3. Conteúdo do instalador


A versão 1.0.21 deste instalador contém os instaladores dos seguintes
aplicativos, executados na ordem apresentada a seguir:
 Firefox 28 (32 bits)
 Firefox 40 (32 bits)
 Programador Web 1.2.6
 Programador Web 1.4.0
 Programador Web 1.4.6
 Programador Web 1.4.10
 Programador Web 1.4.14
 Programador Web 1.4.16
 Programador Web 1.6.0 (GW180)
 Programador Web 1.6.2 (GW 108 3G)
 Programador Web 2.0.01
 Programador Web 2.0.04
 Programador Web 2.0.06
 Programador Web 2.0.12
 Programador Web 2.0.14
 Programador Web 2.0.16
 Programador Web 2.0.18
 Programador Web 2.0.20
 Programador Web 2.0.21
 Programador Web 2.0.26
 Programador Web 2.0.28
 Programador Web 2.0.30
 Programador Web 2.0.36
 Programador Web 2.0.38
 Programador Web 2.0.40
 ICTI Manager 3.02.53

1.4. Instalação do Instalador Unificado Impacta-1.0.21

O instalador versão 1.0.21 possui duas versões do navegador Mozilla


Firefox. Versão 28 e 40. O Firefox 28 é compatível com versões de Programador
Web até 1.4.14. A partir da 1.4.16 até a 2.0.40, a versão compatível é Firefox
40.

Atenção:
1. Antes de executar o Instalador Unificado Impacta, verifique se o
computador já possui Firefox, Programador Web e ICTI Manager
instalados. Se houver, remova-os pelo “Painel de Controle > Programas e
Recursos”.

2. O instalador do Firefox, para ambas versões, por padrão, instala no


mesmo diretório “C:\Program Files (x86)\Mozilla Firefox\”, então, para
que a instalação da versão 40 não sobrescreva a instalação 28 e após
instalados possam ser executados de forma independente, deve-se
seguir o procedimento a seguir:

3. Para evitar que o Firefox verifique e instale atualizações


automaticamente, desconecte o computador da internet até que as duas
versões do Firefox estejam instaladas e configuradas para não atualizar
a versão automaticamente.
Execute o InstaladorUnificadoImpacta-1.0.21.exe. A primeira instalação executada será
do Firefox 28.
1.4.1. Instalação do Firefox 28
Atenção:
Na etapa “Tipo de instalação”, selecione a opção “Personalizada”. Na
tela seguinte, acrescente o identificador 28 após a palavra Firefox (junto,
sem espaço) como mostra a Figura 1.

Figura 1. Definição do diretório de instalação do Firefox 28

Nas próximas etapas deste instalador (Firefox 28), desmarque a opção


“Definir o Firefox como o navegador padrão”. Deixe as demais opções
padrão. Desmarque a opção “Iniciar o Firefox agora” e pressione “Concluir”.
Acesse o atalho do Firefox criado na Área de Trabalho e renomeie
acrescentando a identificação 28.

Se a janela do Instalador Unificado Impacta estiver impedindo o


acesso a área de trabalho, pressione tecla Windows + D.
Clique com o botão direito sobre o atalho renomeado, “Propriedades”, aba
“Atalho”. No campo “Destino”, acrescente os parâmetros -no-remote -p
firefox28, como mostra a Figura 2, salve e feche a janela.

Figura 2. Definição do perfil para a versão 28 do Firefox

Dê um duplo clique no atalho do Firefox 28. Deverá abrir o gerenciador de


perfis do Firefox. Clique em “Novo perfil” e defina o nome como firefox28 como
mostra a Figura 3 e salve a configuração.
Figura 3. Definição do nome firefox28 para o perfil do Firefox 28

Com o perfil firefox28 selecionado e a opção “Usar o perfil selecionado


sem perguntar ao iniciar” marcada, como mostra a Figura 4, clique em
“Iniciar o Firefox”.

Figura 4. Deixar marcada a opção "Usar o perfil.."

Assim que o Firefox iniciar, acesse “Opções > Avançado > Atualizações,
Atualizações do Firefox”, marque a opção “Nunca verificar”, desmarque a
opção “Usar um serviço para instalar atualizações em segundo plano”.
Desmarque também a opção “Mecanismos de pesquisa” como mostra a
Figura 5. Salve as alterações e feche o Firefox 28.

Figura 5. Desativando atualização do Firefox 28


Volte para o Instalador Unificado Impacta. A próxima instalação é do
Firefox 40.
1.4.2. Instalação do Firefox 40
Na etapa “Tipo de instalação”, selecione a opção “Personalizada”. Na
tela seguinte, acrescente o identificador 40 após a palavra Firefox (junto,
sem espaço), da mesma forma que foi feito no Firefox 28, Figura 1. Nas
próximas etapas deste instalador (Firefox 40) deixe as opções padrão.
Desmarque a opção “Iniciar o Firefox agora” e pressione “Concluir”.
Acesse o atalho do Firefox criado na Área de Trabalho e renomeie
acrescentando a identificação 40.

Se a janela do Instalador Unificado Impacta estiver impedindo o


acesso a área de trabalho, pressione tecla Windows + D.
Clique com o botão direito sobre o atalho renomeado, Propriedades,
aba Atalho. Acrescente os parâmetros -no-remote -p firefox40 no campo
“Destino”, assim como foi feito no atalho do Firefox28. Dê um duplo clique
no atalho. Ao abrir o gerenciador de perfis, crie um “Novo perfil” e defina o
nome como firefox40, e salve a configuração.
Após criados os perfis, estes devem ser apresentados conforme Figura
6. Com o perfil firefox40 selecionado e a opção “Usar o perfil selecionado
sem perguntar ao iniciar” marcada, clique em “Iniciar o Firefox”.

Figura 6. Perfis criados para o Firefox 28 e 40

Dê um duplo clique sobre o atalho do Firefox 40. Ao inicializar, acesse


“Opções > Avançado > Atualizações, Atualizações do Firefox”, marque a
opção “Nunca verificar”, desmarque a opção “Usar um serviço para instalar
atualizações em segundo plano”. Desmarque também a opção
“Mecanismos de pesquisa” como mostra a Figura 7. Salve as alterações e
feche o Firefox 40.

Figura 7. Desativando atualização do Firefox 40

Caso queira mais informações sobre os perfis criados para usar duas
ou mais versões diferentes do Firefox, acesse a página oficial da Mozilla:
https://support.mozilla.org/pt-BR/kb/usar-o-gerenciador-de-perfil-para-
criar-e-remover-
Volte para o Instalador Unificado Impacta. As próximas instalações
serão dos Programadores Web e, por último, o ICTI Manager.

1.4.3. Instalação do Programador Web 1.2.6


Proceda com a instalação padrão. Desmarque a opção “Executar
Programador WEB – Impacta” e “Abrir página do programador” ao final de
cada versão instalada.

Durante as instalações recomendamos configurar uma porta


diferente do serviço Web LightTPD para cada versão de Programador (Ex.:
8081, 8082...). Dessa forma, os problemas com cache do navegador podem
ser minimizados ao alternar o uso de diferentes versões.
1.4.4. Instalação do Programador Web 1.4.0: idem 1.2.6
1.4.5. Instalação do Programador Web 1.4.6: idem 1.2.6
1.4.6. Instalação do Programador Web 1.4.10: idem 1.2.6
1.4.7. Instalação do Programador Web 1.4.14: idem 1.2.6
1.4.8. Instalação do Programador Web 1.4.16: idem 1.2.6
1.4.9. Instalação do Programador Web 1.6.0: idem 1.2.6
1.4.10. Instalação do Programador Web 1.6.2: idem 1.2.6
1.4.11. Instalação do Programador Web 2.0.01: idem 1.2.6
1.4.12. Instalação do Programador Web 2.0.04: idem 1.2.6
1.4.13. Instalação do Programador Web 2.0.06: idem 1.2.6
1.4.14. Instalação do Programador Web 2.0.12: idem 1.2.6
1.4.15. Instalação do Programador Web 2.0.14: idem 1.2.6
1.4.16. Instalação do Programador Web 2.0.16: idem 1.2.6
1.4.17. Instalação do Programador Web 2.0.18: idem 1.2.6
1.4.18. Instalação do Programador Web 2.0.20: idem 1.2.6
1.4.19. Instalação do Programador Web 2.0.21: idem 1.2.6
1.4.20. Instalação do Programador Web 2.0.26: idem 1.2.6
1.4.21. Instalação do Programador Web 2.0.28: idem 1.2.6
1.4.22. Instalação do Programador Web 2.0.30: idem 1.2.6
1.4.23. Instalação do Programador Web 2.0.36: idem 1.2.6
1.4.24. Instalação do Programador Web 2.0.38: idem 1.2.6
1.4.25. Instalação do Programador Web 2.0.40: idem 1.2.6
1.4.26. Instalação do ICTI Manager 3.02.53: Proceda com a instalação
padrão.

Ao final da instalação do Instalador Unificado ImPacta, não é


necessário reiniciar o computador. Caso seja apresentada uma notificação de
que o computador precisa ser reiniciado, você pode responder “Não”.

2. ICTI Manager com nova implementação


2.1. Sobre
A partir da versão 3.02.33, o ICTI Manager apresentará, assim que a
conexão com o PABX ou GW 180 ou GW 108 3G for estabelecida, a versão do
equipamento, a versão do Programador compatível com a versão do
equipamento e, caso seja o Programador Web, a versão do Firefox compatível
com a versão do Programador Web. Dessa forma, caso o computador possua as
versões de Programador e Firefox compatíveis, será possível iniciar o
Programador Web e o Firefox através do próprio ICTI Manager.

2.2. Operação
2.2.1. Sem conexão com equipamento
Enquanto o ICTI não estiver conectado ao equipamento, a tela irá
apresentar as informações conforme figura 8.
Figura 8. ICTI Manager sem conexão com o equipamento.

2.2.2. Conectado a equipamento com versão não recomendada


A Tabela de Compatibilidade Centrais ImPacta, disponível na seção
Downloads de nosso site, apresenta as versões recomendadas
(estáveis) liberadas ao longo do tempo. Quando conectado a um
equipamento com versão que não conste nesta tabela, será
apresentada uma mensagem recomendando a atualização da versão
do equipamento. No exemplo da Figura 9, a ImPacta 220 está com a
versão 3.18.17 que não consta na tabela. Neste caso, a solução seria
atualizar para a versão 3.18.18 que consta na tabela ou, de
preferência, para a última versão do release 3.20. Assim, o campo
“Versão do programador a utilizar” poderá apresentar a versão de
programador compatível com a versão do equipamento.

Figura 9. Conexão a um equipamento com versão que não consta na Tabela de Compatibilidade.

2.2.3. Conectado a equipamento com versão recomendada


Quando conectado a um equipamento com versão recomendada, ou
seja, que conste na Tabela de Compatibilidade Centrais ImPacta, o
campo “Versão do programador a utilizar” apresentará a versão do
programador compatível com a versão do equipamento e a
“Localização do programador”. Neste caso, como o Programador é
Web, será apresentado também a “Versão do navegador a utilizar” e a
“Localização do navegador”. No exemplo da Figura 10, os diretórios da
versão do programador e do navegador foram localizados, então o
botão “Executar Programador” será habilitado para que os aplicativos
possam ser executados.

Figura 10. Conexão a um equipamento com versão que consta na Tabela de Compatibilidade.

Ao clicar em “Executar Programador” o programador será executado. Se o


programador for WEB e já estiver em execução, seja qual for a versão, este
será encerrado e iniciado novamente na versão compatível. Se for o
Programador Web, o navegador será aberto na sequência.

Caso o Programador ou o navegador não sejam executados


corretamente, pressione novamente o botão Executar Programador.

Para versões do programador anteriores a 3.08.73, o botão Executar


Programador não será habilitado, pois nessas versões mais antigas o diretório
de instalação padrão era o mesmo, então essa medida visa evitar que o ICTI
abra versão incorreta de programador.

2.2.4. Conexão à ImPacta com CPU que possua Ethernet


A partir da versão 3.20.02, se a placa CPU possuir a interface Ethernet,
será apresentado junto do “Modelo do equipamento” a informação
“com Ethernet”. A Figura 11 mostra um exemplo.
Figura 11. Conexão à ImPacta com placa CPU que possua Ethernet

2.2.5. Programador recomendado não localizado


Caso o programador recomendado não esteja instalado em seu
diretório padrão, o campo “Localização do programador” será
apresentado em vermelho e o botão “Executar Programador” ficará
desabilitado, como pode ser visto na Figura 12. Se esta versão de
programador estiver instalada no computador (ou não estiver),
recomenda-se desinstalar/instalar o Programador em seu diretório
padrão.

Figura 12. Diretório do Programador não localizado

2.2.6. Navegador recomendado não localizado


Caso o navegador recomendado não esteja instalado no diretório
indicado no campo “Localização do navegador”, este será apresentado
em vermelho como mostra a Figura 13. O botão “Executar
Programador” ficará habilitado para executar o programador, porém o
navegador não será executado. Se esta versão de navegador estiver
instalada no computador (ou não estiver), recomenda-se
desinstalar/instalar o navegador no mesmo diretório indicado pelo
campo (observe a identificação da versão).

Figura 13. Diretório do navegador não localizado

2.2.7. Versão do equipamento mais atual que a versão do ICTI


Manager
Caso a tabela de compatibilidade do ICTI Manager esteja
desatualizada, ou seja, conectou-se a um equipamento com versão
mais nova do que as que estão na sua base de conhecimento, então
será apresentada a mensagem conforme figura 14 para que seja
verificado no site se há nova versão do ICTI.
Figura 14. Versão do equipamento superior as que estão na tabela do ICTI

2.2.8. Diretório de programas do Windows não localizado


O ICTI Manager procura os Programadores Web e Firefox nos
diretórios de instalação padrão do Windows XP ao 10, nos idiomas
Português Brasil, Português Portugal e Espanhol México. Os
diretórios considerados padrão são: C:\Program Files (x86),
C:\Program Files, C:\Arquivos de Programas, C:\Programas,
C:\Archivos de Programa (x86) e C:\Archivos de Programa. Caso a
instalação esteja em um diretório diferente destes citados, a
mensagem apresentada será como a da Figura 15. Se os arquivos nas
versões indicadas em “Versão do programador a utilizar” e “Versão
do navegador a utilizar” estão instalados corretamente, então, como
alternativa, sugere-se executar manualmente a partir dos diretórios
em que estão instalados.
Figura 15. Diretórios de programas padrão do Windows não localizado.

2.2.9. Firefox atualizou automaticamente para uma versão superior a


recomendada.

Se a atualização automática do Firefox não foi desativada, conforme


descrito nos itens 1.4.1 e 1.4.2 deste procedimento, e o Firefox
atualizou automaticamente para uma versão superior às
recomendadas, então o campo “Localização do navegador” será
apresentado em vermelho como mostra a Figura 16. Abaixo será
apresentada a versão detectada e a instrução para que o Firefox seja
reinstalado e a atualização automática seja desabilitada. O botão
“Executar Programador” ficará habilitado para executar o
programador, porém o navegador não será executado.
Figura 16. Firefox atualizou automaticamente para uma versão superior às recomendadas.