Você está na página 1de 26

algoritmo "Ex01"

// Fun��o : Quais valores s�o negativos


// Autor : Thiego Moura
// Data : 20/04/2015
// Se��o de Declara��es
var
a,b,cont:real
inicio
// Se��o de Comandos
b<-0
cont<-0
enquanto cont<5 faca
escreval("Digite um valor para 'a': ")
leia(a)
se a<0 entao
b<-b+1
fimse
cont<-cont+1
fimenquanto
se b=1 entao
escreval("Dos 5 valores atribuidos para 'a',",b," � negativo")
senao
escreval("Dos 5 valores atribuidos para 'a',",b," s�o negativos")
fimse
fimalgoritmo
algoritmo "Ex_11"
// Fun��o : PA
// Autor : Thiego Moura
// Data : 21/04/2015
// Se��o de Declara��es
var
n,a1,r,x,s:inteiro
inicio
// Se��o de Comandos
escreval("Qual o n�mero de termos da progress�o aritm�tica: ")
leia(n)
escreval("Qual o primeiro termo: ")
leia(a1)
escreval("Qual a raz�o: ")
leia(r)
escreval("Os termos da progress�o s�o: ")
para x de 1 ate n faca
escreva(a1)
s<-s+a1
a1<-a1+r
fimpara
escreval(" ")
escreval("A soma dos termos �: ",s)
fimalgoritmo
algoritmo "Ex_12"
// Fun��o : Calcular tabuada
// Autor : Thiego R. Moura
// Data : 21/04/2015
// Se��o de Declara��es
var
n,x,j:inteiro
inicio
// Se��o de Comandos
para x de 1 ate 20 faca
escreval("Digite o valor de n: ")
leia(n)
se n = 0 entao
escreval(" 0 x 0 = 0")
senao
para j de 1 ate n faca
escreval(j," x",n," =",j*n)
fimpara
fimse
fimpara
fimalgoritmo
algoritmo "Ex_13"
// Fun��o : Fatorial
// Autor : Thiego Moura
// Data : 21/04/2015
// Se��o de Declara��es
var
nt,n,fat,x,aux:inteiro
inicio
// Se��o de Comandos
escreval("Digite o valor de n(quantos n�mero dever�o ser lidos): ")
leia(nt)
para x de 1 ate nt faca
escreval("Digite o valor: ")
leia(n)
se n = 0 entao
escreval("Valor = 0 Fatorial = 1")
senao
aux <- n
fat <- n
enquanto aux <> 1 faca
fat<-fat*(aux-1)
aux<-aux-1
fimenquanto
escreval("Valor = ",n," Fatorial =",fat)
fimse
fimpara
fimalgoritmo
algoritmo "Ex_15"
// Fun��o : Frequ�ncia de valores em determinados intervalos
// Autor : Thiego Moura
// Data : 21/04/2015
// Se��o de Declara��es
var
n,i1,i2,i3,i4:inteiro
inicio
// Se��o de Comandos
repita
escreval("Digite um n�mero (a entrada ser� finalizada por um n�mero negativo): ")
leia(n)
se n < 0 entao
interrompa
fimse
se (n >= 0) e (n <= 25) entao
i1 <- i1+1
senao
se (n >= 26) e (n <= 50) entao
i2 <- i2+1
senao
se (n >= 51) e (n <= 75) entao
i3 <- i3+1
senao
se (n >= 76) e (n <= 100) entao
i4 <- i4+1
fimse
fimse
fimse
fimse
ate falso
escreval(i1," valor(es) est�(�o) entre 0-25")
escreval(i2," valor(es) est�(�o) entre 26-50")
escreval(i3," valor(es) est�(�o) entre 51-75")
escreval(i4," valor(es) est�(�o) entre 76-100")
fimalgoritmo
algoritmo "Ex_16"
// Fun��o : Tabela contendo raiz quadrada, quadrado e cubo de n valores
// Autor : Thiego
// Data : 22/04/2015
// Se��o de Declara��es
var
n,c:inteiro
rn:real
inicio
// Se��o de Comandos
c<-0
n<-1
enquanto n<>0 faca
escreval("Digite um valor (0 p/ encerrar a entrada de dados): ")
leia(n)
se (c=0) ou (c=20) entao
escreval("Valor Valor^2 Valor^3 RaizQuadrada")
c<-1
fimse
rn<-raizq(n)
escreval(n," ",n^2," ",n^3," ",rn)
c<-c+1
fimenquanto
fimalgoritmo
algoritmo "Ex_17"
// Fun��o : Soma dos inteiros positivos de pares (m,n)
// Autor : Thiego Moura
// Data : 27/04/2015
// Se��o de Declara��es
var
m,n,soma:inteiro
inicio
// Se��o de Comandos
repita
escreval("Digite um para inteiro e positivo, ou valor negativo para encerrar")
escreval("Digite o valor do 1� (m) n�mero inteiro e positivo do par: ")
leia(m)
se m < 0 entao
interrompa
fimse
escreval("Digite o valor do 2� (n) n�mero inteiro e positivo do par: ")
leia(n)
se n < 0 entao
interrompa
fimse
se m = n-1 entao
soma<-soma+n
fimse
ate falso
escreval("A soma dos n consecutivos a partir de m �: ",soma)
fimalgoritmo
algoritmo "Ex_18"
// Fun��o : Verificar divisores, fatorial e soma do inteiros
// Autor : Thiego Moura
// Data : 22/04/2015
// Se��o de Declara��es
var
m,x,aux:inteiro
inicio
// Se��o de Comandos
repita
repita
aux<-0
escreval("Digite um valor inteiro e positivo (0 p/ finalizar): ")
leia(m)
ate m>=0
se m = 0 entao
interrompa
fimse
se m mod 2=0 entao
para x de m ate 1 passo -1 faca
se m mod x =0 entao
aux<-aux+1
fimse
fimpara
escreval("Existem",aux," divisores para",m)
senao
se m < 10 entao
aux <- m
x <- m
enquanto aux <> 1 faca
m <- m*(aux-1)
aux <- aux-1
fimenquanto
escreval("O fatorial de",x," �",m)
senao
para x de m ate 1 passo-1 faca
aux<-aux+x
fimpara
escreval("A soma dos inteiros de 1 at�",m," �: ",aux)
fimse
fimse
ate falso
fimalgoritmo
algoritmo "Ex_19"
// Fun��o : Verifcar quantos s�o �mpares e quantos s�o pares e mostrar as m�dias
// Autor : Thiego Moura
// Data : 22/04/2015
// Se��o de Declara��es
var
n,qi,qp,mp,mgeral:inteiro
inicio
// Se��o de Comandos
repita
repita
escreval("Digite um n�mero positivo (0 p/ encerrar): ")
leia(n)
ate n>=0
se n = 0 entao
interrompa
fimse
se n mod 2 = 0 entao
qp<-qp+1
mp<-mp+n
mgeral<-mgeral+n
senao
qi<-qi+1
mgeral<-mgeral+n
fimse
ate falso
escreval("A quantidade de pares �: ",qp)
escreval("A quantidade de �mpares �: ",qi)
escreval("A m�dia dos pares �: ",mp/qp)
escreval("A m�dia geral �: ",mgeral/(qp+qi))
fimalgoritmo
algoritmo "Ex_20"
// Fun��o : Calcular a soma dos numeros negativos
// Autor : Thiego Moura
// Data : 22/04/2015
// Se��o de Declara��es
var
n,som:inteiro
inicio
// Se��o de Comandos
repita
escreval("Digite um n�mero inteiro (0 p/ encerrar): ")
leia(n)
se n = 0 entao
interrompa
fimse
se n < 0 entao
som<-som+n
fimse
ate falso
escreval("A soma dos n�meros negativos �: ",som)
fimalgoritmo
algoritmo "Ex_21"
// Fun��o : Calcular o produto dos numeros inteiros, positivos e pares
// Autor : Thiego Moura
// Data : 22/04/2015
// Se��o de Declara��es
var
n,som:inteiro
inicio
// Se��o de Comandos
repita
repita
escreval("Digite um n�mero inteiro e positivo (0 p/ encerrar): ")
leia(n)
se n < 0 entao
escreval("Erro!")
fimse
ate n>=0
se n = 0 entao
interrompa
fimse
se n mod 2 = 0 entao
som<-som+n
fimse
ate falso
escreval("O produt�rio do n�meros inteiros, positivos e pares �: ",som)
fimalgoritmo
algoritmo "Ex_02"
// Fun��o : Resolver a equa��o
// Autor : Thiego Moura
// Data : 20/04/2015
// Se��o de Declara��es
var
n,aux:inteiro
inicio
// Se��o de Comandos
escreval("Dada a equa��o E=1+1/1!+1/2!+1/3!+1/N!")
escreval("Digite um valor inteiro e positivo para N: ")
leia(n)
enquanto n<0 faca
escreval("Erro! Digite um valor positivo para 'n'")
leia(n)
fimenquanto
se n=0 entao
aux<-1
senao
aux<-n
enquanto n<>1 faca
aux<-aux*(n-1)
n<-n-1
fimenquanto
fimse
escreval("E=",1+1/(1*1)+1/(2*1)+1/(3*2*1)+1/aux)
fimalgoritmo
algoritmo "Ex_22"
// Fun��o :
// Autor : Thiego Moura
// Data : 22/04/2015
// Se��o de Declara��es
var
medsal,sal:real
id,c,maid,meid,qtdm:inteiro
sexo:caracter
inicio
// Se��o de Comandos
repita
escreval("Digite a idade (digite uma idade negativa p/ encerrar): ")
leia(id)
se id<0 entao
interrompa
fimse
escreval("Digite o sexo (M/F): ")
leia(sexo)
escreval("Digite o sal�rio: ")
leia(sal)
se c=0 entao
meid<-id
fimse
se id > maid entao
maid<-id
fimse
se id < meid entao
meid<-id
fimse
se (sexo="F") e (sal<=100) entao
qtdm<-qtdm+1
fimse
medsal<-medsal+sal
c<-c+1
ate falso
escreval("A m�dia do sal�rio do grupo �: ",medsal/c)
escreval("A maior idade �",maid," e a menor �",meid)
escreval(qtdm," mulher(es) tem sal�rio inferior a R$ 100,00")
fimalgoritmo
algoritmo "Ex_23-24"
// Fun��o : Pesquisa de caracter�sticas f�sicas de um popula��o
// Autor : Thiego Moura
// Data : 23/04/2015
// Se��o de Declara��es
var
sexo,olhos,cabelos:caracter
id,mid,qntind:inteiro
inicio
// Se��o de Comandos
repita
escreval("Digite a idade (negativa p/ encerrar): ")
leia(id)
se id<0 entao
interrompa
fimse
se sexo="" entao
mid<-id
fimse
se id > mid entao
mid<-id
fimse
repita
escreval("Sexo (M/F): ")
leia(sexo)
//se (sexo<>"M") ou (sexo<>"m") ou (sexo<>"F") ou (sexo<>"f") entao
//escreval("Erro!")
//fimse
ate (sexo="M") ou (sexo="m") ou (sexo="f") ou (sexo="F")
repita
escreval("Digite a cor dos olhos (azuis, verdes ou castanhos): ")
leia(olhos)
//se (olhos<>"azuis") ou (olhos<>"verdes") ou (olhos<>"castanhos") entao
//escreval("Erro!")
//fimse
ate (olhos<>"azuis") ou (olhos<>"verdes") ou (olhos<>"castanhos")
repita
escreval("Digite a cor dos cabelos (louros, castanhos ou pretos): ")
leia(cabelos)
//se (cabelos<>"louros") ou (cabelos<>"pretos") ou (cabelos<>"castanhos") entao
//escreval("Erro!")
//fimse
ate (cabelos="louros") ou (cabelos="pretos") ou (cabelos="castanhos")
se (sexo="F") ou (sexo="f") e (id>=18) e (id<=35) e(cabelos="louros") e
(olhos="verdes") entao
qntind<- qntind+1
fimse
ate falso
escreval("A maior idade entre os habitantes �: ",mid)
escreval("A qntd de mulheres cuja idade est� entre 18 e 35")
escreval("anos que tem olhos verdes e cabelos louros �: ",qntind)
fimalgoritmo
algoritmo "Ex_25"
// Fun��o : Aumentar o pre�os em 20%
// Autor : Thiego Moura
// Data : 24/04/2015
// Se��o de Declara��es
var
cod,c:inteiro
avgc,avgs,p:real
inicio
// Se��o de Comandos
enquanto verdadeiro faca
escreval("Digite o c�digo do produto (negativo p/ encerrar a entrada): ")
leia(cod)
se cod<0 entao
interrompa
fimse
escreval("Digite o pre�o: ")
leia(p)
avgs<-avgs+p
avgc<-avgc+(p+(p*20/100))
escreval("C�digo: ",cod)
escreval("Pre�o c/ aumento: ",p+(p*20/100))
fimenquanto
escreval("M�dia de pre�os s/ aumento: ",avgs)
escreval("M�dia de pre�os c/ aumento: ",avgc)
fimalgoritmo
algoritmo "Ex_26"
// Fun��o : numeros divisiveis por 11 que tenham resto igual a 5 entre mil e 1999
// Autor : Thiego Moura
// Data : 24/04/2015
// Se��o de Declara��es
var
n:inteiro
inicio
// Se��o de Comandos
para n de 1000 ate 1999 faca
se n mod 11 = 5 entao
escreval(n)
fimse
fimpara
fimalgoritmo
algoritmo "Ex_27"
// Fun��o : encontrar o maior menor e m�dia entre 500 valores
// Autor : Thiego Moura
// Data : 24/04/2015
// Se��o de Declara��es
var
x,v,me,ma,avg:inteiro
inicio
// Se��o de Comandos
escreval("Digite 500 valores inteiros positivos")
para x de 1 ate 500 faca
repita
escreval(x,"� valor: ")
leia(v)
se v<0 entao
escreval("Erro!")
fimse
ate v>=0
se x=1 entao
ma<-v
me<-v
fimse
se v>ma entao
ma<-v
fimse
se v<me entao
me<-v
fimse
avg<-avg+v
fimpara
escreval("O maior valor dentre os lidos �: ",ma)
escreval("O menor valor dentre os lidso �: ",me)
escreval("A m�dia dos valores lidos �: ",avg/500)
fimalgoritmo
algoritmo "Ex_28"
// Fun��o : calcular a seguinte soma s:=1+1/2+1/3+1/4+...+1/n
// Autor : Thiego Moura
// Data : 24/04/2015
// Se��o de Declara��es
var
n,x:inteiro
s:real
inicio
// Se��o de Comandos
escreval("S := 1 + 1/2 + 1/3 + 1/4 + ... + 1/n")
repita
escreval("Digite o valor de 'n': ")
leia(n)
ate n>=0
se n=1 entao
s<-1
escreval("S:= 1")
senao
escreval("S:= 1")
fimse
para x de 2 ate n faca
se x=2 entao
escreval("S:= S + 1/",x)
s<-s+(1+(1/x))
senao
escreval("S:= S + 1/",x)
s<-s+(1/x)
fimse
fimpara
escreval(" ")
escreval("S = ",s:2:2)
fimalgoritmo
algoritmo "Ex_29"
// Fun��o : Calcular a m�dia de entre 13 e 73
// Autor : Thiego Moura
// Data : 25/04/2015
// Se��o de Declara��es
var
n,c,avg:real
inicio
// Se��o de Comandos
repita
escreval("Atribua N valores (digite um n�mero negativo p/ encerrar): ")
leia(n)
se n<0 entao
interrompa
fimse
se (n >= 13) e (n <= 73) entao
avg<-avg+n
c<-c+1
fimse
ate falso
escreval("A m�dia aritm�tica dos n�meros lidos entre 13 e 73 �: ",avg/c)
fimalgoritmo
algoritmo "Ex_30"
// Fun��o : Escrever os n�meros impares entre 100 e 200
// Autor : Thiego Moura
// Data : 25/04/2015
// Se��o de Declara��es
var
x:inteiro
inicio
// Se��o de Comandos
para x de 100 ate 200 faca
se x mod 2 <> 0 entao
escreval(x)
fimse
fimpara
fimalgoritmo
algoritmo "Ex_31"
// Fun��o : Saber de 10 valores quantos est�o em determinado intervalo
// Autor : Thiego Moura
// Data : 25/04/2015
// Se��o de Declara��es
var
x:inteiro
v,di,fi:real
inicio
// Se��o de Comandos
escreval("Digite 10 valores")
para x de 1 ate 10 faca
escreval(x,"� valor: ")
leia(v)
se (v >= 10) e (v <= 20) entao
di<-di+1
senao
fi<-fi+1
fimse
fimpara
escreval("Dos 10 valores digitados")
escreval(di," est�o dentro do intervalo de 10 e 20")
escreval("e",fi," n�o est�o nesse intervalo")
fimalgoritmo
algoritmo "Ex_32"
// Fun��o : Escrever os n�meros pares de um intervalo
// Autor : Thiego Moura
// Data : 25/04/2015
// Se��o de Declara��es
var
a,b,x,y:inteiro
inicio
// Se��o de Comandos
escreval("Digite 5 pares (a,b) de n�meros inteiros e positivos")
para x de 1 ate 5 faca
repita
escreva(x,"� par a: ")
leia(a)
escreval("b: ")
leia(b)
ate (a>=0) e (b>=0)
para y de a ate b faca
se y = a entao
escreval("Os n�meros pares dentro do intervalo (",a,",",b,") s�o: ")
fimse
se y mod 2 = 0 entao
escreval(y)
fimse
fimpara
fimpara
fimalgoritmo
algoritmo "Ex_03"
// Fun��o : Pesquisa p/ prefeitura
// Autor : Thiego Moura
// Data : 20/04/2015
// Se��o de Declara��es
var
sal,medsal,msal:real
f,medf:inteiro
tpessoa,percpessoa:real
inicio
// Se��o de Comandos
medsal<-0
tpessoa<-0
percpessoa<-0
sal<-1
msal<--99999999
enquanto sal > 0 faca
escreval("Digite o sal�rio: ")
leia(sal)
medsal<-medsal+sal
se sal > msal entao
msal<-sal
fimse
se sal <=100 entao
percpessoa<-percpessoa+1
fimse
escreval("Digite o n�mero de filhos: ")
leia(f)
medf<-medf+f
tpessoa<-tpessoa+1
fimenquanto
escreval("A m�dia do sal�rio da popula��o �: ", medsal/tpessoa)
escreval("A m�dia do n�mero de filhos �: ",medf/tpessoa)
escreval("O maior sal�rio �: ", msal)
escreval("O percentual de pessoas com sal�rio at� R$100,00 �:
",percpessoa*100/tpessoa,"%")
fimalgoritmo
algoritmo "Ex_33"
// Fun��o : Calcular a tabuada de 1 at� N
// Autor : Thiego Moura
// Data : 28/04/2015
// Se��o de Declara��es
var
n,x,y:inteiro
inicio
// Se��o de Comandos
escreval("Digite 20 vezes o valor de N")
para x de 1 ate 20 faca
escreval(x,"� valor: ")
leia(n)
se n = 0 entao
escreval(" 0 x 0 = 0")
fimse
para y de 1 ate n faca
escreval(y," x",n," =",y*n)
fimpara
escreval(" ")
fimpara
fimalgoritmo
algoritmo "Ex_34"
// Fun��o : Encontrar o aluno mais baixo e mais alto e informar seu codigo
// Autor : Thiego Moura
// Data : 28/04/2015
// Se��o de Declara��es
var
x,h,n:inteiro
ma,me,nma,nme:inteiro
inicio
// Se��o de Comandos
escreval("Digite 5 conjuntos de 2 valores, o primeiro representando o n�mero")
escreval("de um aluno, e o segundo representando a sua altura em cent�metros")
para x de 1 ate 5 faca
escreva(x,"� conjunto n: ")
leia(n)
escreva(" h: ")
leia(h)
se x = 1 entao
ma<-h
me<-h
nma<-n
nme<-n
senao
se h > ma entao
ma<-h
nma<-n
senao
se h < me entao
me<-h
nme<-n
fimse
fimse
fimse
fimpara
escreval(" ")
escreval("O n�mero do aluno mais alto �: ",nma," e sua altura �: ",ma)
escreval("O n�mero do aluno mais baixo �: ",nme," e sua altura �: ",me)
fimalgoritmo
algoritmo "semnome"
// Fun��o :
// Autor :
// Data : 28/04/2015
// Se��o de Declara��es
var
h,c,x,avg,avgm,ma,me,qtdm:inteiro
inicio
// Se��o de Comandos
escreval("Digite um conjunto de 50 informa��es contendo cada uma delas, a altu-")
escreval("ra e o sexo de uma pessoa (c�digo=1, masculino c�digo=2, feminino)")
para x de 1 ate 50 faca
repita
escreva(x,"� conjunto, altura: ")
leia(h)
escreva(" sexo (M=1 e F=2): ")
leia(c)
ate (h>=0) e (c=1) ou (c=2)
se x = 1 entao
ma<-h
me<-h
fimse
se c=2 entao
avgm<-avgm+h
qtdm<-qtdm+1
fimse
se h > ma entao
ma<-h
fimse
se h < me entao
me<-h
fimse
avg<-avg+h
fimpara
escreval(" ")
escreval("A maior altura da turma � ",ma," e a menor � ",me)
escreval("A m�dia das alturas das mulheres � ",avgm/qtdm)
escreval("A m�dia das alturas da turma � ",avg/50)
fimalgoritmo
algoritmo "Ex_36"
// Fun��o : Calcular o fatorial dos valores lidos
// Autor : Thiego Moura
// Data : 28/04/2015
// Se��o de Declara��es
var
n,aux,x,y,v:inteiro
inicio
// Se��o de Comandos
escreval("Quantos valores deveram ser lidos a seguir: ")
leia(n)
para x de 1 ate n faca
escreval("Digite o",x,"� valor: ")
leia(v)
aux<-v
se v = 0 entao
escreval(" 0, o fatorial � 1")
senao
para y de (v-1) ate 1 passo-1 faca
aux<-aux*y
fimpara
escreval(v,", o fatorial �",aux)
fimse
fimpara
fimalgoritmo
algoritmo "Ex_37"
// Fun��o : Mostrar os 20 primeiros termos da s�rie
// Autor : Thiego Moura
// Data : 28/04/2015
// Se��o de Declara��es
var
x,y:inteiro
inicio
// Se��o de Comandos
escreva("Digite o valor de X: ")
leia(x)
escreval("Os 20 primeiros termos da s�rie �")
para y de 1 ate 20 faca
escreval(x*y)
fimpara
fimalgoritmo
algoritmo "Ex_38"
// Fun��o : Calcular o produto dos n�meros primos entre 92 e 1478
// Autor : Thiego Moura
// Data : 28/04/2015
// Se��o de Declara��es
var
soma,x,y,cont:inteiro
inicio
// Se��o de Comandos
escreval("Os n�meros primos entre 92 e 1478 s�o: ")
para x de 92 ate 1478 faca
para y de x ate 1 passo-1 faca
se (x mod y )= 0 entao
cont<-cont+1
fimse
fimpara
se cont=2 entao
escreval(x)
soma<-soma+x
fimse
cont<-0
fimpara
escreval(" ")
escreval("O produto dos n�meros primos entre 92 e 1478 �: ",soma)
fimalgoritmo
algoritmo "Ex_39"
// Fun��o : Achar os 5 primeiros n�meros primos
// Autor : Thiego Moura
// Data : 29/04/2015
// Se��o de Declara��es
var
x,y,c,p,qtd:inteiro
inicio
// Se��o de Comandos
escreval("Os 5 primeiros n�meros primos s�o: ")
y<-2
repita
para x de y ate 1 passo-1 faca
se x = y entao
senao
se (y mod x) = 0 entao
p<-p+x
fimse
fimse
fimpara
se p = y entao
escreval(y)
qtd<-qtd+1
fimse
p<-0
y<-y+1
se qtd = 5 entao
interrompa
fimse
ate falso
fimalgoritmo
algoritmo "Ex_40"
// Fun��o : Escrever um algoritmo que leia um valor que indica quantos valores
//dever�o serem lidos a seguir, o somatorio dos valores de 1 ate m, e o fat de m
// Autor : Thiego Moura
// Data : 30/04/2015
// Se��o de Declara��es
var
n,m,x,y,z,soma,aux:inteiro
inicio
// Se��o de Comandos
escreva("Quanto valores dever�o ser lidos a seguir: ")
leia(n)
para x de 1 ate n faca
repita
escreva(x,"� valor: ")
leia(m)
ate m >= 0
para y de 1 ate m faca
soma<-soma+y
fimpara
aux<-m
para z de (m-1) ate 1 passo-1 faca
aux<-aux*z
fimpara
se m = entao
aux<-1
fimse
escreval("Valor lido Soma dos inteiros de 1 at�",m," Fatorial de",m)
escreval(m," ",soma," ",aux)
soma<-0
fimpara
fimalgoritmo
algoritmo "Ex_41"
// Fun��o : Calcular a m�dia ponderada de 50 alunos
// Autor : Thiego Moura
// Data : 30/04/2015
// Se��o de Declara��es
var
x,y:inteiro
avg,nt,avgp:real
inicio
// Se��o de Comandos
para x de 1 ate 50 faca
para y de 1 ate 3 faca
escreval(x,"� aluno, nota[",y," ]")
leia(nt)
se y = 1 entao
avgp<-avgp+nt*2
senao
se y = 2 entao
avgp<-avgp+nt*4
senao
avgp<-(avgp+nt*3)/10
fimse
fimse
fimpara
avg<-avg+avgp
escreval(" ")
escreval("A m�dia � ",avgp:2:1)
se avgp >= 7 entao
escreval("Situa��o: Aprovado")
senao
escreval("Situa��o: Reprovado")
fimse
fimpara
escreval(" ")
escreval("A m�dia geral � ",(avg/50):2:1)

fimalgoritmo
algoritmo "Ex_42"
// Fun��o : Calcular o valor de H
// Autor : Thiego Ramos Moura
// Data : 30/04/2015
// Se��o de Declara��es
var
h,n,x:inteiro
inicio
// Se��o de Comandos
escreval("H = 10 + 10 + 10 + ... + 10")
repita
escreval("Digite quantos valores ser�o acomulados em H: ")
leia(n)
se n < 0 entao
escreval("Digite um valor inteiro e positivo")
fimse
ate n >=0
para x de 1 ate n faca
h <- h + 10
fimpara
escreval("H = ",h)
fimalgoritmo
algoritmo "Ex_04"
// Fun��o : Saber quando Z� ser� maior que Chico
// Autor : Thiego Moura
// Data : 20/04/2015
// Se��o de Declara��es
var
ano,hze,hch:real
inicio
// Se��o de Comandos
hch<-150
hze<-110
ano<-0
enquanto hze<=hch faca
hch<-hch+2
hze<-hze+3
ano<-ano+1
fimenquanto
escreval("Ap�s",ano," anos, Z� com",hze/100,"(m) de altura ser� maior que
Chico",hch/100,"(m) de altura")
fimalgoritmo
algoritmo "Ex_43"
// Fun��o : Ordenar valores
// Autor : Thiego Moura
// Data : 30/04/2015
// Se��o de Declara��es
var
x,y:inteiro
a,b,c,d,aux:real
inicio
// Se��o de Comandos
escreval("Digite 5 grupos de valores (A,B,C,D)")
para x de 1 ate 5 faca
para y de 1 ate 4 faca
se y = 1 entao
escreval("Valor de A: ")
leia(a)
senao
se y = 2 entao
escreval("Valor de B: ")
leia(b)
senao
se y = 3 entao
escreval("Valor de C: ")
leia(c)
senao
escreval("Valor de D: ")
leia(d)
fimse
fimse
fimse
fimpara
escreval("Ordem de dita��o A=",a," B=",b," C=",c," D=",d)
repita
se d > c entao
aux<-d
d<-c
c<-aux
fimse
se c > b entao
aux<-c
c<-b
b<-aux
fimse
se b > a entao
aux<-b
b<-a
a<-aux
fimse
ate (a>=b) e (b>=c) e (c>=d)
escreval("A nova ordem � A=",a," B=",b," C=",c," D=",d)
fimpara
fimalgoritmo

algoritmo "Ex_44"
// Fun��o : Coletar dados sobre acidentes
// Autor : Thiego Moura
// Data : 05/05/2015
// Se��o de Declara��es
var
est:caracter
medv,meda:real
x,cod,cont,vp,vit,maind,meind,cidma,cidme:inteiro
inicio
// Se��o de Comandos
para x de 1 ate 200 faca
escreval("Digite o c�digo da cidade: ")
leia(cod)
repita
escreval("Digite o estado(MT,SP,MG,RS e etc): ")
leia(est)
maiusc(est)
ate (est="AL") ou (est="AP") ou (est="AM") ou (est="BA") ou (est="CE") ou
(est="DF") ou (est="ES") ou (est="GO") ou (est="MA") ou (est="MT") ou (est="MS") ou
(est="MG") ou (est="PA") ou (est="PB") ou (est="PR") ou (est="PE") ou (est="PI") ou
(est="RJ") ou (est="RN") ou (est="RS") ou (est="RO") ou (est="PR") ou (est="SC") ou
(est="SP") ou (est="SE") ou (est="TO")
escreval("Digite o n�mero de ve�culos de passeio (em 1992): ")
leia(vp)
escreval("Digite o n�mero de acidentes de tr�nsito com v�timas (em 1992): ")
leia(vit)
se x = 1 entao
maind<-vit
meind<-vit
cidma<-cod
cidme<-cod
fimse
se vit > maind entao
maind<-vit
cidma<-cod
fimse
se vit < meind entao
meind<-vit
cidme<-cod
fimse
medv<-medv+vp
se est="rs" entao
meda<-meda+vit
cont<-cont+1
fimse
fimpara
escreval("O maior �ndice pertence a cidade com cod: ",cidma,"o indice �: ",maind)
escreval("O menor pertece a cidade com cod: ",cidme,"o indice �: ",meind)
escreval("A m�dia de veiculos nas cidades brasileias �: ",medv/200)
escreval("A m�dia de acidentes com v�timas nas cidades do Rio Grande do Sul:
",meda/cont)
fimalgoritmo
algoritmo "Ex_45"
// Fun��o : Pesquisa entre 100 habitantes
// Autor : Thiego Moura
// Data : 05/05/2015
// Se��o de Declara��es
var
s,id,h,cont,contm,conth:inteiro
medid,medhmu,medhho,p:real
inicio
// Se��o de Comandos
repita
escreval("Digite o sexo (0-feminino, 1-masculino): ")
leia(s)
escreval("Digite a idade: ")
leia(id)
escreval("Digite a altura: ")
leia(h)
medid<-medid+id
se s=0 entao
medhmu<-medhmu+h
contm<-contm+1
senao
medhho<-medhho+h
conth<-conth+1
fimse
se (id>=18) e (id<=35) entao
p<-p+1
fimse
ate cont=10
escreval("M�dia da idade do grupo: ",meid/1000)
escreval("M�dia da altura das mulheres: ",medhmu/contm)
escreval("M�dia da altura dos homens: ",medhho/conth)
escreval("Percentual de pessoas com idade entre 18 e 35 anos: ",1000*p/100," %
cont<-cont+1
atecont = 1000
fimalgoritmo
algoritmo "Ex_46"
// Fun��o : Pesquisa de caracteristas de uma popula��o
// Autor : Thiego Moura
// Data : 05/05/2015
// Se��o de Declara��es
var
s,o,c:caracter
x,maid,qtd,id:inteiro
inicio
// Se��o de Comandos
repita
repita
escreval(x+1,"� pessoa")
escreval("Digite o sexo (M-Masculino F-Feminino): ")
leia(s)
ate (s="m") ou (s="f")
repita
escreval("Digite a cor dos olhos (A-Azuis, V-Verdes e C-Castanhos): ")
leia(o)
ate (o="a") ou (o="v") ou (o="c")
repita
escreval("Digite a cor dos cabelos (L-Louros, C-Castanhos e P-Pretos): ")
leia(c)
ate (c="l") ou (c="c") ou (c="p")
escreval("Digite a idade: ")
leia(id)
se x=0 entao
maid<-id
fimse
se (s="f") e (o="v") e (c="l") e (id>=19) e (id<=35) entao
qtd<-qtd+1
fimse
x<-x+1
limpatela
ate x=500
escreval("A maior idade do grupo �: ",maid)
escreval("A quantidade de indiv�duos do sexo feminino, cuja idade est� entre
escreval("18 e 35 anos e que tenham olhos verdes e cabelos louros �: ",qtd)
fimalgoritmo
algoritmo "Ex_46"
// Fun��o : Pesquisa de caracteristas de uma popula��o
// Autor : Thiego Moura
// Data : 05/05/2015
// Se��o de Declara��es
var
n:caracter
v:real
x:inteiro
inicio
// Se��o de Comandos
repita
escreval(x+1,"� Cliente")
escreval("Digite o nome: ")
leia(n)
escreval("Digite o valor das compras: ")
leia(v)
se v < 500 entao
v <- v*10/100
senao
v <- v*15/100
fimse
escreval(n," o seu b�nus � de ",v)
escreval(" ")
x<-x+1
ate x=150
escreval("A maior idade do grupo �: ",maid)
escreval("A quantidade de indiv�duos do sexo feminino, cuja idade est� entre
escreval("18 e 35 anos e que tenham olhos verdes e cabelos louros �: ",qtd)
fimalgoritmo
algoritmo "Ex_48"
// Fun��o : Mostrar os conceitos finais de alunos
// Autor : Thiego Moura
// Data : 05/05/2015
// Se��o de Declara��es
var
m,x:inteiro
nt:real
inicio
// Se��o de Comandos
repita
escreval("Digite a matricula do ",x+1,"� aluno")
leia(m)
escreval("Nota final: ")
leia(nt)
se (nt>=0) e (nt<5) entao
escreval("Seu conceito � D")
senao
se nt<7 entao
escreval("Seu conceito � C")
senao
se nt<9 entao
escreval("Seu conceito � B")
senao
escreval("Seu conceito � A")
fimse
fimse
fimse
x<-x+1
ate x=75
fimalgoritmo
algoritmo "Ex_49"
// Fun��o : Calcular o fatorial
// Autor : Thiego Moura
// Data : 05/05/2015
// Se��o de Declara��es
var
n,x,aux:inteiro
inicio
// Se��o de Comandos
repita
escreval("Digite um valor inteiro e positivo: ")
leia(n)
ate n>=0
aux<-n
para x de n ate 2 passo -1 faca
aux<-aux*(x-1)
fimpara
escreval("O fatorial de ",n," � ",aux)
fimalgoritmo
algoritmo "Ex_50"
// Fun��o : Calcular a fun��o pot�ncia
// Autor : Thiego Moura
// Data : 05/05/2015
// Se��o de Declara��es
var
x,y:inteiro
inicio
// Se��o de Comandos
escreval("Digite 2 valores inteiros e positivos")
escreva("X: ")
leia(x)
escreva("Y: ")
leia(y)
escreval("A fun��o pot�ncia de",x," por ",y," � ",x^y)
fimalgoritmo
algoritmo "Ex_51"
// Fun��o : Calcular o fatorial de um n�mero
// Autor : Thiego Moura
// Data : 05/05/2015
// Se��o de Declara��es
var
x,n,aux:inteiro
inicio
// Se��o de Comandos
repita
escreval("Digite um n�mero inteiro e positivo: ")
leia(n)
ate n>=0
aux<-n
escreval(n,"!")
para x de n ate 2 passo-1 faca
aux<-aux*(x-1)
se x = n entao
escreva(n)
fimse
escreva(" x ",x-1)
se x = 2 entao
escreva(" = ",aux)
fimse
fimpara
se n = 0 entao
aux<-1
fimse
se n = 1 entao
aux<-1
fimse
fimalgoritmo
algoritmo "Ex_53"
// Fun��o : Achar os 20 primeiros n�meros primos
// Autor : Thiego Moura
// Data : 29/04/2015
// Se��o de Declara��es
var
x,y,c,p,qtd:inteiro
inicio
// Se��o de Comandos
escreval("Os 20 primeiros n�meros primos s�o: ")
escreval("1")
escreval("2")
escreval("3")
y<-2
repita
para x de y ate 1 passo-1 faca
se x = y entao
senao
se (y mod x) = 0 entao
p<-p+x
fimse
fimse
fimpara
se p = y entao
escreval(y)
qtd<-qtd+1
fimse
p<-0
y<-y+1
se qtd = 17 entao
interrompa
fimse
ate falso
fimalgoritmo
algoritmo "Ex_05"
// Fun��o : M�dia aritm�tica de valores inteiros positivos
// Autor : Thiego Moura
// Data : 20/04/2015
// Se��o de Declara��es
var
v,c:inteiro
m:real
inicio
// Se��o de Comandos
v<-1
m<-0
c<-0
enquanto v > 0 faca
escreval("Digite um valor inteiro e positivo: ")
leia(v)
se v < 0 entao
senao
m<-m+v
c<-c+1
fimse
fimenquanto
escreval("A m�dia aritm�tica dos valores digitados �: ",m/c)
fimalgoritmo
algoritmo "Ex_54"
// Fun��o : Dividir os intervalos de
// Autor : Thiego Moura
// Data : 05/05/2015
// Se��o de Declara��es
var
a,b,aux:inteiro
inicio
// Se��o de Comandos
escreval("Digite o primeiro n�mero: ")
leia(a)
escreval("Digite o segundo n�mero: ")
leia(b)
se a>b entao
aux<-a-b
senao
aux<-b-a
fimse
escreval("O intervalo dos dois n�meros dividido por 3 �: ",aux/3)
fimalgoritmo
algoritmo "Ex_06"
// Fun��o : Urna eleitoral
// Autor : Thiego Moura
// Data : 20/04/2015
// Se��o de Declara��es
var
ca,cb,cc,cd,cnulo,cbranco,v:inteiro
inicio
// Se��o de Comandos
ca<-0
cb<-0
cc<-0
cd<-0
cnulo<-0
cbranco<-0
repita
escreval("Digite o n�mero referente ao seu voto: ")
leia(v)
escolha v
caso 0
escreval("Vota��o encerrada")
caso 1
escreval("Voto registrado para o candidato A")
ca<-ca+1
caso 2
escreval("Voto registrado para o candidato B")
cb<-cb+1
caso 3
escreval("Voto registrado para o candidato C")
cc<-cc+1
caso 4
escreval("Voto registrado para o candidato D")
cd<-cd+1
caso 5
escreval("Voto nulo")
cnulo<-cnulo+1
caso 6
escreval("Voto em branco")
cbranco<-cbranco+1
outrocaso
escreval("Voto nulo")
cnulo<-cnulo+1
fimescolha
ate v=0
escreval(" ")
escreval("Total de votos")
escreval("Candidato A: ",ca)
escreval("Candidato B: ",cb)
escreval("Candidato C: ",cc)
escreval("Candidato D: ",cd)
escreval("Votos nulos: ",cnulo)
escreval("Votos em branco: ",cbranco)
fimalgoritmo
algoritmo "Ex_08"
// Fun��o : M�dia de n�meros pares
// Autor : Thiego Moura
// Data : 21/04/2015
// Se��o de Declara��es
var
m,n,c:inteiro
inicio
// Se��o de Comandos
n<-1
m<-0
c<-0
enquanto n <> 0 faca
escreval("Digite um n�mero: ")
leia(n)
se (n mod 2 = 0) e (n <> 0) entao
m<-m+n
c<-c+1
fimse
fimenquanto
escreval("A m�dia dos n�mero pares digitados �: ",m/c)
fimalgoritmo
algoritmo "Ex_09"
// Fun��o : Achar o maior e menor entre 50 valores
// Autor : Thiego Moura
// Data : 21/04/2015
// Se��o de Declara��es
var
ma,me,v,c:real
inicio
// Se��o de Comandos
escreval("Digite 50 valores: ")
leia(v)
c<-1
ma<-v
me<-v
enquanto c < 50 faca
leia(v)
se v > ma entao
ma<-v
fimse
se v < me entao
me<-v
fimse
c<-c+1
fimenquanto
escreval("O maior valor �: ",ma)
escreval("O menor valor �: ",me)
fimalgoritmo
algoritmo "Ex_10"
// Fun��o : M�dia pondeirada de um aluno
// Autor : Thiego Moura
// Data : 21/04/2015
// Se��o de Declara��es
var
n1,n2,n3,ma,aux1,aux2,med:real
cod:inteiro
inicio
// Se��o de Comandos
cod<-1
repita
escreval("Digite o c�digo do aluno: ")
leia(cod)
se cod=0 entao
interrompa
fimse
escreval("Digite a primeira nota: ")
leia(n1)
escreval("Digite a segunda nota: ")
leia(n2)
escreval("Digite a terceira nota: ")
leia(n3)
ma<-n1
aux1<-n2
aux2<-n3
se n2>ma entao
ma<-n2
aux1<-n1
aux2<-n3
fimse
se n3>ma entao
ma<-n3
aux1<-n1
aux2<-n3
fimse
escreval(" ")
escreval("O c�digo do aluno �: ", cod)
escreval("Suas notas s�o: ",n1,",",n2," e",n3)
med<-((ma*4)+(aux1*3)+(aux2*3))/10
escreval("Sua m�dia ponderada �: ",med)
se med>=5 entao
escreval("Situa��o: APROVADO")
senao
escreval("Situa��o: REPROVADO")
fimse
escreval(" ")
ate falso
fimalgoritmo