Você está na página 1de 9

Algoritmos e Programação

Para Engenharia

Desafio Profissional
Prof. Me. Marcos Candia
Integrantes
Bruna Oliveira RA: 1913121725
Daniel Felipe da Silva Cruz RA: 15003901
Daniel Lourival Stabile RA: 17004561
Leandro Henrique Targino RA: 16000929
Jéssica Thomaz Medeiros Neto RA: 1821320684
Tema
Programação para
Papelaria
O que é Codigo?
A linguagem de programação é um método padronizado, formado por um conjunto de regras
sintáticas e semânticas, de implementação de um código fonte - que pode ser compilado e
transformado em um programa de computador, ou usado como script interpretado - que
informará instruções de processamento ao computador. Permite que um programador
especifique precisamente quais os dados que o computador irá atuar como estes dados serão
armazenados ou transmitidos e, quais ações devem ser tomadas de acordo com as
circunstâncias. Linguagens de programação podem ser usadas para expressar algoritmos com
precisão.
Desenvolvimento
Programa Utilizado “VisualG 3.0.7.0”

Pseudocódigo

Algoritmo "Papelaria Lápis Colorido"


Descrição : Programa em que, ao se digitar o código de um produto cadastrado da
Papelaria Lápis Colorido, este retorne o nome do produto. Se o código do produto não
estiver cadastrado, o programa deve exibir a mensagem: “produto não cadastrado”.

Data atual : 19/04/2021


Desenvolvimento
Var:
cod:inteiro

Inicio
Escreval("--------------------------------")
Escreval("----Papelaria Lápis Colorido----")
Escreval("--------------------------------")
Escreval("")
Escreva ("Digite o código do produto: ")
leia(cod)
Se (cod = 100) Então
Escreva ("Lápis preto N.2")
senão
Se (cod = 150) Então
Escreva ("Borracha Branca")
senao
se (cod =200) entao
escreva ("Caneta Azul")
senao
se (cod = 230)entao
escreva ("Caneta Vermelha")
senao
se (cod =256)entao
Desenvolvimento
escreva ("Giz de cera 12un")
senao
se (cod = 300)entao
escreva ("Cartolina Branca")
senao
se(cod= 310 )entao
escreva ("Resma de sulfite branco A4")
senao
se (cod= 400) entao
escreva("Estojo escolar verde")
senao
se (cod = 470)entao
escreva ("Caderno universitário 100fls")
senao
se (cod =500)entao
escreva("Caderno brochura 50fls")
senao
Escreva ("Produto não cadastrado")
fimse
fimse
fimse
fimse
fimse
Desenvolvimento
fimse
fimse
fimse
fimse
fimse

Fimalgoritmo
Bibliografia

Linguagem De Programação:
https://pt.wikipedia.org/wiki/Linguagem_de_programa%C3%A7%C3%A3o#:~:text=A%20linguagem%20
de%20programa%C3%A7%C3%A3o%20%C3%A9,instru%C3%A7%C3%B5es%20de%20processamento%2
0ao%20