Você está na página 1de 5

ALGORITMO E PROGRAMAÇÃO

ATIVIDADES DA AULA 07

Todos os algoritmos desta atividade deverão ser desenvolvidos no VISUALG e


enviados no Microsoft Word.

1. Faça um algoritmo para ler um vetor de 10 números inteiros e depois exibi-lo em


ordem inversa.

Algoritmo "aula 7 exe 1 "

// Disciplina : Algoritimo e Programação

// Professor : Marcos Alves Mariano

// Descrição : ler numero e os da em ordem inversa

// Autor(a) : Constantino Costa de Lima

// Data atual : 18/11/2017

var

a: vetor [1..10] de inteiro

i : inteiro

inicio

para i de 1 ate 10 faca

escreva("digite o valor nunmero",i, " ")

leia( a[i])

fimpara

escreva (" o vetor inverso é")


para i de 10 ate 1 passo -1 faca

escreva (a[i])

fimpara

Fimalgoritmo

2. Faça um algoritmo para ler um vetor de 15 números inteiros e calcular e mostrar


quantas vezes o número 10 apareceu no vetor.

Algoritmo "aula 7 exe 2 "

// Disciplina : Algoritimo e Programação

// Professor : Marcos Alves Mariano

// Descrição : ler numero e os da em ordem inversa

// Autor(a) : Constantino Costa de Lima

// Data atual : 18/11/2017

var

a: vetor [1..15] de inteiro

i : inteiro

dez:inteiro

inicio

para i de 1 ate 15 faca

escreva("digite o valor nunmero",i, " ")

leia( a[i])
se ( a[i]=10) entao

dez <- dez+1

fimse

fimpara

escreva (" a quantidade de 10 digitados foram de",dez)

Fimalgoritmo

3. Faça um algoritmo para ler dois vetores A e B com 20 números inteiros cada, e
construir um vetor C, de forma que cada elemento de C seja a subtração da
respectiva posição de A com a respectiva posição de B.

Algoritmo "aula 7 exe 3 "

// Disciplina : Algoritimo e Programação

// Professor : Marcos Alves Mariano

// Descrição : ler numero e os da em ordem inversa

// Autor(a) : Constantino Costa de Lima

// Data atual : 18/11/2017

var

a,b,c: vetor [1..20] de inteiro

i : inteiro

inicio

para i de 1 ate 20 faca

escreva("digite o valor numero",i, " ")

leia( a[i])
fimpara

para i de 1 ate 20 faca

escreva("digite o valor numero",i, " ")

leia( b[i])

fimpara

para i de 1 ate 20 faca

c[i]<-a[i]-b[i]

fimpara

para i de 1 ate 20 faca

fimpara

Fimalgoritmo

4. Faça um algoritmo para ler dois vetores A e B com 15 inteiros cada, e construir
um vetor C, com 30 elementos, onde os 15 primeiros são os elementos de A e o
restante os elementos de B.

Algoritmo "aula 7 exe 4 "

// Disciplina : Algoritimo e Programação

// Professor : Marcos Alves Mariano

// Descrição : ler a e b e dar c que e a e b

// Autor(a) : Constantino Costa de Lima

// Data atual : 20/11/2017

Var

// Seção de Declarações das variáveis

a,b:vetor [1..15]de inteiro


c:vetor [1..15,1..15]de logico

i:inteiro

Inicio

// Seção de Comandos, procedimento, funções, operadores, etc...

para i <-1 ate 15 faca

escreva ("digite A ",i, " ")

leia( a [i])

fimpara

para i <- 1 ate 15 faca

escreva ("digite B",i, " ")

leia (b[i])

fimpara

para i<- 1 ate 15 faca

escreva ("[",c[i] = a[i],"]")

fimpara

para i <- 1 ate 15 faca

escreva ("[", c[i] = b[i], "]")

fimpara

Fimalgoritmo

Você também pode gostar