Você está na página 1de 9

1

Uso da função SOMASE


Na Planilha SOMASE:

Iremos estudar a função de soma condicional (Uma condição).


Sua sintaxe é dada por =SOMASE(intervalo; critérios ; [intervalo_soma] ).

1. Clique na célula D6 e insira a fórmula =SOMASE(A4:A16;"<20"). São aspas duplas (se você colocar
DUAS aspas simples, não vai dar certo). Ao pressionar Enter, o Excel irá localizar as células do intervalo
A4:A16 que estão abaixo de R$ 20,00 e somar seus valores.

2. Clique na célula D10 e insira a fórmula =SOMASE(A4:A16;">100"). O Excel vai localizar as células do
intervalo A4:A16 que estão acima de R$ 100,00 e somar seus valores.

Veja que nos dois casos acima, o último argumento da função, [intervalo_soma], não foi informado,
então o Excel entende que o intervalo a ser somado é o próprio A4:A16.
Argumentos entre colchetes são opcionais.

Vamos ver um caso onde é necessário diferenciar o intervalo de procura do intervalo de soma.

3. Clique na célula E22 e insira a fórmula =SOMASE($A$22:$A$33;D22;$B$22:$B$33). Arraste a fórmula


até a célula E25. Observe que os intervalos A22:A33 e B22:B33 precisam ser travados (fixos) e que a
célula D22 deve permanecer livre pois ao arrastar para baixo, o Excel deverá procurar os nomes dos
garçons nas células D23, D24 e D25.

Intervalo onde o Excel irá procurar o conteúdo


que está em D25 Intervalo onde o Excel irá somar o conteúdo que
corresponde à procura.
Ele vai encontrar TRÊS ocorrências:
Ele vai somar TRÊS valores:
Em A24, A27 e A33 (destacados em vermelho).
Em B24, B27 e B33 (destacados em vermelho).
2

Uso da função SOMASES


Na Planilha SOMASES:

Iremos estudar a função de soma condicional (duas ou mais condições).


Sua sintaxe é dada por:
=SOMASES(intervalo_soma; intervalo_critérios1 ; critérios1 ; intervalo_critérios2 ; critérios2 ; ... ).

1. Clique na célula C16 e insira a fórmula =SOMASES(C3:C14;B3:B14;"Juliana";C3:C14;">10").

2. Clique na célula C18 e insira a fórmula =SOMASES(C3:C14;B3:B14;"Juliana";A3:A14;"Outubro").

3. Na célula C20 insira =SOMASES(C3:C14;B3:B14;"João";C3:C14;">5";C3:C14;"<20").

Mais alguns exemplos:


4. Clique na célula B34 e insira =SOMASES(B27:B32;A27:A32;">=300000").
Obs. Neste caso, também funcionaria a função =SOMASE(A27:A32;">=300000";B27:B32) pois só existe um critério.

5. Clique na célula B35 e insira =SOMASES(B27:B32;A27:A32;">=200000";A27:A32;"<=400000").

6. Na célula B36 insira =SOMASES(B27:B32;A27:A32;">200000";A27:A32;"<400000").

7. Em B37 insira =SOMASES(B27:B32;A27:A32;">=200000";A27:A32;"<500000").

8. Em B38 insira =SOMASES(B27:B32;A27:A32;">300000";A27:A32;"<500000").


3

Nomeando grupos de dados

Neste exercício, vamos nomear dois grupos de dados e utilizar estes nomes para calcular uma
média ponderada.

Na Planilha: Notas

1. Selecione as células B2:B5.

2. Na Caixa de nome da extremidade esquerda da barra de fórmulas, digite Notas e pressione Enter para
criar um intervalo nomeado como Notas.

3. Selecione as células C2:C4. (Isso mesmo, estamos errando de propósito! Vamos corrigir daqui a pouco)

4. Na Caixa de nome, digite Pesos e pressione Enter para criar um intervalo nomeado com este nome.

5. Na guia Fórmulas, no grupo Nomes Definidos, clique em Gerenciador de Nomes para abrir a caixa de
diálogo Gerenciador de Nomes.

6. Clique no nome Pesos. O intervalo de células aparecerá na caixa Refere-se a na parte inferior da caixa
de diálogo Gerenciador de Nomes.
4

7. Altere o intervalo de células da caixa Refere-se a para =Notas!$C$2:$C$5 (mude o 4 para 5) e clique no
botão de marca de seleção à esquerda da caixa para finalizar a atualização.

8. Clique em Fechar para fechar a caixa de diálogo Gerenciador de Nomes.

9. Clique na célula C7 e digite =SOMARPRODUTO(n , neste momento o Excel irá sugerir uma lista de
funções iniciadas com “n”. Dê um clique duplo em Notas (ou clique em Notas e pressione Tab). Não
pressione Enter ainda...

10. Continue a editar a fórmula digitando ; “ponto e vírgula” para selecionar a segunda matriz a ser
multiplicada. Ao começar a digitar p . O Excel novamente irá sugerir uma lista com funções iniciadas
com “p”. Dê um clique duplo em Pesos.

11. Continue a digitação fechando os parênteses, inserindo a barra de divisão / e efetuando a divisão pela
soma dos pesos. Sua fórmula ficará com o seguinte aspecto:

12. Pressione Enter. O resultado deverá ser 5,0.


5

Uso da função SE
A função SE verifica se uma condição foi satisfeita e retorna um valor se for verdadeiro e um outro
valor se for falso.
Sua sintaxe é dada por =SE(teste_lógico; [valor_se_verdadeiro] ; [valor_se_falso] ).

Na função SOMASE eu comentei que argumentos entre colchetes são opcionais, não tratarei destas sutilezas no estudo
do SE, mas se você se interessar me pergunte como isto funciona.

Use a Planilha: SE

1. Clique na célula A1 e insira o número 5.

2. Clique na célula B1 e digite =SE(A1=5;"O valor é 5";"Este número não é 5"). Pressione Enter. O Excel
deve apresentar o texto O valor é 5 em B1.

3. Mude o conteúdo da célula A1 para 6 (ou qualquer coisa que não seja 5!). Veja que o texto da célula B1
irá mudar.

4. A função SE também testa valores de Texto. Por exemplo, na célula C4 insira a fórmula
=SE(B4="Mensalidade Paga";"Dar baixa";"Enviar cobrança"). Pressione Enter e arraste a alça de
preenchimento de C4 até a célula C12 e veja os resultados.
Obs. Você também poderia usar a condicional =SE(B4="Em atraso";"Enviar cobrança";"Dar baixa")
Teste essa alternativa, se quiser.

5. A função SE pode ser encadeada para testar três situações ou mais. Na célula B18 insira
=SE(A18<$B$15;"Título Vencido";"A vencer"). Arraste esta fórmula até a linha 37. O Excel irá mostrar
quais os títulos que estão vencidos e quais estão a vencer (em dia).

6. Na célula C18 insira =$B$15-A18, para o Excel calcular quantos dias estão em atraso (os números
positivos) ou quantos dias a vencer (os negativos). Arraste a fórmula até C37.

7. Na coluna D, você verá que o Excel pode encadear uma função SE dentro de outra função SE, várias
vezes, para avaliar diversas situações. Na célula D18 insira
=SE(C18>30;"Enviar para protesto";SE(C18>1;"Comunicar Cliente";"Aguardar pagamento"))
(usei a cor verde para destacar que outra função SE foi colocada no lugar da situação “FALSO”, ou seja,
o que o Excel deve fazer se a condição lógica não for atendida)

8. Arraste essa fórmula até a linha 37. Veja que foram impostas três situações:
 Títulos vencidos há mais de 30 dias são enviados para protesto;
 Os clientes devem ser comunicados se os títulos estão vencidos há menos de 30 dias
 Para os títulos que ainda não venceram, aguarda-se o pagamento.

DICA. Aqui fica interessante a aplicação de uma formatação condicional na


coluna D. Quer tentar? Você pode deixar esta coluna com três cores
diferentes, destacando qual cliente deve ser protestado ou comunicado.
6

Uso da função PROCV


A função PROCV procura um valor na primeira coluna à esquerda de uma tabela e retorna um
valor na mesma linha de uma coluna especificada.
Sua sintaxe é dada por:
=PROCV(valor_procurado ; matriz_tabela ; núm_índice_coluna ; [procurar_intervalo] ).

Use a Planilha: PROCV

1. Nesta planilha já existe uma tabela (matriz_tabela) no intervalo A1:E6. Este é o local onde a função
PROCV vai fazer a busca vertical.
2. Clique na célula C12 e insira a fórmula =PROCV($B$10;$A$2:$E$6;2;FALSO). Pressione Enter. O Excel
irá retornar a mensagem #N/D porque nenhum valor foi informado na célula B10.
3. Arraste esta fórmula até a célula C15.
4. Faça as seguintes alterações no argumento núm_índice_coluna nas células C13, C14 e C15:
Em C13  =PROCV($B$10;$A$2:$E$6;3;FALSO)
Em C14  =PROCV($B$10;$A$2:$E$6;4;FALSO)
Em C15  =PROCV($B$10;$A$2:$E$6;5;FALSO)

5. Na célula B10 digite Paula. Todas as informações dessa cliente serão colocadas no intervalo C12:C15.
6. Na célula B10 digite simone (somente letras minúsculas). Todas as informações dessa cliente serão
colocadas no intervalo C12:C15. O Excel ignora a diferença entre maiúscula e minúscula.
7. Na célula B10 digite Antônio (com acento ^). Desta vez o Excel não reconhecerá o cliente devido à
diferença na acentuação.

Uso da função PROCH


A função PROCH pesquisa um valor na linha superior de uma tabela ou matriz de valores e retorna
o valor na mesma coluna a partir de uma linha especificada.
É bem semelhante ao PROCV, mas com busca na horizontal. Sua sintaxe é dada por:
=PROCH(valor_procurado ; matriz_tabela ; núm_índice_lin ; [procurar_intervalo] ).

Use a Planilha: PROCH

1. Nesta planilha já existe uma tabela (matriz_tabela) no intervalo A1:I3. Este é o local onde a função
PROCH vai fazer a busca horizontal.
2. Clique na célula B10 e insira a fórmula =PROCH(A8;B1:I3;2). Pressione Enter.
3. Clique na célula B11 e insira a fórmula =PROCH(A8;B1:I3;3). Pressione Enter.
4. Clique na célula A8 e insira o valor 3.
5. Clique na célula A8 e insira o valor 1.
7

Uso da função CONCATENAR


É uma função utilizada para unir duas ou mais cadeias de texto em uma única cadeia.
Sua sintaxe é dada por:
=CONCATENAR(texto1, [texto2], ...))

Vamos voltar à Planilha: PROCV

1. Clique na célula B18 e insira a fórmula:


=CONCATENAR(B10;" gosta de beber ";C13;" e costuma gastar até R$ ";C15;",00")
OBSERVE todo o cuidado que devemos ter ao inserir espaços e outros
símbolos, no uso da função concatenar.

2. Pressione Enter.
3. Clique na célula B10 e mude o nome do cliente.
4. Veja que a função concatenar irá atualizar a frase.

Uso da função CORRESP

Esta função retorna a posição relativa de um item em uma matriz que corresponda a um valor
específico em uma ordem específica.
Sua sintaxe é dada por:
=CORRESP(valor_procurado ; matriz_procurada; [tipo_correspondência] ).

Ainda na Planilha: PROCV

1. Escreva Pedro na célula B10.


2. Na célula B20 digite =CORRESP(B10;A2:A6;0). O Excel irá procurar qual a posição de Pedro na lista de
clientes. Ao pressionar Enter, saberemos que Pedro é o 3º da lista.
3. Na célula B21 digite =CORRESP(C14;D2:D6;0). Obviamente, açaí é a terceira sobremesa da lista, mude
o nome do cliente em B10 e você verá que a ordem dos itens em B20 e B21 também mudarão.
4. Agora vamos fazer um exercício interessante. Misturar as funções CONCATENAR e CORRESP. Clique na
célula B23 e digite =CONCATENAR(B10;" é o ";CORRESP(B10;A2:A6;0);"º cliente da lista.")
Cuidado com os espaços!
5. Mude o nome do cliente em B10.
6. Se quiser brincar um pouco, inclua o seu nome e de seus amigos na lista, com suas “gordices”
preferidas.

A próxima atividade é opcional, se você não quiser saber


como funcionam fórmulas com matrizes, tchau!
8

Usando fórmulas de matriz

Somente para os fortes! (Exercício opcional)


Nesta planilha vamos resolver alguns problemas com matrizes:

A. Multiplicando Matrizes.
8 2
Exemplo: [ 1 2 5 .
0 2 1 ][
0 3
2 5 ]
1. Clique na célula I2 e insira a fórmula =MATRIZ.MULT(B2:D3;F2:G4). Pressione Enter.
2. O Excel multiplicou a primeira linha da 1ª matriz pela primeira coluna da 2ª matriz. Ou seja, ele
efetuou 1 ×8+2 ×0+ 5× 2=18
3. Para que o Excel estenda o cálculo para as outras linhas e colunas, o operador (neste caso, você)
deve saber previamente o formato da matriz resultante. A primeira matriz é 2x3 a segunda é 3x2.
A matriz resultante deve ter um formato 2x2.
4. Selecione o intervalo I2:J3 (são quatro células). Com este intervalo selecionado e a célula I2 em
destaque,

5. pressione F2 e depois Ctrl + Shift e Enter, simultaneamente.

Obs. Se você quiser alterar uma fórmula de matriz, o Excel irá exibir uma mensagem de erro.

Pressione OK e em seguida ESC para sair da edição de matriz.

B. Calculando Determinante.
1 2 5
Exemplo: Achar o determinante da matriz 0 2

1. É bem mais fácil que multiplicar matrizes.


[ ] 1.
7 1 1
9

2. Clique na célula F9 e digite a fórmula =MATRIZ.DETERM(B8:D10). Pressione Enter. Pronto, acabou!

C. Calculando uma matriz inversa.


1 2 5

[ ]
Exemplo: Vamos calcular a matriz inversa de 0 2 1 .
7 1 1
1. É um procedimento semelhante ao da multiplicação de matrizes.
2. Clique na célula F14 e digite a fórmula =MATRIZ.INVERSO(B14:D16). Pressione Enter.
3. Agora vamos estender a seleção. Você deve saber que a matriz inversa de uma matriz quadrada é
outra matriz quadrada com o mesmo formato (mesmo número de linhas e colunas). Então
selecione o intervalo F14:H16 (uma matriz quadrada 3x3).
4. Com este intervalo selecionado e a célula F14 em destaque, pressione F2 e, em seguida, Ctrl + Shift
e Enter, simultaneamente.

D. (Resolvendo um sistema de equações) Uma construtora tem dois projetos de casas pré-fabricadas,
uma casa grande e uma média. Uma imobiliária fez duas cotações, recebendo os seguintes orçamentos:
- sete casas grandes e três médias, no total de R$ 965.000,00;
- três casas grandes e cinco médias, no total de R$ 655.000,00.

Este problema pode ser resolvido pelo seguinte sistema:

{73 x+3 y =965


x+5 y =655
Que é equivalente a [ 73 35 ] .[ xy]=[ 965
655 ]
Ou seja, passamos para o formato AX =B, cuja solução é X =A −1 B .

Agora é só usar os conceitos anteriores (inverter e multiplicar as matrizes).


1. Na célula H21 digite =MATRIZ.INVERSO(B21:C22).
2. Selecione o intervalo H21:I22, com a célula ativa em H21, pressione F2 e Ctrl Shift Enter,
simultaneamente.
3. Clique em H27 e insira a fórmula =MATRIZ.MULT(H21:I22;C27:C28).
4. Selecione o intervalo H27:H28, pressione F2 e Ctrl Shift Enter.

Os valores encontrados em H27 e H28 estão em milhares e correspondem a R$ 110.000,00 (valor da


casa grande) e R$ 65.000,00 (valor da casa média).

Mais para a frente iremos aprender algumas noções sobre o suplemento Solver.
Então estudaremos mais algumas formas de resolver equações e sistemas.

Você também pode gostar