Você está na página 1de 3

Governo do Distrito Federal

Secretaria de Estado de Educação


Subsecretaria de Educação Básica
Coordenação Regional de Ensino de Planaltina
Centro de Educação Profissional - Escola Técnica de Planaltina

Disciplina Fundamentos de Programação


Tipo de Envio de arquivo
Tarefa

Tarefa 6

a) O usuário irá digitar 10 elementos para um vetor inteiro. Faça um algoritmo que
determine qual o maior e o menor elemento dentro desse vetor.

R:
Var
vet:vetor[0..9] de inteiro
maior,menor,i:inteiro
Inicio
para i de 0 ate 9 faca
escreva ("Digite um valor inteiro:")
leia(vet[i])
se vet[i]>vet[maior] entao
maior<-i
fimse
se vet[i]<vet[menor] entao
menor<-i
fimse
fimpara
escreval("O maior valor é:",vet[maior], "e o menor valor é:",vet[menor])
fimalgoritmo

Fundamentos de Programação Página 1


Governo do Distrito Federal
Secretaria de Estado de Educação
Subsecretaria de Educação Básica
Coordenação Regional de Ensino de Planaltina
Centro de Educação Profissional - Escola Técnica de Planaltina

b) O usuário irá digitar os valores de uma matriz com 5 x 5 elementos do tipo inteiro.
Faça um algoritmo que determine qual o maior e o menor elemento dentro dessa
matriz.

R:

Var

matriz:vetor[1..5,1..5] de inteiro

linha,coluna,menornumero,maiornumero:inteiro

Inicio

para linha de 1 ate 5 faca

para coluna de 1 ate 5 faca

escreva("Digite o numero da [L=",linha,"C=",coluna,"] :")

leia(matriz[linha,coluna])

fimpara

fimpara

maiornumero<-matriz[1,1]

menornumero<-matriz[1,1]

para linha de 1 ate 5 faca

para coluna de 1 ate 5 faca

se matriz[linha,coluna]>maiornumero entao

maiornumero<-matriz[linha,coluna]

fimse

se matriz[linha,coluna]<menornumero entao

menornumero<-matriz[linha,coluna]

fimse

fimpara

Fundamentos de Programação Página 2


Governo do Distrito Federal
Secretaria de Estado de Educação
Subsecretaria de Educação Básica
Coordenação Regional de Ensino de Planaltina
Centro de Educação Profissional - Escola Técnica de Planaltina

escreval("O maior numero da matriz é:",maiornumero)

escreval("O menor numero da matriz é:",menornumero)

Fimalgoritmo

Fundamentos de Programação Página 3

Você também pode gostar