Você está na página 1de 3

FACULDADE DE ENGENHARIA

Disciplina: Informática Ano: 1º Semestre: 1o Período:Pós Laboral


EXAME NORMAL Data: 01 de Dezembro de 2015 Início:17h00 Duração: 120min
GUIÃO DE CORRECÇÃO

1. Uma enciclopédia com 1000 páginas, quanto espaço, em MB, vai precisar para o seu
armazenamento se a página, em média, tiver 100 linhas com 100 caracteres cada? Apresente todos
os cálculos.

Resolução:
1 caracter =1 Byte (0.25v)
Enciclopédia= 1000*100*100 Bytes=10 000 000 Bytes (0.25v)

1MB  10242 Bytes


xMB 10 000 000 Bytes (0.25 v)
x= 9,5 MB
Resp: Será necessário 9,5MB de espaço para armazenar da enciclopédia. (0.25v)

2. Dado L3 =1111 e Nh =111. Para cada uma das seguintes operações indique a resposta correcta
e aponte na tabela de respostas (tabela 1):
2.1 O resultado de L2+N2 é :
(A) 101102; (B) 1010110012; (C) 1001000002 ; (D) 1001110012; (E) 1011112 [1v]
2.2 O resultado de L8*N8 é :
(A) 1233218; (B) 4677318; (C) 262502 ; (D) 253502; (E) 252508 [1v]

2.3 O resultado inteiro de Nh / Lh é :


(A) 110h; (B) 7h; (C) 6h ; (D) 5h; (E) ABh [1v]

2.4 O resultado inteiro de Nh – Lh é :


[1v]
(A) F9h; (B) 9Eh; (C) E9h ; (D) D9h; (E) DAh

Questão a) b) c) d)
Resposta D E C C

Tabela1: Tabela de Respostas

n se n for termo de Fibonacci


3. Dada a série: 1, 2, 3,16, 5, 36, 49,… an =
n2 se n não for termo de Fibonacci
escreva um algoritmo para impressão dos 700 primeiros termos desta série com recurso a:
3.1 Fluxograma. [3v]
NB: série de Fibonacci: 1,2,3,5,8,13,… an = an-2+ an-1
3.2 Português estruturado. [3v]

__________________________________________________________________________________
Docente: Ticongolo, Inácio
RESOLUÇÃO DE # 2

3.1 Fluxograma
INICIO

n=0

[0,5v]
a1=1
n=n+1 a2=1
termo=0

termo
Não
n<=700 FIM

termo=n*n
Sim
Não [2,5v]
Sim Não
termo=n a=a2 n>a2

Sim

aux=a2
a2=a1+a2
a1=aux

3.2. Português Estruturado


ALGORITMO "EXERCICIO3"
var
n, a1, a2, aux, termo: INTEIRO [0,25v]

inicio

PARA n de 1 ate 700 faca


a1<-1
a2<-1
ENQUANTO n>a2 faca
aux<-a2
a2<-a1+a2
a1<-aux
FIMENQUANTO [2,75v]
SE n=a2 entao
termo<-n
SENAO
termo<-n*n
FIMSE
Escreval(termo)
FIMPARA

FIMALGORITMO

__________________________________________________________________________________
Docente: Ticongolo, Inácio
4. Dado a matriz quadrada M: vetor [1..8, 1..8] de Real, escreva algoritmo em
português estruturado (somente o trecho específico) que Imprime os dados da parte
sombreada da Matriz (fig1) [4v]

Solução:

PARA i de 1 ate 9 FACA Fig 1: Matriz M


PARA j de 1 ate 9 FACA
SE (j=i+1) ENTAO
Escreva (M[i,j])
FIMSE
FIMPARA
FIMPARA

5. Dado o Algoritmo em Português estruturado:


ALGORITMO "EXERCICIO4" Inicio
Algoritmo "Exercicio4" t<-1
var q<-F(v1,v2)
x,y: Inteiro se q>0 entao
Para i de 1 ate q faca
Funcao F(v1,v2:Inteiro):Inteiro t<-t*i
Var Escreval(" Resultado", i, "=", t)
res: Inteiro fimPara
fimSe
Inicio fimProcedimento
res <-v1*v2
v1 <-res-v1 INICIO
Retorne v1 X<- 4
fimFuncao Y<-3
Escreval ("Resultado F=",F(4,4))
Procedimento P(var v1, v2:Inteiro) P(x,y)
FIMALGORITMO
Var
q,t :Inteiro
i: Inteiro
SAÍDA
Resultado F= 12 1.0v
Resultado 1= 1 0.5v
4.1 Apresente a saída: [5v]
Resultado 2= 2 0.5v
Resultado 3= 6 0.5v
Resultado 4= 24 0.5v
Resultado 5= 120 0.5v
Resultado 6= 720 0.5v
Resultado 7= 5040 0.5v
Resultado 8= 40320 0.5v
v

__________________________________________________________________________________
Docente: Ticongolo, Inácio

Você também pode gostar