Você está na página 1de 7

CCNA

200-301
Part VI OSPF

Parte 1 Implementing Single-Area OSPFv2

Chapter 20 Implementing OSPF Parte 2 Using OSPFv2 Interface Subcommands

Parte 3 Additional OSPFv2 Features


Default Route Advertisement
OSPF AREA 0
.1 .2 .1 .2 .1 .2
10.99.0.0/30 10.0.0.0/24 10.20.0.0/24

Internet FW R1 R2 R3
R1(config)# ip route 0.0.0.0 0.0.0.0 10.99.0.1
R1(config)# router ospf 1
R1(config-router)# network 10.0.0.0 0.255.255.255 area 0
R1(config-router)# default-information originate
R2# show ip route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
O*E2 0.0.0.0/0 [110/1] via 10.0.0.1, 00:02:56
R3# show ip route
Gateway of last resort is 10.20.0.1 to network 0.0.0.0
O*E2 0.0.0.0/0 [110/1] via 10.20.0.1, 00:02:56
Default Route Advertisement
OSPF AREA 0
.1 .2 .1 .2 .1 .2
10.99.0.0/30 10.0.0.0/24 10.20.0.0/24

Internet FW R1 R2 R3
R1(config)# ip route 0.0.0.0 0.0.0.0 10.99.0.1
R1(config)# router ospf 1
R1(config-router)# network 10.0.0.0 0.255.255.255 area 0
R1(config-router)# default-information originate always
R2# show ip route
Mesmo se não existir Rota
Gateway of last resort is 10.0.0.1 to network 0.0.0.0
O*E2 0.0.0.0/0 [110/1] via 10.0.0.1, 00:02:56 Default o OSPF vai publicar uma rota
default para os seus vizinhos
R3# show ip route
Gateway of last resort is 10.20.0.1 to network 0.0.0.0
O*E2 0.0.0.0/0 [110/1] via 10.20.0.1, 00:02:56
OSPF Metrics (Cost)
Reference Bandwidth 100Mbs
Cost =
Interface Bandwidth Interface Bandwidth

Topology
100Mbs Lembre-se que o custo de um caminho
Cost = =1 é a soma de dos custos de todas as
interfaces de saída que fazem parte
FastEthernet 10.1.1.0/24
R1 daquele caminho (vc não soma a
interface de entrada)
10
R1# conf t
R1(config)# interface g0/0/0
10 10
R1(config-if)# ip ospf cost 4
R1(config-if)# interface g0/1/0 R3
R1(config-if)# ip ospf cost 5
10.2.2.0/24
R2
10
Posso alterar o custo do OSPF direto na interface
com o comando ip ospf cost ou posso também 10
10
utilizar o comando bandwidth para alterar a banda 20
dessas interface e consequentemente o custo 10.3.3.0/24
OSPF (não é recomendado) 10.4.4.0/24
R4
10
Link Costs
Reference Bandwidth 100Mbs
Cost =
Interface Bandwidth Interface Bandwidth

100Mbs 100Mbs
Cost = =1 Cost = ==0.1
1
FastEthernet GigabitEthernet

=
Para evitar esse tipo de problema devemos altera o valor da Reference
Bandwidth para um valor coerente com a sua rede, por exemplo, se você
tem links de 20Gbps na sua rede você deverá alterar esse valor para 20000
G0/0 R4 (deve ser alterado em TODOS os roteadores:

1
auto-cost reference-bandwidth 20000
R1
Cuidado: O campo do LSA que informa a métrica tem 16bits, isso quer
F0/0 1
dizer que o valor da métrica não pode ser superior a 65535, se tiver
10.0.0.0/24
interfaces com baixa velocidade e outras extremamente rápidas na rede
isso pode ser um problema.
OSPF Load Balancing - Equal-Cost Multipathing
Se houver um empate na métrica, ambas as rotas serão instaladas na RIB equal-cost multipathing (ECMP).

O padrão do ECMP são no máximo 4 caminhos ao mesmo tempo, esse pode ser alterado com o comando:
maximum-paths xyz dentro do processo OSPF

Cost

5
Cost

Cost
R2 R4 10
20

Area 0 10.6.6.0/24
R1 R6
Cost

1
Cost
Cost

20 R3 Cost

R5 10
5
Obrigado!

Você também pode gostar