Você está na página 1de 3

Instituto Federal de Goiás

Goiania,07 de novembro de 2021


Aluno: Pedro Paulo Macedo Silva
Professor: Carlos Augusto Curso: Engenharia de Transportes Período: 2º

Tarefa 7 – Estruturas de Controle :Seleção

1. Ler um número e se ele for maior que 20, então exibir a metade do número.

Inicio
var
real:numero,metade;
escreva(“digite numero”)
leia(numero)
se ( numero> 20) então;
metade  numero/2;
imprima(“\n metade:”, metade);
fimse
fimAlgoritmo

2. Ler um número e, se ele for positivo, exibir o seu inverso; caso contrário, exibir
o número absoluto.
Inicio
var
real:numero,inverso,absoluto;
escreva(“digite numero;”);
leia(numero):
se(numero> 0) então;
inverso  1/numero
escreva(“inverso:”, inverso);
fimse
senão
absoluto  numero*(-1);
// ou absoluto  abs(numero);
escreva(“\n absoluto :”, absoluto);
fimsenao
fimAlgoritmo
3. Ler um número e exibir se ele é par ou ímpar.

Inicio
var
numero:inteiro
inicio
escreva(“ escreva um numero:”)
leia(numero)

se numero mod 2 = 0 entao


escreva (“ o numero”, numero , “ é par!”)
senão
escreva(“ o numero”, numero, “ é impar!”)
fimse
fimalgoritmo

4. Faça um algoritmo para ler um número e exibir se ele é positivo, negativo ou


nulo.

Inicio
Var
Numero:inteiro
Leia(numero)
Se numero<0 entao
Escreval(“negativo”)
Senão
Se( numero = 0) então
Escreval (“nulo”)
Senão
Escreval(“positivo”)
Fimse
fimAlgoritmo

5. Crie uma calculadora na qual o usuário irá digitar dois valores e escolher uma
das quatro operações básicas.
Inicio
Var
a,b: caractere
num, num2 : inteiro
Inicio
Escreval (“Digite um numero.”)
Leia (num)
Escreval (“Digite outro numero.”)
Leia (num2)
Escreval (“Digite qual operação:”)
Escreval (“multiplicar:”)
Escreval (“dividir:”)
Escreval (“subtrair:”)
Escreval (“somar:”)
Leia(a)
Caso “multiplicar”
Escreval(“Resultado da Multiplicação  “ , num * num2 )
Caso “dividir”
Escreval(“Resultado da Dividir  “ , num / num2 )
Caso “subtrair”
Escreval(“Resultado da Subtrair  “ , num - num2 )
Caso “somar”
Escreval(“Resultado da Somar  “ , num + num2 )
Outrocaso
Escreval(“So pode essas quatros operações...!)
Fimescolha
fimalgoritmo

6. Construa um algoritmo que leia dois números e efetue a adição. Caso o valor
somado seja maior que 20, este deverá ser exibido somando-se a ele mais 8;
caso o calor seja menor ou igual a 20, este deverá ser exibido subtraindo-se 5.
Inicio.
real: numero1, numero2, soma;
ler numero1, numero2;
soma <- numero1 + numero2;
se soma > 20 entao
imprimir 'valor somado = ', soma+8;
senao
imprmir 'valor somado = ', soma-5;
fim-se
fim.

7. Construa um algoritmo para o usuário inserir um número, caso seja positivo


será exibida a raiz quadrada, caso seja negativo será exibido o quadrado.

Você também pode gostar