Você está na página 1de 3

Problema: Faça um programa em Linguagem C que

informe o turno de funcionamento de um curso


escolhido por um aluno.
Código Curso Turno
1 Administração Noite
2 Mecânica Manhã
3 Contábeis Tarde

ANÁLISE DO PROBLEMA
1.Entrada (dado informado):
o curso escolhido
2.Processamento:
Se o curso for 1 então o turno é noite
Se o curso for 2 então o turno é manhã
Se o curso for 3 então o turno é tarde
3.Saída (Informação solicitada):
turno de funcionamento do curso

1.Entrada - Leia()
Leia(curso)

2.Processamento -
<-- (Atribuição)
Se (Decisão)
Repita (Repetição)

3.Saída - Escreva()
Escreva(turno)
Algoritmo Curso
Início
Declare curso : Inteiro
turno : Literal
Leia(curso)
Se curso = 1 Então
turno <-- "Noite"
FimSe
Se curso = 2 Então
turno <-- "Manhã"
FimSe
Se curso = 3 Então
turno <-- "Tarde"
FimSe
Escreva(turno)
Fim

#include <iostream>
#include <string.h>
using namespace std;
int main(void)
{
int curso;
char turno[10];
cout << "============================="<<endl;
cout << "Código Curso Turno"<<endl;
cout << "-----------------------------"<<endl;
cout << " 1 Administração Noite"<<endl;
cout << " 2 Mecânica Manhã"<<endl;
cout << " 3 Contábeis Tarde"<<endl;
cout << "-----------------------------"<<endl;
cout << "Digite o código do curso: ";
cin >> curso;
if (curso == 1)
strcpy(turno, "Noite");
if (curso == 2)
strcpy(turno, "Manhã");
if (curso == 3)
strcpy(turno, "Tarde");
cout << endl;
cout << "O turno do curso é " << turno << endl;
return 0;
}
Algoritmo Curso
Início
Declare curso : Inteiro
turno : Literal
Leia(curso)
Se curso = 1 Então
turno <-- "Noite"
Senão
Se curso = 2 Então
turno <-- "Manhã"
Senão
Se curso = 3 Então
turno <-- "Tarde"
Senão
turno <-- "Inválido"
FimSe
Escreva(turno)
Fim

#include <iostream>
#include <string.h>
using namespace std;
int main(void)
{
int curso;
char turno[10];
cout << "============================="<<endl;
cout << "Código Curso Turno"<<endl;
cout << "-----------------------------"<<endl;
cout << " 1 Administração Noite"<<endl;
cout << " 2 Mecânica Manhã"<<endl;
cout << " 3 Contábeis Tarde"<<endl;
cout << "-----------------------------"<<endl;
cout << "Digite o código do curso: ";
cin >> curso;
if (curso == 1)
strcpy(turno, "Noite");
else
if (curso == 2)
strcpy(turno, "Manhã");
else
if (curso == 3)
strcpy(turno, "Tarde");
else
strcpy(turno, "Inválido");
cout << endl;
cout << "O turno do curso é " << turno << endl;
cout << endl;
return 0;
}

Você também pode gostar