Você está na página 1de 11

Apostila - Fórmulas, Funções e Operadores

Fórmulas
A Fórmula é uma série de instruções a fim de realizar algum tipo de cálculo, podendo ir de
um cálculo simples como somar o valor de duas células ou incorporar funções estatísticas avançadas
para detectar tendências ou fazer previsões.
Exemplo de Fórmula:

Funções
Funções são fórmulas predefinidas que estão disponíveis no Excel.
Aonde encontrar dentro do Excel

Barra de Fórmulas
Botão
Inserir Função

1
Exemplo de Função:

2
Operadores Excel
Os operadores especificam o tipo de cálculo que você deseja executar em elementos em uma
fórmula, como adição, subtração, multiplicação ou divisão.
Quadro com operadores no Excel
Diferentes Tipos de Operadores no Excel
Tipo Caractere Operação Exemplo
Aritmético + Adição =A1+B1
- Subtração =A1-B1
* Multiplicação =A1*B1
/ Divisão =A1/B1
% Porcentagem (Divisão por 100) =A1%B1
^ Potência =A1^B1
Comparação = Igual a =A1=B1
> Maior que =A1>B1
< Menor que =A1<B1
>= Maior ou Igual a =A1>=B1
<= Menor ou Igual a =A1<=B1
<> Diferente de =A1<>B1
Texto & Concatenar =A1&" "B1
Referência : Referência para incluir =SOMA(A1:B1)
; Unir Múltiplas Referências =SOMA(A1;B1)

Ordem de operações em fórmulas no Excel


Ordem de Cálculo
As fórmulas calculam valores segundo uma ordem específica. Uma fórmula do Excel sempre
começa com um sinal de igual (=). O Excel interpreta os caracteres depois do sinal de igual como
uma fórmula. Depois do sinal de igual estão os elementos a serem calculados (os operandos), como
constantes ou referências de célula, eles são separados por operadores de cálculo. O Excel calcula a
fórmula da esquerda para a direita, de acordo com uma ordem específica para cada operador da
fórmula.
Precedência do operador em fórmulas do Excel
Se você combinar vários operadores em uma única fórmula, o Excel executará as operações
na ordem mostrada na tabela a seguir. Se uma fórmula contiver operadores com a mesma precedência,
o Excel calculará os operadores da esquerda para a direita.
Usando parênteses em fórmulas
Para alterar a ordem de precedência, coloque entre parênteses a parte da fórmula a ser
calculada primeiro.
Exemplo
I. 30 − 5 ∗ 4 + 8

3
II. 30 − (5 ∗ 4 + 8)
III. (30 − 5) ∗ (4 + 8)

Quadro com a ordem de precedência dos operadores no Excel


ORDEM DE OPERAÇÕES EM FÓRMULAS(PRECEDÊNCIA)
Ordem Operador Descrição
1 () Parêntesis
: (dois-pontos)
2 (espaço simples) Operadores de referência
, (virgula)
3 - Negação (como em -1)
4 % Porcentagem
5 ^ Exponenciação
6 *e/ Multiplicação e Divisão
7 +e- Adição e Subtração
Conecta duas cadeias de texto
8 &
(concatenação)
=
<>
9 Comparação
<=
>=

4
Funções Excel
No Excel infelizmente não existem funções para Subtrair, Dividir ou para Potência. Isso acontece
porque não é muito usual fazermos várias subtrações de uma vez, divisões ou até mesmo potências.
Agora vamos ver como usar as funções básicas do Excel além das quais você viu nos tópicos
anteriores utilizando operadores.
SOMA – Essa é a função mais básica, é bem intuitiva e fácil de usar, basta escrever =SOMA(e então
inserir as células separadas por ; ou selecionar um intervalo de células. Assim ela retorna a soma de
um valor em um determinado intervalo de dados);
=SOMA(E3;E4;E5;E6) ou =SOMA(E3:E6)

MULT – a função funciona da mesma maneira que a função SOMA, mas ao invés de somar vamos
multiplicar todos os elementos que estão dentro dessa função. Assim ela retorna a multiplicação de
um valor em um determinado intervalo de dados;
=MULT(C3:D3)

5
MÁXIMO e MÍNIMO – a função MÁXIMO retorna o valor maior e função MÍNIMO retorna o
valor menor dentro de um intervalo de dados;
=MÍNIMO(D3:D6)
=MÁXIMO(D3:D6)

MAIOR e MENOR – essas duas funções são muito semelhantes as funções MÁXIMO e MÍNIMO,
só que a grande diferença é que essas funções permitem com que você escolha a posição desse
número.
Como assim? Você pode escolher por exemplo o primeiro maior número, o que seria o mesmo que o
valor máximo, mas pode pegar o segundo maior, terceiro, de acordo com a sua necessidade.
=MAIOR(D3:D6;1)
=MENOR(D3:D6;1)

6
MÉDIA – mede a tendência central, que é o local do centro de um grupo de números em uma
distribuição estatística... Média, que é a média aritmética e é calculada por meio da adição de um
grupo de números e, em seguida, da divisão pela contagem desses números;
=MÉDIA(D3:D6)

CONT.NÚM – Essa função conta quantas células contêm números. Use CONT.NÚM para obter o
número de entradas em um campo de número que esteja em um intervalo ou matriz de números.
=CONT.NÚM(A1:F11)

7
CONT.VALORES – a função conta as células contendo qualquer tipo de informações, incluindo
valores de erros e texto vazio (""), além disso a função não conta células vazias.
= CONT.VALORES(A1:F11)

CONT.VAZIO – a função determina o número de células em branco em um intervalo identificado,


mas para que isso aconteça, o intervalo de células devem ser contíguo e em uma pasta de trabalho
aberta.
=CONTAR.VAZIO(A1:F11)

8
SE – a função é uma das funções mais populares do Excel e permite que você faça comparações
lógicas entre um valor e aquilo que você espera.
Portanto, uma instrução SE pode ter dois resultados. O primeiro resultado é se a comparação for
Verdadeira, o segundo se a comparação for Falsa. Então ao analisar uma condição só podemos obter
esses dois resultados e é exatamente isso que essa fórmula vai fazer, vai analisar uma condição e
baseado no resultado vai retornar um valor/texto/fórmula
Por exemplo, =SE(C2 =”Sim”, 1,2) diz SE(C2 = Sim, então retorne a 1, caso contrário retorne a 2).

CONT.SE – uma das funções estatísticas, para contar o número de células que atendem a um critério;
por exemplo, para contar o número de vezes que uma cidade específica aparece em uma lista de
clientes.
Na forma mais simples, a função CONT.SE informa:
=CONT.SE(Onde você quer procurar?; O que você quer procurar?)
=CONT.SE(intervalo; critério)

9
SOMASE – a função é utilizada para somar dados utilizando um critério/restrição, ou seja, é possível
somar uma quantidade numérica em uma coluna baseado em um critério de pesquisa que está em
outra coluna. Como, por exemplo, somar a quantidade comprada de um produto específico que se
repete em uma lista de compras.
É possível observar que precisaremos de 3 argumentos para essa função: intervalo, critérios e
intervalo_soma.
Intervalo: É onde serão procurados os critérios que neste caso serão os produtos, ou seja, será nossa
coluna de países!
Critérios: São os critérios a serem procurados, neste caso iremos procurar por unidade de produtos
que veio do país.
Intervalo_soma: Será a coluna cujos valores serão somados, como queremos saber a quantidade total
de cada produto de cada país iremos utilizar a coluna de unidade. Então, os argumentos são os
seguintes: o primeiro é a coluna de países; o segundo é o critério procurado, no caso o produto
“França” que está na célula “A15″; por último temos a coluna da quantidade que será somada.
=SOMASE(B2:B11;A15;D2:D11)

10
Conclusão
Até aqui te você conheceu as funções básicas no Excel, que são funções que você vai utilizar
bastante no seu dia a dia. E importante você saber que não basta só conhecer a função, é muito
importante que você pratique, que teste, faça mudanças, assim você vai ficar mais familiarizado com
as funções e seus resultados. Dessa forma vai ficar muito mais fácil quando precisar utilizar essas
funções nos seus projetos e relatórios.

11

Você também pode gostar