Você está na página 1de 10

1º Passo – 1ª Etapa – Descrição Narrativa:

Início
Solicitar a quantidade de dolares para a convesão
Informar a quantidade de dolares que deseja adquirir
Solicitar o valor atual do dolar em reais
Informar o valor atual do dolar
Realizar a conversão multiplicando quantidade de dolares e valor do dolar
hoje
Retornar o valor a ser pago já convertido em reais
Fim.

2º Passo – 1ª Etapa – Pseudocódigo:

Inicio
Real: DA, VD, Result;
Escreva (“Quantos Dolares deseja?”);
Leia (DA);
Escreva (“Qual o valor do Dolar hoje?”);
Leia (VD);
Result<-DA*VD;
Escreva (“Voce devera pagar R$ ”,Result);
Fim.

3º Passo – 1ª Etapa – Fluxograma:

Iníci
o
Quantidade de
desejada de
dólares

Informar quantidade
de dólares.

Cotação do
Dólar hoje

Informar cotação
atual

R<-DA*VD

Quantidade em
Reais à pagar

FIM.
2º Passo – 1ª Etapa – Pseudocódigo:
Inicio
Real: DA, DC, ER, VD, RA, RC, RR;
Escreva (“Qual o valor do Dolar Americano?”);
Leia (DA);
Escreva (“Qual o valor do Dolar Canadense?”);
Leia (DC);
Escreva (“Qual o valor do Euro?”);
Leia (ER);
Escreva (“Quantos Reais voce tem?”);
Leia (VD);
RA<-VD/DA;
RC<-VD/DC;
RR<-VD/ER;
Escreva (“Voce tera US$ _ ”,RA);
Escreva (“Voce tera CDN$ _ ”,RC);
Escreva (“Voce tera € _ ”,RR);
Fim.

2º Passo – 1ª Etapa – Fluxograma:

Iníci
o 1
Solicitar valor do
Dólar Americano

R<-VD/DA
Informar valor do
dólar Americano

Solicitar valor do
R<-VD/DC
Dólar
Canadense
R<-VD/ER
Informar valor do
dólar Canadense
Quantidade em
US$ que terá
Solicitar valor do
Euro

Quantidade em
Informar valor do CDN$ que terá
Euro

Solicitar Quantidade em €
quantidade de
que terá
Reais

Informar a quantia
em Reais
Fim.
3º Passo – 1ª Etapa – Pseudocódigo:

Inicio
1
Real: DA, DC, ER, R, VD;
Caractere: X;
Escreva (“Qual a moeda desejada:”);
Escreva (“1 – Dolar Americano”);
Escreva (“2 – Dolar Canadense”);
Escreva (“3 – Euro”);
Leia (X);
Escolha (X);
Caso “1”:
Inicio
Escreva (“Quantos Dolares Americanos
deseja?”);
Leia (“DA”);
Escreva (“Em quantos Reais esta a cotacao
do Dolar Americano?”);
Leia (“VD”);
R<-DA*VD;
Fim;
Caso “2”:
Inicio
Escreva (“Quantos Dolares Canadenses
deseja?”);
Leia (“DC”);
Escreva (“Em quantos Reais esta a cotacao
do Dolar Canadense?”);
Leia (“VD”);
R<-DC*VD;
Fim;
Caso “3”:
Inicio
Escreva (“Quantos Euros deseja?”);
Leia (“ER”);
Escreva (“Em quantos Reais esta a cotacao
do Euro?”);
Leia (“VD”);
R<-ER*VD;
Fim;
Casocontrario: Não ha conversao;
Fimescolha;
Escreva ("Voce tera $ ja convertidos",R);
Fim.

1º Passo - 2ª Etapa - Pseudocódigo:

Inicio
Real: DA, DC, ER, RL, VD, R;
Caractere: X, Y;
Escreva (“Qual sera a moeda base para a conversao:”);
Escreva (“1 – Dolar Americano”);
Escreva (“2 – Dolar Canadense”);
Escreva (“3 – Euro”);
Escreva (“4 – Real”);
Leia (X);
Se (X=1)
Entao: Escreva (“Converter Dolar Americano para:”);
Escreva (“1 – Dolar Canadense”);
Escreva (“2 – Euro”);
Escreva (“3 – Real”);
Leia (Y);
Se (Y=1)
Entao: Escreva (“Qual cotacao do Dolar Canadense em
relacao ao Dolar Americano?”);
Leia (DC);
Escreva ("Quantos Dolares Canadenses deseja
adquirir?");
Leia (VD);
R<–VD*DC;
Senaose (Y=2)
Entao: Escreva (“Qual cotacao do Euro em relacao
ao Dolar Americano?”);
Leia (ER);
Escreva ("Quantos Euros deseja adquirir?");
Leia (VD);
R<–VD*ER;
Senaose (Y=3)
Entao: Escreva (“Qual cotacao do Real em
relacao ao Dolar Americano?”);
Leia (RL);
Escreva ("Quantos Reais deseja
adquirir?");
Leia (VD);
R<–VD*RL;
Fimse;
Fimse;
Fimse;
Senaose (X=2)
Entao: Escreva (“Converter Dolar Canadense para:”);
Escreva (“1 – Dolar Americano”);
Escreva (“2 – Euro”);
Escreva (“3 – Real”);
Leia (Y);
Se (Y=1)
Entao: Escreva (“Qual cotacao do Dolar Americano
em relacao ao Dolar Canadense?”);
Leia (DA);
Escreva ("Quantos Dolares Americanos
deseja adquirir?");
Leia (VD);
R<–VD*DA;
Senaose (Y=2)
Entao: Escreva (“Qual cotacao do Euro em
relacao ao Dolar Canadense?”);
Leia (ER);
Escreva ("Quantos Euros deseja
adquirir?");
Leia (VD);
R<–VD*ER;
Senaose (Y=3)
Entao: Escreva (“Qual cotacao do
Real em relacao ao Dolar Canadense?”);
Leia (RL);
Escreva ("Quantos Reais
deseja adquirir?");
Leia (VD);
R<–VD*RL;
Fimse;
Fimse;
Fimse;
Senaose (X=3)
Entao: Escreva (“Converter Euro para:”);
Escreva (“1 – Dolar Americano”);
Escreva (“2 – Dolar Canadense”);
Escreva (“3 – Real”);
Leia (Y);
Se (Y=1)
Entao: Escreva (“Qual cotacao do Dolar
Americano em relacao ao Euro?”);
Leia (DA);
Escreva ("Quantos Dolares
Americanos deseja adquirir?");
Leia (VD);
R<–VD*DA;
Senaose (Y=2)
Entao: Escreva (“Qual cotacao do
Dolar Canadense em relacao ao Euro?”);
Leia (DC);
Escreva ("Quantos Dolares
Canadenses deseja adquirir?");
Leia (VD);
R<–VD*DC;
Senaose (Y=3)
Entao: Escreva (“Qual cotacao
do Real em relacao ao Euro?”);
Leia (RL);
Escreva ("Quantos Reais
deseja adquirir?");
Leia (VD);
R<–VD*RL;
Fimse;
Fimse;
Fimse;
Senaose (X=4)
Entao: Escreva (“Converter Real para:”);
Escreva (“1 – Dolar Americano”);
Escreva (“2 – Dolar Canadense”);
Escreva (“3 – Euro”);
Leia (Y);
Se (Y=1)
Entao: Escreva (“Qual cotacao do
Dolar Americano em relacao ao Real?”);
Leia (DA);
Escreva ("Quantos Dolares
Americanos deseja adquirir?");
Leia (VD);
R<–VD*DA;
Senaose (Y=2)
Entao: Escreva (“Qual cotacao
do Dolar Canadense em relacao ao Real?”);
Leia (DC);
Escreva ("Quantos
Dolares Canadenses deseja adquirir?");
Leia (VD);
R<–VD*DC;
Senaose (Y=3)
Entao: Escreva (“Qual
cotacao do Euro em relacao ao Real?”);
Leia (ER);
Escreva ("Quantos
Euros deseja adquirir?");
Leia (VD);
R<–VD*ER;
Fimse;
Fimse;
Fimse;
Fimse;
Fimse;
Fimse;
Fimse;
Escreva ("A troca de por foi concluida com sucesso. Você tem
agora $ de ."X,Y,R,X);
Fim.

2º Passo - 2ª Etapa - Pseudocódigo:

Inicio
Real: DA, DC, ER, RL, VD, R1, R2, R3, P1, P2;
Caractere: X, Y;
Escreva (“Qual sera a moeda base para a conversao:”);
Escreva (“1 – Dolar Americano”);
Escreva (“2 – Dolar Canadense”);
Escreva (“3 – Euro”);
Escreva (“4 – Real”);
Leia (X);
Se (X=1)
Entao: Escreva (“Converter Dolar Americano para:”);
Escreva (“1 – Dolar Canadense”);
Escreva (“2 – Euro”);
Escreva (“3 – Real”);
Leia (Y);
Se (Y=1)
Entao: Escreva (“Qual cotacao do Dolar Canadense em
relacao ao Dolar Americano Comercial, Turismo e Paralelo?”);
Leia (DC);
Escreva ("Quantos Dolares Canadenses deseja
adquirir?");
Leia (VD);
R1<–VD*DC;
R2<–VD*(DC+0,05); P1<–(R2*100)/R1;
R3<–VD*(DC-0,12); P2<–(R3*100)/R1;
Escreva ("Dolar Americano Paralelo é % mais
barato que o Comercial e o Dolar Americano Turismo é % mais caro que o
Comercial. Com o Comercial compra-se CDN$ . Com o Turismo compra-se
CDN$ . Como o Paralelo compra-se CDN$ ",P1,P2,R1,R2,R3);
Senaose (Y=2)
Entao: Escreva (“Qual cotacao do Euro em relacao
ao Dolar Americano?”);
Leia (ER);
Escreva ("Quantos Euros deseja adquirir?");
Leia (VD);
R1<–VD*DC;
R2<–VD*(DC+0,05); P1<–(R2*100)/R1;
R3<–VD*(DC-0,12); P2<–(R3*100)/R1;
Escreva ("Dolar Americano Paralelo é %
mais barato que o Comercial e o Dolar Americano Turismo é % mais caro
que o Comercial. Com o Comercial compra-se £ . Com o Turismo compra-se
£ . Como o Paralelo compra-se £ ",P1,P2,R1,R2,R3)
Senaose (Y=3)
Entao: Escreva (“Qual cotacao do Real em
relacao ao Dolar Americano?”);
Leia (RL);
Escreva ("Quantos Reais deseja
adquirir?");
Leia (VD);
R1<–VD*DC;
R2<–VD*(DC+0,05); P1<–
(R2*100)/R1;
R3<–VD*(DC-0,12); P2<–
(R3*100)/R1;
Escreva ("Dolar Americano Paralelo é
% mais barato que o Comercial e o Dolar Americano Turismo é % mais caro
que o Comercial. Com o Comercial compra-se R$ . Com o Turismo compra-
se R$ . Como o Paralelo compra-se R$ ",P1,P2,R1,R2,R3)
Fimse;
Fimse;
Fimse;
Senaose (X=2)
Entao: Escreva (“Converter Dolar Canadense para:”);
Escreva (“1 – Dolar Americano”);
Escreva (“2 – Euro”);
Escreva (“3 – Real”);
Leia (Y);
Se (Y=1)
Entao: Escreva (“Qual cotacao do Dolar Americano
em relacao ao Dolar Canadense?”);
Leia (DA);
Escreva ("Quantos Dolares Americanos
deseja adquirir?");
Leia (VD);
R1<–VD*DC;
R2<–VD*(DC+0,05); P1<–(R2*100)/R1;
R3<–VD*(DC-0,12); P2<–(R3*100)/R1;
Escreva ("Dolar Americano Paralelo é %
mais barato que o Comercial e o Dolar Americano Turismo é % mais caro
que o Comercial. Com o Comercial compra-se CDN$ . Com o Turismo
compra-se CDN$ . Como o Paralelo compra-se CDN$ ",P1,P2,R1,R2,R3)
Senaose (Y=2)
Entao: Escreva (“Qual cotacao do Euro em
relacao ao Dolar Canadense?”);
Leia (ER);
Escreva ("Quantos Euros deseja
adquirir?");
Leia (VD);
R1<–VD*ER;
R2<–VD*ER;
R3<–VD*ER;
Senaose (Y=3)
Entao: Escreva (“Qual cotacao do
Real em relacao ao Dolar Canadense?”);
Leia (RL);
Escreva ("Quantos Reais
deseja adquirir?");
Leia (VD);
R1<–VD*RL;
R2<–VD*RL;
R3<–VD*RL;
Fimse;
Fimse;
Fimse;
Senaose (X=3)
Entao: Escreva (“Converter Euro para:”);
Escreva (“1 – Dolar Americano”);
Escreva (“2 – Dolar Canadense”);
Escreva (“3 – Real”);
Leia (Y);
Se (Y=1)
Entao: Escreva (“Qual cotacao do Dolar
Americano em relacao ao Euro?”);
Leia (DA);
Escreva ("Quantos Dolares
Americanos deseja adquirir?");
Leia (VD);
R1<–VD*DC;
R2<–VD*(DC+0,05); P1<–
(R2*100)/R1;
R3<–VD*(DC-0,12); P2<–
(R3*100)/R1;
Escreva ("Dolar Americano Paralelo é
% mais barato que o Comercial e o Dolar Americano Turismo é % mais caro
que o Comercial. Com o Comercial compra-se £ . Com o Turismo compra-se
£ . Como o Paralelo compra-se £ ",P1,P2,R1,R2,R3)
Senaose (Y=2)
Entao: Escreva (“Qual cotacao do
Dolar Canadense em relacao ao Euro?”);
Leia (DC);
Escreva ("Quantos Dolares
Canadenses deseja adquirir?");
Leia (VD);
R1<–VD*DC;
R2<–VD*DC;
R3<–VD*DC;
Senaose (Y=3)
Entao: Escreva (“Qual cotacao
do Real em relacao ao Euro?”);
Leia (RL);
Escreva ("Quantos Reais
deseja adquirir?");
Leia (VD);
R1<–VD*RL;
R2<–VD*RL;
R3<–VD*RL;
Fimse;
Fimse;
Fimse;
Senaose (X=4)
Entao: Escreva (“Converter Real para:”);
Escreva (“1 – Dolar Americano”);
Escreva (“2 – Dolar Canadense”);
Escreva (“3 – Euro”);
Leia (Y);
Se (Y=1)
Entao: Escreva (“Qual cotacao do
Dolar Americano em relacao ao Real?”);
Leia (DA);
Escreva ("Quantos Dolares
Americanos deseja adquirir?");
Leia (VD);
R1<–VD*DC;
R2<–VD*(DC+0,05); P1<–
(R2*100)/R1;
R3<–VD*(DC-0,12); P2<–
(R3*100)/R1;
Escreva ("Dolar Americano
Paralelo é % mais barato que o Comercial e o Dolar Americano Turismo é
% mais caro que o Comercial. Com o Comercial compra-se R$ . Com o
Turismo compra-se R$ . Como o Paralelo compra-se R$ ",P1,P2,R1,R2,R3)
Senaose (Y=2)
Entao: Escreva (“Qual cotacao
do Dolar Canadense em relacao ao Real?”);
Leia (DC);
Escreva ("Quantos
Dolares Canadenses deseja adquirir?");
Leia (VD);
R1<–VD*DC;
R2<–VD*DC;
R3<–VD*DC;
Senaose (Y=3)
Entao: Escreva (“Qual
cotacao do Euro em relacao ao Real?”);
Leia (ER);
Escreva ("Quantos
Euros deseja adquirir?");
Leia (VD);
R1<–VD*ER;
R2<–VD*ER;
R3<–VD*ER;
Fimse;
Fimse;
Fimse;
Fimse;
Fimse;
Fimse;
Fimse;
Escreva ("");
Fim.