Você está na página 1de 7

Faculdade de Pindamonhangaba Sistemas de Informao Disciplina: Princpio de Desenvolvimento de Algoritmos Notas de Aula Estrutura Condicional Imagine a seguinte situao:

O programa tem que ler a mdia de um aluno e dizer se est aprovado ou reprovado. necessrio verificar a mdia do aluno para ento tomar uma deciso para apresentar a sua situao: se est aprovado ou reprovado. 1.1 Estrutura Condicional Simples A tomada de deciso simples utiliza a instruo se (expresso-lgica) entao <seqncia-de-comandos para expresso lgica verdadeira> fimse Nesta instruo, se a expresso lgica for verdadeira, ser executada a sequncia de comandos. Caso a expresso lgica no seja verdadeira no ser executada a seqncia de comandos. Exemplo 1 Ler a mdia de um aluno e exibir uma mensagem informando se o mesmo est aprovado. algoritmo "VerificaAprovacao" var media: real inicio escreval ("Digite a mdia do aluno") leia (media) se (media >=6) entao escreva ("Parabns!!!! Voc est aprovado.") fimse fimalgoritmo Observe que somente ser exibida a mensagem Parabns!!!! Voc est aprovado." se a mdia for maior ou igual a 6. 1.2 Estrutura Condicional Composta A tomada de deciso composta utiliza a instruo: se (expresso-lgica) entao <seqncia-de-comandos 1, para expresso lgica verdadeira > senao <seqncia-de-comandos 2, para expresso lgica falsa> fimse Nesta instruo, se a expresso lgica for verdadeira, ser executada a seqncia-decomandos 1. Caso a expresso lgica no seja verdadeira ser executada a seqnciade-comandos 2.
Notas de aula Prof Alindacir

Faculdade de Pindamonhangaba Sistemas de Informao Disciplina: Princpio de Desenvolvimento de Algoritmos Notas de Aula Exemplo 2 Ler a mdia de um aluno e escrever se ele est aprovado ou reprovado. algoritmo "VerificaAprovacao" var media: real inicio escreval ("Digite a mdia do aluno") leia (media) se (media >=6) entao escreval ("Parabns!!!! Voc est aprovado.") senao escreval ("Infelizmente voc est reprovado!!!") fimse fimalgoritmo Observe que somente ser escrito "Parabns!!!! Voc est aprovado." se a mdia for maior ou igual a 6. Se a mdia for menor que 6, no ser escrita a referida mensagem, mas sim, "Infelizmente voc est reprovado!!!". 1.2 Estruturas Condicionais Encadeadas Existem casos em que necessrio fazer algumas verificaes sucessivas antes de executar uma seqncia de comandos. Neste caso utiliza-se estruturas condicionais encadeadas ou aninhadas. A tomada de deciso simples utiliza a instruo: se (expresso-lgica 1) entao <seqncia-de-comandos 1, para expresso lgica verdadeira > seno se (expresso-lgica 2) entao <seqncia-de-comandos 2, para expresso lgica verdadeira > fimse Nesta instruo, se a expresso-lgica 1 for verdadeira, ser executada a seqncia-decomandos 1. Caso a expresso-lgica 1 for falsa, ser testada a expresso-lgica 2 e se esta for verdadeira ser executada a seqncia-de-comandos 2. Caso a expressolgica 2 no seja verdadeira, nenhuma seqncia (1 e 2), sero executadas.

Notas de aula Prof Alindacir

Faculdade de Pindamonhangaba Sistemas de Informao Disciplina: Princpio de Desenvolvimento de Algoritmos Notas de Aula Exemplo 3 Ler a mdia de um aluno. Escrever se ele est aprovado (mdia superior ou igual a 6), reprovado (mdia inferior a 4) ou em exame (entre 4 e 6). algoritmo "VerificaAprovacao" var media: real inicio escreval ("Digite a mdia do aluno") leia (media) se (media >=6) entao escreval ("Parabns!!!! Voc est aprovado.") senao se (media < 4) entao escreval ("Infelizmente voc est reprovado!!!") senao escreval("Voc ter uma nova chance. Est em exame. Estude!!!!!") fimse fimse fimalgoritmo Note que somente ser escrito "Parabns!!!! Voc est aprovado.", se a mdia for maior ou igual a 6. Neste caso termina o algoritmo, ou seja, no sero testadas as demais condies. Agora, se a mdia for menor que 6, ser verificado se ela menor que 4. Caso a condio seja verdadeira, ser exibida a mensagem "Infelizmente voc est reprovado!!!". Agora, caso a mdia seja superior ou igual a 4, por exemplo, 5, ser exibida a mensagem: Voc ter uma nova chance. Est em exame. Estude!!!!!".

Expresses Lgicas: so expresses cujo resultado verdadeiro ou falso. Elas usam operadores relacionais e lgicos. Ex. 1) media := 4 se (media >= 6) entao escreva (aprovado) fimse A expresso lgica (media >= 6) falsa porque a media igual a 4. Portanto, no ser escrito aprovado. Ex. 2) media 7 faltas 10 se (media >= 6) e (faltas < 18) entao escreva (aprovado) fimse

Notas de aula Prof Alindacir

Faculdade de Pindamonhangaba Sistemas de Informao Disciplina: Princpio de Desenvolvimento de Algoritmos Notas de Aula A expresso lgica (media >= 6) verdadeira porque a media igual a 7. A expresso lgica (faltas < 18) verdadeira porque faltas igual a 10. Portanto, a expresso lgica ((media >= 6) e (faltas < 18)) verdadeira porque uma e outra so verdadeiras, ou seja, ambas so verdadeiras. Portanto, ser escrito aprovado. Ex. 3) media 4 faltas 10 se (media >= 6) e (faltas < 18) entao escreva (aprovado) fimse A expresso lgica (media >= 6) falsa porque a media igual a 4. A expresso lgica (faltas < 18) verdadeira porque faltas igual a 10. Portanto, a expresso lgica ((media >= 6) e (faltas < 18)) falsa porque uma e outra no so verdadeiras, ou seja, basta que uma das expresses no seja verdadeira para a expresso toda ser falsa. Portanto, no ser escrito aprovado. Ex. 4) media 4 faltas 10 se ((media < 6) ou (faltas > 18) entao escreva (reprovado) fimse A expresso lgica (media < 6) verdadeira porque a media igual a 4. A expresso lgica (faltas > 18) falsa porque faltas igual a 10. Portanto, a expresso lgica (media < 6) ou (faltas > 18) verdadeira porque uma ou outra so verdadeiras, ou seja, basta que uma das expresses seja verdadeira para a expresso toda ser verdadeira. Portanto, ser escrito reprovado.

Comando de Seleo Mltipla (Atividade de Pesquisa)

Notas de aula Prof Alindacir

Faculdade de Pindamonhangaba Sistemas de Informao Disciplina: Princpio de Desenvolvimento de Algoritmos Notas de Aula

Exerccios
1) Leia um nmero inteiro e escrever divisvel por 2 se ele for divisvel por 2. (Dica: o nmero divisvel por 2 se o resto da diviso por 2 for 0). 2) Ler o salrio de uma pessoa e calcular o desconto do imposto de renda, segundo a tabela abaixo: Salrio Desconto At R$ 500 isento (0%) De R$ 501 at R$ 1.500 10% De R$ 1501 at R$ 2500 15% Acima de R$ 2.500 25% (Dica: use o expresses lgicas com o operador e para os descontos de 15% e 25%). 3) Faa um programa que receba a altura (H) e o sexo de uma pessoa, calcule e imprima o seu peso ideal, utilizando as seguintes frmulas: para homens: (72.7 * H) - 58 para mulheres: (62.1 * H) - 44.7 4) Dados trs valores X, Y, Z, verifiquem se eles podem ser os comprimentos dos lados de um tringulo e se forem escrever uma mensagem informando se se um tringulo equiltero, issceles ou escaleno. Observaes: O comprimento de um lado do tringulo sempre menor do que a soma dos outros dois. Eqiltero - Todos lados iguais Issceles - Dois lados iguais Escaleno - Todos os lados diferentes 5) Faa um programa que receba dois nmeros e diga se o primeiro maior que o segundo, se so iguais ou se o segundo maior que o primeiro. 6) Elabore um programa que leia trs valores inteiros e imprima o menor deles. 7) Elabore um aplicativo para calcular as razes de uma equao de 2 grau. 8) Elabore um aplicativo para calcular a mdia aritmtica entre quatro avaliaes e informar: Aprovado Para os alunos com mdia superior ou igual a 6.0 Reprovado Para os alunos com mdia inferior a 4.0 Em exame Para os alunos com mdia superior a 4.0 e inferior a 6.0. Para estes alunos, informar tambm a quantidade de pontos a ser obtida no exame. 9) Escreva um aplicativo que l trs inteiros digitados pelo usurio e exiba a soma, a mdia, o produto, o maior e o menor desses nmeros. OBS: Utilize a estrutura de deciso para definir o maior e o menor dos nmeros.
Notas de aula Prof Alindacir

Faculdade de Pindamonhangaba Sistemas de Informao Disciplina: Princpio de Desenvolvimento de Algoritmos Notas de Aula 10) Escreva um aplicativo que l dois inteiros e imprime se o primeiro mltiplo do segundo. 11) Elaborar um programa que verifique quantos dias tem o ms digitado. 12) Uma pessoa precisa saber se ela esta apta a prestar o servio militar. Prepare um programa para informar a situao da pessoa. 13) Faa um programa que receba cinco nmeros e diga a quantidade de nmeros negativos. 14) Faa um programa que receba o cdigo de um produto e seu valor. Baseado na tabela de aumento abaixo, o seu programa dever dizer qual o novo preo do produto. Cdigo Percentual de aumento % 1 3 4 8 15 20 35 40

15) Uma empresa decide dar um aumento de 30% aos funcionrios cujo salrio inferior a 500 reais. Escreva um programa que receba o salrio de um funcionrio e imprima o valor do salrio reajustado ou uma mensagem caso o funcionrio no tenha direito ao aumento. 16) Faa um programa que receba a idade de uma pessoa e imprima mensagem de maioridade ou no. 17) Faa um programa que calcule e imprima o salrio reajustado de um funcionrio de acordo com a seguinte regra: salrios at R$ 300,00 - reajuste de 50% salrios maiores que R$ 300,00 - reajuste de 30% 18) Elabore um aplicativo para ensinar a operao de multiplicao, para crianas. O aplicativo dever permitir as crianas digitar dois valores numricos. Em seguida, solicitar o resultado da operao. Por ltimo, exibir uma mensagem de Parabns, para acerto ou Tente Novamente, para erro. 19) O cardpio de uma lanchonete o seguinte: Especificao Cdigo Preo Cachorro quente 100 1,20 Bauru simples 101 1,30 Bauru com ovo 102 1,50 Hambrger 103 1,20 Cheeseburguer 104 1,30 Refrigerante 105 1,00 Escrever um algoritmo que leia o cdigo do item pedido, a quantidade e calcule o valor a ser pago por aquele lanche. Considere que a cada execuo somente ser calculado um item.
Notas de aula Prof Alindacir

Faculdade de Pindamonhangaba Sistemas de Informao Disciplina: Princpio de Desenvolvimento de Algoritmos Notas de Aula 20) Escreva um programa que l cinco nmeros e determina e exibe quantos nmeros negativos, quantos nmeros positivos e quantos zeros foram lidos. 21) Escreva um aplicativo que l um nmero que consiste de 3 dgitos digitados pelo usurio, separa o nmero em seus dgitos individuais e exibe os dgitos separados uns dos outros por trs espaos cada. Por exemplo, se o usurio digitar 235, o programa dever exibir: 2 3 5 . 22) Uma empresa conceder um aumento de salrio aos seus funcionrios, varivel de acordo com o cargo, conforme a tabela abaixo. Faa um algoritmo que leia o salrio e o cargo de um funcionrio e calcule o novo salrio. Se o cargo do funcionrio no estiver na tabela, ele dever, ento, receber 40% de aumento. Mostre o salrio antigo, o novo salrio e a diferena. Cdigo Cargo Percentual 101 102 103 Gerente Engenheiro Tcnico 10% 20% 30%

23) Ler o ano de nascimento de duas pessoas e calcular suas idades. Imprimir o nome e a idade de cada uma e indicar qual a mais nova 24) Uma empresa d um prmio aos funcionrios que cumprem ou ultrapassam determinado valor de vendas de produtos. A cada funcionrio foi estabelecido um valor a ser alcanado. Faa um algoritmo para ler o valor fixado e o valor de vendas de um funcionrio, e imprimir a mensagem "Ganhou!", se o funcionrio tiver conseguido o prmio, e "No ganhou!", se no tiver conseguido.

Notas de aula Prof Alindacir