Você está na página 1de 12

Exerccios propostos a) Faa um algoritmo que receba dois nmeros e exiba o resultado da sua soma.

R: var x, y: inteiro inicio // Seo de Comandos Escreval ("Digite o primeiro nmero:) Leia(x) Escreval ("Digite o segundo nmero:) Leia(y) Escreva ("A soma dos nmeros :, x+y) fimalgoritmo 2. Faa um algoritmo que receba dois nmeros e ao final mostre a soma, subtrao, multiplicao e a diviso dos. Nmeros lidos. R: var x, y: real inicio // Seo de Comandos Escreva ("Digite o primeiro nmero:) Leia(x) Escreva ("Digite o segundo nmero:) Leia(y) Escreval ("A soma :, x+y) Escreval ("A subtrao :, x-y). Escreval ("A multiplicao :, x*y). Escreval ("A diviso :, x/y). fimalgoritmo 3. Escrever um algoritmo para determinar o consumo mdio de um automvel sendo fornecida a distncia total percorrida pelo automvel e o total de combustvel gasto. R: var

Distancia, combustvel: real inicio // Seo de Comandos escreval("========== Clculo de consumo mdio de combustvel =========") escreva("Digite a distncia pecorrida: ") leia(distancia) escreva("Digite o combustvel gasto: ") leia(combustivel) escreval("O consumo mdio de combustvel do seu veculo : ",distancia/combustivel) fimalgoritmo 4. Ler uma temperatura em graus Celsius e apresent-la convertida em graus Fahrenheit. A frmula de converso : F=(9*C+160) / 5, sendo F a temperatura em Fahrenheit e C a temperatura em Celsius. R: var cel, far: real inicio // Seo de Comandos escreval("=-=-=-=-=- Tabela de converso: Celcius -> Fahrenheit -=-=-=-=-=") escreva("Digite a temperatura em Celcius: ") leia(cel) far <- (9*cel+160)/5 escreval("A nova temperatura : ",far,"F") fimalgoritmo 5. Elaborar um algoritmo que efetue a apresentao do valor da converso em real (R$) de um valor lido em dlar (US$). O algoritmo dever solicitar o valor da cotao do dlar e tambm a quantidade de dlares disponveis com o usurio. R: var rs, us, cotacao, dolaDisponivel: real inicio // Seo de Comandos escreval("========= Cotao do Dlar ==========")

escreva("Qual a cotao atual do dlar? ") leia(cotacao) escreva("Quantos dlares voc possui? ") leia(us) rs <- us/cotacao limpatela escreval(us," Dlares equivalem : ",rs," R$") fimalgoritmo 6. Faa um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento aps um ms. R: var correcao, deposito: real inicio // Seo de Comandos escreval("Sistema de depsito do Banco do Oeste") escreva("Digite o valor depositado: ") leia(deposito) correcao <- 0.7 * deposito escreva("O rendimento do depsito aps um ms de: ",deposito+correcao) fimalgoritmo Considere fixo o juro da poupana em 0,70% a. m. 7. A Loja Mamo com Acar est vendendo seus produtos em 5 (cinco) prestaes sem juros. Faa um algoritmo que receba um valor de uma compra e mostre o valor das prestaes. R: var compra, prestacao: real inicio // Seo de Comandos escreval("========== Loja Mamo com Acar ==========") escreva("Digite o valor da compra: ") leia(compra) prestacao <- compra/5 escreval("O cliente dever pagar 5 prestaes de R$",prestacao," cada") fimalgoritmo

8. Faa um algoritmo que receba o preo de custo de um produto e mostre o valor de venda. Sabe-se que o preo de custo receber um acrscimo de acordo com um percentual informado pelo usurio. R: var custo, venda, percent: real inicio // Seo de Comandos escreva("Digite o custo do produto: ") leia(custo) escreva("Digite o percentual para venda: ") leia(percent) percent <- (percent/100) * custo venda <- custo + percent escreval("O valor de venda : ",venda) fimalgoritmo 9. O custo ao consumidor de um carro novo a soma do custo de fbrica com a percentagem do distribuidor e dos impostos (aplicados, primeiro os impostos sobre o custo de fbrica, e depois a percentagem do distribuidor sobre o resultado). Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%. Escrever um algoritmo que leia o custo de fbrica de um carro e informe o custo ao consumidor do mesmo. R: var custoFabrica, custoFinal: real inicio // Seo de Comandos escreva("Informe o custo de fbrica do veculo: ") leia(custoFabrica) custoFinal <- custoFabrica + (0.28 * custoFabrica) + (0.45 * custoFabrica) custoFinal <- custoFinal + (0.45 * custoFinal) escreval("O custo para o consumidor final de: ",custoFinal)

fimalgoritmo 10. Faa um algoritmo que receba um nmero e mostre uma mensagem caso este nmero seja maior que 10.

R: var numero: inteiro inicio // Seo de Comandos escreva("Digite um nmero: ") leia(numero) se numero > 10 entao escreval("O nmero maior que 10") fimse fimalgoritmo 11. Faa um algoritmo que receba a idade de 75 pessoas e mostre mensagem Informando maior de idade e menor de idade para cada pessoa. Considere a idade a partir de 18 anos como maior de idade. R: var x, idade: inteiro inicio // Seo de Comandos para x de 1 ate 75 faca escreva("Digite a idade: ") leia(idade) se idade >= 18 entao escreval("Fulano maior de idade!") fimse fimpara fimalgoritmo 12. Faa um algoritmo que receba um nmero e mostre uma mensagem caso este nmero sege maior que 80, menor que 25 ou igual a 40. R: var numero: inteiro inicio // Seo de Comandos escreva("Digite um nmero: ") leia(numero)

se numero > 80 entao escreval("O nmero maior que 80") senao se numero < 25 entao escreval("O nmero menor que 25") senao se numero = 40 entao escreval("O nmero igual a 40") fimse fimse fimse fimalgoritmo

13. Faa um algoritmo que exiba a srie de fibonacci. R: Var {declarao das variveis} a,b: inteiro inicio {atribui o valor inicial 1 a varivel b} b<-1 {Inicia o lao e s para quando a condio torna-se falsa} enquanto a<2000 faca {realizando os clculos} a<- a+b b<- a-b {escreve na tela} escreva(a,",") fimenquanto fimalgoritmo 14. Faa um algoritmo que leia um nmero de 1 a 5 e escreva por extenso.Caso o usurio digite um nmero que no esteja neste intervalo, exibir mensagem: nmero invlido. R: var numero: inteiro inicio // Seo de Comandos escreva("Digite um nmero de 1 a 5: ")

leia(numero) escolha numero caso 1 escreval("Um") caso 2 escreval("Dois") caso 3 escreval("Trs") caso 4 escreval("Quatro") caso 5 escreval("Cinco") outrocaso escreval("Nmero Invlido!!!") fimescolha fimalgoritmo 15. Elabore um algoritmo que, dada a idade de um nadador. Classifique-o em uma das seguintes categorias: Infantil A = 5 - 7 anos Infantil B = 8 - 10 anos juvenil A = 11- 13 anos juvenil B = 14 - 17 anos Snior = 18 - 25 anos Apresentar mensagem idade fora da faixa etria quando for outro ano no contemplado. R: var idade: inteiro inicio // Seo de Comandos escreva("Digite a idade do nadador: ") leia(idade) escolha idade caso 5,6,7 escreval("Infantil A") caso 8,9,10 escreval("Infantil B") caso 11,12,13 escreval("Juvenil A") caso 14,15,16,17 escreval("Juvenil B") caso 18,19,20,21,22,23,24,25

escreval("Snior") outrocaso escreval("Idade fora da faixa etria") fimescolha fimalgoritmo 16.Escreva um algoritmo para ler as dimenses de um retngulo (base e altura), calcular e escrever a rea do retngulo. R: Ler Base Ler Altura rea = Base* Altura 17.Faa um algoritmo que leia a idade de uma pessoa expressa em anos, meses dias e escreva a idadedessa pessoa expressa apenas em dias. Considerar ano com 365 dias e ms com R: Ler A,M,D TotalA = A * 365 TotalM = M *30 Idade = TotalA +Totalm + D Escrever idade 18.Escreva um algoritmo para ler o nmero total de eleitores de um municpio, o nmero de votosbrancos, nulos e vlidos. Calcular e escrever o percentual que cada um representa em relao ao totalde eleitores. R: Ler Tot, VB, VV.VN PB = VB * 100/Tot PV =VV * 100/Tot PN = VN * 100/Tot Escrever PB,PV,PN 19.Escreva um algoritmo para ler o salrio mensal atual de um funcionrio e o percentual de reajuste.Calcular e escrever o valor do novo salrio. 30 dias. R: Ler SalAtual,PerReaj Aumento = PerReaj * SalAtual/100

SalNovo = SalAtual + Aumento Escrever SalNovo 20.O custo de um carro novo ao consumidor a soma do custo de fbrica com a porcentagem do distribuidor e dos impostos (aplicados ao custo de fbrica). Supondo que o percentual do distribuidor seja de 28% e os impostos de 45%, escrever um algoritmo para ler o custo de fbrica de um carro,calcular e escrever o custo final ao consumidor. R: Ler CustoFab PreDist = CustoFab * 28/100 PerDist = CustoFab * 45/100 Custofinal = CustoFab + PreDist + PerImp Escrever CustoFinal 21.Uma revendedora de carros usados paga a seus funcionrios vendedores um salrio fixo por ms,mais uma comisso tambm fixa para cada carro vendido e mais 5% do valor das vendas por ele efetuadas. Escrever um algoritmo que leia o nmero de carros por ele vendidos, o valor total de suas vendas, o salrio fixo e o valor que ele recebe por carro vendido. Calcule e escreva o salrio final do vendedor.4 R: Ler NCV, VTV, SalFixo, VCV Com1 = NCV * VCV Com2 = VTV * 5 / 100 SalFinal = SalFixo + Com1 + Com2 Escrever SalFinal 22. Escreva um algoritmo para ler uma temperatura em graus Fahrenheit, calcular e escrever o valor correspondente em graus Celsius (baseado na frmula abaixo): C F - 32 ---------- = ----------5 9 R: Ler F C = 5 * (F-32)/9 Escrever C

23. Faa um algoritmo que leia trs notas de um aluno, calcule e escreva a mdia final deste aluno.Considerar que a mdia ponderada e que o peso das notas 2, 3 e 5. Frmula para o clculo da mdia final : n1 * 2 + n2 * 3 + n3 * 5 mediafinal = ---- ---- --- --- --------------------10 R: Ler N1,N2,N3 MediaFinal = (N1*2 + N2*3 = N3*5) / 10 Escrever MediaFinal 24. Faa um algoritmo que receba o salrio-base de um funcionrio, calcule e mostre o salrio a receber, sabendo-se que esse funcionrio tem gratificao de 5% sobre o salrio-base e paga imposto de 7% sobre o total. R: salBase, salReceber, grat, imp: real Inicio Leia(salBase) Grat salBase * 5/100 SalReceber salBase +grat imp Imp SalReceber * 7/100 SalReceber SalReceber imp Escreva (salReceber) Fim 25. Faa um algoritmo que receba o ano de nascimento de uma pessoa e o ano atual, calcule e mostre: a) a idade dessa pessoa b) quantos anos ela ter em 2005. R: ano_atual, ano_nascimento, idade_atual, idade_2005: inteiro Inicio Leia (ano_nascimento, ano_atual) Idade_atual ano_atual - ano_nascimento Idade_2005 2005 - ano_nascimento Escreva (idade_atual) Escreva (idade_2005) Fim

26. Faa um algoritmo em pseudocdigo que calcule a mdia ponderada de um aluno, a partir de suas 3 notas obtidas no curso, sabendo-se que a primeira avaliao tem peso 2, a segunda tem peso 4 e a terceira tem peso 4. Mostre, ao final, a mensagem : A MEDIA FINAL DE ... FOI ... . Informar tambm se o aluno foi aprovado, mostrando a mensagem APROVADO caso a nota final seja maior ou superior a 7,0. R: aluno: caracter; nota1, nota2, nota3, media: real; p1, p2, p3: inteiro; Inicio p1 2; p2 4; p3 4; Leia (aluno); Leia (nota1, nota2, nota3); media (nota1 *p1 + nota2 * p2 + nota3 * p3)/10 Escreva (a media de , aluno, foi , media); Se (media >= 7,0) ento Escreva (aprovado); Fim se Fim 28. Modifique o algoritmo da mdia do aluno para informar: APROVADO ............ caso a nota final esteja no intervalo [10, 7] RECUPERAO...... caso a nota final esteja no intervalo [5, 7) REPROVADO .......... caso a nota final esteja no intervalo [0, 5) R: aluno: caracter; nota1, nota2, nota3, media: real; Inicio Leia (aluno); Leia (nota1, nota2, nota3); media (nota1 *0.2 + nota2 * 0.4 + nota3 * 0.4 Escreva (a media de , aluno, foi , media); Se (media >= 7,0) ento Escreva (aprovado); seno Se (media < 7,0 e media >= 5,0) ento Escreva (recuperao); seno Escreva (reprovado); Fim se; Fim se; Fim

29. Faa um algoritmo que leia 2 valores numricos e um smbolo. Caso o smbolo seja um dos relacionados abaixo efetue a operao correspondente com os valores. Ateno para a diviso por 0! + operao de soma - operao de subtrao * operao de multiplicao / operao de diviso R: num1, num2 : real; operador: caracter; Inicio Leia (num1, num2); Leia (operador); Escolha operador caso +: escreva (num1 + num2); caso -: escreva (num1 num2); caso *: escreva (num1 * num2); caso /: Se num2 <>0 ento escreva (num1/num2); seno escreva(diviso indefinida) fim se fim escolha; 30. Em uma eleio para representante existem dois candidatos. Os votos so informados atravs de cdigos. Os dados utilizados para a contagem dos votos obedecem seguinte codificao: R: --> 1 e 2 = voto para os respectivos candidatos; --> 0 = voto nulo; --> 3 = voto em branco Elabore um programa que leia em seqncia os votos (0 a 3). O programa deve finalizar com voto negativo. No final deve-se imprimir: --> total de votos --> total e percentual de votos para cada candidato --> total e percentual de votos para voto nulo --> total e percentual de votos para voto em branco --> candidato vencedor