Você está na página 1de 4

Exerccio de Excel Avanado O Objetivo montar uma Agenda Telefnica utilizando VBA 1 Altere o nome da aba da planilha Plan2

n2 para Agenda 2 Crie a tabela abaixo em Agenda, entre A1:C11


Nome Fabiana Jenifer Joo Jos Maria Marlene Ricardo Rita Rose Telefone Celular 3321-1253 9707-0347 3321-1248 9707-0342 3321-1244 9707-0338 3321-1246 9707-0340 3321-1245 9707-0339 3321-1251 9707-0345 3321-1247 9707-0341 3321-1249 9707-0343 3321-1250 9707-0344

Fernanda 3321-1252 9707-0346

3 Em E2 digite a frmula: =PROCV(D1;$A$2:$C$11;2;FALSO) , para fazer uma pesquisa na tabela. Deixando a procura pronta, fica mais fcil acess-la pelo VBA. 4 Em E3 digite a : =PROCV(D1;$A$2:$C$11;3;FALSO) , para fazer uma pesquisa na tabela. Deixando a procura pronta, fica mais fcil acess-la pelo VBA. 5 Altere o nome da aba da planilha Plan1 para Pesquisa 6 Insira um objeto Activex tipo Caixa de Texto

7 Desenhe a caixa de texto na planilha pesquisa e altere as propriedades, segundo a tabela abaixo, utilizando o boto LinkedCell Agenda!D1 8 Em B1 da planilha Pesquisa, digite a palavra PESQUISAR, selecione de B1:E2, mescle as clulas e depois aumente a fonte para tamanho 24 :

9 Insira o objeto Activex do tipo Boto de Comando

10 Desenhe o boto na planilha pesquisa e altere as propriedades, segundo a tabela abaixo, utilizando o boto Caption Pesquisar 11 O Visual de sua planilha deve ter ficado assim: :

12 Clique dias vezes sobre o boto Pesquisar para entrar no editor VBA.

13 No menu de opes Clique em inserir, e depois Mdulo:

14 No mdulo 1 digite o cdigo da funo abaixo:


Function Pesquisar() Sheets("Agenda").Select Nome = Range("D1").Value Telefone = Range("E2").Value Celular = Range("E3").Value 'Seleciona a Planilha Agenda 'Atribui a Varivel Nome o Valor da Clula D1 'Atribui a Varivel Telefone o Valor da Clula E2 'Atribui a Varivel Celular o Valor da Clula E3

'Atribui a Varivel Mensagem o valor da varivel Nome e pula uma linha com chr(13) Mensagem = "Nome: " & Nome & Chr(13) 'Atribui a Varivel Mensagem o valor da varivel Mensagem mais o Telefone e pula uma linha com chr(13) Mensagem = Mensagem & "Telefone: " & Telefone & Chr(13) 'Atribui a Varivel Mensagem o valor da varivel Mensagem mais o Celular Mensagem = Mensagem & "Celular: " & Celular Sheets("Pesquisa").Select Range("A1").Select MsgBox Mensagem DoEvents End Function 'Seleciona a Planilha Pesquisa 'Seleciona a clula A1

15 Clique 2 vezes em Plan1(Pesquisa) na guia de projetos:

16 Digite o Cdigo para CommandButton1_Click():


Private Sub CommandButton1_Click() a = Pesquisar() End Sub

17 Clique no disquete para salvar a planilha, de o nome Excel Aula4 e salve como tipo Pasta de Trabalho habilitada com Macro do Excel

18 Volte para o Excel e na Planilha Pesquisar, digite um nome e clique no boto Pesquisar dever aparecer a janela:

Boa Sorte!