Como fazer um gráfico de Pareto no Excel | HITec

Página 1 de 7

Submarino.com.br

Blog > Artigos > Softwares > Excel > Como fazer um gráfico de Pareto no Excel

Como fazer um gráfico de Pareto no Excel
Por Arthur Gouveia em 28 de maio de 2010
Vestibular UNINTER 2012
Cursos de graduação a distância. Inscrições abertas.
www.vestibularadistancia.com.br

Obra Padre Pio
Prestando Serviços P/ a Comunidade e Região. Confira o Nosso Site!
www.adestec.org.br

Controle Financeiro
Engefinance® - Software Financeiro. Controle financeiro empresarial.
www.engefinance.com.br

Planilhas Online
ScoreMAX: Transformamos planilhas em painéis gráficos online !
www.scoremax.com.br

Um gráfico de Pareto apresenta os dados em ordem decrescente e atrelados a uma curva de porcentagens acumuladas; também conhecida como curva ABC. Portanto, para fazer um Pareto é necessário apenas colocar os dados em ordem e fazer o cálculo das porcentagens acumuladas. Neste artigo vamos explorar como ordenar os dados no Excel através de fórmulas, sem a necessidade de usar macros ou o botão Classificar na barra de ferramentas do Excel. Para isso vamos fazer um gráfico de Pareto da quantidade em quilogramas de vendas de determinadas frutas.

Preparando a tabela
Para fazer a ordenação automática dos dados são necessárias duas tabelas: uma de entrada, onde serão lançados os dados e outra de saída, onde serão realizados os cálculos para ordenar.

Na tabela de entrada, como vemos na imagem acima, além das informações sobre as categorias (Fruta) e os dados (Qtd) existem duas colunas: Ordenador e Índice. A coluna de índice define qual seria a ordem padrão dos dados caso todos os valores fossem iguais, é como um critério padrão de desempate. Isso é necessário para que as fórmulas do Excel não fiquem em dúvida quando acontecerem valores iguais como no caso das quantidades vendidas de Tangerina e Uva. Já o Ordenador é o valor através do qual a tabela será ordenada. Ele utiliza, além dos dados de quantidade, as informações do índice para que não existam valores iguais. Para que possamos fazer o cálculo das porcentagens acumuladas é necessário ter o valor total das quantidades vendidas. Este valor está na célula D11 e a fórmula para cálculo do total é =SOMA(D3:D10).

Ordenando os valores
Vejamos, então, como criar os dados ordenados. Na tabela de entrada é necessário calcular apenas o valor do ordenador. O valor do ordenador é a soma da quantidade com 1 / (índice * 1000). Fazer 1 / índice é necessário para que as frutas com maior índice apareçam primeiro e a multiplicação por mil é necessária para que o “critério de desempate” apareça apenas após a terceira casa decimal. Agora, cada fruta tem um número único pelo qual é possível ordenar.

Para gerar a tabela de saída devemos começar com a coluna do Ordenador; é aí onde reside o segredo da ordenação. Para ordenar os dados, vamos utilizar a função MAIOR(matriz;k). Esta função retorna o maior valor k-ésimo do conjunto de dados. Com isso os dados da coluna Ordenador da tabela de saída têm as seguintes fórmulas:
Ordenador

=MAIOR($A$3:$A$10;1) =MAIOR($A$3:$A$10;2)

http://hitec.arthurgouveia.com.br/como-fazer-um-grafico-de-pareto-no-excel/

27/10/2011

Criando as porcentagens acumuladas.arthurgouveia.$A$3:$D$10.3. Clique em Ok.FALSO) =PROCV(H4.FALSO) =PROCV(H6.4.FALSO) =PROCV(H8. http://hitec.4.4.$A$3:$D$10.$A$3:$D$10.3.$A$3:$D$10. da coluna Qtd na tabela de saída. As colunas de porcentagem e de porcentagem acumuladas são necessárias para fazer a curva ABC.FALSO) =PROCV(H4.6) =MAIOR($A$3:$A$10.3.FALSO) =PROCV(H8.Como fazer um gráfico de Pareto no Excel | HITec =MAIOR($A$3:$A$10.FALSO) =PROCV(H7. as fórmulas das colunas Fruta e Qtd na tabela de saída são: Fruta Qtd =PROCV(H3.FALSO) =PROCV(H5.3.$A$3:$D$10.$A$3:$D$10. Para isso utilizaremos a função PROCV (valor_procurado.4.FALSO) =PROCV(H3. sem o cabeçalho.3.$A$3:$D$10. Já falamos sobre ela em outro artigo.$A$3:$D$10. mas de um modo geral.3) =MAIOR($A$3:$A$10. Um gráfico em branco irá surgir.$A$3:$D$10.matriz_tabela. na segunda linha o segundo maior valor e assim por diante.FALSO) =PROCV(H10. Já a coluna porcentagem acumulada é o resultado da quantidade vendida de uma fruta adicionada ao valor acumulado até então.8) Assim.procurar_intervalo).FALSO) =PROCV(H9.5) =MAIOR($A$3:$A$10.3.4.7) =MAIOR($A$3:$A$10.$A$3:$D$10. As fórmulas são: % % Acumulada =G3/$D$11 =G4/$D$11 =G5/$D$11 =G6/$D$11 =G7/$D$11 =G8/$D$11 =G9/$D$11 =G10/$D$11 Formate as colunas como porcentagem.3.3.4) =MAIOR($A$3:$A$10. =I3 =I4+J3 =I5+J4 =I6+J5 =I7+J6 =I8+J7 =I9+J8 =I10+J9 Gerando o gráfico de Pareto Clique em uma célula vazia no Excel e insira um novo gráfico de colunas.FALSO) =PROCV(H9.4.FALSO) =PROCV(H7. a função PROCV procura valor_procurado na primeira coluna de matriz_tabela e retorna o valor na mesma linha de valor_procurado e na coluna núm_índice_coluna.$A$3:$D$10. O cálculo da coluna porcentagem é a quantidade vendida de cada fruta em relação à quantidade total. Clique com o botão direito e selecione a opção Selecionar dados.FALSO) Pronto! A tabela já está pronta e ordenará automaticamente os valores com base nas quantidades na tabela de entrada.4. na primeira linha fica o maior valor.$A$3:$D$10.núm_índice_coluna.$A$3:$D$10.$A$3:$D$10.br/como-fazer-um-grafico-de-pareto-no-excel/ 27/10/2011 .FALSO) =PROCV(H6.4. Página 2 de 7 Agora é necessário encontrar a fruta e a quantidade vendida correspondente a cada número da coluna Ordenador. Na janela Selecionar Fonte de Dados clique em Adicionar.$A$3:$D$10. Com isso.$A$3:$D$10. Na caixa Editar Série coloque o nome da série como Quantidade e no campo Valores da série apague o valor atual (={1}) e selecione apenas os dados.FALSO) =PROCV(H5.com.FALSO) =PROCV(H10.

Clique em Ok. Na caixa Selecionar Fonte de Dados. Clique com o botão direito sobre qualquer barra da série Quantidade no gráfico e selecione Formatar Série de Dados.br/como-fazer-um-grafico-de-pareto-no-excel/ 27/10/2011 . apague o conteúdo do campo Valores da série e selecione os dados na coluna de porcentagens acumuladas. Na caixa Formatar Séries de Dados marque a opção Eixo Secundário e coloque Largura do Espaçamento em 10%. A caixa Selecionar Fonte de dados vai ficar assim: Clique em Ok. Pronto! Você já tem um gráfico de Pareto com a curva ABC que será alterado automaticamente se você mudar as quantidades vendidas na tabela de entrada.arthurgouveia. Clique com o botão direito sobre qualquer barra da série Curva ABC e selecione Alterar Tipo de Gráfico de Série. Clique em Fechar.Como fazer um gráfico de Pareto no Excel | HITec Página 3 de 7 Clique novamente no botão Adicionar. clique no botão Editar e selecione os dados da coluna Fruta na tabela de saída e clique em Ok. no grupo Rótulos do Eixo Horizontal (Categorias). Refinando o gráfico de Pareto http://hitec.com. Na janela Alterar Tipo de Gráfico selecione um gráfico de linhas sem marcadores. dê para a série o nome Curva ABC.

disponível no Excel 2007...15 « Como escolher um computador novo: Parte 1 – Desktop.. 19 de julho de 2010 -. 28 de junho de 2010 -.. Matheus! Precisando.. Calcule a média atendendo a determinadas condições. De R$116. 20 de julho de 2010 -. Notebook ou Netbook Home Números de telefone de usuários do Facebook estão sendo divulgados.Excel MédiaSES. Arthur Gouveia 21 de junho de 2010 at 8:42 · Responder Obrigado.. Ana Claudia 22 de setembro de 2010 at 13:44 · Responder Prezado Arthur.. Para isso clique com o botão direito no Eixo Vertical Principal e selecione Formatar Eixo. Com a função MÉDIASES. Excel. » 34 comentários para Como fazer um gráfico de Pareto no Excel Matheus 31 de maio de 2010 at 0:00 · Responder Obrigado amigo.. disponibilizo uma planilha que converte de números binários para caracteres ASC. entre em contato. O resultado é este: Tópicos Relacionados (Gerados automaticamente) 22 de julho de 2010 -.. Softwares 34 comentários Samsung S5260 Star II.00 Nokia X1-01 GSM Desbloqueado. Pareto Arquivado em Excel. Deixe o valor mínimo fixo em zero e o valor máximo fixo em 1. Assine nossos feeds RSS ou siga-nos no Twitter para ficar conectada com todas as novidades do HITec.arthurgouveia.Converter binários em texto Atendendo a pedidos.br/como-fazer-um-grafico-de-pareto-no-excel/ 27/10/2011 .Use nomes e intervalos dinâmicos para cálculos e gráficos no Excel Usando intervalos dinâmicos nomeados no Excel é possível fazer gráficos que se atualizam automaticam. 6 de julho de 2010 -. realmente este seu post me tirou uma duvida muito grande e me ajudou muito! Parabéns pelo seu blog! Arthur Gouveia 31 de maio de 2010 at 14:05 · Responder Valeu. Monique! Você assimilou muito bem o conceito do Gráfico de Pareto: a identificação das causas prioritárias de problemas. Mande suas dúvidas que eu responderei aqui! Monique 20 de junho de 2010 at 9:14 · Responder Muito bom.Publique textos binários no Twitter Após ver um tweet com o texto em binário decidi criar uma planilha em Excel para fazer o mesmo: conv...Tabelas no Excel 2007: Uma grande vantagem Criar uma tabela no Excel é fácil e apresenta várias vantagens como classificação e filtros automáti. realmente muito bom! caiu como uma luva pra mim.. Excelente artigo!! Ja conhecia o conceito de Pareto e Curva ABC. http://hitec.. Fico feliz em saber que meu artigo te ajudou. Faça o mesmo para o Eixo Vertical Secundário fixando o mínimo em zero e o máximo em 360 – o valor total de quantidades vendidas.10 até R$139.. Ordenar dados.12 até R$399. Tags: curva ABC.com. De R$307. muito bom pra indentificar problemas dentro da equipe.Como fazer um gráfico de Pareto no Excel | HITec Página 4 de 7 Algumas pessoas não gostam do gráfico com a forma que ele assume por padrão e preferem que a curva ABC comece no topo da primeira coluna de dados. é possível calcular a média de um conjunto de dados. mas não consegui de maneira alguma fazer o grafico no excel! Suas instruções ajudaram muito.

não obtive sucesso. indo de cima para baixo Leilton Pedro de Brito 5 de janeiro de 2011 at 9:14 · Responder Caro amigo. seu post foi de grande ajuda. Ana Cláudia Página 5 de 7 Adailton Ribeiro 7 de outubro de 2010 at 21:25 · Responder Sr. Adailton Ribeiro Sr. Arthur. Aguardo retorno. vale 5 pontos meu!!! Mauricio 16 de maio de 2011 at 21:36 · Responder Caro Arthur. se o Senhor pudesse me ajudar com algo mais resumido eu agradeceria porque eu tentei porém. tenho o valor anual da empresa e também tenho o valor gasto anual de cada departamento. e nele tenho que demonstrar as seguintes informações: Deixar a mostra no gráfico o faturamento anual da empresa e sobre ele. Gustavo Leite 9 de dezembro de 2010 at 11:51 · Responder Olá. parabéns. foi também para a maioria das pessoas que procuravam por algo a respeito. No entanto. Muito bom seu conteudo. Preciso de uma ajuda. http://hitec.arthurgouveia.com. eu gostaria de agradecer muito a sua ajuda. O total da empresa é a soma dos departamentos… Germana 2 de fevereiro de 2011 at 23:41 · Responder Nossa! Muito bom o artigo. O mais completo e detalhado que encontrei na Web. ou seja. consegui fazer o gráfico perfeitamente!!! Obrigadaa! Daniel Fernandes 29 de abril de 2011 at 13:56 · Responder Amigo.Como fazer um gráfico de Pareto no Excel | HITec Obrigada. muito obrigado.br/como-fazer-um-grafico-de-pareto-no-excel/ 27/10/2011 . a curva ABC do meu gráfico fico ao contrário. Para os colegas que acertaram meus parabéns.Arthur 16 de outubro de 2010 at 10:32 · Responder estou precisando fazer um gráfico onde preciso mostrar ao mês seis colunas. O Senhor pode me enviar um gráfico pronto com a tabela para eu possa só inserir os meus dados de controle de estoque? acredito que já me ajudaria bastante. sem dúvida seu post foi e será de grande ajuda. Tenho que montar um gráfico para análise no excel 2010. nao sei como montar um grafico com 6 colunas pode me ajudar??? EngSilvio 20 de outubro de 2010 at 23:56 · Responder Muito Obrigado!! Foi de muita ajuda… Rodrigo 4 de dezembro de 2010 at 20:35 · Responder Excelente Post! Mto obrigado pela divulgação. pois sempre necessito de criar graficos para demostar estudos e avaliações. Arthur Gouveia 8 de janeiro de 2011 at 8:44 · Responder Leilton. valeu! Adauto Rios 17 de maio de 2011 at 21:54 · Responder Arthur. como demonstrar para uma análise mais profunda e se você tiver mais alguma informação desse genêro para acrescentar. Faça um gráfico de Pizza. estou aprendendo a trabalha com controle de performace e seu material me ajudou muito. Adauto Rios. ficarei agradecido. para mostrar dentro de cada mês o desempenho dos meus vendedores num período de 6 meses. da empresa. calcular uma porcentagem de despesas com cada departamento ou setor. Liste as despesas de todos os departamentos e faça o gráfico. Muito obrigado! Abraço. Att. acredito que assim como foi para mim. boa noite! Apesar de ter dificuldades de trabalhar com o excel. Flávitoo 10 de maio de 2011 at 22:11 · Responder manda o arquivo por e-mail pra facilitar. Um grande abraço a todos! Sds.

O problema/dificuldade dele é “administração”. que a tua explicação está de mestre! O Gráfico ficou perfeito! Muito Obrigada. confesso que necessito relembrar algumas formas de aplicação do “pareto”. ao qual. o material é muito didático e de fácil entendimento. desejo aplicar também o “pareto” no quesito especifico “finanças/empréstimos/financiamentos/taxas de juros/retorno esperado/investimento inicial/ curto e longo prazo… digamos quase um diagnóstico da “saúde da empresa”…pelo que eu percebi no meu irmão foi quase uma “angústia” no curto prazo entre: estoque + contas a receber VS contas à pagar – imediantamente no curto prazo para que ele avalie o “fôlego” que tem… mediante da “análise” já farei as “receitas dos remédios”… Por isso. consegui fazer o gráfico perfeitamente!!! Gustavo Facury Braga 14 de julho de 2011 at 16:39 · Responder Grande Arthur!!! Cara nesse Excel 2007 eu não sabia de jeito nenhum fazer Pareto.br/como-fazer-um-grafico-de-pareto-no-excel/ 27/10/2011 . Adriano 13 de setembro de 2011 at 13:21 · Responder http://hitec. Arthur! Foi realmente um “Eureka!” ter encontrado esse seu post sobre Gráfico de pareto na web. Marco Antonio Pedrina Bertanha 28 de junho de 2011 at 1:39 · Responder Muito obrigada. Na verdade. iniciante (25 anos – sem curso superior). Sr.Como fazer um gráfico de Pareto no Excel | HITec Bruna 29 de maio de 2011 at 9:49 · Responder Muito boa a explicação!!! Simples e fácil de acompanhar! Página 6 de 7 José Almiro Marinho 30 de maio de 2011 at 9:09 · Responder Salve Muito obrigado. Vou direto: Apesar de ser economista e com larga especialização em gestão de pessoas e processos comerciais. Muito. Me ajudou muito. no excel. Mas depois de ler esse seu artigo. mas muito obrigada mesmo. MARCO ANTONIO 4 de junho de 2011 at 9:39 · Responder Olá Arthur. te achei no Grande Oráculo google.com. julguei que o “pareto” pode auxiliar na efetiva “situação” e eventuais ações corretivas. Muito comum aos “micros”… Lembrei-me do mark-up. e estava com dificuldade para ordenar as Categorias em ordem decrescente de forma. Trabalho com TPM – Manutenção Planejada Total em uma grande empresa. Muito OBRIGADO pela ajuda. Roberto. Vou aplicar. trata-se de uma “ajuda” que estou oferecedo à um meu irmão. digamos. “falei” demais… peço desculpas… se você puder me ajudar na aplicação do pareto já ficarei bem agradedcido. agora posso ir mais tranquilo. Seu artigo é resumido. tava tentando montar um pareto mas não tava dando certo e tenho uma prova na empresa que trabalho a alguns dias. o tutorial foi muito didático e de fácil entendimento. Me ajudou muito José Almiro Marinho Elizeu 31 de maio de 2011 at 8:40 · Responder Valeu pela aula. Eu sei Arthur. Sucesso Alex 28 de julho de 2011 at 16:01 · Responder Td Bem?? Cara mez dia como posso inserir umtitulo neste grafico de pareto.arthurgouveia. Sil 30 de agosto de 2011 at 15:26 · Responder Parabéns Arthur! É só ler com atenção. ela ainda vale a pena pq dissemina boas informações sem que a gente saia fisicamente do lugar. passou as orientações acima?? grato. principalmente no quesito: preço de custo – preço de venda – % margem. por disponibilizar seus conhecimentos pra quem quiser. valeu mesmo e parabens pelo tabalho. Foi a melhor ajuda que encontrei na NET sobre o assunto. Porém. didático e bem explicativo. Abração Colega!!! PS depois deixo um recado mais sem educação no seu FACEBOOK!!! Roberto Dias 17 de julho de 2011 at 10:25 · Responder Ola. automática. parabens pelas suas informações/contribuições. Grato. Ele está iniciando uma micro-empresa voltada exclusivamente à area de confecções – moda feminina. bom dia ! Inicialmente. ficou muito fácil. Márcia 22 de julho de 2011 at 13:58 · Responder No meio de um monte de besteiras que são publicadas na internet. Nisso ele é craque.

disponibilizar Download da planilha. Otima atitude sua em dividir seus conhecimentos Abraço Patricia 14 de outubro de 2011 at 15:51 · Responder Obrigada pelo post Artur! Realmente tirou uma grande dúvida que tinha – e de maneira rápida e fácil. nao foi útil para mim . O desenvolvimento passo a passo ficou ótimo.br/como-fazer-um-grafico-de-pareto-no-excel/ 27/10/2011 . Sucessos !! adrino de souza 25 de setembro de 2011 at 20:09 · Responder Sr Arthur MUITO OBRIGADO ME AJUDOU MUITO MESMO PARABÉNS valdelirio moura maciel 5 de outubro de 2011 at 23:05 · Responder SR.Como fazer um gráfico de Pareto no Excel | HITec Parabéns pela explicação. Abraço « Como escolher um computador novo: Parte 1 – Desktop. excelente esta sua explicação. Página 7 de 7 Pimentel 14 de setembro de 2011 at 12:12 · Responder Não é possivel. MUITO BOM mesmo! Parabéns pelo trabalho e por compartilhar conosco. Julio Cesar 6 de outubro de 2011 at 11:52 · Responder Artur. de como ajustar a linha de % para que ficasse no topo das colunas. » http://hitec. Notebook ou Netbook Home Números de telefone de usuários do Facebook estão sendo divulgados. mesmo seguindo as orientações não se consegue de maneira alguma. facil e bem didatica. e parabens pela pasciencia.arthurgouveia.ARTHUR MUITO OBRIGADO MESMO CONSEGUIU ME AJUDAR E MUITO PARABENS PELA INICIATIVA ABRAÇOS. as vezes. mas nao ha nada melhor que um conhecimento agregado ! parabens pela ajuda . Parabéns. heheh . fazer o grafico no excel! willian Rangel 15 de setembro de 2011 at 12:31 · Responder parabens Sr Arthur ! agradeçemos pela iniciativa.com. Grande abraço.

Sign up to vote on this title
UsefulNot useful