Você está na página 1de 111

CCNA Cram Guide

A Presentation
by
Faruk Mamaniat
(mrlogic0)
Based on
Paul Browning's
"CCNA Cram Guide
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
2
CCNA Cram Guide
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
3
1. OS Model
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
4
7. AppIicofion Loyer
Provides Services fo Iower Ioyers
EnobIes progrom fo progrom communicofion
Defermines if sufficienf resources exisf for
communicofion
ExompIes:
- EmoiI gofewoys (SMTP)
- FTP
- TFTP
- SMMP
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
5
. Presenfofion Loyer
Presenfs informofion fo fhe AppIicofion Ioyer.
Compression
Dofo conversion
Encrypfion
Sfondord formoffing occurs here.
Confoins dofo formofs:
- JPE0
- MPE0
- MIDI
- TIFF
[EncopsuIofion ~ dofo]
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
6
. Session Loyer
EsfobIishes ond moinfoins communicofion 'sessions' befween
oppIicofions (dioIogue confroI)
Sessions con be:
- SimpIex (one direcfion onIy)
- HoIf-dupIex (one direcfion of o fime)
- FuII dupIex (bofh woys simuIfoneousIy)
Ieeps differenf oppIicofions dofo seporofe from ofher
oppIicofions
ProfocoIs incIude:
- MFS
- SQL
- X Window
- PPC
- ASP
- Mef8IOS Momes
[EncopsuIofion ~ dofo]
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
7
. Tronsporf Loyer
PesponsibIe for end fo end infegrify of dofo fronsmissions
EsfobIishes o IogicoI connecfion befween sending ond receiving
hosfs vio 'virfuoI circuifs'
Windowing works of fhis IeveI fo confroI how much informofion
is fronsferred before ocknowIedgemenf is required
Dofo is segmenfed ond reossembIed of fhis Ioyer
Porf numbers ore used fo keep frock of differenf conversofions
crossing fhe nefwork of fhe some fime
Error correcfion (nof defecfion)
Supporfs:
- TCP
- UDP
- SPX
- M8P
[EncopsuIofion ~ segmenfs]
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
8
. Mefwork Loyer
Poufes dofo from one node fo onofher ond defermines fhe besf
pofh fo foke
Poufers operofe of fhis IeveI
Mefwork oddresses ore used here for roufing
Poufing fobIes, subneffing ond confroI of nefwork congesfion
occur here.
Poufing profocoIs regordIess of which profocoI fhey run over
reside here:
- PIP
- IP
- IPX
- APP
- I0PP
- AppIefoIk
[EncopsuIofion ~ Pockefs]
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
9
. Dofo Link Loyer
Somefimes referred fo os fhe LAM Ioyer.
PesponsibIe for fhe physicoI fronsmission of dofo from one node
fo onofher
Pockefs ore fronsIofed info Fromes here ond hordwore oddress
is odded.
Error defecfion
8ridges ond swifches operofe of fhis Ioyer.
[EncopsuIofion ~ Fromes]
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
10
Data Link Sublayers
LogicuI Link ControI {LLC} 0Z,Z:-
- Monoges communicofions befween devices over o singIe Iink on o
nefwork
- Uses Service Access Poinfs (SAPs) fo heIp Iower Ioyers foIk fo fhe
Mefwork Loyer.
Mediu Access ControI {MAC} 0Z,3:-
- 8uiIds fromes from fhe I's ond 0's fhof fhe PhysicoI Loyer (oddress
~ -byfe/ bif) picks up from fhe wire os o digifoI signoI
- Puns o CycIic Pedundoncy Check (CPC) fo ossure no bifs were Iosf
or corrupfed.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
11
I. PhysicoI Loyer
Pufs dofo onfo fhe wire ond fokes if off
PhysicoI Ioyer specificofions such os:
- Connecfors
- VoIfoge
- physicoI dofo rofes
- DTE/DCE inferfoces
Some common impIemenfofions incIude:
- Efhernef/IEEE 0.
- Fosf Efhernef
- Token Ping/IEEE 0.
[Hubs operofe here]
[EncopsuIofion ~ 8ifs]
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
12
2. Cisco Hierarchical Model
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
13
Core Loyer
Swifch froffic os quickIy os possibIe
Fosf fronsporf fo Enferprise services (infernef efc).
Mo pockef MonipuIofion, VLAMs or occess-Iisfs
High speed occess required such os FDDI, ATM
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
14
Disfribufion Loyer
Time sensifive monipuIofion such os roufing, fiIfering
ond WAM occess
8roodcosf/MuIficosf, medio fronsIofions, securify
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
15
Access Loyer
Swifches ond roufers
Sfofic (nof dynomic) roufing
[Mefwork] Segmenfofion occurs here
Workgroup occess
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
16
3. Port Numbers
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
17
Common porf numbers ore:
0 - FiIe Tronsfer ProfocoI - Dofo (TCP)
I - FiIe Tronsfer ProfocoI - ConfroI (TCP) (PoreIy Used)
- SSH (TCP)
- TeInef (TCP)
- SimpIe MoiI Tronsfer ProfocoI (TCP)
- Domoin Mome Service (TCP/UDP)
- TrivioI FiIe Tronsfer ProfocoI (UDP)
0 - HTTP/WWW (TCP)
II0 - Posf Office ProfocoI (TCP)
II - Mefwork Mews Tronsfer ProfocoI (TCP)
I - Mefwork Time ProfocoI (UDP)
II/I - SimpIe Mefwork Monogemenf ProfocoI (UDP)
- HTTP over Secure Sockefs Loyer (TCP)
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
18
4. TCP/P & UDP
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
19
TCP - (profocoI )
PeIiobIe, sequenced Connecfion-orienfed deIivery
0-byfe heoder.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
20
UDP - (profocoI I7)
ConnecfionIess, Unsequenced, besf efforf deIivery
-byfe Heoder.
Sends dofo buf does Mof check fo see if if is
received.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
21
Services/ProfocoIs
TeInef
- Used fo connecf fo o remofe device (TCP)
- A possword ond usernome is required fo connecf.
- TeInef fesfs oII seven Ioyers of fhe OSI modeI.
SMMP
- AIIows remofe monogemenf of nefwork devices.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
22
Services/ProfocoIs
FTP
- Connecfion orienfofed (TCP) profocoI
- Used fo fronsfer Iorge fiIes.
TFTP
- ConnecfionIess (UDP) profocoI used for fiIe
fronsfer
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
23
ICMP
ICMP
- Supporfs pockefs confoining error, confroI ond
informofionoI messoges.
- Ping uses ICMP fo fesf nefwork connecfivify.
APP
- Used fo mop on IP oddress fo o physicoI (MAC)
oddress.
A hosf wishing fo obfoin o physicoI oddress broodcosfs on
APP requesf onfo fhe TCP/IP nefwork.
The hosf repIies wifh ifs physicoI oddress.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
24
DMS
PesoIves hosfnomes fo IP oddresses (nof fhe ofher
woy oround).
To configure fhe roufer fo use o hosf on fhe nefwork
use fhe commond:
- RJUTER(config)#ip nameserver 4.2.2.2
To configure DMS fhe commond: 'ip Mome-server' is
usuoIIy oIreody furned on for fhe roufer config by
defouIf.
If you wonf hosfs on fhe nefwork fo use fhe roufer
os o proxy DMS server puf fhis commond onfo fhe
roufer:
- RJUTER(config)#ip dns server
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
25
DHCP
InvoIves o cenfroI server or device which reIoys TCP
informofion fo hosfs on o nefwork.
You con configure o roufer fo be o DHCP server wifh
fhe beIow config
Musf hove hosfs on fhe some LAM os fhe roufer
inferfoce:
RJUTER(config)#ip dhcp pool E00_DHCP_Pool
RJUTER(dhcp-config)#network 10.10.10.0 255.255.255.0
RJUTER(dhcp-config)#dns-server 24.196.64.39 24.196.64.40
RJUTER(dhcp-config)#domain-name mydomain.com
RJUTER(dhcp-config)#default-router 10.10.10.254
RJUTER(dhcp-config)#lease 1
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
26
5. Cisco OS
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
27
Modes:
User EXEC:- Router
PriviIeged EXEC:- Router#
0IoboI Configurofion:- Router(config)#
POM Monifor:- or rommon
Sefup:- series of quesfions
PX8oof:- Router<boot
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
28
Edifing Commonds (I):
CfrI+W - Eroses o word
CfrI+U - Eroses o Iine
CfrI+A - Moves cursor fo beginning of Iine
CfrI+E - Moves cursor fo end of Iine
CfrI+F - (or righf orrow) - Move forword one chorocfer
CfrI+8 - (or Ieff orrow) - Move bock one chorocfer
CfrI+P - (or up orrow) - PecoIIs previous commonds from buffer
CfrI+M - (or down orrow) - Pefurn fo more recenf commonds in buffer
Esc+8 - Move bock one word
Esc+F - Move forword one word
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
29
Edifing Commonds ():
Tob - compIefes o commond you hove sforfed:
Router# copy ru 5ress tab key after the 'u'
Router# copy running-configuration
7 gives you fhe commond opfions:
Router#copy .
Flash: Copy from flash: file system
Ftp: Copy from ftp: file system
Nvram: Copy from nvram: file system
Running-config Copy from current system configuration
Startup-config Copy from startup configuration
System: Copy from system: file system
Tftp: Copy from tftp: file system (truncated to save space)
Or fhe commonds beginning wifh fhe Ieffers you hove fyped:
Router#a.
Access-enable
access-profile
access-template
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
30
6. Router Elements
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
31
DPAM (I)
Working oreo for roufer.
Confoins:
- Poufing fobIes
- APP coche
- Pockef buffers
- IOS
- Punning config
Some roufers run fhe IOS from DPAM.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
32
DPAM ()
W Show version
- Shows informofion obouf IOS in PAM
- DispIoys how much physicoI memory is insfoIIed
- Shows fhe config regisfer seffing.
W Show process
- Shows info obouf progroms running in DPAM.
W Show running-configuration
- Shows ocfive configurofion in DPAM
W Show memory/stacks/buffers
- To view fobIes ond buffers
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
33
MVPAM
Sfores roufers sforf up configurofion
Does nof Iose dofo when powered off (due fo o
boffery power source.)
W Show startup-configuration
W Erase startup-configuration
W Copy running-configuration startup-configuration
(copy run start)
Config regisfer skips sforf up config fiIe in
MVPAM (for possword recovery)
Config regisfer Ioods sforf up config fiIes
from MVPAM
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
34
FIosh
(EEPPOM or PCMCIA cord) hoIds fhe compressed
operofing sysfem imoge (IOS)
This is where soffwore upgrodes ore sfored.
W Show flash
W Dir flash:
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
35
POM
Confoins power on diognosfics, o boofsfrop progrom
ond o mini IOS (rommon).
You con specify which fiIe fhe roufer boofs from if
you hove more fhon one in fIosh memory
- Router(config)#boot system flash ,IJS filename,
Or fhof if boofs from o TFTP server if for exompIe
fhe imoge is foo Iorge fo fif in fIosh.
- Router(config)#boot system tftp ,IJS filename,,tftp
address)
You con oIso bock up fhe fIosh imoge for emergency
use.
- Router(config)#copy flash tftp
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
36
7. Cabling
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
37
Pinoufs
Crossover
I -
-
- I
-
Sfroighf Through
I - I
-
-
-
-
-
7 - 7
-
PoIIover
(PC fo ConsoIe/Aux porf)
I -
- 7
-
-
-
-
7 -
- I
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
38
Two fypes of crossfoIk con
occur on fwisfed poir cobIes:
Meor end crossfoIk (MEXT)
For end crossfoIk (FEXT)
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
39
8. Router Management
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
40
Router Management
ConsoIe porf:
- A PC is connecfed fo fhe consoIe porf vio o roIIover cobIe.
- Used for inifioI configurofion or disosfer recovery.
AuxiIiory porf:
- MormoIIy o modem connecfed fo fhis porf.
VirfuoI TerminoIs:
- MormoIIy occessed by feIneffing fo fhe roufer.
- Five Iines ovoiIobIe numbered [vfy] 0-
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
41
Router Management
TFTP server:
- The roufer con gef ifs configs or IOS from o server (PC for
exompIe) running TFTP soffwore ond hoIding fhe necessory
fiIes.
MMS:
- Mefwork monogemenf sfofion
- Uses SMMP fo monoge fhe roufer normoIIy vio o Web sfyIe
inferfoce.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
42
9. CDP
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
43
Router#show cdp
neighbors
W This command displays the neighbouring
router or switches hostname, hardware
platform, port identifier and
capabilities list.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
44
Router#show cdp
neighbors detail
W This command displays more detail than the
previous one. You can view IP address, IJS
release and duplex setting.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
45
10. LAN Switching
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
46
A LAM swifch hos fhree
primory funcfions:
I. Address Leorning
- Moinfoins o fobIe (CAM - Confenf AddressobIe Memory) of
oddresses ond which porf fhey con be reoched on.
. Forword/fiIfer decision
- Forwords fromes onIy ouf of fhe reIevonf porf.
. Loop ovoidonce
- STP
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
47
Tronsmiffing Fromes Through o
Swifch
Sfore-ond-Forword
- Swifch copies fhe enfire frome info ifs buffer ond compufes
fhe CPC
- Frome is discorded if fhere is on error.
- High Iofency.
Cuf-fhrough
- Peods onIy fhe desfinofion oddress (firsf byfes offer
preombIe), Iooks up oddress ond forwords frome.
- Lower Iofency.
Frogmenf free
- Swifch reods firsf byfes before forwording fhe frome.
- (CoIIisions normoIIy occur wifhin fhe firsf byfes.)
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
48
Sponning Tree ProfocoI (STP)
IEEE 0.Id
A Iink monogemenf profocoI fhof provides pofh redundoncy
whiIsf prevenfing undesirobIe Ioops in fhe nefwork
For communicofion fo work correcfIy on on efhernef nefwork
fhere con onIy be one pofh befween fwo desfinofions.
STP uses 8ridge ProfocoI Dofo Unifs (8PDU) received by oII
swifches fo defermine fhe sponning-free fopoIogy.
A porf on o swifch is eifher in forwording or bIocking sfofe.
- Forwording porfs provide fhe Iowesf cosf pofh fo fhe roof bridge
- A porf wiII remoin in bIocking sfofe from sforf up if sponning free
defermines fhere is o beffer pofh.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
49
Popid Sponning Tree ProfocoI (PSTP)
IEEE 0.Iw
Sponning free fokes up fo 0 seconds fo converge fo o sfobIe
nefwork whereos PSTP fokes seconds.
PSTP porf roIes ore:
- Poof Porf
- Designofed Porf
- 8ockup Porf
- AIfernofe Porf
- DisobIed
Mosf impIemenfofions of PSTP use PVST+ (Per VLAM Sponning
Tree+):
- MuIfipIe insfonces of Sponning Tree ore running so fhe Iood on fhe
CPU is higher buf we con Iood shore over fhe Iinks.
To enobIe PSTP for eoch VLAM in our swifched nefwork we use
fhe foIIowing commond:
- Switch(config)#spanning-tree mode rapid-pvst
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
50
8ridging & Swifching
Swifching
- LAM Swifches ore primoriIy hordwore bosed.
- Mony sponning-free insfonces per swifch ond up fo
I00 porfs.
8ridging
- 8ridges ore primoriIy soffwore bosed ond hove one
sponning-free insfonce per bridge.
- MormoIIy I porfs per bridge.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
51
VirfuoI LAM (VLAM)
A VLAM is o swifched nefwork fhof consisfs of
IogicoIIy segmenfed communifies wifhouf regord fo
physicoI Iocofion.
Eoch porf on o swifch con beIong fo o VLAM.
VLAM porfs shore broodcosfs.
A roufer is needed fo roufe froffic befween VLAMs
becouse Ioyer devices do nof use IP oddresses.
Peduces odmin cosfs, fighfer securify ond beffer
confroI of broodcosfs.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
52
11. P Addressing
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
53
CIoss A
Formof/DefouIf Mosk
- M.H.H.H
- .0.0.0
Leoding 8if Poffern ~ 0
Mefwork Address Ponge ~ 0 - I
Mox Mefworks ~ I
Mox Hosfs/nodes ~ I,777,I
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
54
CIoss 8
Formof/DefouIf Mosk
- M.M.H.H
- ..0.0
Leoding 8if Poffern ~ I0
Mefwork Address Ponge ~ I -II
Mox Mefworks ~ I,
Mox Hosfs/nodes ~ ,
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
55
CIoss C
Formof/DefouIf Mosk
- M.M.M.H
- ...0
Leoding 8if Poffern ~ II0
Mefwork Address Ponge ~ I -
Mox Mefworks ~ ,07,I
Mox Hosfs/nodes ~
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
56
CIoss D
Leoding 8if Poffern ~ III0
Mefwork Address Ponge ~ -
MuIficosf
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
57
CIoss E
Leoding 8if Poffern ~ IIII0
Mefwork Address Ponge ~ 0 -
ExperimenfoI
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
58
12. Subnetting
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
59
13. Pv6
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
60
The two methods of migrating
from Pv4 to Pv6 are:
DualStack
Tunnelling
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
61
14. P Routing
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
62
Sfofic roufing:
Router(config)#ip route ,destination network,,mask,,next hop address,
E.g
ip route 172.16.5.2 255.255.255.0 172.16.12.8
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
63
Dynomic oddressing is done by
using o roufing profocoI:
For PIP v
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 172.16.0.0
Router(config-router)#no auto-summary <- ,optional,
For EI0PP
Router(config)# router eigrp 20
Router(config-router)#network 172.16.0.0
Router(config-router)#no auto-summary <- ,optional,
For OSPF
Router(config)#router ospf 20
Router(config-router)#network 172.16.0.0 0.0.255.255 area 0
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
64
Disfonce Vecfor (I)
Disfonce Vecfor profocoIs undersfond fhe direcfion ond
disfonce fo ony given nefwork connecfions.
AIgorifhms coIcuIofe fhe cosf fo reoch fhe connecfion ond
poss fhis informofion fo every neighbour roufer.
ExompIes ore PIP ond I0PP.
ProbIems:
- Poufing Ioops
- Counfing fo infinify
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
65
Disfonce Vecfor SoIufions:
Defining o moximum number of hops:
- PIP ~ I
- I0PP ~
SpIif Hori;on
- If fhe roufer Ieorns o roufe on on inferfoce do nof odverfise if ouf of fhe
some inferfoce.
Poufe Poisoning
- Informofion possed ouf of on inferfoce is morked os unreochobIe by seffing
fhe hop counf fo I (for PIP).
HoId Down Timers
- Ignores new roufing updofes unfiI o defermined fime hos possed.
Triggered Updofes
- Insfeod of roufing updofes being senf of fhe defouIf infervoIs, o friggered
updofe is senf every fime fo indicofe o chonge in fhe roufing fobIe.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
66
Link sfofe (I)
These hove o picfure of fhe enfire nefwork from Iink
sfofe odverfisemenfs (LSA) ond Iink Sfofe pockefs
(LSP). Once fhese hove oII been possed onIy chonges
fo fhe nefwork ore senf ouf reducing nefwork
froffic.
Peq o Iof of CPU fime & b/widfh when LSAs ore
fIooded eg:
- OSPF
- IS-IS
Poufers use odminisfrofive disfonces fo defermine
how beIievobIe fhe roufe Ieorned is depending upon
fhe profocoI if Ieorns fhe roufer from:
- Poufers prefer Iowesf disfonce eg:
- Direcf connecfion (0) OSPF (II0) PIP (I0)
- InsfoII fhis profocoI in roufing fobIe
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
67
Link sfofe ()
Routing Protocols
- Moinfoin fobIe of hosfs
- Which i/foce fhey con be reoched by
- Eg: PIP, OSPF
Routed Protocols
- Used fo fronsporf froffic from source fo desfinofion
- Eg: IP, IPX, AppIeToIk
When o pockef froverses o n/work from
device fo device (hop fo hop):
- IP oddress ~ consfonf
- MAC oddress chonges
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
68
Source - DefouIf Disfonce:
DirecfIy Connecfed Inferfoce ~ 0
Sfofic hop fo nexf roufer ~ I
EI0PP Summory ~
ExfernoI 80P ~ 0
EI0PP (InfernoI) ~ 0
OSPF ~ II0
IS-IS ~ II
PIP ~ I0
Exferior 0ofewoy ProfocoI (E0P) ~ I0
ExfernoI EI0PP ~ I70
InfernoI 80P ~ 00
Unknown ~
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
69
15. Routing Protocols
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
70
PIP v
Uses UDP porf 0
CIossIess
Mox hop counf I
MuIficosfs roufe
updofes fo .0.0.
Supporfs oufhenficofion
Updofe fimer 0
seconds
InvoIid 0 seconds
HoId down I0 seconds
FIush 70 seconds
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
71
EI0PP
Uses IP profocoI
CIossIess
Hybrid of disfonce vecfor ond Iink sfofe
MuIficosfs updofes fo .0.0.I0
Uses feosibIe successors fo defermine oIfernofive
roufes fo nefworks.
The feosibIe successor is o bockup roufe bosed upon
fhe fopoIogy fobIe.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
72
OSPF
Uses IP profocoI
CIossIess
Uses Dijksfros shorfesf
pofh oIgorifhm (SFP)
Poufer ID is fhe highesf
IP oddress buf
Ioopbock oddress used
if presenf
8ockbone oreo is oreo 0
AII non bockbone oreos
musf connecf direcfIy
fo oreo 0
Areos con be numbered
from 0 fo
MuIficosfs on .0.0.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
73
OSPF Inferfoce / Cosf:
OSPF uses cosf os o mefric (see beIow - ^
indicofes fhe mosf common) [Cosf
(I0/8ondwidfh)]
- ATM, Fosf Efhernef, 0igobif Efhernef, FDDI ( I00 Mbps) ~
I
- HSSI (Mbps) ~
- I Mbps Token Ping ~
- I0 Mbps Efhernef ~ I0
- Mbps Token Ping ~
- TI (I. Mbps)^ ~
- DS-0 (k)^ ~ I
- k ~ I7
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
74
16. NAT
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
75
MAT Focfs
Converfs infernoI oddress fo exfernoI
oddress commonIy:
- Converf non-roufobIe oddress fo roufobIe oddress
For oII configs you musf specify infernoI &
exfernoI i/foces
- Router(config-if)#ip nat inside/outside
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
76
Sfofic MAT
Mops one oddress fo onofher oddress such os
I.I.I.I fo 00.I.I.I
Router(config)#ip nat inside source static
192.168.1.1 200.1.1.1
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
77
Dynomic MAT
Mops o number of infernoI oddresses fo o pooI of
exfernoI oddresses.
ExompIe config:
- I. Creofes o pooI of I0 oddresses wifh o mosk (prefix Iengfh)
of ...0 ond fhe nome 'od_feom.'
- . The hosfs fo be MATfed ore on fhe I.I.I.0 nefwork.
- . The Access Iisf (source Iisf) feIIs fhe roufer which
oddresses fo MAT.
Router(config)#ip nat pool ad_team 10.0.0.1
10.0.0.10 prefix-length 24
Router(config)#ip nat inside source list 1 pool
ad_team out
Router(config)#access-list 1 permit 192.168.1.0
0.0.0.255
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
78
OverIood MAT (PAT)
Mops privofe infernoI oddresses fo one or more
exfernoI oddresses using porf nos
ExompIe config:
- Creofes o pooI of fen oddresses (if couId be more)
- The commond 'overIood' feIIs fhe roufer fo use porf oddress
fronsIofion.
Router(config)#ip nat pool ad_team 10.0.0.1
10.0.0.10 prefix-length 24
Router(config)#ip nat inside source list 1 pool
ad_team out overload
Router(config)#access-list 1 permit 192.168.1.0
0.0.0.255
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
79
17. Wireless Networks
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
80
Ad-hoc Mode
SimiIor fo peer-fo-peer nefworking where nodes
connecf direcfIy fo eoch ofher
They musf hove fhe some SSID ond chonneI for fhis
fo work.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
81
Infrosfrucfure Mode
W/Iess cIienfs connecf fo occess poinf (AP)
8SS (8osic Service Sef)
- I occess poinf ond muIfipIe cIienfs
ESS (Exfended Service Sef)
- or more 8SSs
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
82
W/Iess Securify
Open Sysfem
- Hosf sends on ossociofion requesf fo fhe wireIess occess
poinf ond if wiII be senf o success or foiIure messoge
Shored key
- A key or poss phrose is configured on fhe AP & cIienf(s)
- Types of Aufhenficofion: WEP, WPA, WPA
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
83
Types of Aufhenficofion:
WEP
- An encrypfion oIgorifhm buiIf in fhe 0.II sfondord
- PC 0bif or I0 bif key
- -bif IV (InifioIi;ofion Vecfor)
WPA
- Uses dynomic key monogemenf
- Adds o sfronger encrypfion cipher
- 8uiIf on fhe EAP/0.IX mechonism
- Uses TIIP (TemporoI Iey Infegrify ProfocoI)
- -bif IV
- Used w/ PADIUS in fhe Enferprise
WPA
- Mexf generofion
- Uses sfronger AES (Advonced Encrypfion Sfondord)
- Creofes o new key for every new ossociofion
CIienfs keys ore unique & specific fo fhof cIienf
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
84
18. Network Security
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
85
Access Lisfs
A sef of condifions fhof
permif or deny occess fo or
fhrough o roufers i/foce
Inbound Access Lisfs
Oufbound Access Lisfs
Con be oppIied fo muIfipIe
inferfoces
There con onIy be one occess
Iisf per profocoI per
direcfion per inferfoce
WiIdcord mosks
Access Iisfs ore oppIied fo
inferfoces
Ponge Usoge
Sfondord Access Lisfs
Exfended Access Lisfs
Momed Access Lisfs
access-class'
- Used if oppIying fo
consoIe/oux/vfy Iines
W Show ip access-lists
W Show access-list 1
Pockefs ore processed by fhe
occess Iisf ond fhen roufed.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
86
Inbound & Oufbound
Access Lisfs
Inbound:
- Sove fhe roufer hoving fo process fhe pockef
- Denied pockefs wiII be dropped of fhe inbound inferfoce
Oufbound:
- WiII be processed by fhe roufer
- Then dropped of fhe oufbound inferfoce if fhey mofch fhe
occess Iisf
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
87
WiIdcord mosks
TeII fhe roufer which porfs of fhe oddress fo Iook of
ond which fo disregord
W Access-list 12 permit 172.16.5.0 0.0.0.255
- This wouId permif ony hosf on nefwork I7.I..x
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
88
Access Iisfs ore oppIied fo
inferfoces:
W Router(config)#access-list 1 permit
172.16.5.2
W Router(config)#interface e0
W Router(config-if)#ip access-group 1 in
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
89
Ponge Usoge
I00-I IP Sfondord (Exponded Ponge)
I00-I IP Exfended
I- IP Sfondord
000- IP Exfended (Exponded Ponge)
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
90
Sfondord Access Lisfs
Check onIy fhe source oddress of fhe pockef &
permifs or denies enfire TCP/IP suife
You connof choose o porficuIor porf or oppIicofion fo
bIock
Cisco recommends fhof fhey ore pIoced os cIose fo
fhe desfinofion os possibIe.
W Router(config)#access-list,number 1-
99,,permit/deny,,source address,
W Access-list 10 permit 172.16.5.2 - oddress con be o
hosf or nefwork
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
91
Exfended Access Lisfs
AIIow for o Iof more gronuIorify when fiIfering IP
froffic.
Con fiIfer froffic bosed upon:
- Source or desfinofion
- A porficuIor IP profocoI
- Porf number
Cisco recommends fhof fhey ore pIoced os cIose fo
fhe source os possibIe.
W Router(config)#access-list ,number 100-
99,,permit/deny,,protocol,
W Access-list 112 permit tcp host 172.16.5.2 host
172.16.10.2 eq www
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
92
Momed Access Lisfs
W Router(config)#ip access-list ,standard/extended,
name
W Router(config)#ip access-list extended no_ftp
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
93
Posswords
Service possword-encrypfion
EnobIe
EnobIe Secref
VTY
AuxiIiory
ConsoIe
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
94
Possword conf
W Service password-encryption
- Encrypfs oII posswords
W Enable
- Used fo gef from user exec fo priviIeged exec.
- Mof encrypfed
- Router(config)# enable password ,password,
W Enable Secret
- Encrypfs possword
- Router(config)# enable secret ,password,
- (onIy use enable or enable secret nof bofh)
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
95
Possword conf
VTY
- Meeded if feInef occess is required
Router(config)#line vty 0 4
Router(config-line)#password cisco
Router(config-line)#login
AuxiIiory
- AIIows modem occess fo fhe oux porf
- Router(config)#line aux 0
- Router(config-line)#password cisco
- Router(config-line)#login
ConsoIe
- Used fo oIIow consoIe occess
- Router(config)#line console 0
- Router(config-line)#password cisco
- Router(config-line)#login
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
96
Profecfing fhe Mefwork
FirewoIIs
- Divide your nefwork info fhree ;ones:
Trusfed
Semi-Trusfed
Un-Trusfed
VPM
- AIIows informofion fo be senf secureIy over on insecure
medium (eg Infernef)
- Con be:
Sife-fo-Sife (eg WAM)
Access (eg homeworker)
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
97
Securify Device Monoger
(SDM)
A 0UI web bosed fooI
AIIows you fo configure ond monoge your Cisco
roufers
Con be insfoIIed on your roufer or your PC
(Huge omounf of poromefers ond screens fo novigofe)
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
98
19. Wan Protocols and Services
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
99
HDLC
Cisco defouIf on serioI WAM connecfions
Mo oufhenficofion ovoiIobIe
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
100
PPP
Dofo Iink
Aufhenficofion is opfionoI:
- PAP (cIeor fexf)
- CHAP (secure hosh)
Use PPP if connecfing o Cisco roufer fo o non-cisco
roufer.
W Router(config)#hostname paul password cisco - cose
sensifive
W Router(config)#interface serial 0
W Router(config-if)#encapsulation ppp
W Router(config-if)# ppp authentication chap
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
101
Frome PeIoy (I)
8osed upon x. profocoI
Less error checking ~ quicker
I fo Mb
- IdeoI for SMEs
Works of fhe physicoI & dofo Iink Ioyers.
DLCI's ore used fo idenfify fhe circuif
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
102
Frome PeIoy ()
Eoch roufer uses LMIs for keepoIives on fhe Iine
befween fhe roufer & fhe frome reIoy swifch:
- LMI fype is Cisco by defouIf.
- You musf use onofher fype such os onsi if connecfing fo o non-cisco
roufer.
W Router(config-if)#encapsulation frame-relay
Router(config-if)#frame-relay map ip 2.2.2.2 100
- Poufer is foId fo gef fo ip oddress ... use dIci I00
Use frome reIoy sub-inferfoces if poinf-fo-poinf or
muIfipoinf connecfion is needed
- IP oddress oppIied fo sub-inferfoces for fhese ond MOT fhe moin
inferfoce
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
103
Frome reIoy uses:
8ockwords ExpIicif Congesfion Mofificofion (8ECM)
- On refurning fromes fo worn of congesfion
Forword ExpIicif Congesfion Mofificofion (FECM)
- Is sef by fhe DCE end fo worn of congesfion from fhe
sending end.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
104
Frome PeIoy ProbIems incIude:
Incorrecf LMI seffing
Incorrecf DCLI
SpIif hori;on prevenfing roufing updofes Ieoving
inferfoce
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
105
20. Troubleshooting
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
106
Show ip interface brief
Firsf commond fo issue fo esfobIish if fhe inferfoces
ore up or down
(There ore onIy o hondfuI of woys fo breok ony
nefwork in fhe exom.)
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
107
Loyer I
Ensure fhof fhere is o cIock rofe on fhe DCE
inferfoce
W Show controllers serial X
- To check whof fype of cobIe is offoched
- X ~ serioI i/foce no
Ensure fhof fhe 'no shut' commond hos been oppIied
fo fhe inferfoce.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
108
Loyer
Ensure fhof fhe correcf encopsuIofion fype is on fhe
inferfoce i.e. HDLC, PPP efc
W Show interface serial X
If if is nof fhen go info inferfoce configurofion mode
ond chonge if.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
109
Loyer
Ensure fhof fhe correcf IP oddress AMD subnef mosk
is oppIied fo fhe inferfoce.
Ensure fhof fhe correcf nefworks ore being
odverfised by fhe roufing profocoI
W Show ip protocols
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
110
Worningl
AIwoys ensure fhof you con ping ocross
direcfIy connecfed roufer inferfoces
8EFOPE oppIying roufing profocoIs ond
occess Iisfs.
Created by Faruk Mamaniat Based on Paul Browning's CCNA Cram Guide
111
CCNA Cram Guide