Você está na página 1de 7

1algoritmo "semnome" // Função : // Autor : // Data : 01/11/2011 // Seção de Declarações var i:inteiro numeros: vetor [1..

10]de inteiro inicio // Seção de Comandos para i de 1 ate 10 faca leia (numeros [i]) fimpara para i de 10 ate 1 passo -1 faca escreva (numeros[i], ", ") fimpara fimalgoritmo 2algoritmo "semnome" // Função : // Autor : // Data : 01/11/2011 // Seção de Declarações var par,i:inteiro numeros: vetor [1..10]de inteiro inicio // Seção de Comandos para i de 1 ate 10 faca leia (numeros [i]) fimpara para i de 1 ate 10 faca se (i % 2 = 0)entao escreva (numeros [i], ", ") fimse fimpara fimalgoritmo 3algoritmo "semnome" // Função : // Autor : // Data : 01/11/2011 // Seção de Declarações var par,i:inteiro numeros: vetor [1..10]de inteiro inicio // Seção de Comandos para i de 1 ate 10 faca

".leia (numeros [i]) fimpara para i de 1 ate 10 faca se (numeros [i] % 2 <> 0)entao escreva (numeros [i]...a[k] + b[k] escreval (c [k]. ".10] de inteiro inicio // Leia dois vetores A e B..5] de inteiro b: vetor [1. ") fimpara fimalgoritmo 5algoritmo "do_professor" // Função : // Autor : // Data : 08/11/2011 // Seção de Declarações var a:vetor [1.5] de inteiro c: vetor [1.i: inteiro a: vetor [1. ") fimse fimpara fimalgoritmo 4algoritmo "vetor_exercicio_2" // Função : // Autor : // Data : 01/11/2011 // Seção de Declarações var k.j.5] de inteiro x. crei um terceiro vetor (C) que recebe a soma dos elementos correspondentes em A e B escreva("Leia o vetor a: ") para i de 1 ate 5 faca leia (a [i]) fimpara escreva("Leia o vetor b: ") para j de 1 ate 5 faca leia (b [j]) fimpara escreva("Gerar vetor c: ") para k de 1 ate 5 faca c[k] <.i:inteiro inicio .. Em seguida.

0 maior<-9999 menor<-9999 para i de 1 ate 5 faca se (a [i] < maior)entao maior <.i. cont1. com seus respctivos tempos.. i) fimse fimpara para i de 1 ate 5 faca se (a [i] % x = 0)entao escreva ("Multiplo de x na posicao". ordenada pela colocação na corrida. Em seguida imprima a l ista // participantes. i) fimse fimpara igual <.a [i] fimse fimalgoritmo 6algoritmo "semnome" // Função : // Autor : // Data : 08/11/2011 // Seção de Declarações var inicio // Faça um program para ler o tempo e nome de N candidatos.k.h: inteiro a: vetor [1. fimalgoritmo 7algoritmo "vetor_exercicio_2" // Função : // Autor : // Data : 01/11/2011 // Seção de Declarações var cont.i"]: " ) leia (a [i]) escreva ("Digite o valor de x: ") leia (x) para e de 1 ate 5 faca se (a [i]=x)entao escreval ("Achou na posição".// Seção de Comandos para i de 1 ate 5 faca escreva ("Digite o valor de a [".a [i] fimse se (a [i] < menor)entao menor <.5] de inteiro .j.

i:inteiro qtd_mulher.somaf.maior_a..1 para k de 1 ate 5 faca c [h] <.h +1 c [h] <.menor_a. ". crei um terceiro vetor (C) que recebe a soma dos elementos correspondentes em A e B escreval("Leia o vetor a: ") para i de 1 ate 5 faca leia (a [i]) fimpara escreval("Leia o vetor b: ") para j de 1 ate 5 faca leia (b [j]) fimpara h <. ") fimpara fimalgoritmo algoritmo "Lista_repeticao_questao60" // Função : // Autor : // Data : 22/11/2011 // Seção de Declarações var inicio // Calcule o imposto de renda de 10 contribuinte.5] de inteiro c: vetor [1.b: vetor [1. considerando que os dados: CPF .soma_a.f.somam.(a [k]) h <. fimalgoritmo algoritmo "lista_repet_quest56" // Função : // Autor : // Data : 22/11/2011 // Seção de Declarações var m. //Os valores da alíquota para o cálculo do imposto são: //renda liquida aliquota //ate 2 salarios insento //2 a 3 salario 5% //3 a 5 salario 10% // 5 a 7 salario 15% //acima de 7 salario 20% //por fim imprima o cpf e o imposto de renda de cada contribuinte.10] de inteiro inicio // Leia dois vetores A e B.. mediaf. Para cada contribuinte será feito um desconto do sálario mínimo por dependente.media_a. número de dependentes //e renda mensal.b[k] escreval (c [h]. Em seguida.media:real .

A maior e a menor altura da turma.2 para i de 1 ate 5 faca escreva ("Informe sexo: ") leia (sexo [i]) se (sexo [i] = 2)entao f <.f + 1 somaf <. media_a) escreval ("A media de altura das mulheres é: ".0 para i de 1 ate 5 faca escreva ("Informe alturas: ") leia (altura [i]) se (altura [i] > maior_a)entao maior_a <.. mediaf) fimalgoritmo .(soma_a / i) fimpara f <.(soma_a + altura [i]) media_a <.somaf + 1 fimse fimpara mediaf <.menor_a) escreval ("A media das altura é: ".0 media_a <.5] de inteiro inicio // Leia um conjunto de 10 fichas. Em seguida.0 qtd_mulher <. // -A média de alturas das mulheres.5] de real sexo: vetor [1.. maior_a <.altura [i] fimse soma_a <.altura [i] fimse se (altura [i] < menor_a)entao menor_a <. cada uma contendo a altura e o código do sexo // de uma pessoa (código = 1 se for masculino e 2 se for feminino).9999 soma_a <.altura: vetor [1.maior_a) escreval ("A menor altura é: ".somaf/f escreval("A maior altura é: ".-9999 menor_a <. ca lcule e imprima // . //-A média de altura da turma.

troque o primeiro elemento com o último. Caso o elemento não esteja no vetor. apresent e uma mensagem informando tal situação.com algoritmo "Troca Valores" var A: vetor[1. Se estiver. Tiago Eugenio de Melo // Data: 04. Em seguida. " ") fimpara para i de 1 ate 10 faca aux<-A[i] A[i]<-A[21-i] A[21-i]<-aux fimpara escreval("") para i de 1 ate 20 faca escreva(A[i]. " ") fimpara fimalgoritmo Escreva um algoritmo que leia um vetor com 10 posições de números inteiros e verifiqu e se um determinado valor.20] de inteiro i.. aux: inteiro inicio para i de 1 ate 20 faca leia (A[i]) fimpara para i de 1 ate 20 faca escreva(A[i]. // Autor: Prof.07. está no vetor. o segundo com o penúltimo. também digitado pelo usuário. o terceiro com o antep enúltimo e assim sucessivamente.2011 // Contato: tiagodemelo@gmail. Mostre o novo vetor depois da troca. in forme a posição desse elemento no vetor. .lista encontrada Escreva um algoritmo que leia um vetor de 20 posições e mostre-o.

com algoritmo "Buscar elemento" var v: vetor [1.2011 // Contato: tiagodemelo@gmail.10] de inteiro i.06.verdadeiro fimse fimpara se (achou=falso) entao escreval ("O valor "..// Autor: Prof. " não está no vetor.") achou <. " está no vetor na posição". Tiago Eugenio de Melo // Data: 29.") fimse fimalgoritmo . x. i. x. ". x: inteiro achou: logico inicio achou<-falso para i de 1 ate 10 faca leia (v[i]) fimpara leia(x) para i de 1 ate 10 faca se (x=v[i]) entao escreval("O valor ".