Você está na página 1de 6

TRANSIO DE VISUALG PARA C

Ol caro(a) aluno(a), tudo bem? Neste material relaciono os principais comandos do Visualg e seus equivalentes na linguagem C, quando isso for possvel. Voc perceber que C tem mais recursos que Visualg, pois esta uma ferramenta didtica para o aprendizado de programao. Espero que este material te ajude na passagem de Visualg para C. Faa bom proveito!

ESTRUTURA BSICA DE UM PROGRAMA


Visualg algoritmo Exemplo var // variveis inicio ... seu cdigo ... fimalgoritmo ...seu cdigo... return 0; } C /* comentario */ #include ... int main(void){ int main(){ ...seu cdigo... } C (outra opo) /* comentario */ #include ...

INCLUSO DE BIBLIOTECAS
Visualg No faz uso Chamada biblioteca padro biblioteca do usurio no subdiretrio de trabalho C #include < stdio.h > #include "agua.i"

DELIMITADORES
Visualg // No faz uso , <inicio ... fimalgoritmo ( ... ) Funo delimitadores de comentrio separar comandos e terminar declaraes separar identificadores e parmetros atribuio de valor delimita blocos de instrues delimita teste de condio C /* */ ou // ; , = { ... } ( ... )

OPERADORES DE COMPARAO
Visualg = <> < > <= >= Funo termo esquerda igual ao termo direita termo esquerda diferente do termo direita menor maior menor ou igual maior ou igual C == != < > <= >=

DECLARAES
Visualg var const no faz uso no faz uso Funo declarao de variveis declarao de constantes declarao de estruturas ou tipos definio de estruturas ou tipos C no incio de cada bloco #define struct enum

TIPOS DE DADOS NUMRICOS


Visualg inteiro Inteiros (faixa de abrangncia) -128 a +127 -32.768 a +32.767 -2.147.483.648 a +2.147.483.647 C char int long

TIPOS DE DADOS NUMRICOS


Visualg real Nmeros de Ponto Flutuante (faixa de abrangncia) 3,4*10(-38) a 3,4*10(38) (6 dgitos significativos) (C) 1,7*10(-308) a 1,7*10(308) (10-15 dgitos significativos) (C) 1,7*10(-308) a 1,7*10(308) (18 dgitos significativos) (C) C float double long double

TIPOS DE DADOS ALFANUMRICOS


Visualg caractere caractere Funo um caracter corrente de caracteres 2 C char char

FORMATO PARA AS VARIVEIS


Visualg Funo C (printf() e scanf() ) "%c"(caracter) "%s"(string) "%i"ou "%d" (inteiro) "%ld" (long) "%f" (float) "%lf"(double)

no h

declarao de formato de variveis

COMANDOS MAIS FREQUENTES


Visualg leia escreva limpatela inicio (instrues) fimalgoritmo Funo l um ou mais valores do usurio para uma ou mais variveis imprime na tela as informaes passadas como parmetros limpa a tela corrente, ou seja, o cursor movido para o canto superior esquerdo da tela bloco de instrues C scanf( ); printf( ); clrscr( ); int main(void){ (instrues); }

COMANDOS DE LAOS E DECISO


Visualg para k de 1 ate 10 faca (instrues) fimpara for executa um comando repetidamente, indicando um aumento ou diminuio na varivel de controle C for (k=0 ;k<=n-1; k++){ (instrues); }

Visualg se (condio) entao (instrues 1) senao (instrues 2) fimse

if testa uma condio e se ela for verdadeira, executa o comando subordinado ao entao, caso contrrio executa o comando subordinado ao senao

C if (condio){ (instrues 1); } else{ (instrues 2); }

Visualg enquanto (condio) faca (instrues) fimenquanto

while repete uma srie de comandos at a condio tornar-se falsa

C while (condio){ (instrues); }

Visualg repita (instrues 1) at(condio)

do repete uma srie de comandos at a condio tornar-se falsa ( diferente do comando anterior pois executa pelo menos uma vez) switch

C do{ (instrues); } while (condio);

Visualg

C switch (escolha){ case opo: (instrues 1); break; case opo: (instrues 2); break; case opo: (instrues 3); break; default: msg_erro( ); }

escolha (opo) caso opo (instrues 1) caso opo (instrues 2) outrocaso (instrues 3) fimescolha

seleciona uma de vrias aes, dependendo do resultado de um teste

OPERADORES ARITMTICOS
Visualg + * / mod ou % Funo adio subtrao multiplicao diviso resto da diviso expresso como inteiro (mdulo) C + * / %

OPERADORES LGICOS
Consideraes sobre Verdadeiro ou Falso Visualg C VERDADEIRO FALSO Visualg verdadeiro (1) falso (0)

(()E())

(()E()) C ( (1) e (1) ) da (1) ( (1) e (0) ) da (0) ( (0) e (1) ) da (0) ( (0) e (0) ) da (0) ( ( ) && ( ) ) Caso as expresses sejam verdadeiras retorna 1. Caso a expresso esquerda seja falsa (0) no avalia a segunda parte e retorna 0. ( ( ) OU ( ) ) ( (1) ou (1) ) da (1) ( (1) ou (0) ) da (1) ( (0) ou (1) ) da (1) ( (0) ou (0) ) da (0) Caso uma das expresses seja verdadeira retorna 1. Se a expresso esquerda for verdadeira retorna 1 e no avalia a segunda parte, caso contrrio retorna 0. C

Visualg

( ( ) OU ( ) )

( ( ) || ( ) )

APONTADORES
Visualg Funo dado referncia ao dado na memria C *nome &nome

EXEMPLO SIMPLES
Visualg
algoritmo "Exemplo" var n1, n2, prod: real inicio // leitura de dados escreval("Digite o primeiro nmero: ") leia(n1) escreval("Digite o segundo nmero: ") leia(n2) // processamento prod <- n1 * n2 // impresso do resultado escreval("O produto dos nmeros : ", prod) fimalgoritmo /* programa Exemplo */ #include < stdio.h > int main(void){ float n1, n2, prod; // leitura de dados printf(\nDigite o primeiro numero: ); scanf(%d, &n1); printf(\nDigite o segundo numero: ); scanf(%d, &n2); // processamento prod = n1 * n2; // impresso do resultado printf(\nO produto dos nmeros: %d\n, prod ); return 0; }