Você está na página 1de 7

IPv6 RIPng Over Frame Relay

Configuration

IPv6 RIPng RIP FrameRelay

R1,R2,R3 RIPng

R1

!
hostname R1
!
ipv6 unicast-routing
!
interface loopback0
ipv6 address 2001:1:1::1/64
ipv6 rip R1RIP enable
!
interface Serial3/0
no ip address
encapsulation frame-relay
ipv6 address 2001:100::1/64
ipv6 enable
frame map ipv6 2001:100::2 102 broadcast
frame map ipv6 2001:100::3 103 broadcast
serial restart-delay 0
!
ipv6 router rip R1RIP
!

R2
!
hostname R2
!
ipv6 unicast-routing
!
interface loopback0
ipv6 address 2001:1:1::2/64
ipv6 rip R2RIP enable
!
interface Serial3/0
no ip address
encapsulation frame-relay
ipv6 address 2001:100::2/64
ipv6 enable
frame map ipv6 2001:100::1 101 broadcast
frame map ipv6 2001:100::3 103 broadcast
serial restart-delay 0
!
ipv6 router rip R2RIP
!

R3
!
hostname R3
!
ipv6 unicast-routing
!
interface loopback0
ipv6 address 2001:1:1::3/64
ipv6 rip R3RIP enable
!
interface Serial3/0
no ip address
encapsulation frame-relay
ipv6 address 2001:100::3/64
ipv6 enable
frame map ipv6 2001:100::1 101 broadcast
frame map ipv6 2001:100::2 102 broadcast
serial restart-delay 0
!
ipv6 router rip R3RIP
!

R2
R1
R1#show ipv rip
RIP process "cisco", port 521, multicast-group FF02::9, pid 131
Administrative distance is 120. Maximum paths is 16
Updates every 30 seconds, expire after 180
Holddown lasts 0 seconds, garbage collect after 120
Split horizon is on; poison reverse is off
Default routes are not generated
Periodic updates 4, trigger updates 3
Interfaces:
Serial3/0
Loopback0
Redistribution:

None
R1#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C 2001:1:1::/64 [0/0]
via ::, Loopback0
L 2001:1:1::1/128 [0/0]
via ::, Loopback0
R 2001:2:2::/64 [120/2]
via FE80::C838:2FF:FEC8:0, Serial3/0
R 2001:3:3::/64 [120/2]
via FE80::C839:FFF:FE84:0, Serial3/0
C 2001:100::/64 [0/0]
via ::, Serial3/0
L 2001:100::1/128 [0/0]
via ::, Serial3/0
L FE80::/10 [0/0]
via ::, Null0
L FF00::/8 [0/0]
via ::, Null0
R1#show ipv6 rip database
RIP process "cisco", local RIB
2001:2:2::/64, metric 2, installed
Serial3/0/FE80::C838:2FF:FEC8:0, expires in 168 secs
2001:3:3::/64, metric 2, installed
Serial3/0/FE80::C839:FFF:FE84:0, expires in 161 secs
2001:100::/64, metric 2
Serial3/0/FE80::C839:FFF:FE84:0, expires in 161 secs
Serial3/0/FE80::C838:2FF:FEC8:0, expires in 168 secs
R1#show ipv6 rip next-hops
RIP process "cisco", Next Hops
FE80::C838:2FF:FEC8:0/Serial3/0 [2 paths]
FE80::C839:FFF:FE84:0/Serial3/0 [2 paths]
debug ipv6 rip RIPng
R1#debug ipv6 rip

RIP Routing Protocol debugging is on


R1#
*Feb 4 11:36:02.559: RIPng: response received from FE80::C838:2FF:FEC8:0 on
Serial3/0 for cisco
*Feb 4 11:36:02.563: src=FE80::C838:2FF:FEC8:0 (Serial3/0)
*Feb 4 11:36:02.563: dst=FF02::9
*Feb 4 11:36:02.563: sport=521, dport=521, length=52
*Feb 4 11:36:02.567: command=2, version=1, mbz=0, #rte=2
*Feb 4 11:36:02.567: tag=0, metric=1, prefix=2001:2:2::/64
*Feb 4 11:36:02.571: tag=0, metric=1, prefix=2001:100::/64
R1#
*Feb 4 11:36:09.035: RIPng: Sending multicast update on Serial3/0 for cisco
*Feb 4 11:36:09.035: src=FE80::C837:9FF:FEB4:0
*Feb 4 11:36:09.039: dst=FF02::9 (Serial3/0)
*Feb 4 11:36:09.039: sport=521, dport=521, length=52
*Feb 4 11:36:09.039: command=2, version=1, mbz=0, #rte=2
*Feb 4 11:36:09.043: tag=0, metric=1, prefix=2001:1:1::/64
*Feb 4 11:36:09.043: tag=0, metric=1, prefix=2001:100::/64
*Feb 4 11:36:09.043: RIPng: Sending multicast update on Loopback0 for cisco
*Feb 4 11:36:09.043: src=FE80::C837:9FF:FEB4:0
*Feb 4 11:36:09.043: dst=FF02::9 (Loopback0)
R1#
*Feb 4 11:36:09.043: sport=521, dport=521, length=92
*Feb 4 11:36:09.043: command=2, version=1, mbz=0, #rte=4
*Feb 4 11:36:09.043: tag=0, metric=1, prefix=2001:1:1::/64
*Feb 4 11:36:09.043: tag=0, metric=2, prefix=2001:2:2::/64
*Feb 4 11:36:09.043: tag=0, metric=2, prefix=2001:3:3::/64
*Feb 4 11:36:09.043: tag=0, metric=1, prefix=2001:100::/64
*Feb 4 11:36:09.043: RIPng: Process cisco received own response on Loopback0
R1#
R1 Ping RIpng ping
R1#ping 2001:2:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2::1, timeout is 2 seconds:
*Feb 4 11:38:53.335: ICMPv6: Sending echo request to 2001:2:2::1.
*Feb 4 11:38:55.339: ICMPv6: Sending echo request to 2001:2:2::1.
*Feb 4 11:38:57.343: ICMPv6: Sending echo request to 2001:2:2::1.

show ipv route


R 2001:2:2::/64 [120/2]
via FE80::C838:2FF:FEC8:0, Serial3/0
R 2001:3:3::/64 [120/2]
via FE80::C839:FFF:FE84:0, Serial3/0

R1(config-if)#frame map ipv6 FE80::C838:2FF:FEC8:0 102 b


R1(config-if)#frame map ipv6 FE80::C839:FFF:FE84:0 103 b

Serial3/0 (up): ipv6 FE80::C838:2FF:FEC8:0 dlci 102(0x66,0x1860),


static,
broadcast,
CISCO, status defined, active
Serial3/0 (up): ipv6 FE80::C839:FFF:FE84:0 dlci 103(0x67,0x1870),
static,
broadcast,
CISCO, status defined, active
Serial3/0 (up): ipv6 2001:100::2 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
Serial3/0 (up): ipv6 2001:100::3 dlci 103(0x67,0x1870), static,
broadcast,
CISCO, status defined, active
ping RipNG ping

R1#ping 2001:2:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/100/200 ms
R1#
*Feb 4 11:41:13.327: ICMPv6: Sending echo request to 2001:2:2::1
*Feb 4 11:41:13.527: ICMPv6: Received ICMPv6 packet from 2001:2:2::1, type
129
*Feb 4 11:41:13.527: ICMPv6: Received echo reply from 2001:2:2::1

*Feb
*Feb
129
*Feb
*Feb
*Feb
129
*Feb
R1#
*Feb
*Feb
129
*Feb
*Feb
*Feb
129
*Feb

4 11:41:13.531: ICMPv6: Sending echo request to 2001:2:2::1


4 11:41:13.635: ICMPv6: Received ICMPv6 packet from 2001:2:2::1, type
4 11:41:13.635: ICMPv6: Received echo reply from 2001:2:2::1
4 11:41:13.639: ICMPv6: Sending echo request to 2001:2:2::1
4 11:41:13.679: ICMPv6: Received ICMPv6 packet from 2001:2:2::1, type
4 11:41:13.679: ICMPv6: Received echo reply from 2001:2:2::1
4 11:41:13.683: ICMPv6: Sending echo request to 2001:2:2::1
4 11:41:13.755: ICMPv6: Received ICMPv6 packet from 2001:2:2::1, type
4 11:41:13.755: ICMPv6: Received echo reply from 2001:2:2::1
4 11:41:13.759: ICMPv6: Sending echo request to 2001:2:2::1
4 11:41:13.839: ICMPv6: Received ICMPv6 packet from 2001:2:2::1, type
4 11:41:13.839: ICMPv6: Received echo reply from 2001:2:2::1

R2,R3

Cisco IOS IPv6 Configuration Library