Você está na página 1de 16

FACULDADE ANHANGUERA DE RONDONPOLIS

Av. Ary Coelho, n 829 Cidade Salmen Rondonpolis MT


CEP 78705-050 (66) 3411-7600

ATPS ATIVIDADES PRTICAS SUPERVISIONADAS


DESENVOLVIMENTO ETAPA 2

RONDONPOLIS MT
2011

NOME COMPLETO - RA: Patricia Pereira Moura - 2505073301


NOME COMPLETO - RA: Thiago Lima Duarte - 2504023778
NOME COMPLETO - RA: Bruno Henrique Soares de Freitas - 2504007356
NOME COMPLETO - RA: Gustavo Schneider - 1107307561

CURSO SISTEMAS DE INFORMAO


2 Bimestre

ATPS ATIVIDADES PRTICAS SUPERVISIONADAS

Trabalho desenvolvido durante a Etapa 2 na disciplina


de Construo de Algoritmo 1 semestre do Curso de
Sistemas de Informao, Anhanguera Educacional
Rondonpolis/MT como parte da avaliao da
disciplina.
Prof. Rafael Rodrigues Garcia

RONDONPOLIS - MT

2011

SUMRIO
1- Etapa 2................................................................................................................................03
1.1. Passo 1..........................................................................................................................03
1.2. Passo 2..........................................................................................................................06
1.3. Passo 3..........................................................................................................................10

1. Etapa 2
Desenvolvimento de algoritmos: anlise e resoluo de problemas, tcnicas top-down.
Estruturas de controle: seleo. Estruturas de controle: Iterao.
1.1. Passo 1
Nessa nova etapa do desafio ser considerada uma nova solicitao do diretor da
agncia de turismo: que o aplicativo faa converses de no s para o Real, mas da moeda y
para a moeda x, sendo x e y uma das moedas j definidas e que sero indicadas pelo usurio. Ou
seja, o usurio escolher uma das opes para indicar qual a moeda base e para qual deseja
verificar a converso. Por exemplo: N Reais equivalem a M Euros Reais a moeda base e
Euros a moeda que se deseja saber a converso.
Para realizao desse aplicativo tivemos que aplica no algoritmo uma estrutura de
escolha, onde o usurio escolhe o que gostaria de fazer e o algoritmo faz o processo de
comparao para realizao da converso exata. Pseudocdigo do algoritmo, abaixo:
var
moeda_real, dolar, dolar_cnd, real_dolcnd,
euro, real_euro, dolar_dolcnd, dolar_euro,
dolar_real, dolcnd_dolar, dolcnd_euro,
dolcnd_real, euro_dolar, euro_dolcnd,
euro_real, comer,parale, turis, dolar2,
dolar3, res1,res2:real
escolha1, escolha2:inteiro

escreval
("------------------------------------------------------------------")
escreval ("Deseja Converter qual moeda ?")
escreval ("Pressione: 1 - Real, 2 - Dolar, 3 Dolar Canadense, 4 - Euro")
leia(escolha1)
escreval
("------------------------------------------------------------------")

inicio
turis <- 1.52
real_dolcnd <- 0.60
real_euro <- 0.43
dolar_dolcnd <- 0.97
dolar_euro<- 0.70
dolar_real<- 0.62
dolcnd_dolar <- 1.03
dolcnd_euro<- 0.72
dolcnd_real <- 1.66
euro_dolar <- 1.43
euro_dolcnd <- 1.38
euro_real<-2.31
escreval ("Convesor de Moedas")

se (escolha1=1) entao
escreval ("Voce escolheu converter
Real.")
escreval ("Deseja Converter a moeda
Real para qual moeda ?")
escreva ("1 - Dolar, 2 - Dolar
Canadense, 3 - Euro: ")
leia (escolha2)
escreval
("------------------------------------------------------------------")
se (escolha2=1) entao
escreval("Voce decidiu converter da
moeda Real para Dolar.")
escreva("Insira o valor em Reais: ")
leia(moeda_real)

escreval
("------------------------------------------------------------------")
dolar <- moeda_real / turis
escreval ("Valor em Dolar Turismo:
",dolar :4:2)
senao
fimse
se (escolha2=2) entao
escreval("Voce decidiu converter da
moeda Real para Dolar Canadense.")
escreva("Insira o valor em Reais: ")
leia(moeda_real)
escreval
("------------------------------------------------------------------")
dolar_cnd <- moeda_real *real_dolcnd
escreval ("Valor em Dolar Canadense:
",dolar_cnd)
escreval
("------------------------------------------------------------------")
senao
fimse
se (escolha2=3)entao
escreval("Voce decidiu converter da
moeda Real para Euro.")
escreva("Insira o valor em Reais: ")
leia(moeda_real)
escreval
("------------------------------------------------------------------")
euro <- moeda_real * real_euro
escreval ("Valor em Euro: ",euro)
escreval
("------------------------------------------------------------------")
senao
fimse
senao
fimse
se(escolha1=2)entao
escreval("Voc escolheu converter em
Dolar.")
escreval("Deseja converter a moeda
Dolar para qual moeda ?")
escreva("Pressione: 1 - Dolar
Canadense, 2 - Euro, 3 - Real: ")
leia(escolha2)

escreval
("------------------------------------------------------------------")
se (escolha2=1)entao
escreval("Voce decidiu converter da
moeda Dolar para Dolar Canadense.")
escreva("Insira o valor em Dolares: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
dolar_cnd <- dolar * dolar_dolcnd
escreval("Valor em Dolar
Canadense",dolar_cnd)
escreval
("------------------------------------------------------------------")
senao
fimse
se (escolha2=2)entao
escreval("Voce decidiu converter da
moeda Dolar para Euro.")
escreva("Insira o valor em Dolares: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
euro <- dolar * dolar_euro
escreval("Valor em Euro: ",euro)
escreval
("------------------------------------------------------------------")
senao
fimse
se (escolha2=3)entao
escreval("Voc decidiu converter da
moeda Dolar para a moeda Real.")
escreva("Insira o valor em Dolares: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
moeda_real <- dolar * dolar_real
escreval("Valor em Reais:
",moeda_real)
escreval
("------------------------------------------------------------------")

senao
fimse
senao
fimse
se(escolha1=3)entao
escreval("Voc escolheu converter em
Dolar Canadense.")
escreval("Deseja converter a moeda
Dolar Canadense para qual moeda ?")
escreva("Pressione: 1 - Dolar, 2 - Euro,
3 - Real: ")
leia(escolha2)
escreval
("------------------------------------------------------------------")
se (escolha2=1)entao
escreval("Voce decidiu converter da
moeda Dolar Canadense para Dolar.")
escreva("Insira o valor em Dolares
Canadense: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
dolar<- dolar * dolcnd_dolar
escreval("Valor em Dolar: ",dolar)
escreval
("------------------------------------------------------------------")
senao
fimse
se (escolha2=2)entao
escreval("Voce decidiu converter da
moeda Dolares Canadense para Euro.")
escreva("Insira o valor em Dolares
Canadense: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
euro <- dolar * dolcnd_euro
escreval("Valor em Euro: ",euro)
escreval
("------------------------------------------------------------------")
senao
fimse

se (escolha2=3)entao
escreval("Voc decidiu converter da
moeda Dolares Canadense para a moeda
Real.")
escreva("Insira o valor em Dolares
Canadense: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
moeda_real <- dolar * dolcnd_real
escreval("Valor em Reais:
",moeda_real)
escreval
("------------------------------------------------------------------")
senao
fimse
senao
fimse
se (escolha1=4)entao
escreval("Voce escolheu converter
Euro.")
escreval("Deseja Converter a moeda
Euro para qual moeda ?")
escreva("Pressione: 1 - Dolar, 2 Dolar Canadense, 3 - Real: ")
leia(escolha2)
escreval
("------------------------------------------------------------------")
se(escolha2=1)entao
escreval("Voce decidiu converter da
moeda Euro para a moeda Dolar.")
escreva("Insira o valor em Euro: ")
leia(euro)
escreval
("------------------------------------------------------------------")
dolar <- euro * euro_dolar
escreval("Esse valor em Dolar: ",dolar)
escreval
("------------------------------------------------------------------")
senao
fimse

se(escolha2=2)entao
escreval("Voce decidiu converter da
moeda Euro para a moeda Dolar
Canadense.")
escreva("Insira o valor em Euro: ")
leia(euro)
escreval
("------------------------------------------------------------------")
dolar_cnd <- euro * euro_dolcnd
escreval("Valor em Dolar Canadense:
",dolar_cnd)
escreval
("------------------------------------------------------------------")
senao
fimse

se(escolha2=3)entao
escreval("Voce decidiu converter da
moeda Euro para a moed Real.")
escreva("Insira o valor em Euro: ")
leia(euro)
escreval
("------------------------------------------------------------------")
moeda_real <- euro * euro_real
escreval("Valor em Real:
",moeda_real)
escreval
("------------------------------------------------------------------")
senao
fimse
fimse
fimalgoritmo

1.2. Passo 2
Outra nova solicitao feita pelo diretor que ao realizar a solicitao
de converso para Dlar Americano o aplicativo mostre o resultado para
Turismo, Comercial e Paralelo, pois muitas vezes o usurio que cliente da
agncia quer analisar converses de valores gastos em carto de crdito. A
apresentao da converso dever ser seguida da diferena em percentual
entre o menor valor do Dlar Americano para os demais. Por exemplo, se o
Dlar Americano Comercial estiver com cotao inferior, ento dever ser
apresentada a diferena percentual do Comercial com o Turismo e do
Comercial com o Paralelo.
Nessa melhoria na converso apenas foi inserido uma estrutura que
determina qual o menor pela comparao entre eles e fazer o calculo.
Pseudocdigo, abaixo:
var
moeda_real, dolar, dolar_cnd,
real_dolcnd, euro, real_euro, dolar_dolcnd,
dolar_euro, dolar_real, dolcnd_dolar,
dolcnd_euro, dolcnd_real, euro_dolar,
euro_dolcnd, euro_real, comer,parale, turis,
dolar2, dolar3, res1,res2:real
escolha1, escolha2:inteiro
inicio
turis <- 1.52
real_dolcnd <- 0.60

real_euro <- 0.43


dolar_dolcnd <- 0.97
dolar_euro<- 0.70
dolar_real<- 0.62
dolcnd_dolar <- 1.03
dolcnd_euro<- 0.72
dolcnd_real <- 1.66
euro_dolar <- 1.43
euro_dolcnd <- 1.38
euro_real<-2.31
parale<-1.70
comer<- 1.56

escreval ("Convesor de Moedas")


escreval
("------------------------------------------------------------------")
escreval ("Deseja Converter qual
moeda ?")
escreval ("Pressione: 1 - Real, 2 Dolar, 3 - Dolar Canadense, 4 - Euro")
leia(escolha1)
escreval
("------------------------------------------------------------------")
se (escolha1=1) entao
escreval ("Voce escolheu
converter Real.")
escreval ("Deseja Converter a
moeda Real para qual moeda ?")
escreva ("1 - Dolar, 2 - Dolar
Canadense, 3 - Euro: ")
leia (escolha2)
escreval
("------------------------------------------------------------------")
se (escolha2=1) entao
escreval("Voce decidiu
converter da moeda Real para Dolar.")
escreva("Insira o valor em
Reais: ")
leia(moeda_real)
escreval
("------------------------------------------------------------------")
dolar <- moeda_real / turis
dolar2<- moeda_real / comer
dolar3<- moeda_real / parale
escreval ("Valor em Dolar
Turismo: ",dolar :4:2)
escreval ("Valor em Dolar
Comercial: ",dolar2 :4:2)
escreval ("Valor em Dolar
Paralelo: ",dolar3 :4:2)
escreval
("------------------------------------------------------------------")
se (turis < comer) e (turis <
parale) entao
res1 <- ((comerturis)/turis)*100

res2 <- ((paraleturis)/turis)*100


escreval ("Menor Cotao foi
Dolar Turismo: ", turis)
escreval ("Diferena do
Comercial: ", res1 :2:2, "%" )
escreval ("Diferena do
Paralelo: ", res2 :2:2, "%" )
escreval
("------------------------------------------------------------------")
senao
se (comer < turis) e
(comer<parale) entao
res1 <- ((turiscomer)/comer)*100
res2 <- ((paralecomer)/comer)*100
escreval ("Menor Cotao foi
Dolar Comercial: ", comer)
escreval ("Diferena do
Turismo: ", res1 :2:2, "%" )
escreval ("Diferena do
Paralelo: ", res2 :2:2, "%" )
escreval
("------------------------------------------------------------------")
senao
res1 <- ((turisparale)/parale)*100
res2 <- ((comerparale)/parale)*100
escreval ("Menor Cotao foi
Dolar Paralelo: ", parale)
escreval ("Diferena do
Turismo: ", res1 :2:2, "%" )
escreval ("Diferena do
Comercial: ", res2 :2:2, "%" )
escreval
("------------------------------------------------------------------")
fimse
fimse
senao
fimse
se (escolha2=2) entao
escreval("Voce decidiu
converter da moeda Real para Dolar
Canadense.")

escreva("Insira o valor em

escreva("Insira o valor em

Reais: ")

Dolares: ")

leia(moeda_real)
escreval
("------------------------------------------------------------------")
dolar_cnd <- moeda_real
*real_dolcnd
escreval ("Valor em Dolar
Canadense: ",dolar_cnd)
escreval
("------------------------------------------------------------------")
senao
fimse
se (escolha2=3)entao
escreval("Voce decidiu
converter da moeda Real para Euro.")
escreva("Insira o valor em
Reais: ")
leia(moeda_real)
escreval
("------------------------------------------------------------------")
euro <- moeda_real * real_euro
escreval ("Valor em Euro:
",euro)
escreval
("------------------------------------------------------------------")
senao
fimse
senao
fimse
se(escolha1=2)entao
escreval("Voc escolheu
converter em Dolar.")
escreval("Deseja converter a
moeda Dolar para qual moeda ?")
escreva("Pressione: 1 - Dolar
Canadense, 2 - Euro, 3 - Real: ")
leia(escolha2)
escreval
("------------------------------------------------------------------")
se (escolha2=1)entao
escreval("Voce decidiu
converter da moeda Dolar para Dolar
Canadense.")

leia(dolar)
escreval
("------------------------------------------------------------------")
dolar_cnd <- dolar *
dolar_dolcnd
escreval("Valor em Dolar
Canadense",dolar_cnd)
escreval
("------------------------------------------------------------------")
senao
fimse
se (escolha2=2)entao
escreval("Voce decidiu
converter da moeda Dolar para Euro.")
escreva("Insira o valor em
Dolares: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
euro <- dolar * dolar_euro
escreval("Valor em Euro:
",euro)
escreval
("------------------------------------------------------------------")
senao
fimse
se (escolha2=3)entao
escreval("Voc decidiu
converter da moeda Dolar para a moeda
Real.")
escreva("Insira o valor em
Dolares: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
moeda_real <- dolar *
dolar_real
escreval("Valor em Reais:
",moeda_real)

escreval
("------------------------------------------------------------------")
senao
fimse
senao
fimse
se(escolha1=3)entao
escreval("Voc escolheu
converter em Dolar Canadense.")
escreval("Deseja converter a
moeda Dolar Canadense para qual
moeda ?")
escreva("Pressione: 1 - Dolar, 2
- Euro, 3 - Real: ")
leia(escolha2)
escreval
("------------------------------------------------------------------")
se (escolha2=1)entao
escreval("Voce decidiu
converter da moeda Dolar Canadense para
Dolar.")
escreva("Insira o valor em
Dolares Canadense: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
dolar<- dolar * dolcnd_dolar
escreval("Valor em Dolar:
",dolar)
escreval
("------------------------------------------------------------------")
senao
fimse
se (escolha2=2)entao
escreval("Voce decidiu
converter da moeda Dolares Canadense
para Euro.")
escreva("Insira o valor em
Dolares Canadense: ")
leia(dolar)
escreval
("------------------------------------------------------------------")

euro <- dolar * dolcnd_euro


escreval("Valor em Euro:
",euro)
escreval
("------------------------------------------------------------------")
senao
fimse
se (escolha2=3)entao
escreval("Voc decidiu
converter da moeda Dolares Canadense
para a moeda Real.")
escreva("Insira o valor em
Dolares Canadense: ")
leia(dolar)
escreval
("------------------------------------------------------------------")
moeda_real <- dolar *
dolcnd_real
escreval("Valor em Reais:
",moeda_real)
escreval
("------------------------------------------------------------------")
senao
fimse
senao
fimse
se (escolha1=4)entao
escreval("Voce escolheu
converter Euro.")
escreval("Deseja Converter a
moeda Euro para qual moeda ?")
escreva("Pressione: 1 - Dolar, 2
- Dolar Canadense, 3 - Real: ")
leia(escolha2)
escreval
("------------------------------------------------------------------")
se(escolha2=1)entao
escreval("Voce decidiu
converter da moeda Euro para a moeda
Dolar.")
escreva("Insira o valor em
Euro: ")
leia(euro)

escreval
("------------------------------------------------------------------")
dolar <- euro * euro_dolar
escreval("Esse valor em Dolar:
",dolar)
escreval
("------------------------------------------------------------------")
senao
fimse
se(escolha2=2)entao
escreval("Voce decidiu
converter da moeda Euro para a moeda
Dolar Canadense.")
escreva("Insira o valor em
Euro: ")
leia(euro)
escreval
("------------------------------------------------------------------")
dolar_cnd <- euro *
euro_dolcnd
escreval("Valor em Dolar
Canadense: ",dolar_cnd)

escreval
("------------------------------------------------------------------")
senao
fimse
se(escolha2=3)entao
escreval("Voce decidiu
converter da moeda Euro para a moed
Real.")
escreva("Insira o valor em
Euro: ")
leia(euro)
escreval
("------------------------------------------------------------------")
moeda_real <- euro * euro_real
escreval("Valor em Real:
",moeda_real)
escreval
("------------------------------------------------------------------")
senao
fimse
fimse
fimalgoritmo

1.3. Passo 3
Exemplo 1
1-Vamos abiri o programa e selecionar a opo em que desejamos converter
neste exemplo vamos utilisar o real

2-Sendo assim apos digitarmos a tecla 1 e precinarmos enter iremos escolher em


qual moeda iremos converter o real neste exemplo usaremos o Dolar.

3-Agora iremos colocar o valor em Real que o programa ira converter para o dolar

4-Apos teclar enter o programa ira nos dizer o valor do Real em Dolar.

Exemplo 2
Escolhemos a moeda e sem seguida escolhemos em qual ela sera transformada

Entao digitamos o valor que desejamos converter.

E o programa ira nos dizer que 100 Euro sera 231 Reais.
Exemplo 3

Apos escolhermos a opo 3-Dolar Canadense+3-Real e o valor em Dolar


Canadensse o programa nos dara a resposta em reais que seria 166

Você também pode gostar