Você está na página 1de 10

Estrutura Condicional if else

Estrutura Condicional
Simples if <condio> di <instruo>;
a instruo ser executada se a expresso for verdadeira

Composta if <condio> <instruo 1 ; instruo 1>; else ; <instruo 2>;


a instruo 1 ser executada se a expresso for verdadeira, seno a instruo 2 ser executada

Estrutura if else if if <condio 1> di <instruo 1>; else if < di 2> l <condio <instruo 2>; else if <condio 3> <instruo 3>; else <instruo padro>;
uma instruo ser executada quando uma condio for verdadeira. A instruo padro opcional e s executada quando i l t d d todas as outras condies forem falsas

Estrutura Condicional Aninhada


Um condicional aninhado Um simplesmente um if dentro de outro if externo O nico cuidado que deve-se ter com a identificao de qual else pertence a determinado if O emprego de tcnicas de texto estruturado f ili d facilitam a correta identificao da estrutura condicional aninhada
if <condio 1> { if <condio 2> <instruo 1>; <i t 1> else <instruo 2>; } else { if <condio 3> <instruo 3>; else <instruo 4>; }

ESTRUTURA CONDICIONAL
Usando o Operador ? Este operador no atende a uma gama grande de casos, mas pode ser usado para simplificar expresses complicadas (ternrio) <condio> ? <expresso 1> : <expresso 2>; Exemplo: Com a expresso Posso simplificar para if (A > 0) B = -50; ; B = A > 0 ? -50 : 100; ; else B = 100; vrias podem ser as formas de se combinarem (aninharem) as estruturas condicionais, as demais sero abordadas no decorrer deste c rso curso

EXERCCIOS
Algoritmos ExercciosdeFixao EstruturadeControleSeqencial 1.Faaumalgoritmoquerecebaosalriobasedeum funcionrio,calculeemostreosalrioareceber,sabendose queessefuncionriotemgratificaode5%sobreosalrio que esse funcionrio tem gratificao de 5% sobre o salrio baseepagaimpostode7%sobreototal. 2.Faaumalgoritmoquerecebaoanodenascimentodeuma 2 Faa um algoritmo que receba o ano de nascimento de uma pessoaeoanoatual,calculeemostre: aidadedessapessoaquantosanoselaterem2005enoano a idade dessa pessoa quantos anos ela ter em 2005 e no ano corrente.

Continuao
Algoritmos Exerccios de Fixao
Estrutura de Controle Condicional (ou de Seleo) 3. Faa um algoritmo em pseudocdigo que calcule a mdia 3 F l it d di l l di ponderada de um aluno, a partir de suas 3 notas obtidas no curso, sabendo-se que a primeira avaliao tem peso 2, a segunda tem peso 4 e a terceira tem peso 4. Mostre, ao final, a mensagem : A MEDIA FINAL DE ... FOI ... . Informar tambm se o aluno foi aprovado, mostrando a mensagem APROVADO caso a nota final seja maior ou superior a 7,0. 4. Elabore um algoritmo usando notao de fluxogramas que verifique se um dado nmero inteiro positivo PAR ou MPAR MPAR. 5. Modifique o algoritmo da mdia do aluno para informar: APROVADO ............ caso a nota final esteja no intervalo [10, 7] RECUPERAO...... caso a nota final esteja no intervalo [5, 7) REPROVADO .......... caso a nota final esteja no intervalo [0, 5)

Continuao
Algoritmos Exerccios de Fixao
Estrutura de Controle Condicional (ou de Seleo) 6. Faa um algoritmo que l i 2 valores numricos e um smbolo. C 6 F l it leia l i b l Caso o smbolo seja um dos relacionados abaixo efetue a operao correspondente com os valores. Ateno para a diviso por 0! + operao de soma - operao de subtrao * operao de multiplicao / operao de diviso 7. Dados 3 valores A, B, C, verifique se podem ser valores de lados um tringulo (cada lado ser menor do que a soma dos outros dois) e, se for, determine se o tringulo equiltero, issceles ou escaleno. Calcule ainda a rea do tringulo sabendo que o semipermetro e tringulo, sp=(ll + l2 + l3)/2. rea=sqrt(sp*(sp-l1)*(sp-l2)*(sp-l3)). 8. Sejam 3 nmeros distintos A, B, C. Coloque-os em ordem crescente, utilizando seleo encadeada ( aninhada). tili d l d d (ou i h d )

Soluo
1. Soluo 1: salBase, salReceber, grat, salBase salReceber grat imp: real Inicio Leia(salBase) Grat salBase * 5/100 SalReceber salBase +grat imp Imp SalReceber * 7/100 SalReceber SalReceber imp Escreva ( lR E (salReceber) b ) Fim Soluo 2: salBase, salReceber, salBase salReceber Imp: real Inicio Leia(salBase) SalReceber (salBase * 5/100 ) Imp SalReceber * 7/100 SalReceber SalReceber imp Escreva (salReceber) Fim Fi

2. ano_atual, ano_nascimento, idade_atual, idade_2005: inteiro Inicio Leia (ano_nascimento, L i ( i t ano_atual) Idade_atual ano_atual ano_nascimento ano nascimento Idade_2005 2005 ano_nascimento Escreva (idade atual) (idade_atual) Escreva (idade_2005)

3. aluno:caracter; nota1,nota2,nota3,media:real; p ,p ,p p1,p2,p3:inteiro; ; Inicio p1 2; p2 p2 4; p3 4; Leia(aluno); Leia(nota1,nota2,nota3); Leia (nota1 nota2 nota3); media (nota1*p1+nota2*p2+nota3*p3)/10 Escreva(amediade,aluno,foi,media); Se(media>=7,0)ento S ( di 7 0) Escreva(aprovado); Fimse Fim

5. aluno:caracter; aluno: caracter; nota1,nota2,nota3,media:real; Inicio Leia(aluno); L i ( l ) Leia(nota1,nota2,nota3); media (nota1*0.2+nota2*0.4+nota3*0.4 Escreva(amediade,aluno,foi,media); Se(media>=7,0)ento Escreva(aprovado); seno Se(media<7,0emedia>=5,0)ento Escreva( recuperao ); Escreva (recuperao); seno Escreva(reprovado); Fimse; Fim se; Fimse; Fim