Você está na página 1de 50

Nvel Intermedirio

Capacitao Contax
Planejamento Estudos e Anlises

Agenda Introduo Excel - Ferramenta Aplicabilidade Geral Ferramenta Demonstrativo Conceitos e Funcionalidades Operaes Matemticas Facilidades e Atalhos Grficos Filtros Formataes Vnculos Configuraes Frmulas Testes de Hipteses Introduo ao VBA Visual Basic Visual Basic Funes
Nvel Intermedirio

Funes
Toda funo retorna um valor especfico; Para reconhecimento do Excel as funes sempre comeam com o sinal de igual (=); Cada argumento separado por ponto-e-vrgula (;); Para identificarmos um intervalo de clulas utilizamos os dois pontos (:);

Nvel Intermedirio

No Excel podemos utilizar todos os operadores aritmticos para criar frmulas que resultaro em outros valores.

=5^3

125

Frmula
Frmula um DADO que resulta em um VALOR.

Valor

Funes utilizando referncias de clulas


Uma outra forma de desenvolvermos um calculo utilizar clulas como referncia e no um dado constante.

Nvel Intermedirio

No ser necessrio alterar a frmula caso os valores mudem.


=B5+B6+B7

Quando utilizamos uma variedade de operadores aritmticos o Excel segue uma seqncia de prioridades: 1. Parnteses; 2. Exponenciao; 3. Multiplicao ou diviso; 4. Soma ou subtrao.

Funo SOMA e MDIA


Duas funes simples, porm, de grande utilidade.

Nvel Intermedirio

=SOMA(clula x : clula y)

=MDIA(clula x : clula y)

Informando o intervalo de clulas que queremos somar o Excel automaticamente no apresenta esse valor.

O mesmo procedimento da soma foi utilizado para a mdia, porm, trocando a palavra de referncia.

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Funes MINMO E MXIMO


=MXIMO(clula x : clula y)
Nvel Intermedirio

Neste exemplo estamos buscando o Dia de Maior Movimento (DMM). =MXIMO. Para encontrar o menor valor, necessrio utilizar: =MNIMO.

Funes HOJE, AGORA e CONT. VALORES

Nvel Intermedirio

=HOJE()

Com a funo HOJE, ns temos a atualizao automtica da data em nossa planilha. Com a funo AGORA, ns temos a atualizao automtica da data junto com o horrio.

=AGORA() =CONT.VALORES()

O CONT.VALORES faz contagem de clulas que no esto vazias.

Funo SE
A funo SE utilizada quando existe a necessidade de apresentar um valor de acordo com dada condio caso seja verdadeira e outro valor caso seja falsa. Para essa funo utilizamos com freqncia os seguintes operadores:

Nvel Intermedirio

= igual a; <> diferente de; > maior que; >= maior ou igual a; < menor que; <= menor ou igual a.
Sintaxe:

=SE (Teste_lgico; Valor_se_verdadeiro; Valor_se_falso)


Condio para que seja apresentado o valor verdadeiro. Resultado que ser exibido caso o teste lgico seja verdadeiro. Resultado que ser exibido caso o teste lgico seja falso.

Funo SE

=SE(teste_lgico ; valor_se_verdadeiro] ; [valor_se_falso])

Nvel Intermedirio

SE A mdia for maior ou igual a 3% ento mostre Crtico seno mostre normal.

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Funes com E e OU
Podemos inserir condies em um teste lgico utilizando o conector E ou OU.
Onde quando o E inserido, obrigatoriamente as duas condies precisam ser satisfeitas para retornar o resultado VERDADEIRO.

Nvel Intermedirio

Quando o OU inserido, para que seja retornado o valor VERDADEIRO preciso que somente uma condio seja satisfatria.

Funes com mais de duas possibilidades


Trabalhando com mais de duas possibilidades para o resultado final de uma funo SE.

Nvel Intermedirio

Neste caso ns temos 3 resultados finais. SE (Contact Rate for menor que 70% ento Farol ser SE (Contact Rate for maior que 90% ento Farol ser

) )

SE (Contact Rate estiver entre 70% e 90% ento o Farol ser

)
NOTA: Foi utilizado a fonte Wingdings 3 para utilizao das setas.

Funes SOMASE
=SOMASE(intervalo ; critrios ; [intervalo_soma])
Nvel Intermedirio

A SOMASE ir calcular o total dos valores que atingem o critrio pr estabelecido.

Nesta tabela s ir ocorrer a soma dos valores que o nome da localidade esteja digitado na clula G9.

Funes CONT.SE
=SE(intervalo ; critrios)

Nvel Intermedirio

A funo CONT.SE no soma os valores. Ela conta quantos produtos satisfazem o critrio estabelecido.

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Funo MEDIANA

Nvel Intermedirio

A funo MEDIANA elimina o menor e o maior valor gradualmente a fim de equilibrar a mdia para que impacto dos maiores desvios. Se calcularmos a MDIA desse volume o valor seria de: =MEDIA(B3:B15)

245,63

Funo SOMARPRODUTO

Nvel Intermedirio

A funo SOMARPRODUTO demonstra o produto final entre duas matrizes selecionadas.

O calculo de forma manual feito da seguinte forma: B2*C2+B3*C3+B4*C4

A funo SOMARPRODUTO pode ser aplicada na MEDIA PONDERADA. = C6/B6 =SOMARPRODUTO([matriz1];[matriz2]) ou =SOMARPRODUTO([MATRIZ1];[MATRIZ2])/B6

Grficos
Na guia INSERIR temos um conjunto de opes para um grfico apropriado.

Nvel Intermedirio

Com base em uma tabela podemos exemplificar os tipos de grficos.

Aps selecionar toda a tabela

Clique na ABA INSERIR e escolha qual tipo de grfico voc deseja.

Grficos
Ms de Setembro 2012 Nvel de servio
TAM 80% 70% 92% 82% TICKET 89% SANTANDER ITAU TAM INTERMEDICA 0% 100% 90% 80% 70% 82% 60% 50% 40% 30% 20% 10% 0% 100% 90% 80% 70% 60% 50% 40% 30% 20% 10% 0% 20% 40% 60% 80% 100% SANTANDER TICKET ITAU INTERMEDICA

Nvel Intermedirio

89%

92% 70% 80%

Ms de Setembro 2012 Nivel de servio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Teste de Hipteses (Atingir Metas)


O recurso Atingir Meta localizar a entrada correta quando voc souber o valor desejado. Nvel Intermedirio

=B2/(A2-C2)

A clula que contm a formula ser usada no primeiro quadrante: Definir clula. O prximo quadrante define a meta que deseja atingir. E para que isso acontea poder alternar o valor da clula estipulada abaixo. A prxima tela apresenta a soluo para a meta estabelecida.

O valor encontrado para que a meta fosse atingida aparece no endereo definido.

Tabela dinmica

Nvel Intermedirio

Na aba INSERIR, temos a opo TABELA DINMICA. Com uma clula da sua tabela selecionada clique na opo TABELA DINAMICA.

A prxima janela que ir aparecer mostra o intervalo de clulas que ir compor a tabela dinmica e onde voc deseja que ela seja criada.

Tabela dinmica

Nvel Intermedirio

Aqui temos os campos que constituem a tabela selecionada.

Qual campo apropriado para filtrar as informaes?

Definindo quais campos sero apresentados na tabela dinmica, iremos arrast-los para a rea desejada.
Os campos que estiverem aqui as informaes ficaram em coluna.
Aqui podemos colocar campos onde precisamos somar, contar... Entre outros clculos.

As informaes situadas aqui ficaram dispostas em linha.

Tabela dinmica

Nvel Intermedirio

O exemplo demostra a soma de PAs e HCs de cada empresa.

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Funo INDIRETO

Nvel Intermedirio

Em um planilha com varias ABAS Podemos utilizar a funo INDIRETO para criar um RESUMO das informaes.

A,BeC

Funo INDIRETO

Nvel Intermedirio De acordo com o nome digitado na clula B2 teremos os respectivos valores. Na ABA RESUMO teremos a soma do TMO e do VOLUME

INDIRETO(texto_ref)

INDIRETO(B2 & !C:C)


INDIRETO transforma texto em frmula. Com isso temos como buscar diferentes referencias a partir do que o usurio digitar.
Busque o valor da respectiva clula. Neste exemplo podemos observar que a frmula completada com a informao que est na clula B2. E complete com a seguinte instruo .

Use INDIRETO quando quiser mudar a referncia a uma clula, sem mudar a prpria frmula.

Funo PROCV
A funo PROCV uma busca com referncia na vertical, ou seja, ela procura valores Nvel Intermedirio entre as colunas estabelecidas. Ela bastante utilizada para facilitar o encontro de algum dado dentro de um grande nmero de informaes. COLUNA

Clula de REFERNCIA. Em cada clula ser digitada a frmula PROCV

=PROCV(valor_procurado;matriz_tabela;nm_indice_coluna;[procurar_intervalo])
Clula que o usurio ir digitar o valor para a busca. EX: Cdigo Intervalo de clulas que sero pesquisadas.

Numero da coluna para apresentar o valor. EX: 2 (2 coluna- MARCA)

0 (zero) para valor exato. 1(um) para valor aproximado.

Funo ENDEREO

Cria uma referncia de clula como texto, de acordo com nmeros de linha e coluna especficos.

Nvel Intermedirio

AQUI TEMOS AS REFERNCIAS DE LINHA E COLUNA PARA AS FRMULAS

Esta planilha contm duas tabelas para o mesmo clculo. Onde o que ir diferenciar ser se o funcionrio bateu a meta ou no. Para especificar na frmula qual tabela ser utilizada, primeiro iremos definir os ENDEREOS DE REFERNCIA.

Meta batida? NO TABELA 01

Meta batida? SIM TABELA 02

AQUI UTILIZAMOS A FUNO ENDEREO PARA APRESENTAR A REFERNCIA DAS TABELAS.

PARA TER O ENDEREO DA CLULA EM NMERO UTILIZAMOS A FRMULA =COL(NUMERO DA COLUNA) E =LIN(NUMERO DA LINHA)

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Funo ENDEREO

Cria uma referncia de clula como texto, de acordo com nmeros de linha e coluna especficos.

Nvel Intermedirio

=ENDEREO(LINHA_INICIAL ; COLUNA_INICIAL) =ENDEREO(3 ; 14)

ENDEREO(LINHA_FINAL ; COLUNA_FINAL) =ENDEREO(12 ; 15)

14 3

15

$N$3
12

$O$12

Para unir os dois termos e apresentar o endereo de referncia vamos concatenar.

=ENDEREO(LINHA_INICIAL ; COLUNA_INICIAL) & : &ENDEREO(LINHA_FINAL ; COLUNA_FINAL)


$N$3:$O$12
A combinao do conjunto de linhas e colunas apresenta a referncia que precisamos para incluir na frmula seguinte.

Funo ENDEREO + PROCV + INDIRETO

=ENDEREO(LINHA_INICIAL ; COLUNA_INICIAL) & : &ENDEREO(LINHA_FINAL ; COLUNA_FINAL)

Nvel Intermedirio

=PROCV(B5; INDIRETO (PROCV (B2 ; $D$2:$E$3 ; 2 ; 0 )) ; 2 ; 0)

Organizao de dados
O FILTRO um recurso do Excel que mostra registros de uma lista de acordo com critrios pr estabelecidos.
Para ativar o filtro primeiro vamos selecionar a linha que contm os rtulos das colunas

Nvel Intermedirio

Clique no boto FILTRO.

Formatao de clula
A FORMATAO da clula pode ser feita atravs dos botes existentes na barra de inicio do Excel. Aqui encontrado as principais funes que normalmente so mais utilizadas.
Quebra automtica do texto. Mesclar duas ou mais clulas.

Nvel Intermedirio

Formatao do texto Borda da clula Cor de preenchimento da clula Cor do texto

Alinhamento do texto Orientao Recuo

Tipo de texto da clula Porcentagem Quantidade de casas decimais.

Podemos tambm clicar com o boto direito sobre a clula e escolher a opo: FORMATAR CLULA

Formatao de clula

Na opo FORMATAR CLULA temos 04 abas referente a formatao da clula.

Nvel Intermedirio

Todos os botes que aparecem no menu INICIO esto reunidos com mais detalhe. Lembrando que as alteraes sero aplicadas somente nas clulas selecionadas.

A 5 aba (Proteo), s ter efeito quando a pasta de trabalho for protegida.

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Nvel Intermedirio

Visual Basic

Capacitao Contax
Planejamento Estudos e Anlises

Os Exerccios sero feitos em exerccios prticos:

Nvel Intermedirio

1. Lgica de Programao 2. Bibliotecas 3. Variveis e Constantes 4. Macros 5. Funes For, If, If not, Do While, GoTo:, Matriz 1x1, Matriz 1x1x1, Cells, Forms

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Tome nota! hora de anotaes importantes!!!

Nvel Intermedirio

Nvel Intermedirio

Capacitao Contax
Planejamento Estudos e Anlises