Você está na página 1de 110

CAMADA DE ENLACE Ethernet

Introduo VLANs Protocolos Spanning-Tree PVST Rapid-PVST MST

I Introduo ao Ethernet

Evoluo do Ethernet
1970 - 1976 Xerox Corporation Robert Metcalfe Artigo: Ethernet: Distributed Packet-Switching For Local Computer Networks 3 Mbps CSMA/CD: Carrier Sense Multiple Access with Collision Detection 1980 Xerox, Digital, Intel Robert Metcalfe fundou a 3Com Ethernet I: no mais usado Ethernet II: formato DIX (DEC, Intel, Xerox) Padro proposto em 10 Mbps 1985 ANSI/IEEE 802.3 Formato do quadro: IEEE 802.3 LLC

QUADROS ETHERNET II
O quadro (frame) a menor estrutura de informao transmitida atravs de uma rede local.

ENDEREO (FSICO) DE DESTINO (6 bytes) ENDEREO (FSICO) DE ORIGEM (6 bytes) FRAME CHECK SEQUENCE (4 bytes)

TIPO ou TAMANHO (2 bytes)

DA

SA

Length/ Type

DADOS

FCS

46 1500 bytes CABEALHO FECHO

processo transmissor

dados

dados

processo receptor

dados

APDU

dados

dados

PPDU

dados

dados

SPDU TPDU

dados

dados

dados

pacote
3 3 4 5 6 7 dados

NPDU

dados

quadro
2 2 3 4 5 6 7 dados 2

DL-PDU

dados

dados

dados

0 1 0 0 1 0 0 ...

Comunicao no Modelo OSI


Aplicao Apresentao Sesso Transporte
protocolo rede protocolo sesso protocolo transporte protocolo aplicao protocolo apresentao

Aplicao Apresentao Sesso Transporte Rede

Rede Enlace de Dados Fsica


protocolo enlace

Enlace de Dados Fsica

protocolo da camada fsica

Camadas do Modelo OSI


HTTP, FTP,, DNS, DHCP, etc JPEG, MPEG, etc
RPC, NFS, SQL, etc TCP, SPX, NetBEUI IP, IPX, OSPF Ethernet, PPP, HDLC

Aplicao Apresentao Sesso Transporte Rede Gateway de Aplicao

segmento
Router

pacote

Enlace de Dados
Fsica

Ponte, Switch quadro Hub, Repetidor

bit

Padres IEEE 802.3

Aplicao

Apresentao
Sesso Transporte Rede Enlace de Dados

A camada de enlace dividida em 2 subcamadas Camada LLC: Logical Link Control Camada MAC: Medium Access Control
IEEE 802.2 IEEE 802.3

Logical Link Control (LLC) Media Access (MAC)

Fsica

Physical (PHY)

Quadro Ethernet
Os quadros Ethernet incluem informaes de prembulo utilizados para sincronizao e delimitao dos quadros.

Tipos de Quadros Ethernet


A mxima unidade transportvel em quadros Ethernet (MTU) 1500 bytes. Dois tipos de quadros Ethernet so utilizados. Formato DIX: Utiliza o campo Type Formato IEEE 802.x LLC: Utiliza o campo Length Valores at 1500: O quadro do tipo IEEE 802.x, e o significado do campo Tamanho Valores acima de 1500 O quadro do tipo Ethernet II, e o significado do campo Tipo Exemplos: 0x0806 ARP, 0x0800 IP

A camada LLC
A camada LLC introduz um nvel adicional de endereamento, permitindo a multiplexagem de vrios protocolos sobre a camada MAC. O cabealho LLC pode ser seguido do cabealho SNAP (Subnetwork Access Protocol) que inclui um campo com a mesma funo que o Ethertype do formado DIX.

IEEE Organizationally Unique Identifier

Endereo MAC
O padro IEEE 802 define 2 formas de endereamento MAC endereos administrados localmente
Quem instala a placa de rede.

endereos universais
OUI (Organizationally Unique Identifier). 1 2 3 4 5 6 Exemplos de OUI: XEROX 00-00-00 a 00-00-09 CISCO 00-00-0C

OUI

Nmero de Srie

Endereos MAC
Endereos MAC podem ser individuais ou em grupo. Endereos de grupo podem ser broadcast (FF-FF-FF-FF-FF-FF) ou mulitcast (e.g. 01-00-5EXX-XX-XX)

Multicast para Protocolos Padronizados


The following 48-Bit Universal Address Block has been allocated for use by standard protocols: 0X-80-C2-00-00-00 to 0X-80-C2-FF-FF-FF X = 0 (unicast) X = 1 (grupo) IEEE 802.1D MAC Bridge Filtered MAC Group Addresses: 01-80-C2-00-00-00 to 01-80-C2-00-00-0F; No encaminhados por bridges IEEE 802.1D. Standard MAC Group Addresses: 01-80-C2-00-00-10 to 01-80-C2-FF-FF-FF; Encaminhados por bridges IEEE 802.1D.

Princpio do Ethernet
A tecnologia de redes locais (Ethernet) baseia-se no princpio de comunicao com broadcast fsico.
B A DADOS FCS

A quadro

Recepo: Filtragem de Endereos


IP REDE
INTERRUPO

MAC
ENLACE/FSICA

MACD = PLACA DE REDE LOCAL MACD = BROADCAST (FF.FF.FF.FF.FF.FF) MACD = MULTICAST (01.5E )

MACD

MACO

DADOS

FCS

Transmisso: CSMA/CD
Meio Livre ? S S Iniciar Transmisso N Aguarda o meio ficar livre Nmero de Tentativas Esgotado ? N Espera um tempo aleatrio

Houve Coliso ? N Informa Sucesso para Camadas Superiores

Continuar at atingir o tamanho mnimo

Informa Falha para Camadas Superiores

ETHERNET NO COMUTADA
Tempo para acesso a rede aumenta com o nmero de terminais.

ESCUTANDO

ESCUTANDO

B
quadros na fila de espera

ETHERNET NO COMUTADA
Taxa de ocupao mxima diminui com a distncia entre os terminais

O tempo de propagao entre as estaes afeta a taxa de ocupao T t mxima da rede.


A
A TRANSMITE A RECEBE

B RECEBE

B TRANSMITE

tempo para o sinal ir de A para B

Exemplo
Quadro de 100 bit e Taxa de Transmisso = 10 Mbit/s: Tempo para transmitir um quadro T = 10 10-6 s Velocidade de propagao no meio: 200 000 Km/s Tempo de propagao: t = 1 10-6 s para 200 m Tempo de propagao: t= 10 10-6 para 2 Km HALF-DUPLEX

eficincia = T/(T+t)
L

eficincia200m = 91%
eficincia2Km = 50% eficincia100Mbits e 2Km = 9,1%

ETHERNET NO COMPUTADA
Existe possibilidade de coliso

COLISO DETECTADA POR A

A TRANSMITE t RECEBIDO DE C COLISO DETECTADA POR C

RECEBIDO DE A C TRANSMITE

Exemplo
eficiencia = 1/(1 + 6,44t/T) t: tempo de propagao
L = 200m ento t=1 10-6s

T: tempo para transmitir o quadro


T = 10 10-6 s (quadro de 100 bits a 10 Mbits/s) HALF-DUPLEX

eficienciaL=200m = 60,8 %

eficienciaL=2Km = 13,4%
eficienciaL=2Km e 100Mbits/s = 1,52 %

LIMITAES DAS LANS NO COMUTADAS


O NMERO DE COMPUTADORES LIMITADO Como apenas um computador pode transmitir de cada vez, o desempenho da rede diminui na medida em que muitos computadores so colocados no mesmo barramento. A DISTNCIA ENTRE OS COMPUTADORES LIMITADA Para evitar colises, os computadores escutam o barramento antes de transmitir, e s transmitem se o barramento estiver desocupado. Quanto maior a distncia entre os computadores, maior a chance de ocorrer colises no barramento, levando a rede para um estado de colapso e baixo desempenho.

HUBS
Hubs ou concentradores so dispositivos que simulam internamente a construo dos barramentos fsicos. HUB
C A C A C A

Repetidor: BIT
10101 10101

repetidor
amplitude

fibra

cobre

distncia

Hub: Bit
Hub

Operao Half-Duplex
O tamanho mnimo do quadro est relacionado com o mximo dimetro de coliso. O quadro deve ser suficientemente grande para que a coliso seja detectada pelo transmissor antes que a transmisso termine. Isso impe limitaes ao tamanho mnimo de um quadro ou a mxima distncia de operao.

Parameter Minimum frame size

10 Mbps 64 bytes

100 Mbps 64 bytes

1000 Mbps 520 bytes1 (with extension field added) 100 meters UTP 316 meters fiber 200 meters 1

Maximum collision diameter, DTE to DTE Maximum collision diameter with repeaters Maximum number of repeaters in network path

100 meters UTP 2500 meters 5

100 meters UTP 412 meters fiber 205 meters 2

ETHERNET COMUTADA: SWITCH


Hubs ou concentradores so dispositivos que simulam internamente a construo dos barramentos fsicos.

SWITCH
1
C A C A

PORTA

COMPUTADOR

2
C A

A C

A C

SWITCH
Os switchs so dispositivos capazes de segmentar a rede local analisando os endereos fsicos. Permitem tambm interligar dispositivos que trabalham com velocidades de transmisso diferentes.

SWITCH

HUB

HUB

Operao em Full-Duplex
O modo de operao em full-duplex bem mais simplex que a operao half-duplex, pois no existe necessidade de controlar o compartilhamento do meio. O quadros podem ser transmitidos em um fluxo contnuo, mas h necessidade de respeitar-se um intervalo mnimo entre frames (IFG InterFrame Gap). A operao full-duplex inclui a implementao do controle de congestionamento por hardware.
Flow Control

Autonegociao
A auto-negociao ocorre na inicializao do link: O n envia uma mensagem de anuncio, com sua verso de Ethernet e capacidades opcionais. Reconhece o recebimento dos modos operacionais compartilhados pelas NICs Rejeita os modos operacionais que no so compartilhados Configura sua NIC com o maior modo operacional que ambas as placas podem suportar.
Operational Mode 1000Base-T full-duplex 1000Base-T half-duplex 100Base-T2 full-duplex 100Base-TX full-duplex 100Base-T2 half-duplex 100Base-T4 half-duplex 100Base-TX half-duplex 10Base-T full-duplex 10Base-T half-duplex Maximum Total Data Transfer Rate (Mbps)1 2000 1000 200 200 100 100 100 20 10

Selection Level 9 8 7 6 5 4 3 2 1

Exerccio - 1
Comandos Bsicos show interfaces show interfaces interface-id show mac address table dynamic show mac address table aging-time Verifique: Mecanismo de aprendizagem do switch Atualizao da tabela MAC em caso de reconfigurao (troca de cabos)

Exercocio - 2 Verificar tabela MAC nos Switches

SWITCH

SWITCH

SWITCH

Exerccio 3 Verificar tabela MAC nos Switches

SWITCH

SWITCH

SWITCH

Exerccio 4 Verificar tabela MAC nos Switches

SWITCH

SWITCH

SWITCH

Auto-MDIX
Auto-MDIX: Automatic Medium-Dependent Crossover
switch

Cabo paralelo (straight through)

host

switch

Cabo cruzado (crossovet)

switch

switch

Cabo paralelo (straight through)

roteador

Configurao das Portas do Switch


1) Entrar em modo terminal: configure terminal 2) Selecionar uma interface interface Gi1/0/1 ou interface Fa0/1 interface range Gi1/0/1 10 3) Executar comando de configurao: speed auto duplex auto flowcontrol receive on mdix auto 4) Sair do modo terminal end 5) Mostrar configurao show interfaces

Cascateamento de Switches
O cascateamento de switches na presena de VLANS motivou a elaborao dos seguintes padres IEEE: IEEE 802.1Q: define o funcionamento de VLANs
Acrescenta dois campos no quadro:
Identificador de VLAN Prioridade

IEEE 802.1p: define o uso do campo prioridade.

Quadros Ethernet
Ethernet I & II
MAC origem (6 bytes) MAC destino (6 bytes) Tipo Proto. (2 bytes) Dados (46 a 1500 bytes) FCS (4 bytes)

IEEE 802.3
MAC origem (6 bytes) MAC destino (6 bytes) Tamanho Dados (46 a 1500 bytes) FCS (4 bytes)

(2 bytes)

IEEE 802.1Q
MAC origem (6 bytes) MAC destino (6 bytes) Tipo Proto (2 bytes) VLAN id e prioridade (2 bytes) Dados (46 a 1500 bytes) FCS (4 bytes)

Tipo 802.1Q = 0x8100

Prioridade (3 bits) + CF (1bit) + VLANID (12 bits)

Spanning Tree Protocol: STP


Quando os switches colocados em cascata formam caminhos com loops fechados, o encaminhamento de quadros pode levar ao congestionamento da rede. O STP um protocolo de camada 2 utilizado para prevenir a ocorrncia desses loops.

Loops em Cascateamento de Switches


Os switches criam tabelas de encaminhamento escutando os endereos MAC de origem enviado para suas portas.

C,D

A,B

Cascateamento de Switches
C,D,E,F A,B E,F

A,B,C,D

Cascateamento de Switches
A,B,C,D,E,F A,B,C,D,E,F A,B,C,D,E,F A,B,C,D,E,F A B C D

A,B,C,D,E,F E F

A,B,C,D,E,F

Princpio do STP
O STP executado em cada switch da rede Princpio: Somente um caminho ativo pode existir entre 2 estaes na rede Bloquear as portas que impliquem em loops fechados. A estratgia consiste em escolher um switch como Root, e construir uma rvore como o menor caminho at o Root.

SPT
O STP utiliza um protocolo chamado BPDU: Bridge Protocol Data Unit Mensagens em Multicast (MAC)
DE: 0x0180C20000000 AT: 0x0180C20000010

STP funciona continuamente, de maneira a refletir mudanas de topologia na rede. Se SPT est ativo, os pacotes multicast so recebidos, mas no encaminhados. Se SPT est desativo, os pacotes multicast so encaminhados como multicast desconhecido.

Topologia STP
As portas na direo oposta ao root so chamadas de designadas.

A
RP

RP

RP

D
As portas na direo do root so chamadas porta Root

BPDU: Padro IEEE 802.1D

Campos do BPDU
Protocol Identifier: 0 (SPT) Version: 0 (ST) Message Type: 0 (Configuration) Flags: Topology change (TC), Topology change acknowledgment (TCA) Root ID: 2-Byte Prioridade + 6-Byte MAC da Bridge Root Path Cost: 4-Bytes custo da Bridge at o root. Bridge ID: 2-Byte Prioridade + 6-Byte MAC da Bridge (por VLAN) Port ID: 2 Bytes (usado para escolher a porta a ser bloqueada em caso de loop) Message Age: Tempo decorrido desde que a mensagem repassada foi enviada pelo Root Maximum Age: Idade a partir do qual a mensagem deve ser ignorada Hello Time: Intervalo entre mensagens da root bridge Forward Delay: Tempo que a bridge deve esperar antes de mudar de estado em caso de mudana de topologia.

Topologia STP
Todas as portas so DP ROOT = Bridge com a menor Bridge ID (menor prioridade ou menor MAC)

Porta Root aquela que tem a menor distncia at o Switch Root

Por default, a prioridade de todos os switches 32768.

Esses caminhos foram bloqueados. Em caso de caminhos paralelos, a interface mais lenta sempre bloqueada.

Mensagens BPDU
Todos os switches so root inicialmente Todos os switches enviam mensagens BPDU em multicast para todas as suas interfaces. Se SPT est ativo, as mensagens recebidas no so propagadas pelo switch. Se a mensagem recebida por um switch superior (menor bridge ID, custo) ele armazenada, seno ignorada. Se a mensagem superior for recebida pela porta root, ela propagada para as demais portas DP, correspondendo as redes LAN onde o switch designado.

Estados de uma Porta


Apenas recebe BPDUS Apenas recebe BPDUS

timer
Problema de conectividade

Recebe BPDUS Aprende Endereos


Recebe BPDUS Aprende Endereos Encaminha Quadros

Configurao Default

Exemplo
Fa0/1-5 vlan1 10.26.136.60 Fa0/6-10 vlan1 Fa0/1-5 vlan1 10.26.136.184 Fa0/6-10 vlan1

Fa0/24

Fa0/23

Fa0/23

Fa0/24

Fa0/18 10.26.136.13 vlan1 Fa0/1-5 vlan1

Fa0/21

Fa0/6-10

Exemplo
Verifique a configurao atual do SPT show spanning-tree summary show spanning-tree detail show spanning-tree active show spanning-tree interface interface-id show spanning-tree blocked ports Identifique: switch root topologia da rvore formada

LANS Virtuais
SEGMENTO = Domnio de Coliso Os computadores de um Hub esto no mesmo segmento fsico. VLAN = Domnio de Broadcast O trfego de broadcast pode passar de uma VLAN para outra apenas atravs de um roteador.
FF.FF.FF.FF.FF.FF FF.FF.FF.FF.FF.FF FF.FF.FF.FF.FF.FF

A SWITCH

A,B,C: VLAN 1
D,E: VLAN 2

Interligao de Switches
B C

VLAN 2

VLAN 2

VLAN 1

VLAN 1,2,3 SWITCH SWITCH TRUNK VLAN 3 VLAN 1,2,3 VLAN 1,2,3 D

A
ACCESS

Interface Trunk: Trfego de Vrias VLANs IEEE 802.1Q

SWITCH

Interface de Acesso: Trfego de uma nica VLAN IEEE 802.3

VLAN 2 E

BroadCast e Multicast Ethernet


Por default, quadros transmitidos com endereos de destino multicast desconhecidos ou endereos broadcast so encaminhados para todas as portas do switch.

SWITCH
F A F

PORTA

COMPUTADOR

F A F

F A F

Modos das Portas de Switch


As portas de um switch pode trabalhar em dois modos: Modo Access
Cada porta do switch pertence a uma nica VLAN. Quadros Ethernet: Formato Normal.

Modo Trunk
O trfego de mltiplas VLANs multiplexado em um nico link fsico. Usualmente interconectam switches. Quadros Ethernet: formato especial (VLAN). Apenas computadores com placas especiais podem se conectar a essas portas.

Protocolos Trunk
Os quadros nas interfaces Trunk so formatados em quadros especiais para identificar a quais LANs eles pertencem. O IEEE 802.1Q um protocolo para interface Trunk.

0x8100
6 Bytes 6 Bytes 2 Bytes 3 Bits 1 Bit 12 Bits 2 Bytes

DESTINO

ORIGEM

TYPE

PRIO

CFI

VLAN ID

TYPE

Dados

CRC

Esses campos so removidos quando o quadro enviado para uma interface do tipo access.

PRIO: IEEE 802.1 P CFI: Canonical Format Indicator 0 em redes Ethernet

Exerccio- 5
Divida cada um dos switches em 3 VLANS: VERMELHO VERDE AZUL Utilizando o Ethereal verifique: Como o trfego broadcast se propaga entre as VLANs Como o trfego unicast se propaga entre as VLANs

Comandos para VLANs


Criao de VLANs configure terminal vlan 20 name test20 end Adio de portas as VLANs configure terminal interface G1/0/1 switchport mode access switchport access vlan 2 end Verificar configurao atual show VLAN brief

Aprimorando SPT
possvel induzir o protocolo SPT a escolher portas e caminhos diferentes para cada conjunto de VLANs. Essa configurao feita alterando-se o nvel de prioridade (ou custo) associado as portas trunks.

Exemplo
O switch escolhido como root pode no ser o melhor switch da topologia. possvel alterar o switch root com o seguinte comando: configure terminal
spanning-tree vlan vlan-id root primary [diameter netdiameter [hello-time seconds]] end

show spanning-tree detail O dimetro da spanning tree o nmero mximo de switches entre dois terminais [2-7] O hello o intervalo de envio de mensages de configurao pelo switch root (1 a 10s)

Exerccio 6
Fa0/1-5 vlan1 Fa0/6-10 vlan20 B = 10.26.136.60 Fa0/1-5 vlan1 Fa0/6-10 vlan20

C = 10.26.136.184

Fa0/24

Fa0/23

Fa0/23

Fa0/24

Fa0/18 A = 10.26.136.13 vlan1 Fa0/1-5 vlan1

Fa0/21

Fa0/6-10

Comandos
Adio de portas as VLANs configure terminal
interface range Fa0/6 - 10
#switchport mode access switchport access vlan 2

end

Verificar configurao atual show VLAN brief

Comandos
Verifique o efeito de desabilitar o protocolo SPT nos switches, desabilitando SPT para VLAN 20: configure terminal
no spanning-tree vlan vlan-id end.

show spanning-tree vlan vlan-id Para reabilitar o SPT utilize o comando: spanning-tree vlan vlan-id

Portas VLANS em Switches CISCO


A Cisco define 6 modos de operao de portas para VLAN:
Fora a porta a operar em modo acesso Permite que a interface entre em modo trunk Entra prioritariamente em modo trunk Fora a porta a operar em modo trunk No negocia com a porta vizinha Fora o encapsulamento em modo 802.1q

switchport mode access


switchport mode dynamic auto
switchport mode dynamic desirable switchport mode trunk switchport nonegotiate

switchport mode dot1q-tunnel

Negociao
auto trunk desirable dynamic desirable switch

switch

Trunk nonegotiate
switch Access nonegotiate switch

Trunk switch

Host

Modos de Encapsulamento
A cisco possui um modo de encapsulamento trunk proprietrio denominado ISL. As seguintes opes de encapsulamento esto disponveis para o switch cisco: switchport trunk encapsulation isl switchport trunk encapsulation dot1q switchport trunk encapsulation negotiate
isl o modo preferido

Configurao Default
switchport mode dynamic auto Negocia se a porta ser trunk ou no com o vizinho switchport trunk encapsulation negotiate Negocia o modo de encapsulamento (dot1q) ou (isl) com o vizinho Range de VLANs 1 at 4094 (1006 a 4004 so extendidas) VLAN default em modo acesso 1

Exemplo de Comandos
configure terminal interface rage Fa0/1 - 24
switchport mode dynamic desirable switchport access vlan 1 #switchport trunk encapsulation dot1q end

Mapeamento de VLANs em portas trunk


Por default, cada porta trunk pode ser utilizada por todos as VLANs do switch. Todavia, no caso de haver caminhos redundantes, possvel restringir o uso das VLANs para portas trunks especficas. Isso permite efetuar balaceamento de carga, mas sem failback.

Exerccio 7
Fa0/1-5 vlan1 Fa0/6-10 vlan20 B = 10.26.136.60 Fa0/1-5 vlan1 Fa0/6-10 vlan20

C = 10.26.136.184

Fa0/24

Fa0/23

Fa0/23

Fa0/24

Vlan1 somente Fa0/18 A = 10.26.136.13 vlan1 Fa0/1-5 vlan1

Vlan20 somente Fa0/21

Fa0/6-10

Portas Trunk
Verifique a configurao atual dos switches

show interfaces trunk show spanning-tree blocked ports

Comandos para Mapeamento da VLANs


configure terminal interface Fa0/18 (A) ou Fa0/24 (B)
switchport trunk allowed vlan remove all switchport trunk allowed vlan add 1 end

interface Fa0/21 (A) ou Fa0/24 (C)


switchport trunk allowed vlan remove all switchport trunk allowed vlan add 20 end

Portas SPAN
A fim de verificar para qual porta trunk o trfego das VLANs est sendo encaminhado necessrio utilizar portas SPAN. As portas SPAN fazem uma cpia da porta trunk para outra porta do switch, permitindo que o trfego seja monitorado com o Ethereal. As portas SPAN so configuradas em sesses. Cada sesso representa uma regra de cpia de uma porta de origem para uma porta de destino.

Comando para Portas SPAN


configure terminal no monitor session 1 monitor session 1 source interface Fa0/18
monitor session 1 destination interface Fa0/5 encapsulation replicate end

show monitor

Exerccio 8
Configure as portas SPANs nos switches para verificar o fluxo do trfego trunk: 2950-2 e 2950-3 Fa0/23: cpia da Fa0/1 Fa0/24: cpia da Fa0/2 2950-1 Fa0/18: cpia da Fa0/1 Fa0/21: cpia da Fa0/2

Native VLAN
Uma porta trunk est sujeita a dois tipos de trfego: Trfego com TAG:
resultantes do trfego de VLANs de um switch para outro

Trfego sem TAGs:


utilizados normalmente por protocolos intra-switch, como o protocolo de configurao de portas trunk

O trfego sem TAGs associado a Native VLAN da porta trunk. Por default, a native VLAN das portas trunk VLAN 1

Native VLAN
A fim de haver negociao entre entre portas trunk necessrio que elas pertenam a mesma VLAN O trfego direcionado de uma VLAN para a porta Trunk no receber o cabealho de VLAN, se seu cdigo coincidir com a Native VLAN do switch.

Trfego com TAG

Trfego sem TAG

vlan1 2950-1

vlan20 10.0.0.2

Native VLAN 1

vlan1 2950-1

vlan20 10.0.0.2

Native VLAN 1

Configurao da Native VLAN


configure terminal interface interface-id
switchport trunk native vlan vlan-id end

show interfaces interfaceid switchport

Balanceamento de Carga com Prioridade de Portas


O mapeamento esttico de VLANs para portas trunk no permite a reorganizao automtica do fluxo de dados quando uma enlace trunk danificado. A alternativa mais adequada priorizar a utilizao de certas VLANs em certas portas, ao invs de bloquear sua utilizao. Por default, a prioridade de utilizao de VLANs em portas trunk 128.

Exerccio 9
Fa0/1-5 vlan1 Fa0/6-10 vlan20 B = 10.26.136.60 Fa0/1-5 vlan1 Fa0/6-10 vlan20

C = 10.26.136.184

Fa0/24
Vlan1 prio 16

Fa0/23

Fa0/23

Fa0/24
Vlan1 prio 128

Vlan 20 prio 128


Fa0/18 A = 10.26.136.13 vlan1 Fa0/1-5 vlan1 Fa0/6-10 Fa0/21

Vlan 20 prio 16

Balanceamento de Carga
Aumentar a prioridade para 16: VLAN 1 no trunk A B VLAN20 no trunk A - C Verificar o balanceamento de carga com show spanning-tree detail Provocar a falha no trunk e verificar o fail-over

Comandos
configure terminal interface Fa0/18 (A) ou Fa0/24 (B)
spanning-tree vlan 1 port-priority 16 spanning-tree vlan 20 port-priority 128 exit

interface Fa0/21 (A) ou Fa0/24 (C)


spanning-tree vlan 20 port-priority 16 spanning-tree vlan 1 port-priority 128 end

show running-config

Balanceamento de Carga com STP Path Cost


Por default, o custo dos caminhos trunk est associado a velocidade das portas do switch. Porta Ethernet: 100 Porta Fast-Ethernet: 19 Porta Giga-BitEthernet: 4 Em caso de haver trunks redundantes para o mesmo caminho, o STP ir selecionar com caminho com o menor custo (i.e., maior velocidade). Por default, o valor do custo o mesmo para todas as VLANs, mas pode ser alterado para prover balanceamento de carga. O custo acumulativo quando switches so cascateados

Exerccio 10
Fa0/1-5 vlan1 Fa0/6-10 vlan20 B = 10.26.136.60 Fa0/1-5 vlan1 Fa0/6-10 vlan20

C = 10.26.136.184

Fa0/24
Vlan1 path 19

Fa0/23

Fa0/23

Fa0/24
Vlan1 path 30

Vlan 20 path 30
Fa0/18 A = 10.26.136.13 vlan1 Fa0/1-5 vlan1 Fa0/6-10 Fa0/21

Vlan 20 prio 19

Comandos
Exemplo:

configure terminal
interface Fa0/18 (A) ou Fa0/24 (B)
spanning-tree vlan 20 cost 30 end

configure terminal
interface Fa0/21 ou Fa0/24 (C)
spanning-tree vlan 1 cost 30 end

Modos e Protocolos de Spanning Tree


PVST+: Protocolo da cisco baseado no IEEE 802.1d Usa um algoritmo de SPT por VLAN Rapid PVST+: (RSTP) Convergncia rpida baseada no IEEE 802.1w Apaga imediatamente as entradas MAC aps uma mudana de topologia, ao invs de aguardar o aging-time de 5 minutos. MSTP: Baseado no padro IEEE 802.1s Permite mapear mltiplas VLANs em uma nica instncia de SPT. Executado sobre o RSTP (IEEE 802.1w) (uso obrigatrio)

Limitaes
PVST+ e RSTP: 128 instncias de SPT (i.e., 128 VLANs) MSTP: 65 MST instncias Nmero ilimitado de VLANs por MST.

Configurao Default
STP mode: PVST+ Switch Priority: 32768 Port Priority: 128 Port Cost: 4 (1G), 19 (100M), 100 (10M) Timers: Hello: 2s (gerado pelo root para indicar que est funcionando) Forward-delay: 15s, Maximum-age: 20 seconds (tempo que o switch aguarda sem receber PDUs antes de tentar uma re-configurao) Transmit Hold Count: 6 BPDUs (n. PDUs por 1s de pausa evita uso excessivo de CPU)

Exerccio 11
Compare o desempenho dos protocolos de spanningtree PVST e Rapid-PVST no caso de reconfigurao de caminhos. Para o teste matenha um ping permanente entre dois computadores situados na mesma VLANs em switches diferentes. Remova o cabo de entroncamento da porta do trunk que no estiver bloqueada e conte o nmero de pings perdidos.

Exerccio 12
Fa0/1-5 vlan1 Fa0/6-10 vlan20 B = 10.26.136.60 Fa0/1-5 vlan1 Fa0/6-10 vlan20

C = 10.26.136.184

Fa0/24

Fa0/23

Fa0/23

Fa0/24

Vlan1 somente Fa0/18 A = 10.26.136.13 vlan1 Fa0/1-5 vlan1

Vlan20 somente Fa0/21

Fa0/6-10

Comandos
Cenrio 1: spanning-tree normal configure terminal spanning-tree mode pvst end show spanningtree summary Cenrio 2: rapid-spanning tree configure terminal spanning-tree mode rapid-pvst end show spanningtree summary

Funcionamento do STP com Stack SwitchApenas uma porta no stack


escolhida como root. Todos os switches tem o mesmo id

Porta Bloqueada

Root Todas as portas DP

Porta na Direo do root

MSTP Multiple Spanning-Tree Protocol


MSTP: IEEE 802.1s Melhora a tolerncia a falhas Mltiplos forwarding paths Permite balanceamento de carga Mais escalabilidade que o PVST

Problema do PVST
PSVT permite balanceamento de carga, escolhendo trunks diferentes para diferentes VLANs. D1: root para Vlans 501 a 1000 e D2: root para Vlans 1-500 Problema: 1000 instncias de PSVT com uma topologia de apenas 2 caminhos alternativos. Alto consumo de CPU nos switches e pouca escalabilidade.

Padro 802.1q
Define apenas uma instncia de ST para todas as VLANs: CST (Common Spanning Tree) No permite balanceamento de carga. OBS. PVST no padro IEEE 802.1q

Padro IEEE 802.1s (MST)


Permite agrupar VLANs em instncias de SPT. Intancia 1: VLANs 1 a 500 Instancia 2: VLANs 501 a 1000 Cada instncia pode ter um caminho diferente. Apenas duas instncias de SPT para 2 alternativas de topologia.

Regies MST
A fim de prover maior escalabiliade, o padro MST define que uma rede pode ser organizada em regies Cada regio pode possuir mltiplas instncias, sendo
1 instncia IST (Internal Spanning Tree) Instncia 0
Transmite BPDUs

1 ou mais instncias MST


Transmite MSTP BDUs

IST Master
MST Region 1

IST Master
MST Region 2

IST Master
MST Region 3

Regio MST
Switches pertencem a mesma regio MST se: Tiverem o mesmo nome de regio Tiverem a mesma verso Tiverem o mesmo mapeamento de instncias para VLAN

Exerccio 13
Fa0/1-5 vlan1 Fa0/6-10 vlan20 B = 10.26.136.60 Fa0/1-5 vlan1 Fa0/6-10 vlan20

C = 10.26.136.184

Fa0/24
Instance 1 prio 16 Instance 2 prio 128 Fa0/18

Fa0/23

Fa0/23

Fa0/24
Instance 2 prio 16

Instance 1 Vlan 1 e 10 Instance 2 Vlan 2 e 20

Instance 1 prio 128


Fa0/21 A = 10.26.136.13

vlan1 Fa0/1-5

vlan1 Fa0/6-10

Comandos Todos os Switches


configure terminal spanning-tree mst configuration
instance 1 vlan 1 Instance 1 vlan 10 instance 2 vlan 2 Instance 2 vlan 20 name region1 revision 1 show pending spanning-tree mode mst end

Configurao de Port Priority 2950


configure terminal interface Fa0/18 (A) ou Fa0/24 (B)
spanning-tree mst 1 port-priority 16 spanning-tree mst 2 port-priority 128 exit

interface Fa0/21 (A) ou Fa0/24 (C)


spanning-tree mst 1 port-priority 128 spanning-tree mst 2 port-priority 16 end

show spanning-tree mst 1 show spanning-tree mst 2

Configurao Path Cost


configure terminal interface interface-id
spanning-tree mst instance-id cost cost end

show spanning-tree mst instance-id

Escolhendo o Swith Root para uma instncia


configure terminal spanning-tree mst instance-id priority priority end show spanning-tree mst instance-id

OBS. VTP
A cisco utiliza um protocolo denominado VTP para manter a consistncia de configurao entre os switches. Utilizando o protocolo VPT possvel fazer a configurao de VLANs em um nico switch, e repassar essa configurao para os demais switches que pertenam a um mesmo domnio administrativo.

Entidades VTP
VTP Server Recebe novas configuraes e repassa para os demais switches do domno VTP Client Apenas recebe configuraes do server. No pode ser configurado diretamente. VTP Transparent Recebe configuraes e pode ser alterado diretamente. Todavia, as alteraes feitas num switch em modo transparent no so repassadas aos demais.

Configurao Default

Alterando a Configurao
configure terminal vtp mode server vtp domain domain-name vtp password password end show vtp status