Você está na página 1de 56

EtherChannel/IEEE 802.

3ad
Tunelamento VLAN /IEEE 802.3ac
Q-in-Q/IEEE 802.1ad
MAC-in-MAC/IEEE 802.1 ah
MPLS
EtherChannel
• Agregação de Portas:
– Etherchannel é um padrão
que permite agregar
múltiplas portas de
características comuns a fim
de formar uma porta de
maior capacidade.
• Atualmente é possível
criar portas agregadas
full-duplex com até 800
Mbps (Fast) ou 8 Gbps
(Giga)
• O número total de
Etherchannels é 48.
Modos EtherChannel
• Apenas portas trunk com características
idênticas podem ser agregadas.
• A configuração pode ser:
• Automática:
– PAgP: Port Aggregation Protocol
– LACP: Link Aggregation Control Protocol
• Manual:
– On: sem protocolo de negociação
• Usado apenas para compatibilidade entre switches
que não suportam os protocolos de negociação.
Identificação da Porta Agregada
• As portas Etherchannel são identificadas por uma interface lógica
(Logical port-channel), numerada de 1 até 8.
– Comandos aplicados a interface lógica afetam simultaneamente todas
as portas do grupo.
– Comandos aplicados as portas físicas não afetarão as demais portas do
grupo

Quando o grupo é criado pela primeira


vez, as portas seguem a configuração
da primeira porta do grupo:
• Allowed-VLAN list
• Spanning-tree path cost for each VLAN
• Spanning-tree port priority for each VLAN
• Spanning-tree Port Fast setting
PAgP – Port Aggregation Protocol
• Protocolo proprietário da cisco
– Apenas para switches simples, não funciona em
stacks.
• Agrupa automaticamente portas com as
mesmas caracterísiticas:
– Velocidade, modo duplex, native VLAN, VLAN range,
trunking status.
• Porta Access devem pertencer a mesma VLAN
• Portas Trunk devem pertencer a mesma native VLAN
• O grupo de portas é passado ao protocolo
Spanning-Tree como sendo uma porta única.
• Permite agregar até 8 portas.
Modos PAgP
• Auto: modo passivo que apenas responde a
solicitação para entrar no grupo.
• Desirable: modo ativo, que solicita a outra porta
entrar no modo Etherchannel.

Desirable Desirable

Desirable Auto

Auto Auto

Auto Não PAgP


Desirable
(Silent mode)
Se não for usado o modo silent, a porta
não entra em operação
Endereço MAC
• A primeira porta do Etherchannel que se
torna ativa provê o endereço MAC para
todo o grupo.
• Se a porta que cedeu o MAC for
removida, outra porta oferecerá o
endereço para o grupo.
• As mensagens PAgP são enviadas na
menor VLAN associada a porta.
LACP: Link Aggregation Control
Protocol
• Padrão IEEE 802.3ad
• Operação similar ao PAgP, mas suporta
também stack switching.
• Modos de operação:
– Passivo
• Similar ao modo auto PAgP
– Ativo
• Similar ao modo desirable PAgP
• A escolha do MAC é similar ao PAgP
• Permite agregar até 16 portas, mas
apenas 8 estão ativas num dado instante.
Configuração do EtherChannel
• Step 1:
– configure terminal
• Step 2:
– interface interface-id
• Step 3:
– switchport mode {access | trunk}
– switchport access vlan vlan-id
• Step 4:
– channel-group channel-group-number mode
• {auto [non-silent] | desirable [non-silent] | on} | {active | passive}
– PaGP: Auto/Desirable
– LACP: Active/Passive
• Step 5:
– end
• Step 6:
– show running-config
Remover a porta do Channel Group
• Step 1:
– configure terminal
• Step 2:
– interface interface-id
• Step 3:
– no channel-group
• Step 4:
– end
• Step 5:
– show running-config
Exercício 1

Fa0/1-5 Fa0/6-10 Fa0/1-5 Fa0/6-10


vlan1 vlan20 vlan1 vlan20
B = 10.26.136.60 C = 10.26.136.184

Fa0/23 Fa0/24 Fa0/23 Fa0/24

Ether 1 Ether 2

Fa0/18 Fa0/19 Fa0/20 Fa0/21

A = 10.26.136.13

vlan1 vlan20

Fa0/1-5 Fa0/6-10
Comandos
• 2950 -A
– configure terminal
• interface range Fa0/18-19
– channel-group 1 mode desirable
– end
• interface range Fa0/20-21
– channel-group 2 mode desirable
– exit
• 2950 -B
– configure terminal
• interface range Fa0/23-24
– channel-group 1 mode desirable
– end
• 2950 -C
– configure terminal
• interface range Fa0/23-24
– channel-group 2 mode desirable
– end
Verificando a Configuração
• Para zerar os contadores:
– clear pagp {channel-group-number counters | counters}
– clear lacp {channel-group-number counters | counters}
Verifique a configuração
• Comandos
– show etherchannel ?
– show interface ?
– show pagp ?
• Acrescente mais uma porta no
etherchannel e veja a alteração da
configuração
• Desconecte o cabo da nova porta, e após
verificar o efeito no switch, remova a porta
do Etherchannel
Balanceamento de Carga
• O balanceamento de carga pode ser feito com
base:
– Endereço Mac de Origem
• Pacotes com o mesmo MAC de origem são sempre
alocados na mesma porta do grupo.
• Diferentes MACs de origem são distribuídos entre as portas.

A C

D
B
E

F
Balanceamento de Carga
– Endereço Mac de Destino
• Pacotes com o mesmo MAC de destino são sempre
alocados na mesma porta do grupo.
• Diferentes MACs de destino são distribuídos entre os pares
– Ambos
• Mantém na mesma porta apenas o fluxo de quadro trocado
entre os mesmos parceiros.

A C

D
B
E

F
Escolha do Método de Balanceamento
• A escolha do
método depende
da topologia de
rede.
• O método deve
ser escolhido de
maneira a prover a
máxima utilização
de porta no
Etherchannel.
Configuração Default
Balanceamento de Carga
• configure terminal
– port-channel load-balance {dst-ip | dst-mac
| src-dst-ip | src-dst-mac | src-ip | src-mac}
– end
• show etherchannel load-balance
Exercício 2 - SPT com EtherChannel

Fa0/1-5 Fa0/6-10 Ether 3 Fa0/1-5 Fa0/6-10


vlan1 vlan20 vlan1 vlan20
Fa0/21
B = 10.26.136.60 C = 10.26.136.184
Fa0/23 Fa0/24 Fa0/22 Fa0/23 Fa0/24

Ether 1 Ether 2

Fa0/18 Fa0/19 Fa0/20 Fa0/21

A = 10.26.136.13

vlan1 vlan20

Fa0/1-5 Fa0/6-10
Comandos
• 2950 -B
– configure terminal
• interface range Fa0/21 - 22
– channel-group 3 mode desirable
– end
• 2950 -C
– configure terminal
• interface range Fa0/21 - 22
– channel-group 2 mode desirable
– end
Trabalhando com as Portas Lógicas
• Os comandos de configuração do SPT
podem ser aplicados aos
EtherChannels alterando-se a seleção
da interface para:
– interface port-channel port-channel-number
• Para apagar um EtherChannel
– no interface port-channel port-channel-
number
Exercício 3 - Balanceamento de Carga
Vlan 20
prio 16
Fa0/1-5 Fa0/6-10 Fa0/1-5 Fa0/6-10
Ether 3
vlan1 vlan20 vlan1 vlan20
Fa0/21
B = 10.26.136.60 C = 10.26.136.184
Fa0/23 Fa0/24 Fa0/22 Fa0/23 Fa0/24

Ether 1 Ether 2

Fa0/18 Fa0/19 Fa0/20 Fa0/21

A = 10.26.136.13

vlan1 vlan20

Fa0/1-5 Fa0/6-10
Comandos: 2950
• Switch B
– configure terminal
• interface port-channel 3
• spanning-tree vlan 20 port-priority 16
• end
– show interface trunk
– show spanning tree
• Switch C
– idem
Configurações Adicionais
• Hot-StandBy
– Portas Hot-StandBy são portas que só se
tornam ativas quando alguma outra porta não
pode mais operar.
• LACP: Quando mais de 8 portas são colocadas no
grupo, as demais entram em Hot-Standby. A
escolha das portas pode ser feita por prioridade
• PAgP: Pode-se colocar uma porta em maior
prioridade, fazendo-se com que as demais entrem
em Hot-Standby para operação.
Arquitetura Metro Ethernet
Q-in-Q e MAC-in-MAC

WAN

User-facing provider edge (U-PE)


Network-facing provider edge (N-PE)
Provider edge aggregation (PE-AGG)
Ethernet access domains [EADs]

Intra-EAD and Inter-EAD Services


Blocos Funcionais

USUÁRIO ACESSO CORE WAN

QinQ
ou
MinM MPLS MPLS
Networks

U-PE PE
N-PE
Q
Qin
MinM e QinQ

Customer Metro Ethernet Metro Core WAN


Prem Access Access/Aggregation

QinQ QinQ
Or Or
50ms Ethernet MinM MinM
Access Ring MPLS MPLS
Networks

U-PE N-PE
Q
Qin

nM
Mi

Os novos padrões QinQ e MinM são utilizados para prover


escalabilidade na construção de backbones
metropolitanos.
Gerenciamento em Ethernet

Gerenciamento Ethernet

Customer Edge
CO/POP Device
Premises Ethernet
Backbone
CPE NTU Access
Aggregator

• O gerenciamento da camada Ethernet inclui:


• Marcação e Re-Marcação de TAGs VLAN
• Gerenciamento de Banda
• Alarmes de falha e diagnósticos
QinQ e MinM

IEEE802.1ad QinQ (Stacked VLAN)


IEEE802.1ah MinM (Backbone Provider Bridge)
MinM QinQ
Cabeçalho Cabeçalho Cabeçalho
Dados na rede do Dados da rede do
do Service
usuário Provider usuário

• Um novo cabeçalho acrescido pelo


SP contém endereços MAC VLAN IDs
• Permite a reutilização de VLANs no
• As VLANs ID são colocadas no
cabeçalho do usuário.
cabeçalho da rede do usuário.
• Permite a reutilização de VLANs nos
sub-campos
Princípio MinM
O pacote é
O switch de borda encaminhado pela O switch de saída
Pacotes Ethernet
acrescenta um rede utilizando as remove o Site Y
Chegam da rede
novo cabeçalho informações do cabeçalho SP
da empresa
(SP) com cabeçalho SP
endereços MAC

Ethernet Ethernet
Switches UNI
(destination)

Site X

Ethernet
UNI
(source)
Service Provider
Metro Ethernet
network Enterprise
User Ethernet SP Ethernet
data header header
Quadro Mac-in-Mac
Destination MAC address
SP MAC • If destination unknown, then
DA 0xFFFFFF
Source MAC address
SP Header SP MAC
SA Traffic Management
3 1 12
ET=0x81 P
00 C
- Tunnel ID
SP Q- F
bit (XXX)
tag1 I
SP Payload ET=MiM s
Service 7 1 24
Tag
Reser P Service ID
Customer ved T (YYY)
Ethernet
Frame Future EVC ID
Growth. Payload Type 16M
SP FCS Vendor (data or control)
specific
fields.
ET: Ethertype
CTI: Canonical Field Identifier
Princípios do QinQ

a1 Enterprise Carrier Carrier Carrier b1


Carrier Enterprise
CPE Access Core Core Access CPE

a1 b1 Q a1 b1 Q

a1 b1 Q Q a1 b1 Q Q

a1 b1 Q Q Q a1 b1 Q Q Q
Q in Q data frame format
Customer internal MAC

P-Ethertype
C-MAC DA P-VLAN SP CoS
S TagSA CoS
C-MAC
C Tag P CFI
P VLAN ID SP EVC ID
C-Payload 4096
C-FCS

Customer original Tag


Q in Q data frame format

C-MAC DA P-Ethertype
C-MAC SA P-VLAN
S Tag CoS

C Tag P CFI B-MAC DA


P VLAN ID BBN Frame
C-Payload Header B-MAC SA
C-FCS C-MAC DA B Tag

C-MAC SA
S Tag
C Tag
C-Payload
C-FCS
BBN-FCS
Camadas de QoS
• Múltiplas tecnologias de QoS estão
disponíveis em diferentes camadas de rede
• Nenhuma tecnologia sozinha consque prover
QoS fim a fim.

Application-signaled
SIP/SDP, H.323
QoS
QoS Monitoring and
Measurement

IP QoS IP Differentiated Services (DiffServ)


Network-signaled QoS ATM PNNI, MPLS RSVP-TE or CR-LDP
Traffic Engineered
ATM PVCs, MPLS E-LSPs and L-LSPs
Paths
Ethernet 802.1p, VLANs, ATM, PPP, MPLS
Link Layer QoS EXP, DOCSIS, Frame Relay, 802.11e
WLAN QoS
Physical Layer QoS λs, Virtual Circuits (VCs), Ports, Frequencies
QoS Fim-a-Fim

QoS Monitoring / Measurement

Traffic Engineered Link Layer QoS –


Paths - MPLS Ethernet 802.1p
Link Layer QoS
– DOCSIS L3 L2
Ethernet Ethernet
Switch Switch
Cable Cable
Modem
Access
Provider OE MAN
CMTS OE
Switch
Physical Layer QoS
Network-signaled – Port Prioritization
QoS – RSVP-TE

IP QoS - DiffServ
Exemplo de CoS-based SLA

• 4 classes de serviço
• CoS determinado via 802.1p
CoS ID

Service Service Characteristics CoS ID Bandwidth Profile per Service


Class EVC per CoS ID Performance
Delay < 5ms
CIR > 0
Premium VoIP e Video 6, 7 Jitter < 1ms
EIR = 0
Loss < 0.001%
Delay < 5ms
Aplicações de Missão CIR > 0
Silver 4, 5 Jitter = N/S
Crítica (e.g. sistema ERP) EIR ≤ UNI Speed
Loss < 0.01%
Delay < 15ms
Trágo do tipo burst com CIR > 0
Bronze 3, 4 Jitter = N/S
necessidade de banda EIR ≤ UNI Speed
Loss < 0.1%
Delay < 30ms
CIR=0
Standard Best effort 0, 1, 2 Jitter = N/S
EIR=UNI speed
Loss < 0.5%
Tunelamento IEEE 802.1Q
• O objetivo do tunelamento IEEE 802.1Q é permitir que a identidade
das VLANs nas redes de acesso seja mantida através do
BACKBONE.
• Sem tunelamento, a quantidade total de VLANs numa rede é 4096.
Portas Túnel
• Os links com tunelamento são ditos
assimétricos, pois a configuração na
extremidade dos links não é a mesma.

switch cliente switch Edge

Porta IEEE 802.1Q convencional. Porta Tunel, associada a uma


Associada a múltiplas VLANs VLAN específica. e.g. 30
Double TAG
• O tunelamento é feito através de um duplo TAG.
– O TAG externo, associado ao túnel, é normalmente
referencido como metro-tag.

METRO-TAG
Inserção e Remoção de TAGs

Porta IEEE Porta IEEE Túnel


802.1Q (Remove o Metro
Vê apenas o Porta IEEE TAG)
Metro TAG 802.1Q

Switch switch switch switch Switch


Cliente Edge Core Edge Cliente

Porta IEEE
802.1Q
Porta IEEE Porta Porta IEEE Porta IEEE
802.1Q Tunel 802.1Q 802.1Q
(Acrescente o
Metro TAG)
Formatação do TAG
• Todos os quadros que atravessam a porta
túnel recebem o Metro-TAG:
– Quadros sem TAG
– Quadros com TAG
• O campo CoS do Metro-TAG é definido na
configuração da porta túnel.
• Todos os quadros que saem pela porta
túnel possuem o TAG mais externo
removido, seja ele um Metro-TAG ou não.
Native VLAN
• Portas Túnel não são trunks.
– Elas pertencem a uma VLAN de acesso.
• A VLAN de acesso de uma porta túnel
não pode coincidir com a Native VLAN de
nenhuma outra porta trunk no mesmo
switch.
– Em caso de coincidência, os pacotes
recebidos pela porta Túnel e direcionados
para porta trunk não receberão o metro TAG.
Native VLAN
• Pacotes recebidos pelo Switch A não vão receber o Metro-TAG.
– O TAG desses pacotes conterá 30 (a VLAN especificada pelo switch A).
• Os pacotes serão enviados para o Switch C, e o TAG será removido. O
pacote resultante, sem TAG será enviado erroneamente para o Switch E.

O quadro Porta túnel remove o TAG 30


atravessa a rede
com o TAG do
cliente: 30

O pacote sem tag


é enviado para o
switch errado

mesma VLAN: o quadro


não recebe metro-tag
Correção do Problema
• 1) Utilizar apenas ISL trunks entre os
switches de core
• 2) Usar vlan dot1q tag native, para obrigar
o tageamento de todos os quadros,
inclusive da native VLAN.
• 3) Fazer com que a Native VLAN dos
trunks dos switches edge nunca
coincidam com as VLANs na rede do
usuário.
Configuração Assimétrica
• Porta Túnel não é uma porta Trunk, e
dessa forma, não irá realizar auto-
negociação com a porta do outro switch.
• A porta trunk no switch da rede do usuário
deve ser configurado manualmente como
trunk.
Exercício 4
Fa0/1-5 Fa0/6-10 Fa0/1-5 Fa0/6-10

vlan1 vlan20 vlan1 vlan20


B = 10.26.136.60 C = 10.26.136.184
Porta Trunk
Fa0/23 Manual Fa0/23
Native VLAN 1

Porta Tunel
Fa0/22 Access VLAN 30 Fa0/23

Tunel Tunel
A = 10.26.136.13

Fa0/1-5 vlan1 vlan30 Fa0/6-10


Configuração
• Configuração Switch Tunel = A
– configure terminal
• interface Fa0/22 - 23
– switchport access vlan 30
– switchport mode dot1q-tunnel
– exit
• vlan dot1q tag native (opcional)
• Configuração Switch Cliente = B e C
– configure terminal
• interface Fa0/23
– switchport mode trunk
– exit
Verificação
• show running-config
• show dot1q-tunnel
• show vlan dot1q tag native
MTU
• Para suportar Metro-TAGs o MTU nas portas
trunk do switch precisa ser aumentado em pelo
menos 4 bytes.
– O MTU default para tráfego no switch é 1500 bytes.
– Com um TAG o MTU deve se de 1504 bytes
• Porta Fast-Ethernet:
– Máximo MTU 1546
• Portas Gigabit-Ethernet
– Máximo MTU 9000 bytes
• Para alterar o MTU utilize:
– system MTU
Fragmentação de datagramas
• As redes Ethernet limitam o tamanho dos quadros a
apenas 1500 bytes, enquanto os datagramas IP podem
chegar até 64 K bytes. Nesse caso, é necessário transmitir
um datragrama utilizando vários quadros.

Cabeçalho do Campo de dados do datagrama


datagrama
0 600 1200 1500 bytes

Dados1 Dados2 Dados3


o cabeçalho do
datagrama
Cabeçalho do Dados1
original é Fragmento 1 (Deslocamento 0)
datagrama
reproduzido em
cada um dos
segmentos.
Cabeçalho do Dados2 Fragmento 2 (Deslocamento 600)
datagrama

Cabeçalho do Dados3 Fragmento 3 (Deslocamento 1200)


datagrama
Formato de um datagrama
• O formato de um datagrama é mostrado abaixo:
0 4 8 12 16 20 24 28 31

Byte 1 Byte 2 Byte 3 Byte 4

VERS HLEN Tipo de serviço Comprimento total

Identificação flags Deslocamento do fragemento

Tempo de vida Protocolo Checksum do cabeçalho

Endereço IP de origem cabeçalho

Endereço IP de destino

Opções IP Preenchimento

Dados
dados
…..
Prática
• Utilizando o comando ping do Windows e
o Ethereal verifique o processo de
fragmentação do IP sobre o Ethernet.

• ping –l tamanho_mensagem_bytes
ip_destino –t

• Analise:
– Ponto de fragmentação
– Identificadores de Fragmento
Aumentar o MTU do sistema

Você também pode gostar