Você está na página 1de 12

Introduo a Algoritmos Seqenciais

Algoritmos Estruturados Prof. Robson Ferreira

Algoritmos Seqenciais
O que um algoritmo?
Um conjunto finito de regras, bem definidas, Para a soluo de um problema em um tempo finito.

Algoritmo Seqencial

A execuo das tarefas corretamente cumprida, se executarmos todos os passos (instrues) na seqncia em que elas aparecem, da primeira at a ltima, sem omisses e sem repeties.
Algoritmos Estruturados 2

Prof. Robson Ferreira

Exemplo #1
Dados trs valores positivos, a, b e c, determine a sua mdia aritmtica, harmnica, geomtrica e ponderada com pesos de 1, 2 e 3 respectivamente.

Quais as tarefas a serem executadas para a soluo deste problema?

Prof. Robson Ferreira

Algoritmos Estruturados

Entrada e Sada
Entrada Conjunto de Regras
Obter os valores para a, b e c. Calcular a mdia aritmtica. Calcular a mdia harmnica. Calcular a mdia geomtrica. Calcular a mdia ponderada. Comunicar os resultados.

Sada

Prof. Robson Ferreira

Algoritmos Estruturados

Soluo Exemplo #1a


1. 2. 3. 4. 5. 6. 7. Obter os valores para a, b e c. ma a b c 3 Calcular a mdia aritmtica. 3 Calcular a mdia harmnica. mh 1 / a 1 / b 1 / c Calcular a mdia geomtrica. mg 3 a.b.c Calcular a mdia ponderada. 1a 2b 3c mp 1 2 3 Comunicar os resultados. Terminar.
Algoritmos Estruturados 5

Prof. Robson Ferreira

Soluo Exemplo #1b


Algoritmo Declare a,b,c numrico Leia (a, b , c) Calcule as_mdias Escreva (os_resultados) Fim algoritmo Ref as_mdias Ma <=(a+b+c)/3 Mh<=3/(1/a+1/b+1/c) Mg<=(a*b*c)^(1/3) Mp<=((1*a)+(2*b)+(3*c))/(1+2+3) Fim ref
Prof. Robson Ferreira

Algoritmos Estruturados

Soluo Exemplo #1c


Algoritmo Declare a,b,c: numrico Leia (a, b , c) Calcule as_mdias Escreva (os_resultados) Fim algoritmo
Prof. Robson Ferreira

Algoritmos Estruturados

Soluo Exemplo #1d


Algoritmo Declare a,b,c : real Leia (a, b , c) Calcule a_mdia_aritmtica Calcule a_mdia_harmnica Calcule a_mdia_geomtrica Calcule a_mdia_ponderada Escreva (as_mdias) Fim algoritmo
Prof. Robson Ferreira

Algoritmos Estruturados

Exerccios
Quais os passos/regras necessrias para
1. 2.

Trocar um pneu de carro? Fazer um bolo de chocolate?

Prof. Robson Ferreira

Algoritmos Estruturados

Efetividade e Tempo
Todo o algoritmo possui pelo menos um resultado. Princpio da Efetividade

Execuo exata e em tempo finito.

Os passos devem ser precisos, no dando margem a ambigidades. Um algoritmo til deve terminar em um tempo muito finito.
Prof. Robson Ferreira

Algoritmos Estruturados

10

Critrios para um algoritmo


Ter um nmero finito de passos Os passos devem ser precisamente definidos. Existir um conjunto de zero ou mais entradas, bem definidas. Existir uma ou mais sadas. Ter um conjunto de passos que leve a execuo de uma tarefa til. Ter uma condio de fim sempre atingida para quaisquer entradas e num tempo finito.
Prof. Robson Ferreira

Algoritmos Estruturados

11

Exerccios
Escreva um algoritmo que aps ler a resistncia (R) e a tenso (V), calcule a lei de ohm (V=R*I). Escrever um algoritmo que escreve os nmeros mpares entre 10 e 20. Escrever um algoritmo que calcula e escreve o fatorial de 5.
Prof. Robson Ferreira

Algoritmos Estruturados

12