Você está na página 1de 19

Algoritmos Prof. Msc.

Wender Silva

Exerccio 01 Um cliente de um banco tem um saldo positivo de R$ 500,00. Fazer um algoritmo que leia um cheque que entrou e calcule o saldo, mostrando (escrevendo) o saldo na tela.
Tentem fazer!!!

www.estacio.br

Resoluo Exerccio 01
Algoritmo "saldo Var novo_saldo, valor_saldo, cheque_entrou: real Inicio valor_saldo <- 500; Escreva("Digite o valor do cheque que entrou: ") Leia(cheque_entrou) novo_saldo <- valor_saldo - cheque_entrou Escreva ("O saldo atual e : ", novo_saldo) fimalgoritmo

www.estacio.br

Exerccio 02
O custo ao consumir de um carro novo, a soma do custo de fbrica com a percentagem do revendedor e com o custo dos impostos (aplicados ao custo de fbrica). Supondo que a percentagem do revendedor seja de 25% do custo de fbrica e que os impostos custam 45% do custo de fbrica, faa um algoritmo que leia o valor de custo de fbrica e determine o preo final do automvel (custo ao consumidor)
www.estacio.br

Resoluo Exerccio 02
algoritmo "automovel Var custo_fabrica, perc_revendedor, impostos, preco_final: real inicio Escreva("Digite o valor do custo de fbrica deste automvel: ") Leia(custo_fabrica) perc_revendedor <- (25 * custo_fabrica)/100 impostos <- (45 * custo_fabrica) / 100 preco_final <- custo_fabrica + perc_revendedor + impostos Escreva("Custo de Fabrica: ", custo_fabrica) Escreva("Percentual Revendedor: ", perc_revendedor) Escreva("Impostos: ", impostos) Escreva("O preco final e: ", preco_final) fimalgoritmo

www.estacio.br

Exerccio 03
Duas variveis (A e B) possuem valores distintos (A <- 5 e B <- 10). Crie um algoritmo que armazene esses dois valores nessas duas variveis, e efetue a troca dos valores de forma que a varivel A passe para a varivel B e que a varivel B passe a possuir o valor da varivel A. Por fim, apresentar os valores trocados.

www.estacio.br

Resoluo Exerccio 03
algoritmo "operacoes var A, B, auxiliar: inteiro inicio A <- 5 B <- 10 auxiliar <- A A <- B B <- auxiliar Escreval("Valor de B: ", B) Escreval("Valor de A: ", A) fimalgoritmo

www.estacio.br

Exerccio 04 O sistema de avaliao de determinada disciplina, composto por trs provas. A primeira prova tem peso 2, a segunda tem peso 3 e a terceira prova tem peso 5. Faa um algoritmo para calcular a mdia final de um aluno desta disciplina.

www.estacio.br

Resoluo Exerccio 04
algoritmo "avaliacao Var prova1, prova2, prova3, media: real inicio Escreva("Digite a nota01: ")

Leia(prova1)
Escreva("Digite a nota02: ") Leia(prova2) Escreva("Digite a nota03: ") Leia(prova3) prova1<- prova1 * 2/10

prova2<- prova2 * 3/10


prova3<- prova3 * 5/10 media<- (prova1 + prova2 + prova3) Escreva("A media final e: ", media) fimalgoritmo

www.estacio.br

Exerccio 05 Uma empresa de venda de softwares paga a seu vendedor um fixo de R$ 800,00 por ms, mais uma comisso de 15% pelo seu valor de vendas no ms. Faa um algoritmo que leia o valor da venda e determine o salrio total do funcionrio. Mostre as informaes que voc achar necessrio.
www.estacio.br

Resoluo Exerccio 05
algoritmo "avaliacao Var prova1, prova2, prova3, media: real inicio Escreva("Digite a nota01: ")

Leia(prova1)
Escreva("Digite a nota02: ") Leia(prova2) Escreva("Digite a nota03: ") Leia(prova3) prova1<- prova1 * 2/10

prova2<- prova2 * 3/10


prova3<- prova3 * 5/10 media<- (prova1 + prova2 + prova3) Escreva("A media final e: ", media) fimalgoritmo

www.estacio.br

Exerccio 06 Crie um algoritmo para calcular o salrio lquido de um funcionrio, considerando que seu salrio bruto, incide um desconto de 9% em INSS para a previdncia. O algoritmo deve mostrar o nome do funcionrio, o seu salrio bruto, o valor de desconto de INSS e o seu salrio lquido.
www.estacio.br

Resoluo Exerccio 06
lgoritmo "salario var salario_liquido, salario_bruto, inss: real nome: caracter inicio

Escreva("Digite o nome do Funcionario: ")


Leia(nome) Escreva("Digite o valor do Salario Bruto: ") Leia(salario_bruto) inss <- (salario_bruto * 9) / 100 salario_liquido <- salario_bruto inss

Escreval("O Salario bruto e: ", salario_bruto)


Escreval("O Desconto de INSS e: ", inss) Escreval("O Salario Lquido e: ", salario_liquido) Escreval("Funcionario e: ", nome) fimalgoritmo

www.estacio.br

Exerccio 07.1 Crie um algoritmo que leia o valor do raio e calcule a rea do crculo correspondente. Etapa 1: o clculo da rea do crculo Pi*R2. Etapa 2: o dado necessrio o valor do raio, que ser lido (colocado) na varivel Raio.
- Faa no caderno com as especificaes do VisualG.
www.estacio.br

Exerccio 07.2 Crie um Algoritmo que leia dois valores numricos, e calcule e exiba a sua mdia aritmtica.
- Faa no caderno com as especificaes do VisualG.

www.estacio.br

Exerccio 07.3 Crie um Algoritmo que leia o nome de um aluno, as notas de suas trs provas e calcule e exibe a mdia harmnica das provas.
-Faa no caderno com as especificaes do VisualG. -A mdia harmnica dada por

www.estacio.br

Exerccio 07.4 Uma Empresa de desenvolvimento de software paga seu vendedor um fixo de R$ 500,00 por ms, mais um bnus de R$ 50,00 por sistema vendido. Faa um algoritmo que leia quantos softwares o funcionrio vendeu e determine o salrio total do funcionrio. Mostre as informaes que voc achar necessrio.
-Faa no caderno com as especificaes do VisualG.
www.estacio.br

www.estacio.br