Você está na página 1de 17

Curso : Anlise e desenvolvimento

de Sistemas

ALGORITMOS - CCT0001
Aulas 6 e 7- Estrutura condicional

Prof. Marlia S. Mendes


mariliamendes@gmail.com

ESTRUTURA CONDICIONAL
Algoritmo <nome>
Var <varivel1>, <varivel2>: <tipo>;

Incio
SE (<Condio>) ENTO <Comando1>; SENO <Comando 2>; FimSe

Fim.

ESTRUTURA CONDICIONAL
Algoritmo <nome>
Declare <varivel1>, <varivel2>: <tipo>;

Incio
SE (<Condio>) ENTO <Comando1>; <Comando 2>; SENO <Comando 3>; <Comando 4>; <Comando 5>; FimSe

Fim.

ESTRUTURA CONDICIONAL
Algoritmo <nome>
Declare <varivel1>, <varivel2>: <tipo>;

Incio
SE (<Condio>) ENTO SE (<Condio>) ENTO <Comando1>; FimSe SENO <Comando 3>; SE (<Condio>) ENTO <Comando1>; FimSe FimSe

Fim.

ESTRUTURA CONDICIONAL
Algoritmo <nome>
Declare <varivel1>, <varivel2>: <tipo>;

Incio

SE (<Condio>) E (<Condio>) ENTO <Comando1>; <Comando 2>; SENO <Comando 3>; <Comando 4>; <Comando 5>; FimSe

F V

F V

Fim.

ESTRUTURA CONDICIONAL
Algoritmo <nome>
Declare <varivel1>, <varivel2>: <tipo>;

Incio

SE (<Condio>) OU (<Condio>) ENTO <Comando1>; <Comando 2>; SENO <Comando 3>; <Comando 4>; <Comando 5>; FimSe

F V

F V

Fim.

ESTRUTURA CONDICIONAL
Algoritmo <nome>
Declare <varivel1>, <varivel2>: <tipo>;

Incio

F V

SE NO (<Condio>) ENTO <Comando1>; <Comando 2>; SENO <Comando 3>; <Comando 4>; <Comando 5>; FimSe

Fim.

ESTRUTURA CONDICIONAL
Exerccio: Faa um programa que receba dois nmeros e mostre o maior.

ESTRUTURA CONDICIONAL
Faa um programa que receba dois nmeros e mostre o maior:

Algoritmo Maior
Var n1 , n2: inteiro;

Incio
Escreva (Digite o primeiro nmero); Leia (n1); Escreva (Digite o segundo nmero); Leia (n2); Se (n1 > n2) ento Escreva (O nmero maior , n1); Seno Escreva (O nmero maior , n2); FimSe

Fim.

EXERCCIOS ESTRUTURA CONDICIONAL


2. Faa um algoritmo que receba 3 notas de um estudante, calcule sua mdia aritmtica e verifique se ele est aprovado ou no. A mdia na sua instituio de ensino 6,0.

EXERCCIOS ESTRUTURA CONDICIONAL


3. Faa um programa que receba duas notas, calcule e mostre a mdia aritmtica e a mensagem que est na tabela a seguir:

EXERCCIOS ESTRUTURA CONDICIONAL


4. Faa um programa que receba a idade de uma pessoa e mostre se ela maior de idade ou no. 5. Faa um programa que receba trs nmeros e mostreos em ordem crescente. 6. Faa um programa que mostre o menu de opes a seguir, receba a opo do usurio e os dados necessrios para executar cada operao Menu de opes: 1. Somar dois nmeros 2. Calcular a raiz quadrada de um nmero

EXERCCIOS ESTRUTURA CONDICIONAL


7. Faa um algoritmo que dado dois nmeros inteiros, verifique qual o maior e mostre: O resultado da diviso do maior pelo menor; O resto da diviso do maior pelo menor 8. Faa um programa que receba um nmero inteiro e verifique se esse nmero par ou impar.

9. Faa um programa que verifique a validade de uma senha fornecida ao usurio. A senha 4561. O programa deve mostrar uma mensagem de permisso de acesso ou no.

EXERCCIOS ESTRUTURA CONDICIONAL


10.

EXERCCIOS ESTRUTURA CONDICIONAL


11. Faa um algoritmo que receba um nmero e diga se este nmero est no intervalo entre 100 e 200 (inclusive). 12. Faa um algoritmo que receba dois nmeros e execute uma das operaes listadas a seguir, de acordo com a escolha do usurio. Se for digitada uma opo invlida mostrar mensagem de erro e terminar a execuo do programa. As opes so: 1. Mdia entre os dois nmeros; 2. Diferena do maior pelo menor; 3. O produto entre os dois nmeros.

EXERCCIOS ESTRUTURA CONDICIONAL


13. Uma empresa decide dar um aumento d 30%aos funcionrios com salrios inferiores a R$ 500,00. Faa um algoritmo que receba o salrio do funcionrio e mostre o valor do salrio reajustado ou uma mensagem, caso o funcionrio no tenha direito ao aumento.

EXERCCIOS ESTRUTURA CONDICIONAL


14. Faa um algoritmo para calcular e mostrar o salrio reajustado de um funcionrio. Sabe-se que o percentual de aumento o mesmo da tabela a seguir: