Você está na página 1de 9

Prof.

: Carlos Alberto
E-mail: carlos.batista@facape.br
carlos36_batista@yahoo.com.br
Algoritmos
Estruturas Seqenciais
De forma genrica, a construo de um algoritmo
se resume s seguintes etapas:

entendimento do problema;
elaborao da soluo algortmica; e
codificao da soluo no Portugus Estruturado.

Geralmente a etapa 2 a mais complexa, pois
depende da engenhosidade e experincia do
construtor.
Estruturas Seqenciais
Os comandos so executados numa seqncia
pr-estabelecida.

A passagem para o prximo passo automtica
e cada passo executado uma nica vez.

algoritmo exemplo_sequencial
var
x, y: inteiro
inicio
escreva(Informe o valor de x: )
leia (x)
y := 2 * x
escreva (O valor de y , y)
fimalgoritmo
Estruturas Seqenciais
Exemplo
Enunciado: Faa um programa que leia dois
valores numricos, e calcule e exiba a sua
mdia aritmtica.

1 Passo
Sabemos que a mdia aritmtica de dois
valores calculada como (a+b)/2
2 Passo
Os dados necessrios sero os dois valores,
que colocaremos em duas variveis A e B, do
tipo numrico, e uma terceira varivel, que
chamaremos Mdia, que armazenar a
mdia aritmtica calculada.

Estruturas Seqenciais
Exemplo
Enunciado: Faa um programa que leia dois
valores numricos, e calcule e exiba a
sua mdia aritmtica.
3 Passo
A obteno dos dados neste programa
simples e direta. Basta pedir ao usurio que
digite os valores.
4 Passo
O processamento aqui o clculo da mdia.
O resultado do clculo ser armazenado na
varivel Mdia.
5 Passo
Exibir o contedo da varivel Mdia.

Estruturas Seqenciais

algoritmo "Clculo de Mdia Aritmtica"
var
A,B,Media : real
inicio
escreval (Calcula a mdia aritmtica de dois valores.")
escreva ("Digite um valor : ")
leia (A)
escreva ("Digite outro valor : ")
leia (B)
Media := (A+B)/2
escreval ("A mdia dos dois valores : ", Media)
fimalgoritmo
Estruturas Seqenciais
Exerccios
1. Faa um algoritmo que l o nome de um aluno,
as notas de suas trs provas e calcule e exibe a
mdia harmnica das provas.

2. Faa um algoritmo que l o valor do raio e
calcule a rea do crculo correspondente.

3. Calcular e apresentar o volume um cilindro.

Estruturas Seqenciais
Exerccios
4. Elabore algoritmos para resolver o que se pede:
a. Leia seu nome, endereo, telefone, ano de
nascimento, ano atual, e escreva na tela. Calcule
a sua idade e escreva na tela.
b. Dado o preo de um produto em reais, converter
este valor para o equivalente em dlares. O
algoritmo dever ler o preo e a taxa de
converso para o dlar.
c. Calcular a rea do trapzio. O usurio dever
informar a base maior, a base menor e a altura.

Estruturas Seqenciais


Resolver os exerccios das pginas 38 a 41 da
apostila do Visualg, disponvel em
www.facape.br/carlos.