Você está na página 1de 34

UNIVERSIDAD SAN LUIS GONZAGA

ARQUITECTURA DE REDES Y PROTOCOLOS


CONCEPTO DE PROTOCOLOS






PROF. ING. JAVIER RIVAS LEON
EL ROUTER
Es un dispositivo de hardware para interconexin de red de datos que opera
en la capa tres (nivel de red).

Es un dispositivo para la interconexin de redes informticas que permite
asegurar el enrutamiento de paquetes entre redes o determinar la mejor ruta
que debe tomar el paquete de datos.

SIMBOLOGIA DE ROUTERS
CISCO


SIMBOLOGIA DE SWITCH
CISCO

EJEMPLO DE APLICACION
Typical Networking Scheme of MPLS VPN Typical Networking Scheme of Core Router of
Enterprise Network
EJEMPLO DE APLICACION
RECONOCIMIENTO DE PUERTOS
PUERTOS SERIALES
PUERTOS
FAST ETHERNET

PUERTO
CONSOLA

PUERTO
AUXILIAR


CONEXIN
ENERGIA
VAC

VISTAS
MODULARES
DEL ROUTER
PARTE POSTERIOR
HARDWARE DEL ROUTER
HARDWARE DEL ROUTER
Los componentes bsicos de la arquitectura interna de un router comprenden:
CPU:
La unidad central de procesamiento. (CPU) ejecuta las instrucciones del sistema
operativo. Estas funciones incluyen la inicializacin del sistema, las funciones de
enrutamiento y el control de la interfaz de red. La CPU es un microprocesador. Los
grandes routers pueden tener varias CPU.
RAM:
La memoria de acceso aleatorio (RAM) se usa para la informacin de las
tablas de enrutamiento, el cach de conmutacin rpida, la configuracin
actual y las colas de paquetes. En la mayora de los routers, la RAM
proporciona espacio de tiempo de ejecucin para el software IOS de
Cisco y sus subsistemas. El contenido de la RAM se pierde cuando se
apaga la unidad. En general, la RAM es una memoria de acceso aleatorio
dinmica (DRAM) y puede actualizarse agregando ms Mdulos de
memoria en lnea doble (DIMM).
HARDWARE DEL ROUTER
Memoria flash:
La memoria flash se utiliza para almacenar una imagen completa del
software IOS de Cisco. Normalmente el router adquiere el IOS por
defecto de la memoria flash. Estas imgenes pueden actualizarse
cargando una nueva imagen en la memoria flash. El IOS puede estar
comprimido o no. En la mayora de los routers, una copia ejecutable del
IOS se transfiere a la RAM durante el proceso de arranque. En otros
routers, el IOS puede ejecutarse directamente desde la memoria flash.
Agregando o reemplazando los Mdulos de memoria en lnea simples
flash (SIMMs) o las tarjetas PCMCIA se puede actualizar la cantidad de
memoria flash.
NVRAM:
La memoria de acceso aleatorio no voltil (NVRAM) se utiliza para
guardar la configuracin de inicio. En algunos dispositivos, la NVRAM se
implementa utilizando distintas memorias de solo lectura programables,
que se pueden borrar electrnicamente (EEPROM). En otros dispositivos,
se implementa en el mismo dispositivo de memoria flash desde donde se
carg el cdigo de arranque. En cualquiera de los casos, estos
dispositivos retienen sus contenidos cuando se apaga la unidad.
HARDWARE DEL ROUTER
Buses:
La mayora de los routers contienen un bus de sistema y un bus de CPU.
El bus de sistema se usa para la comunicacin entre la CPU y las
interfaces y/o ranuras de expansin. Este bus transfiere los paquetes
hacia y desde las interfaces.

La CPU usa el bus para tener acceso a los componentes desde el
almacenamiento del router. Este bus transfiere las instrucciones y los
datos hacia o desde las direcciones de memoria especificadas.
HARDWARE DEL ROUTER
ROM:
La memoria de solo lectura (ROM) se utiliza para almacenar de forma
permanente el cdigo de diagnstico de inicio (Monitor de ROM). Las
tareas principales de la ROM son el diagnstico del hardware durante
el arranque del router y la carga del software IOS de Cisco desde la
memoria flash a la RAM. Algunos routers tambin tienen una versin
ms bsica del IOS que puede usarse como fuente alternativa de
arranque. Las memorias ROM no se pueden borrar. Slo pueden
actualizarse reemplazando los chips de ROM en los tomas.
HARDWARE DEL ROUTER
Interfaces:
Las interfaces son las conexiones de los routers con el exterior. Los tres
tipos de interfaces son la red de rea local (LAN), la red de rea amplia
(WAN) y la Consola/AUX. Las interfaces LAN generalmente constan de
uno de los distintos tipos de Ethernet o Token Ring. Estas interfaces tienen
chips controladores que proporcionan la lgica necesaria para conectar el
sistema a los medios. Las interfaces LAN pueden ser configuraciones fijas
o modulares.

Las interfaces WAN incluyen la Unidad de servicio de canal (CSU)
integrada, la RDSI y la serial. Al igual que las interfaces LAN, las interfaces
WAN tambin cuentan con chips controladores para las interfaces. Las
interfaces WAN pueden ser de configuraciones fijas o modulares.
Los puertos de Consola/AUX son puertos seriales que se utilizan
principalmente para la configuracin inicial del router. Estos puertos no son
puertos de networking. Se usan para realizar sesiones terminales desde
los puertos de comunicacin del computador o a travs de un mdem.
HARDWARE DEL ROUTER
Fuente de alimentacin: La fuente de alimentacin brinda la energa
necesaria para operar los componentes internos. Los routers de mayor
tamao pueden contar con varias fuentes de alimentacin o fuentes
modulares. En algunos de los routers de menor tamao, la fuente de
alimentacin puede ser externa al router.
La tecnologa de routers est basada en su sistema operativo, que es el software que
controla las funciones de enrutamiento y conmutacin de los dispositivos de red.

Los fabricantes denominan a su sistema operativo como un Sistema operativo de
internetworking. Sin un sistema operativo, el hardware no puede hacer ninguna funcin.

El sistema operativo brinda los siguientes servicios de red:

Funciones bsicas de enrutamiento y conmutacin
Acceso confiable y seguro a los recursos de la red
Escalabilidad de la red


La interfaz de lnea de comando (CLI) usa una estructura jerrquica. Esta estructura
requiere el ingreso a distintos modos para realizar tareas particulares. Por ejemplo, para
configurar una interfaz del router, el usuario debe ingresar al modo de configuracin de
interfaces.
INTERFAZ DE USUARIO
La peticin de entrada del router cambia para sealar el modo de configuracin en uso y
slo acepta los comandos que son adecuados para ese modo.

El IOS suministra un servicio de intrprete de comandos, denominado comando
ejecutivo (EXEC). Luego de ingresar un comando, el EXEC lo valida y ejecuta.
Permite slo una cantidad limitada
de comandos de monitoreo bsicos.
No permite ningn comando que
pueda cambiar la configuracin del
router.
Modo EXEC Smbolo Usos tpicos
usuario GAD> Verificar el estado del
router
Privilegiado GAD# Acceso al router modos
de configuracin Da acceso a todos los comandos
del router. Se puede configurar este
modo para que solicite una
contrasea del usuario antes de dar
acceso. Permite que slo los
usuarios autorizados puedan
ingresar al router
INTERFAZ DE USUARIO
INTERFAZ DE USUARIO
- El modo EXEC usuario se
puede reconocer por la peticin
de entrada: ">".
- El modo EXEC privilegiado se
puede reconocer por la peticin
de entrada "#".
ACTIVACION DEL ROUTER
Para ello, las rutinas de inicio deben:

- Asegurarse de que el hardware del router est en perfectas condiciones y funcional.
- Encontrar y cargar el software IOS.
- Encontrar y aplicar el archivo de configuracin inicial o entrar al modo de
configuracin inicial (setup).
CONFIGURACION DEL ROUTER
Modos de comando CLI Comand Line Interface
CONFIGURACIONES DEL ROUTER
Configuracin del nombre
del router
Router(config)#hostname URPtelecom
URPtelecom(config)#
Contrasea de consola Router(config)#line console 0
Router(config-line)#password cisco
Router(config-line)#login
Contrasea de terminal
virtual
Router(config)#line vty 0 4
Router(config-line)#password cisco
Router(config-line)#login
Permita la palabra de
acceso
Router(config)#enable password electron-urp
Ejecutar cifrado de
contrasea
Router(config)#service password-encryptation
Router(config)#enable secret <password>
CONFIGURACIONES DEL ROUTER
enable password y enable secret :

Se utilizan para restringir el acceso al modo EXEC privilegiado.
El comando enable password se utiliza slo si no se ha configurado previamente
enable secret.

Router(config)#enable password<password>
Router(config)#enable secret<password>


show running-config o show startup-config

El siguiente comando se utiliza para cifrar las contraseas al mostrar los datos de
configuracin.

Router(config)#service password-encryption
CONFIGURACIONES DEL ROUTER
show interfaces
Muestra las estadsticas completas
de todas las interfaces del router

Router#show interfaces serial 0/1
show controllers serial
muestra informacin especfica de la
interfase de hardware

Router#show controllers serial 0/1
show clock
Muestra la hora fijada en el router
show hosts Muestra la lista en cach de los nombres de
host y sus direcciones.
show users
Muestra todos los usuarios conectados al
router.
show flash
Muestra informacin acerca de la memoria
flash y cules archivos IOS se encuentran
almacenados all.
UTILIZACION DE LOS COMANDOS SHOW
CONFIGURACIONES DEL ROUTER

El argumento tipo incluye serial,
ethernet, fastethernet, token ring y
otros

Router(config)#interface type port
Router(config)#interface type slot/port

Se utiliza para desactivar la interfaz
de forma administrativa

Router(config-if)#shutdown
se utiliza para activar una interfaz
que se ha desactivado

Router(config-if)#no shutdown

se utiliza para salir del modo de
configuracin de interfaz actual

Router(config-if)#exit

CONFIGURACION DE UNA INTERFAZ SERIAL
CONFIGURACIONES DEL ROUTER
A cada interfaz serial activa se le debe asignar una direccin de IP y la
correspondiente mscara de subred, si se requiere que la interfaz enrute
paquetes de IP.

Router(config)#interface serial 0/0
Router(config-if)#ip address <ip address> <netmask>


Los comandos para fijar la velocidad de sincronizacin y activar una interfaz
serial son los siguientes:

Router(config)#interface serial 0/0
Router(config-if)#clock rate 56000
Router(config-if)#no shutdown

CONFIGURACION DE UNA INTERFAZ SERIAL
CONFIGURACIONES DEL ROUTER

La resolucin de nombres de host es el mecanismo que utiliza un
computador para relacionar un nombre de host con una direccin de IP.

Router(config)#ip host machupicchu 172.17.10.1
Router(config)#ip host nazca 190.15.10.1
Router(config)#ip host mochica 10.170.1.1

RESOLUCION DE NOMBRES DE DIRECCIONES DE HOST
Ejemplo prctico1 - CONFIGURACION

So
S1
Fo
Fo
10.1.1.0 /30
196.20.10.0 /24 200.15.1.0 /24
Ejemplo prctico1 - CONFIGURACION

Activacin del password de consola

R# configure terminal
R(config)# line console 0
R(config-line)# password cisco
R(config-line)# login <opcional>


Activacin del password Terminal virtual

R(config)# line vty 0 4
R(config)# password cisco
R(config)# login
Ejemplo prctico1 - CONFIGURACION

Configuracin de las Interfaces Ethernet y Seriales de R0

R> enable
R> configure terminal
R(config)# interface fastethernet 0/0
R(config-ip)# ip address 196.20.10.0 255.255.255.0
R(config-ip)# no shutdown

R(config-ip)# enable
R# show controllers serial2/0 visualiza los controladores

R# configure Terminal
R(config)# interface serial2/0
R(config)# clock rate 125000
R(config)# encapsulation hdlc
R(config)# ip address 10.1.1.2 255.255.255.252
R(config)# no shutdown
Ejemplo prctico1 - CONFIGURACION

Configuracin de las Interfaces Ethernet y Seriales de R1

R> enable
R> configure terminal
R(config)# interface fastethernet 0/0
R(config-ip)# ip address 200.15.1.0 255.255.255.0
R(config-ip)# no shutdown

R(config-ip)# enable
R# show controllers serial2/0 visualiza los controladores

R# configure Terminal
R(config)# interface serial2/0
R(config)# clock rate 125000
R(config)# encapsulation hdlc
R(config)# ip address 10.1.1.3 255.255.255.252
R(config)# no shutdown
VLSM
MASCARA DE SUBRED DE LONGITUD VARIABLE
10.1.1.0 /30
198.20.1.0 /24
192.1.12.0 /24
2
1
3
4
5
Ejemplo de
aplicacin
198.10.10.0 /24
VLSM

MASCARA DE
SUBRED DE
LONGITUD
VARIABLE

Esta tcnica es utilizada
con el fin de evitar el
desperdicio de direcciones
IP y subredes.

Para el ejemplo se tienen
las siguientes direcciones
IP y subredes:
10.1.1. 0 0 0 0 0 0 0 0
10.1.1. 0 0 0 0 0 0 1 1
10.1.1.0 /30
10.1.1.3 /30
WAN1
10.1.1. 0 0 0 0 0 1 0 0
10.1.1. 0 0 0 0 0 1 1 1
10.1.1.4 /30
10.1.1.7 /30
WAN2

10.1.1. 0 0 0 0 1 0 0 0
10.1.1. 0 0 0 0 1 0 1 1
10.1.1.8 /30
10.1.1.11 /30
WAN3

10.1.1. 0 0 0 0 1 1 0 0
10.1.1. 0 0 0 0 1 1 1 1
10.1.1.12 /30
10.1.1.15 /30
WAN4

10.1.1. 0 0 0 1 0 0 0 0
10.1.1. 0 0 0 1 0 0 1 1
10.1.1.16 /30
10.1.1.19 /30
WAN5

10.1.1. 0 0 0 1 0 1 0 0
10.1.1. 0 0 0 1 0 1 1 1
10.1.1.20 /30
10.1.1.23 /30
WAN6

10.1.1. 0 0 0 1 1 0 0 0
10.1.1. 0 0 0 1 1 0 1 1
10.1.1.24 /30
10.1.1.27 /30
WAN7

10.1.1. 0 0 0 1 1 1 0 0
10.1.1. 0 0 0 1 1 1 1 1
10.1.1.28 /30
10.1.1.31 /30
WAN8

VLSM
Para
Enlaces
WAN
ID
host
Ejemplo de aplicacin VLSM
198.20.1.0 /24
192.1.12.0 /24
2
1
3
4
5
Ejemplo de
aplicacin
198.10.10.0 /24
10.1.1.1 /30
10.1.1.2 /30
10.1.1.5 /30
10.1.1.6 /30
10.1.1.9 /30
10.1.1.10 /30
10.1.1.13 /30
10.1.1.14 /30
10.1.1.17 /30
10.1.1.18 /30
Ejemplo de aplicacin VLSM
ROUTER RED DE
DESTINO
MASCARA DE
SUBRED
SALTO
SIGUIENTE

ROUTER0
198.20.1.0
198.10.10.0
255.255.255.0
255.255.255.0
10.1.1.2
10.1.1.6

ROUTER1
192.1.12.0
198.10.10.0
198.10.10.0
255.255.255.0
255.255.255.0
255.255.255.0
10.1.1.1
10.1.1.1
10.1.1.10

ROUTER3
192.1.12.0
198.20.1.0
198.20.1.0
255.255.255.0
255.255.255.0
255.255.255.0
10.1.1.5
10.1.1.14
10.1.1.5

ROUTER4
198.10.10.0
192.1.12.0
198.20.1.0
255.255.255.0
255.255.255.0
255.255.255.0
10.1.1.13
10.1.1.17
10.1.1.9
TABLAS DE ENRUTAMIENTO