Você está na página 1de 55

EtherChannel/IEEE 802.

3ad
Tunelamento VLAN /IEEE 802.3ac
Q-in-Q/IEEE 802.1ad
MAC-in-MAC/IEEE 802.1 ah
MPLS

EtherChannel
Agregao de Portas:
Etherchannel um padro
que permite agregar
mltiplas portas de
caractersticas comuns a fim
de formar uma porta de
maior capacidade.

Atualmente possvel
criar portas agregadas
full-duplex com at 800
Mbps (Fast) ou 8 Gbps
(Giga)
O nmero total de
Etherchannels 48.

Modos EtherChannel
Apenas portas trunk com caractersticas
idnticas podem ser agregadas.
A configurao pode ser:
Automtica:
PAgP: Port Aggregation Protocol
LACP: Link Aggregation Control Protocol

Manual:
On: sem protocolo de negociao
Usado apenas para compatibilidade entre switches
que no suportam os protocolos de negociao.

Identificao da Porta Agregada


As portas Etherchannel so identificadas por uma interface lgica
(Logical port-channel), numerada de 1 at 8.
Comandos aplicados a interface lgica afetam simultaneamente todas as
portas do grupo.
Comandos aplicados as portas fsicas no afetaro as demais portas do
grupo

Quando o grupo criado pela primeira


vez, as portas seguem a configurao
da primeira porta do grupo:
Allowed-VLAN list
Spanning-tree path cost for each VLAN
Spanning-tree port priority for each VLAN
Spanning-tree Port Fast setting

PAgP Port Aggregation Protocol


Protocolo proprietrio da cisco
Apenas para switches simples, no funciona em
stacks.

Agrupa automaticamente portas com as


mesmas caractersiticas:
Velocidade, modo duplex, native VLAN, VLAN range,
trunking status.
Porta Access devem pertencer a mesma VLAN
Portas Trunk devem pertencer a mesma native VLAN

O grupo de portas passado ao protocolo


Spanning-Tree como sendo uma porta nica.
Permite agregar at 8 portas.

Modos PAgP
Auto: modo passivo que apenas responde a
solicitao para entrar no grupo.
Desirable: modo ativo, que solicita a outra porta
entrar no modo Etherchannel.
Desirable

Desirable

Desirable

Auto

Auto

Auto

Auto
Desirable
(Silent mode)

No PAgP
Se no for usado o modo silent, a porta
no entra em operao

Endereo MAC
A primeira porta do Etherchannel que se
torna ativa prov o endereo MAC para
todo o grupo.
Se a porta que cedeu o MAC for
removida, outra porta oferecer o
endereo para o grupo.
As mensagens PAgP so enviadas na
menor VLAN associada a porta.

LACP: Link Aggregation Control


Protocol
Padro IEEE 802.3ad
Operao similar ao PAgP, mas suporta
tambm stack switching.
Modos de operao:
Passivo
Similar ao modo auto PAgP

Ativo
Similar ao modo desirable PAgP

A escolha do MAC similar ao PAgP


Permite agregar at 16 portas, mas
apenas 8 esto ativas num dado instante.

Configurao do EtherChannel
Step 1:
configure terminal

Step 2:
interface interface-id

Step 3:
switchport mode {access | trunk}
switchport access vlan vlan-id

Step 4:
channel-group channel-group-number mode
{auto [non-silent] | desirable [non-silent] | on} | {active | passive}
PaGP: Auto/Desirable
LACP: Active/Passive

Step 5:
end

Step 6:
show running-config

Remover a porta do Channel Group

Step 1:

configure terminal

Step 2:

interface interface-id

Step 3:

no channel-group

Step 4:

end

Step 5:

show running-config

Exerccio 1
Fa0/1-5

Fa0/6-10
vlan1

Fa0/1-5

vlan20

vlan1

B = 10.26.136.60
Fa0/23

vlan20

C = 10.26.136.184
Fa0/24

Fa0/23

Fa0/24

Ether 1
Fa0/18

Fa0/6-10

Ether 2
Fa0/19

Fa0/20

Fa0/21

A = 10.26.136.13
vlan1
Fa0/1-5

vlan20
Fa0/6-10

Comandos
2950 -A
configure terminal
interface range Fa0/18-19
channel-group 1 mode desirable
end

interface range Fa0/20-21


channel-group 2 mode desirable
exit

2950 -B
configure terminal
interface range Fa0/23-24
channel-group 1 mode desirable
end

2950 -C
configure terminal
interface range Fa0/23-24
channel-group 2 mode desirable
end

Verificando a Configurao
Para zerar os contadores:
clear pagp {channel-group-number counters | counters}
clear lacp {channel-group-number counters | counters}

Verifique a configurao
Comandos
show etherchannel ?
show interface ?
show pagp ?

Acrescente mais uma porta no


etherchannel e veja a alterao da
configurao
Desconecte o cabo da nova porta, e aps
verificar o efeito no switch, remova a porta
do Etherchannel

Balanceamento de Carga
O balanceamento de carga pode ser feito com
base:
Endereo Mac de Origem
Pacotes com o mesmo MAC de origem so sempre
alocados na mesma porta do grupo.
Diferentes MACs de origem so distribudos entre as portas.
A
B

C
D
E
F

Balanceamento de Carga
Endereo Mac de Destino
Pacotes com o mesmo MAC de destino so sempre
alocados na mesma porta do grupo.
Diferentes MACs de destino so distribudos entre os pares

Ambos
Mantm na mesma porta apenas o fluxo de quadro trocado
entre os mesmos parceiros.
A
B

C
D
E
F

Escolha do Mtodo de Balanceamento


A escolha do
mtodo depende
da topologia de
rede.
O mtodo deve
ser escolhido de
maneira a prover a
mxima utilizao
de porta no
Etherchannel.

Configurao Default

Balanceamento de Carga
configure terminal
port-channel load-balance {dst-ip | dst-mac
| src-dst-ip | src-dst-mac | src-ip | src-mac}
end

show etherchannel load-balance

Exerccio 2 - SPT com EtherChannel


Fa0/1-5

Fa0/6-10
vlan1

Fa0/1-5

Ether 3

vlan20

vlan1

Fa0/21

B = 10.26.136.60
Fa0/23

Fa0/6-10
vlan20

C = 10.26.136.184
Fa0/24

Fa0/22

Fa0/23

Fa0/24

Ether 2

Ether 1

Fa0/18

Fa0/19

Fa0/20

A = 10.26.136.13
vlan1
Fa0/1-5

vlan20
Fa0/6-10

Fa0/21

Comandos
2950 -B
configure terminal
interface range Fa0/21 - 22
channel-group 3 mode desirable
end

2950 -C
configure terminal
interface range Fa0/21 - 22
channel-group 2 mode desirable
end

Trabalhando com as Portas Lgicas


Os comandos de configurao do SPT
podem ser aplicados aos
EtherChannels alterando-se a seleo
da interface para:
interface port-channel port-channel-number

Para apagar um EtherChannel


no interface port-channel port-channelnumber

Exerccio 3 - Balanceamento de Carga


Vlan 20
prio 16
Fa0/1-5

Fa0/6-10
vlan1

Fa0/1-5

Ether 3

vlan20

vlan1

Fa0/21

B = 10.26.136.60
Fa0/23

Fa0/6-10
vlan20

C = 10.26.136.184
Fa0/24

Fa0/22

Fa0/23

Fa0/24

Ether 2

Ether 1

Fa0/18

Fa0/19

Fa0/20

A = 10.26.136.13
vlan1
Fa0/1-5

vlan20
Fa0/6-10

Fa0/21

Comandos: 2950
Switch B
configure terminal
interface port-channel 3
spanning-tree vlan 20 port-priority 16
end

show interface trunk


show spanning tree

Switch C
idem

Configuraes Adicionais
Hot-StandBy
Portas Hot-StandBy so portas que s se
tornam ativas quando alguma outra porta no
pode mais operar.
LACP: Quando mais de 8 portas so colocadas no
grupo, as demais entram em Hot-Standby. A
escolha das portas pode ser feita por prioridade
PAgP: Pode-se colocar uma porta em maior
prioridade, fazendo-se com que as demais entrem
em Hot-Standby para operao.

Arquitetura Metro Ethernet


Q-in-Q e MAC-in-MAC

WAN

User-facing provider edge (U-PE)


Network-facing provider edge (N-PE)
Provider edge aggregation (PE-AGG)

Ethernet access domains [EADs]

Intra-EAD and Inter-EAD Services

Blocos Funcionais
USURIO

ACESSO

CORE
QinQ
ou
MinM

U-PE
Q
Qin

WAN

MPLS

PE
N-PE

MPLS
Networks

MinM e QinQ
Customer
Prem Access

Metro Ethernet
Access/Aggregation
QinQ
Or
MinM

50ms Ethernet
Access Ring
U-PE

Metro Core
QinQ
Or
MinM

WAN

MPLS

MPLS
Networks

N-PE

Q
Qin

nM
Mi

Os novos padres QinQ e MinM so utilizados para prover


escalabilidade na construo de backbones
metropolitanos.

Gerenciamento em Ethernet
Gerenciamento Ethernet
Customer
Premises

CPE

CO/POP
Ethernet

NTU

Backbone
Access
Aggregator

O gerenciamento da camada Ethernet inclui:


Marcao e Re-Marcao de TAGs VLAN
Gerenciamento de Banda
Alarmes de falha e diagnsticos

Edge
Device

QinQ e MinM
IEEE802.1ad QinQ (Stacked VLAN)
IEEE802.1ah MinM (Backbone Provider Bridge)
MinM
Dados

Cabealho
na rede do
usurio

QinQ
Cabealho
do Service
Provider

Um novo cabealho acrescido pelo


SP contm endereos MAC
Permite a reutilizao de VLANs no
cabealho do usurio.

Cabealho
Dados da rede do
usurio

VLAN IDs

As VLANs ID so colocadas no
cabealho da rede do usurio.
Permite a reutilizao de VLANs nos
sub-campos

Princpio MinM
Pacotes Ethernet
Chegam da rede
da empresa

O switch de borda
acrescenta um
novo cabealho
(SP) com
endereos MAC

O pacote
encaminhado pela
rede utilizando as
informaes do
cabealho SP

O switch de sada
remove o
cabealho SP

Ethernet
Switches

Site Y

Ethernet
UNI
(destination)

Site X

Ethernet
UNI
(source)

Service Provider
Metro Ethernet
network

User
data

Enterprise
Ethernet
header

SP Ethernet
header

Quadro Mac-in-Mac
Destination MAC address

SP MAC
DA
SP Header

If destination unknown, then


0xFFFFFF

Source MAC address

SP MAC
SA

Traffic Management
3

ET=0x81
00
SP Payload

Pbit
s

SP Qtag1
ET=MiM
Service
Customer
Tag
Ethernet
Customer
Frame
Ethernet
Frame
SP FCS

Reser P
ved
T
Future
Growth.
Vendor
specific
fields.

C
F
I

12

Tunnel ID
(XXX)
24

Service ID
(YYY)
Payload Type
(data or control)

EVC ID
16M

ET: Ethertype
CTI: Canonical Field Identifier

Princpios do QinQ

a1

Enterprise
CPE

Carrier
Access

Carrier
Core

Carrier
Core

Carrier
Access

a1 b1 Q

a1 b1

a1 b1 Q Q

a1 b1

a1 b1

Q Q Q

a1 b1

b1

Enterprise
CPE

Q Q Q

Q Q

Q in Q data frame format


Customer internal MAC
P-Ethertype
C-MAC DA
S TagSA
C-MAC

P-VLAN
CoS

C Tag

P CFI

C-Payload

P VLAN ID

C-FCS
Customer original Tag

SP CoS

SP EVC ID
4096

Camadas de QoS
Mltiplas tecnologias de QoS esto
disponveis em diferentes camadas de rede

QoS Monitoring and


Measurement

Nenhuma tecnologia sozinha consque prover


QoS fim a fim.

Application-signaled
QoS

SIP/SDP, H.323

IP QoS

IP Differentiated Services (DiffServ)

Network-signaled QoS

ATM PNNI, MPLS RSVP-TE or CR-LDP

Traffic Engineered
Paths

ATM PVCs, MPLS E-LSPs and L-LSPs

Link Layer QoS

Ethernet 802.1p, VLANs, ATM, PPP, MPLS


EXP, DOCSIS, Frame Relay, 802.11e
WLAN QoS

Physical Layer QoS

s, Virtual Circuits (VCs), Ports, Frequencies

QoS Fim-a-Fim

QoS Monitoring / Measurement


Traffic Engineered
Paths - MPLS

Link Layer QoS


DOCSIS
Cable
Modem

Cable
Access
Provider
CMTS

Link Layer QoS


Ethernet 802.1p
L3
Ethernet
Switch

OE MAN
Network-signaled
QoS RSVP-TE
IP QoS - DiffServ

OE
Switch

L2
Ethernet
Switch

Physical Layer QoS


Port Prioritization

Exemplo de CoS-based SLA

Service
Class

Service Characteristics

Premium VoIP e Video

Silver

Bronze

Aplicaes de Misso
Crtica (e.g. sistema ERP)
Trgo do tipo burst com
necessidade de banda

Standard Best effort

CoS ID

4 classes de servio
CoS determinado via 802.1p
CoS ID

Bandwidth Profile per


EVC per CoS ID

Service
Performance

6, 7

CIR > 0
EIR = 0

Delay < 5ms


Jitter < 1ms
Loss < 0.001%

4, 5

CIR > 0
EIR UNI Speed

Delay < 5ms


Jitter = N/S
Loss < 0.01%

3, 4

CIR > 0
EIR UNI Speed

Delay < 15ms


Jitter = N/S
Loss < 0.1%

CIR=0
EIR=UNI speed

Delay < 30ms


Jitter = N/S
Loss < 0.5%

0, 1, 2

Tunelamento IEEE 802.1Q

O objetivo do tunelamento IEEE 802.1Q permitir que a identidade


das VLANs nas redes de acesso seja mantida atravs do
BACKBONE.
Sem tunelamento, a quantidade total de VLANs numa rede 4096.

Portas Tnel
Os links com tunelamento so ditos
assimtricos, pois a configurao na
extremidade dos links no a mesma.

switch cliente

Porta IEEE 802.1Q convencional.


Associada a mltiplas VLANs

switch Edge

Porta Tunel, associada a uma


VLAN especfica. e.g. 30

Double TAG
O tunelamento feito atravs de um duplo TAG.
O TAG externo, associado ao tnel, normalmente
referencido como metro-tag.

METRO-TAG

Insero e Remoo de TAGs

Porta IEEE
802.1Q
V apenas o
Metro TAG

Switch
Cliente

Porta IEEE
802.1Q

switch
Edge

Porta
Tunel
(Acrescente o
Metro TAG)

switch
Core

Porta IEEE
802.1Q

Porta IEEE
802.1Q

switch
Edge

Porta IEEE
802.1Q

Porta IEEE Tnel


(Remove o Metro
TAG)

Switch
Cliente

Porta IEEE
802.1Q

Formatao do TAG
Todos os quadros que atravessam a porta
tnel recebem o Metro-TAG:
Quadros sem TAG
Quadros com TAG

O campo CoS do Metro-TAG definido na


configurao da porta tnel.
Todos os quadros que saem pela porta
tnel possuem o TAG mais externo
removido, seja ele um Metro-TAG ou no.

Native VLAN
Portas Tnel no so trunks.
Elas pertencem a uma VLAN de acesso.

A VLAN de acesso de uma porta tnel no


pode coincidir com a Native VLAN de
nenhuma outra porta trunk no mesmo
switch.
Em caso de coincidncia, os pacotes
recebidos pela porta Tnel e direcionados
para porta trunk no recebero o metro TAG.

Native VLAN

Pacotes recebidos pelo Switch A no vo receber o Metro-TAG.


O TAG desses pacotes conter 30 (a VLAN especificada pelo switch A).

Os pacotes sero enviados para o Switch C, e o TAG ser removido. O


pacote resultante, sem TAG ser enviado erroneamente para o Switch E.
O quadro
atravessa a rede
com o TAG do
cliente: 30

Porta tnel remove o TAG 30

O pacote sem tag


enviado para o
switch errado

mesma VLAN: o quadro


no recebe metro-tag

Correo do Problema
1) Utilizar apenas ISL trunks entre os
switches de core
2) Usar vlan dot1q tag native, para obrigar
o tageamento de todos os quadros,
inclusive da native VLAN.
3) Fazer com que a Native VLAN dos
trunks dos switches edge nunca
coincidam com as VLANs na rede do
usurio.

Configurao Assimtrica
Porta Tnel no uma porta Trunk, e
dessa forma, no ir realizar autonegociao com a porta do outro switch.
A porta trunk no switch da rede do usurio
deve ser configurado manualmente como
trunk.

Exerccio 4
Fa0/1-5

Fa0/6-10

Fa0/1-5

vlan1

vlan20

vlan1

B = 10.26.136.60
Fa0/23

Porta Trunk
Manual
Native VLAN 1

Porta Tunel
Access VLAN 30

Fa0/22

Tunel

Fa0/6-10

vlan20

C = 10.26.136.184
Fa0/23

Fa0/23

Tunel
A = 10.26.136.13

Fa0/1-5

vlan1

vlan30

Fa0/6-10

Configurao
Configurao Switch Tunel = A
configure terminal
interface Fa0/22 - 23
switchport access vlan 30
switchport mode dot1q-tunnel
exit

vlan dot1q tag native (opcional)

Configurao Switch Cliente = B e C


configure terminal
interface Fa0/23
switchport mode trunk
exit

Verificao
show running-config
show dot1q-tunnel
show vlan dot1q tag native

MTU
Para suportar Metro-TAGs o MTU nas portas
trunk do switch precisa ser aumentado em pelo
menos 4 bytes.
O MTU default para trfego no switch 1500 bytes.
Com um TAG o MTU deve se de 1504 bytes

Porta Fast-Ethernet:
Mximo MTU 1546

Portas Gigabit-Ethernet
Mximo MTU 9000 bytes

Para alterar o MTU utilize:


system MTU

Fragmentao de datagramas
As redes Ethernet limitam o tamanho dos quadros a apenas
1500 bytes, enquanto os datagramas IP podem chegar at
64 K bytes. Nesse caso, necessrio transmitir um
datragrama utilizando vrios quadros.
Cabealho do
datagrama

Campo de dados do datagrama


600

Dados1
o cabealho do
datagrama
original
reproduzido em
cada um dos
segmentos.

1500 bytes

1200

Dados2

Dados3

Cabealho do
datagrama

Dados1

Fragmento 1 (Deslocamento 0)

Cabealho do
datagrama

Dados2

Fragmento 2 (Deslocamento 600)

Cabealho do
datagrama

Dados3

Fragmento 3 (Deslocamento 1200)

Formato de um datagrama
O formato de um datagrama mostrado abaixo:
0

12

Byte 1

VERS

16

Byte 2

HLEN

Byte 3

Tipo de servio

28

31

Byte 4

Comprimento total

Identificao
Tempo de vida

24

20

flags
Protocolo

Deslocamento do fragemento
Checksum do cabealho
cabealho

Endereo IP de origem
Endereo IP de destino
Opes IP

Preenchimento
Dados
..

dados

Prtica
Utilizando o comando ping do Windows e
o Ethereal verifique o processo de
fragmentao do IP sobre o Ethernet.
ping l tamanho_mensagem_bytes
ip_destino t
Analise:
Ponto de fragmentao
Identificadores de Fragmento

Aumentar o MTU do sistema