Você está na página 1de 16

Lógica de Programação

Aula 4

Professora: Mariane Gavioli Bergamini


E-mail: maah.bergamini@gmail.com
Roteiro
Comandos de Repetição
Enquanto
Repita
Para

2
Comando de Repetição
Este procedimento não se repete eternamente, mas é
encerrado quando alcança seu objetivo.

• Comando Enquanto
Verificação de encadeamento de atividades antes de se
iniciar (ou reiniciar) uma execução do bloco de instruções.

3
Comando de Repetição: Enquanto
Verificação de encadeamento de atividades antes de se
iniciar (ou reiniciar) uma execução do bloco de instruções.

4
Comando de Repetição: Enquanto
Exemplo: Exiba os números de 1 a 10 em ordem
crescente.

5
Comando de Repetição: Enquanto

6
Comando de Repetição: Enquanto
Exercício: Faça um fluxograma que represente 100 vezes a
seguinte frase: “ HOJE É DIA DE IR EMBORA MAIS CEDO, NÃO
ENROLEM!!!”

7
Comando de Repetição: Enquanto
Resolução:
Algoritmo "Frase de repetição"

Var
count : inteiro

Inicio
count <- 0
enquanto count < 100 faça
escreva ("HOJE É DIA DE IR EMBORA MAIS CEDO, NÃO ENROLEM!")
count <- count + 1
Fimenquanto
Fimalgoritmo

8
Comando de Repetição: Repita
Permite que comandos sejam repetidos até que uma
condição não seja atendida.

repita
//sequencia-de-comandos
ate (condição)

Exemplo: Exiba os números de 1 a 10 em ordem


crescente.

9
Comando de Repetição
Exercício: Construa o fluxograma de um contador crescente
de 1 a 10 e depois implemente no VisualG utilizando o
comando de repetição PARA.

10
Comando de Repetição
Exercício: Construa o fluxograma de um contador crescente
de 1 a 10 e depois implemente no VisualG utilizando o
comando de repetição PARA.

11
Comando de Repetição
Exercício: Construa o fluxograma de um contador crescente
de 1 a 10 e depois implemente no VisualG utilizando o
comando de repetição PARA.

12
Comando de Repetição
Resolução:
Algoritmo “Comando de repetição para"

Var
count : inteiro

Inicio
count <- 0
para count de 1 ate 10 passo 1 faça
escreva (count)
fimpara
Fimalgoritmo

13
Comando de Repetição
Resolução:
Algoritmo “Comando de repetição para"

Var
count : inteiro

Inicio
count <- 0
para count de 1 ate 10 passo 1 faça
escreva (count)
fimpara
Fimalgoritmo

14
Comando de Repetição
Resolução:
Algoritmo “Comando de repetição para"

Var
count : inteiro

Inicio
count <- 0
para count de 1 ate 10 passo 1 faça
escreva (count)
fimpara
Fimalgoritmo

15
Referências

Medina, M., Ferting, C. Algoritmos e Programação: Teoria e Prática.


São Paulo: Novatec Editora, 2006, 2ª ed, pp. 384.

16