Você está na página 1de 25

Configurando roteadores CISCO

Configurando as senhas:
Router > enable entra no modo privilegiado
Router# configure terminal modo de configurao de terminal
Router(config)# hostname Lab_A muda nome do roteador (configurao global)
Lab A(config)#enable secret class habilita a senha do modo privilegiado para class
Lab A(config)#line console 0
Lab_A(config-line)#password cisco
Lab A(confg-line)#login
#exit
define senha para entrar no console Lab A(config-
line)
Lab_A(confg)#line aux 0
Lab_A(config-line)#password cisco
Lab_A(config-line)#login
Lab A(config-line)#exit
define senha para entrar no auxiliar Lab A(config-
line)
Lab_A(confg)#line vty 0 4
Lab_A(config-line)#password cisco
Lab_A(config-line)#login
senhas para os terminais telnet
Configurando as Interfaces
Router>enable entra no modo
privilegiado
Router# configure
terminal
modo de configurao
de terminal
Router(config)#
interface ethernet 0
entra na configurao
da interface
Router(config-if)# ip
address 192.5.5.1
coloca o IP na
interface
255.255.255.0
Router(config-if)# no
shutdown
ativa a interface para
UP Router(config-if)
Router(config-if)# exit sai da interface
Router(config)#
interface ethernet 1
entra na interface
ethernet 1
Router(config-if)# ip
address 205.7.5.1
255.255.255.0
coloca o IP na
interface
Router(confg-if)# no
shutdown
ativa a interface a
interface
Router(confg-if)#exit sai da interface
Router(config)#
interface serial 0
entra na configurao
da interface
Router(config-if)# ip
address 201.100.11.1
255.255.255.0
coloca o IP na
interface
Router(config-if)#
clock rate 56000
define o clock da
interface (DTE)
Router(config-if)# no
shutdown
ativa a interface
Router(config-if)# exit sai da interface
Obs:
show ip protocols v protocolos de roteamento ativados
show ip route mostra a tabela de roteamento ip address
ip address no_ip + mask secondary adiciona um 2

IP na interface
no ip address remover o IP da interface
no ip address ip+mask secondary remove o IP secundrio
Configurando o protocolo de roteamento rip
Router > enable
entra no modo
privilegiado
Router# configure
terminal
modo de
configurao de
terminal
Router(config)#
router rip
modo de
configurao do
protocolo rip
Router(config)#
network 192.5.5.0
ativa o rip na
interface
Router(config)# ativa o rip na
network 207.7.5.0 interface
Router(config)#
network 20
1.100.11.0
ativo o rip na
interface
Router(config)# exit sai
Resolvendo nomes por arquivo host
Router > enable entra no modo privilegiado
Router# configure terminal modo de configurao de terminal
Router(config)# ip host Lab
_
A 192.5.5.1
205.7.5.1 201.100.11.1
Router(config)# ip host Lab
_
C 223.8.151.1
204.204.7.1 199.6.13.2
Router(config)# ip host Lab D 210.93.105.1
204.204.7.2
Router(config)# ip host Lab E 210.93.105.2
Feito tudo isto, salvaremos nossa configurao corrente na NVRAM com comando
Router#copy running-config startup-config Se voc fizer mais alguma alterao e der
errado voc tem como voltar atravs do comando:
Router#copy startup-config running-config Podemos ver a configurao de
inicializao com o comando
Router# show startup-config Para verificar se a interface1 DTE ou DCE
Router# show controllers serial 1
Podemos ver a configurao que est em execuo no momento com o comando
Router# show running-config
Memria FLASH IOS
A memria Flash o local onde o roteador Cisco mantm as imagens binrias
executveis do IOS, que o sistema operacional do router.
Dependendo da quantidade de memria Flash disponvel, pode-se armazenar diversas
imagens do IOS no mesmo, basta executar o comando show flash e ser informado a
quantidade de memria desta memria.
Pode-se usar a transferencia da imagem do IOS via:
TFTP 'Trivial File Transfer Protocol): um servidor de transferencia de arquivos,
baseado no protocolo UDP e que no h necessidade de autenticao por parte
do usurio.
FTP (File Transfer Protocol): requer uma autenticao do usurio atravs de
nome e senha.
Configurando via TFTP
Execute o comando show flash para verificar o contedo de sua memria
FLASH.Armazene a imagem do IOS por exemplo c2500-i-1.120-5.P.bin para o
diretrio C:\Arquivos de programas\Cisco Systems\Cisco TFTP Server. Execute o
comando.Router# copy tftp flashInforme o IP do servidor de TFTP e o nome correto da
imagem do IOS, aps estes procedimentos iniciar o processo de cpia do IOS.
Obs: todos os comandos EXEC, que usam a rede para executar uma ao, retornam um
caractere de ! quando bem sucedido e um (.) para operao mal sucedida.
Gerenciando o Roteador
O Cisco Discovery Protocol (CDP) fornece um nico comando proprietrio que permite
que os administradores de rede acessem um resumo das configuraes dos outros
roteadores conectados diretamente.
O CDP executado em uma camada de enlace de dados que conecta a mdia fsica mais
baixa e os protocolos de camada de rede mais altos
Router(config)#no cdp run Desativa o cdp em todo o roteador
Router(config)#cdp run Ativa o cdp em todo o roteador
Router(confg)# interface serial 0 Entra na interface
Router(config-if)# no cdp enable Desativa somente na interface serial 0
Router(confg)# show cdp
neighbors
Exibe as informaes sobre os dispositivos vizinhos
Router(config)# show cdp
neighbors detail
Exibe as informaes sobre os dispositivos vizinhos
de forma detalha
Router(config)# show cdp entry
[roteador]
Exibe as informaes detalhadas de um roteador
Router(config)# show cdp entry * A mesma funo do show cdp neighbors detail
Router(config)# show cdp traffic Exibe informaes sobre o trfego da interface
Router(config)# show cdp
interface
Exibe o status da interface e as informaes sobre a
configurao do dispositivo local
Estabelecendo uma conexo remota
Router# telnet 10.4.67.31 ou
Router# connect 10.4.67.31 ou
Router# 10.4.67.31
Router# Lab A
Verificando e exibindo sesses Telnet ativas
Na mquina onde foi feito o telnet digite:
Router# show
sessions
Mostra uma lista de hosts com os quais foram estabelecidos conexes
via telnet
Router# show
users
lista as sesses telnet e verifica a atividade da porta console
Router#
disconnect 1
Router# show
users
Quem est logado?
Router# clear
Tine 2
Retirando o usurio do router
Conferindo as configuraes IP das Interfaces
Router# show
protocols
Mostra o status das interfaces, numero IP, protocolo de
roteamento ativado ou no.
Router# show
protocols serial 0
Mostra o status de uma interface especfica
Router# show ip
interface brief
Faz um resumo das configuraes IP e das interfaces
Suspendendo propagaes de RIP de determinada interface
RouterA# conf t
RouterA(config)# router rip
RouterA(config-router)# network 172.16.0.0
RouterA(config-router)#passive-interface ethernet 0
Habilitando o protocolo IGRP
Router# conf terminal
Router(config)#router igrp 100
Router(config-router)# network rede
Router# sh ip protocols
Configurando rotas estticas
ip route rede destino mascara_de_rede gateway
ip route 172.16.1.0 255.255.255.0 172.16.2.1
Configurando rota default
Deve ser adicionado em todos os roteadores ou use o comando redistribute static, para
que todas as redes conheam a rota padro
ip default-network 192.168.76.0
ou
ip route 0.0.0.0 0.0.0.0 192.168.76.0
Checando a tabela de roteamento
show ip route
Trabalhando com arp
show arp clear arp
Checando informaoes da camada 3
show ip protocols
show ip interfaces
Depurando problemas no roteamento
debug ip rip
no debug rip
no debug all
debug ip igrp events Resumo da informao do igrp circulando na rede
DEBUG IP IGRP TRANSACTIONS Mostra solicitaes de mensagem dos routers
vizinhos e os broadcasts enviados
BRINCANDO NOS TEMPORIZADORES
Lab-C#conf t
Lab-C(config)#router rip Lab-C
(config-router)#default-metric 10 Lab-C
(config-router)#timers basic 30 60 150 30
Lab-C(config-router)#exit
Lab-C(config)#int s0
Lab-C(config-if)#ip split-horizon
Lab-C(config-U)#int s1
Lab-C(config-if)#ip split-horizon
Lab-C(config-if)#^Z
Lab-C#
Compreendendo os Temporizadores.
Update:O tempo entre as atualizaes enviadas por um roteador.
Invalid: O termo Invalid usado para os roteadores dos quais no se tenha notcias em
um certo perodo de tempo, para o qual o temporizador definido. Isso significa, por
exemplo, que se um temporizador Invalid for definido como 60, e um anncio de uma
rota do roteador a partir do qual essa rota foi aprendida no tiver sido recebido em 61
segundos, o temporizador Invalid expira e a rota considerada invlida.
Holddown: O termo holddown se refere aos roteadores que foram marcados como
sendo invlidos mas no podem ser substitudos por uma nova rota com mtrica maior.
Esse temporizador determina quanto tempo a rota mantida em holddown. Enquanto
estiver em holddown, o roteador continuar enviando atualizaes sobre a rota, e
encaminhando pacotes atravs da rota at que o holddown atinja seu tempo limite.
Flush: O temporizador flush ser reinicializado toda vez que uma atualizao for
recebida para uma rota do roteador a partir do qual foi aprendida. Os temporizadores
flush e Invalid so reinicializados e executados simultaneamente. Quando o
temporizador flush expirar para uma rota, ela ser removida da tabela de roteamento.
Para o RIP, o temporizador flush expira antes do temporizador hold down.
Tcnicas para evitar o loop de roteamento
Split Horizon: O Split Horizon impede que o roteador envie informaes sobre uma
rota na tabela de roteamento atravs da mesma interface da qual ela aprendeu a rota. Por
exemplo, se o Lab-B enviar informaes sobre o Lab-E para o Lab-A atravs da sua
Ethernet 0, o Lab-A no enviar informaes sobre o Lab-E atravs da Ethernet 0 de
volta para o Lab-B.
Poison Reverse: Isso quando um roteador informa a seus vizinhos que as rotas que
eles atingiam atravs de uma determinada interface no esto mais disponveis, porque a
interface tornou-se inoperante. Os roteadores respondem a uma mensagem de poisou
reverse imediatamente colocando as rotas que sofreram poisou em holddown, ao invs
de esperar que o temporizador invalid expire. Isso economiza tempo de convergncia
em at 180 segundos(temporizador invalid padro), dependendo de quanto tempo aps
uma atualizao regular, chegar a poisou reverse update.
Definindo as mtricas padro: As mtricas padro so definidas para desativar a
contagem at o infinito. Contar at o infinito gera loops de roteamento, incrementando
uma rota que no pode atingir, mas acreditando que seu vizinho possa. Toda vez que
uma rota que no for atingvel por umroteador enviada para seu vizinho, roteadores
que ainda no convergiram, a mtrica dessa rota aumentada em um. Isso acontece
repetidamente at que os roteadores finalmente faam a converso. A mtrica padro
define uma contagem de mtrica, onde permitido que uma rota seja propagada pela
rede vrias vezes antes de ser removida da tabela de roteamento.
CONFIGURANDO O IPX
#conf t
(config)# ipx routing
(config)# int ethernet 0
(config-if)#ipx network 10
(config-io#int s0
(config-if)# ipx network 20Acrescentando endereos de redes secundrios e mltiplos
tipos de frames com ipx# config t
(config)# int ethernet 0
(config-i0#ipx network 10a encapsulation arpa secondaryUsando sub interfaces# config
t(config)# int ethernet 0.1500(config-subif)#ipx network l0b encapsulation sap# config t
(config)# int ethernet 0.1600
(config-subif)#ipx network 10c encapsulation snapVerifique com a configurao com
show ipx route
show ipx interface
show ipx protocol
Ativando a resoluo de nomes Usando tabela hosts ip host roteadorA 172.16.10.6
no ip host roteadorAUsando um DNS#configure terminal
(conf g)# ip domain-lookup
(config)# ip name-server 200.255.31.33
(config)# ip domain-name pitanga.com.brObservando a configurao
sh hosts
A Cisco possui dois tipos de "Major Releases", que sao as versoes principais:
- Main Releases
- Early Deployment (ED)
As Main Releases consolidam vrios recursos, plataformas, tecnologias, etc, sempre
tendo como base as verses ED anteriores de uma determinada verso do Cisco IOS.
Estas Main Releases no agregam novos recursos ou adicionam novas funcionalidades
(apenas consolidam tudo aquilo j testado nas ED), justamente para garantir uma
imagem estvel e de alta qualidade. Alem disto, cada verso de manuteno dos Main
Releases oferecem somente a correo de bugs. Estas verses de manuteno, a
principio, so chamadas de Limited Deployments (LD), e a tendncia e ir corrigindo
estas "LDs" ate o ponto em que a estabilidade da imagem garantira um novo titulo:
General Deployment (GD). Existem vrios critrios para um IOS atingir o nvel "GD",
o que involve uma extensa pesquisa junto ao TAC (Technical Assistance Center),
sempre contando com os problemas reportados pelos usuarios, consumidores Cisco, e os
proprios engenheiros da Cisco. A tendncia e que as Main Releases adquiram status
End of Sale (EOS), End of Engineering (EOE) e End of Life (EOL), justamente porque
as versoes ED consolidaro toda a tecnologia e agregaro mais recursos e
funcionalidades ao Cisco IOS, fazendo o Main Release ficar "obsoleto" (embora muito
estvel).
J no caso das Eariy Deployment, estas so constantemente atualizadas com correo de
bugs e, principalmente, trazendo novos recursos para o Cisco IOS. Estas "EDs"
possuem um ciclo de produo muito frentico, e possuem varias categorias de
desenvolvimento:
- Consolidated Technology Early Deployment (CTED) releases
- Specifc Technology Early Deployment (STED) releases
- Specific Market Eariy Depioyment (SMED) releases
- Short-lived Early Deployment releases, ou simplesmente (XED)
Um bom exemplo de ED e o chamado Technology Eariy Deployment release,
facilmente identificado pela letra "T" nas verses do Cisco IOS (12.2T, por exemplo).
Aproximadamente a cada 2 anos, os recursos e plataformas suportadas pelo ED so
portadas para uma nova Main Release.
A nomenclatura da imagem IOS propriamente dita segue o seguinte padro: plataforma-
features-memoria de execuo e compresso.
Exemplo:
c7500-ajs40-mz significa:
c7500 = modelo do router
a=recursos APPN
j= Enterprise
s= NAT, ISL, VPDN, L2F
40 = criptografia 40-bit
m = o software ser executado na RAM
z = compresso no formato zip
Cada imagem poder rodar em esquemas diferentes. Um IOS pode ser, dependendo do
hardware e versao IOS, f (rodar no flash), r (rodar na ROM), e assim por diante. O
mesmo ocorre para o caso das features.Deferred Release (DF) e quando a Cisco corrige
aquele baita bug no Cisco IOS, e uma nova verso e criada para consertar o problema. A
imagem anterior (a que contem o bug) e "deferred" e a Cisco para de fornecer esta
imagem para seus clientes. Resumindo:
a) Utilize imagens ED caso voc queira inovar e agregar/implementar recursos muito
rapidamente.
b) Utilize imagens Major release caso voc queira usufruir de todos os fixes e recursos
oferecidos pelas versoes ED anteriores. No possui um ciclo de "novidades" to rpido
quando o ED propriamente dito, mas e uma tima escolha.
c) Utilize imagens GD caso a sua rede seja CRITICA, 100% online, e que 1 segundo de
paralisacao fara a sua cabeca rolar pelas escadas da sua empresa; e os gerentes bebendo
sangue direto no pescoco :-) GD nao tem o panelaco do ED, mas em compensacao e
muito estavel.
Pra terminar, sugiro que voc PROCURE pela versao IOS certa para o seu
equipamento, utilizando o proprio site da Cisco. Como voce j deve imaginar, a grande
maioria dos recursos oferecidos pelo IOS so chamados "out-of-the-box" (ou "out-of-
box"), ou seja, sao baseados no software IOS, e nao no hardware. Saber exatamente
qual a imagem voc precisara dependera muito do seu conhecimento sobre os recursos
almejados para a sua rede. Utilize as seguintes ferramentas:
Software Advisor: Duvidas sobre qual versao IOS voce precisara? Consulte o S.A.
Serve tambm para comparar os recursos entre hardwares ou verses distintas do Cisco
IOS. http://www.cisco.com/cQibin/Support/CompNav/Index.pl
Cisco Feature Navigator II: Navegue pelos recursos das versoes IOS disponiveis.
OBS: Exige conta no CCO. http://tools.cisco.com/ITDIT/CFN/isp/index.isp
Guia de Recursos: Ajuda a entender melhor sobre os recursos disponiveis em uma
Main release..
http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/products_feature_Quides_lis
t.html
IOS Upgrade Planner: Ajuda a localizar a imagem certa para o upgrade de seu
equipamento CiscoOBS: Requer uma conta no CCO, e voce devera efetuar o login
primeiro na Home da Cisco.com.
RECUPERANDO SENHAS NOS ROTEADORES 800
1 PASSO: Ligar o roteador e pressionar ctrl+break durante os primeiros 60 segundos, isto colocar o
roteador no modo ROM MON (ROM Monitor)
2
o
PASSO: digite set no prompt e verifique o valor do registro de configurao (conf-register),
conforme exemplo abaixo:
1. boot# set
2. set baud =9600
3. set data-bits =8
4. set parity =nove
5. set stop-bits =1
6. set console-flags =0
7. set mac-address =0050.7307.C329
8. set unit-ip =10.200.40.65
9. set serv-ip =255.255.255.255
10. set netmask =255.255.252.0
11. set gate-ip =10.200.40.1
12. set pkt-timeout =8
13. set tftp-timeout =16
14. set boot-action =flash
15. set file-narre ="c800-nsy6-mw.122-10b.bin"
16. set watchdog =off
17. set prompt ="boot"
18. set ios-conf =0x2102 !--- This is the value to record
3 PASSO: digite set ios-conf = 142 (voc pode usar Ox 142 ou 0x2142) nesta opo diz para no
carregar o contedo da NVRAM, ou seja, o arquivo de configurao;
4

PASSO: digite boot o roteador reiniciar s que no carregar o contedo da NVRAM;
5

PASSO: digite ctrl+c para sair do modo setup;
6

PASSO: entrar no modo privilegiado com comando enable;
7

PASSO: Copie o contedo da NVRAM para RAM: copy startup-config running-config ou


configure memory
8

PASSO: use o comando show running para verificar as configuraes do router, e verifique se
todas as interfaces esto shutdown
9

PASSO: entrar no modo de configurao global com configure terminal
10
0
PASSO: enable secret <nova senha>
11

PASSO: dar o comando no shutdown em cada interface e averiguar via show ip interface brief
12

PASSO: configure terminal e mude o registro para 0x2102, com config-register 0x2102 13

PASSO: Ctrl + Z
14

PASSO: salvar a configurao corrente para a LAVRAM, copy running-config startup-config ou


write memory
RECUPERANDO SENHAS NOS ROTEADORES 25XX
l

PASSO: Ligar o roteador e pressionar ctrl+break durante os primeiros 60 segundos, isto colocar o
roteador no modo ROM MON (ROM Monitor)
2

PASSO: digite o no prompt e verifique o valor do registro de configurao (conf-register)
3

PASSO: digite o/r 0x2142 nesta opo diz para no carregar o contedo da NVRAM, ou seja, o
arquivo de configurao
4
a
PASSO: digite i o roteador reiniciar s que no carregar o contedo da NVRAM
5

PASSO: digite ctrl+c para sair do modo setup
6

PASSO: entrar no modo privilegiado com comando enable
7

PASSO: Copie o contedo da NVRAM para RAM: copy startup-config running-config ou


configure memory
8

PASSO: use o comando show running para verificar as configuraes do router, e verifique se
todas as interfaces esto shutdown
9

PASSO: entrar no modo de configurao global com configure terminal.
10

PASSO: enable secret <nova senha>


11 PASSO: dar o comando interface serial 0 e no shutdown em cada interface e averiguar via
show ip interface brief
12

PASSO: configure terminal e mude o registro para 0x2102, com config-register 0x2102
13

PASSO: Ctrl + Z
14

PASSO: salvar a configurao corrente para a NVRAM, copy running-config startup-config


ou write memory
RECUPERANDO SENHAS NOS ROTEADORES 26XX
1

Passo: Se voc estiver acessando o seu roteados, digite o comando show version e guarde a
configurao do registrador, deve ser tipicamente 0x2102.
2

Passo: Ligar o roteados e pressionar ctrl+break durante os primeiros 60 segundos, isto colocar o
roteados no modo ROM MON (ROM Monitor)
3

Passo: Digite confreg 0x2142 no prompt rommon 1> para no carregar o arquivo de configurao
na NVRAM
4 Passo: Digite reset no prompt rommon 2>, o mesmo ser reiniciado
5

Passo: O roteados entrar no modo setup, portanto digite ctrl+c para sair do modo setup
6

Passo: Entrar no modo privilegiado com comando enable


7

Passo: Copie o contedo da NVRAM para RAM: copy startup-config running-config ou


configure memory
8

Passo: use o comando show running para verificar as configuraes do router, e verifique se
todas as interfaces esto shutdown
9

Passo: use o comando show running para verificar as configuraes do router, e verifique se
todas as interfaces esto shutdown
10

Passo: Entrar no modo de configurao global com configure terminal


11

Passo: enable secret <nova senha>


12

Passo: Dar o comando no shutdown em cada interface e averiguar via show ip interface brief
13

Passo: configure terminal e mude o registro para 0x2102, com config-registes 0x2102 14

PASSO: Ctrl + Z
15

PASSO: salvar a configurao corrente para a NVRAM, copy running-config startup-config


Configurando NAT em roteadores Cisco
A internet uma grande teia de hosts interconectados. Todos os dias milhes de
usurios conectam-se a ela. Para que voc tenha acesso faz-se necessrio uma
identificao, que feita por intermdio de um endereo IP. Quando o endereamento
IP foi criado, no caso o IP verso 4 ou IPV4, acreditava-se que haveria endereos de
sobra, talvez por no acreditarem que Internet se massificaria to ferozmente em nossa
atualidade. A maior preocupao da comunidade da Internet passou a ser o esgotamento
total dos endereos IP tamanho o ritmo de crescimento da estrutura. Alm disso, ocorre
um enorme disperdcio de endereos IP, especialmente por partes de grandes empresas,
que alocaram grandes blocos de endereos inutilmente. Para resolver isso o IANA
especificou atravs da RFC 1918, uma faixa de endereos dentro das trs classes de IP
existente (A, B, C), determinando que estes endereos seriam privativos ou reservados
como queiram, de tal forma que no seriam roteados pela Internet. Portanto, as
empresas podem utilizar estes endereos na sua rede interna economizando assim
endereos vlidos (roteveis) da Internet.
Estes endereos so:
Classe A: Toda a faixa do endereo 10.0.0.0 a 10.255.255.255
Classe B: Toda a faixa do endereo 172.16.0.0 a 172.31.255.255
Classe C: Toda a faixa do endereo 192.168.0.0 a 192.168.255.255
Devido a escassez dos endereos vlidos solues como endereos privativos,
CIDR, VLSM e NAT foram incorporados infraestrutura da internet de forma a se
poder alocar os endereos IP de forma mais eficiente at a chegada total da nova verso
de IP, o IPv6, que resolver por completo este problema. Mas como isto parece estar um
pouco longe, veremos como resolver isso com a traduo de endereos IP, ou NAT.
O que vem a ser NAT?
O Network Address Translator traduz os endereos que entram ou saem de um roteador
dependendo da forma da implementao e configurao para traduo destes endereos.
Este processo pode ser visualizado na figura abaixo:
Figura 1 Nossa topologia de configurao bsica
Tipos de NAT
NAT esttico
Essa configurao pode ser feita de duas formas: cada endereo IP de sua rede interna
ser mapeado para um endereo vlido do conjunto de IPs vlidos designados para sua
empresa. claro que este modelo em nada resolve o problema de disperdcio de
endereos vlidos. Basta pensar que se voc tivesse 150 endereos privados na sua rede,
voc precisaria de 150 endereos vlidos.
A outra forma o sentido inverso da conexo. Mapeando um IP vlido para um
privativo.
NAT Dinmico
Neste modelo, todo o mapeamento dos endereos privativos para os Ips vlidos ocorre
de forma dinmica. O roteador criar esta tabela de tradues automaticamente. Mais
ainda teremos o problema do disperdcio, pois o mapeamento de um para um.
Figura 2 NAT Dinmico
NAT Dinmico e Overloading
Segue o mesmo funcionamento do anterior, sendo que a nica diferena que estaremos
agora compartilhando um nico endereo IP vlido. O roteador ir atribuir uma porta de
conexo de origem para cada traduo efetuada, para que com isso saiba para qual
endereo privado deve ser retornado o pacote. Este mtodo conhecido como traduo
de endereos por porta ou port level multiplexed NAT. Este ser o mtodo adotado na
configurao de nosso roteador.
Configurando o NAT
Vamos demonstrar como configurar nossa rede baseado na topologia adotada da figura-
1 tendo como base um roteador CISCO modelo 2501.
O que faremos agora ser traduzir os endereos 192.168.1.X/24 para o endereo IP
configurado na interface serial conectada a Internet.
Partindo do princpio que o usurio j tenha configurado corretamente as interfaces do
roteador com os IPs e encapsulamento correto partiremos para a traduo dos
endereos. Para acoplar ao seu caso basta substituir o IP 213.18.123.100 pelo seu de
acesso a Internet.
1
o
Passo: Configurar o NAT da rede interna para definir que o endereo de origem
dever ser traduzido.
Router-Rio#configure terminal
Router-Rio(config)# ip nat pool INTERNET 213.18.123.100 213.18.123.100 prefix-
length 24
Router-Rio(config)# ip nat inside source list NAT pool INTERNET overload
2
o
Passo: Configurar a lista de acesso para informar quais os Ips da sua rede interna
devero ser traduzidos.
Router-Rio(config)#ip access-list standard NAT
Router-Rio(config-std-nacl)# permit 192.168.1.0 0.0.0.255
Router-Rio(config-std-nacl)#exit
3
o
Passo: Ativar o NAT nas interfaces corretas.
Router-Rio(config)# interface ethernet 0
Router-Rio(config-if)# ip nat inside
Router-Rio(config-if)#exit
Router-Rio(config)#interface serial 0
Router-Rio(config-if)#ip nat outside
Router-Rio(config-if)#exit
Router-Rio(config)#exit
Router-Rio#
4
o
Passo: Utilize o comando abaixo para verificar a configurao do NAT.
Router-Rio# show ip nat statistics
5
o
Passo: use o comando ping para testar a configurao do NAT
6
o
Passo: podemos observar a traduo com o comando # show ip nat translations
Configurando NAT esttico e com
traduo de portas
Vamos hoje explorar o sonho de todo usurio de redes de banda larga, com uma
soluo simples, caseira e bem econmica. Quem aqui no gostaria de hospedar seus
servidores de web, ftp, e-mail na sua casa e em mquinas distintas? Como resolver este
problema se voc s possui um nico endereo IP fornecido pelo seu provedor (ISP)?
A forma de contornarmos o problema bem simples, usaremos uma configurao
de NAT esttico em conjunto com uma traduo de portas. Vamos a nossa topologia.
O nosso cenrio est montado e pronto para ser configurado, com tudo aquilo que um
usurio ou pequeno administrador sempre sonhou ter...
Para que a configurao abaixo funcione pode usar qualquer roteador CISCO com IOS
(Internetworking Operation System) 12.1 ou acima.
ip nat pool internet 200.234.x.x 200.234.x.x prefix-length 22
ip nat inside source list nat interface serial 0 overload
ip nat inside source static tcp 192.168.0.1 25 interface Serial 0 25
ip nat inside source static tcp 192.168.0.2 80 interface Serial 0 80
ip nat inside source static tcp 192.168.0.3 20 interface Serial 0 20
ip nat inside source static tcp 192.168.0.3 21 interface Serial 0 21
ip nat inside source static tcp 192.168.0.4 119 interface Serial 0 119
Router(config)#ip access-list standard nat
Router(config-std-nacl)#permit 192.168.0.0 0.0.0.255
Router(config-std-nacl)#exit
Router(config)# interface Ethernet 0
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)# interface serial 0
Router(config-if)#ip nat outside
Router(config-if)#exit
Estes comandos permitem que voc utilize o NAT dinmico com overloading e tambm
NAT esttico com traduo de portas. As conexes efetuadas ao seu roteador na porta
80 sero redirecionadas para seu servidor web no endereo 192.168.0.2. Sendo assim,
todos os dispositivos da sua rede interna compartilham o mesmo IP recebido do
provedor.

Configurando FrameRelay em
roteadores Cisco

#configure terminal
(config)#interface serial 0
(config-if)# encapsulation frame-relay ? (aqui pode ser cisco ou ietf) (pegar
informacao da operadora)
(config-if)#frame-relay lmi-type ? (aqui pode ser ansi , cisco , q933a) (pegar
informacao da operadora)
(config-if)#interface serial 0.1 point-to-point
(config-if)#ip address 10.10.10.10 255.255.0.0 (pegar o IP fornecido pela operadora)
(config-if)#frame-relay interface-dlci 102 (pegar o DLCI fornecido pela operadora)
Obs: Criar a rota default
Alguns testes:
show frame-relay lmi --> gerencia a conexo e mantm o status da conexo
out --> mensagens oriundas do roteador
in --> mensagens recebidas do switch
0x2 (ativo) conexo ativa e que os outros roteadores esto prontos
0x0 (inativo) conexo local ativa, mas a conexo com o router remoto no est
funcionando)
0x3(deletado) no est recebendo LMI do switch FR ou no existe servio entre o
router e o switch
show frame-relay pvc 100
show frame-relay map
SNMP - Gerncia de Redes CISCO ACADEMY -
NCE/UFRJ
Prtica - Gerncia de redes utilizando
SNMP
Objetivos
Familiarizar com os procedimentos para efetuar a configurao SNMP de
equipamentos, no caso roteadores Cisco.
Informaes adicionais
Endereo IP dos roteadores: siga indicaes do instrutor Passos do
Laboratrio
Acesso ao roteador
1. Efetue o acesso ao equipamento via telnet. Utilize a senha cisco 2. Senha
de enable: cisco
3. Configure o roteador seguindo os passos abaixo.
Configurao SNMP
1. Habilite o SNMP atravs do comando snmp-server community.
Utilize o nome do grupo como community. Deve ser permitido o
acesso somente de leitura.
snmp-server community <nome do grupo> RO
2. Indique o responsvel pelo equipamento usando o comando snmp-server
contact
snmp-server contact administrador@nce.ufrj.br
3. Indique a localizao do equipamento atravs do comando snmp-server
location
snmp-server location Grupo de Treinamento - NCE/UFRJ 4. Indique o
equipamento para onde devem ser enviados os traps
snmp-server host <endereo IP da sua estao> public 5. Habilite o
envio de traps relativos a erros de autenticao SNMP
snmp server trap-authentication snmpvl
6. Saia do modo de configurao usando as teclas <CTRL z>
7. Salve a configurao via comando copy running-config startup-config
8. Verifique a configurao como comando show running-config
1 PASSO: Ligar o roteador e pressionar ctrl+break durante os primeiros 60 segundos, isto colocar o
roteador no modo ROM MON (ROM Monitor)
2
o
PASSO: digite set no prompt e verifique o valor do registro de configurao (conf-register),
conforme exemplo abaixo:
1. boot# set
2. set baud =9600
3. set data-bits =8
4. set parity =nove
5. set stop-bits =1
6. set console-flags =0
7. set mac-address =0050.7307.C329
8. set unit-ip =10.200.40.65
9. set serv-ip =255.255.255.255
10. set netmask =255.255.252.0
11. set gate-ip =10.200.40.1
12. set pkt-timeout =8
13. set tftp-timeout =16
14. set boot-action =flash
15. set file-narre ="c800-nsy6-mw.122-10b.bin"
16. set watchdog =off
17. set prompt ="boot"
18. set ios-conf =0x2102 !--- This is the value to record
3 PASSO: digite set ios-conf = 142 (voc pode usar Ox 142 ou 0x2142) nesta opo diz para no
carregar o contedo da NVRAM, ou seja, o arquivo de configurao;
4

PASSO: digite boot o roteador reiniciar s que no carregar o contedo da NVRAM;
5

PASSO: digite ctrl+c para sair do modo setup;
6

PASSO: entrar no modo privilegiado com comando enable;
7

PASSO: Copie o contedo da NVRAM para RAM: copy startup-config running-config ou


configure memory
8

PASSO: use o comando show running para verificar as configuraes do router, e verifique se
todas as interfaces esto shutdown
9

PASSO: entrar no modo de configurao global com configure terminal
10
0
PASSO: enable secret <nova senha>
11

PASSO: dar o comando no shutdown em cada interface e averiguar via show ip interface brief
12

PASSO: configure terminal e mude o registro para 0x2102, com config-register 0x2102 13

PASSO: Ctrl + Z
14

PASSO: salvar a configurao corrente para a LAVRAM, copy running-config startup-config ou


write memory