Você está na página 1de 9

Laboratrio Configurao de Rapid PVST+, de PortFast e de

BPDU Guard
Topologia

Tabela de Endereamento

Dispositivo Interface Endereo IP Mscara de sub-rede

S1 VLAN 99 192.168.1.11 255.255.255.0


S2 VLAN 99 192.168.1.12 255.255.255.0
S3 VLAN 99 192.168.1.13 255.255.255.0
PC-A NIC 192.168.0.2 255.255.255.0
PC-C NIC 192.168.0.3 255.255.255.0

Atribuies de VLAN

VLAN Nome

10 Usurio
99 Gerenciamento

Objetivos
Parte 1: Criar a Rede e Implementar as Configuraes Bsicas do Dispositivo
Parte 2: Configurar VLANs, VLAN Nativa e Troncos
Parte 3: Configurar a Bridge Raiz e Examinar a Convergncia de PVST+
Parte 4: Configurar Rapid PVST+, PortFast, BPDU Guard e Examinar a Convergncia

2017 Cisco e/ou suas afiliadas. Todos os direitos reservados. Este documento contm informaes pblicas da Cisco. Pgina 1 de 9
Laboratrio Configurao de Rapid PVST+, de PortFast e de BPDU Guard

Histrico/Cenrio
O protocolo Per-VLAN Spanning Tree (PVST) proprietrio da Cisco. O PVST padro nos switches Cisco.
Rapid PVST+ (IEEE 802.1w) uma verso avanada do PVST+ e permite clculos mais rpidos de
spanning tree e convergncia em resposta s alteraes de topologia da camada 2. Rapid PVST+ define trs
estados da porta: discarding, learning e forwarding, fornecendo vrios aprimoramentos para otimizar o
desempenho da rede.
Neste laboratrio, voc configurar a bridge raiz primria e secundria, examinar a convergncia do PVST+,
configurar o Rapid PVST+ e comparar sua convergncia com o PVST+. Alm disso, voc configurar
portas de borda para transio imediata para um estado forwarding usando o PortFast e para impedir que as
portas de borda encaminhem BDPUs usando BDPU guard.
Observao: este laboratrio oferece assistncia mnima com os comandos reais necessrios para
configurao. No entanto, os comandos necessrios so fornecidos no Apndice A. Teste seu conhecimento
tentando configurar os dispositivos sem consultar o anexo.
Observao: os switches usados com os laboratrios prticos de CCNA so Cisco Catalyst 2960 com Cisco
IOS Verso 15.0(2) (imagem lanbasek9). Podem ser usados outros switches e outras verses do Cisco IOS.
Dependendo do modelo e da verso do Cisco IOS, os comandos disponveis e a sada produzida podem ser
diferentes dos mostrados nos laboratrios.
Observao: confira se os switches foram apagados e se no h configurao de inicializao. Se tiver
dvidas, fale com o instrutor.

Recursos necessrios
3 Switches (Cisco 2960 com a verso 15.0(2) do IOS Cisco, imagem lanbasek9 ou semelhante)
2 PCs (com Windows 7, Vista ou XP com programa de emulao de terminal, como o Tera Term)
Cabos de console para configurar os dispositivos Cisco IOS por meio das portas de console
Cabos ethernet conforme mostrado na topologia

Parte 1: Criar a rede e definir as configuraes bsicas do dispositivo


Na Parte 1, voc vai configurar a topologia de rede e definir configuraes bsicas, como endereos IP das
interfaces, acesso aos dispositivos e senhas.

Etapa 1: Cabeie a rede conforme mostrado na topologia.

Etapa 2: Configure os PCs hosts.

Etapa 3: Inicialize e recarregue os switches, conforme necessrio

Etapa 4: Defina as configuraes bsicas de cada switch.


a. Desative a pesquisa de DNS.
b. Configure o nome do dispositivo conforme mostrado na topologia.
c. Atribua cisco como senhas do console e do vty e habilite o login.
d. Atribua class como a senha criptografada do modo EXEC privilegiado.
e. Configure o registro sncrono para evitar que mensagens do console interrompam a entrada do
comando.
f. Desative todas as portas do switch.
g. Copiar a configurao atual para a configurao de inicializao.

2017 Cisco e/ou suas afiliadas. Todos os direitos reservados. Este documento contm informaes pblicas da Cisco. Pgina 2 de 9
Laboratrio Configurao de Rapid PVST+, de PortFast e de BPDU Guard

Parte 2: Configurar VLANs, VLAN Nativa e Troncos


Na Parte 2, voc criar VLANs, atribuir portas de switch s VLANs, configurar portas de tronco e mudar a
VLAN nativa para todos os switches.
Observao: os comandos necessrios para a Parte 2 so fornecidos no Apndice A. Para testar o
conhecimento, tente configurar as VLANs, a VLAN nativa e os troncos sem consultar o apndice.

Etapa 1: Crie VLANs.


Use os comandos adequados para criar as VLANs 10 e 99 em todos os switches. Nomeie a VLAN 10 como
User e a VLAN 99 como Management.
S1(config)# vlan 10
S1(config-vlan)# name User
S1(config-vlan)# vlan 99
S1(config-vlan)# name Management

S2(config)# vlan 10
S2(config-vlan)# name User
S2(config-vlan)# vlan 99
S2(config-vlan)# name Management

S3(config)# vlan 10
S3(config-vlan)# name User
S3(config-vlan)# vlan 99
S3(config-vlan)# name Management

Etapa 2: Ative as portas do usurio no modo de acesso e atribua as VLANs.


Para S1 F0/6 e S3 F0/18, ative as portas, configure-as como portas de acesso e atribua-as VLAN 10.

Etapa 3: Configure as portas de tronco e atribua-as VLAN nativa 99.


Para as portas F0/1 e F0/3 em todos os switches, ative as portas, configure-as como portas de tronco e
atribua-as VLAN nativa 99.

Etapa 4: Configure a interface de gerenciamento em todos os switches.


Usando a Tabela de Endereamento, configure a interface de gerenciamento em todos os switches com o
endereo IP apropriado.

Etapa 5: Verifique as configuraes e a conectividade.


Use o comando show vlan brief em todos os switches para verificar se todas as VLANs esto registradas na
tabela de VLANs e se as portas corretas esto atribudas.
Use o comando show interfaces trunk em todos os switches para verificar as interfaces do tronco.
Use o comando show running-config em todos os switches para verificar todas as demais configuraes.
Qual a configurao padro para o modo spanning tree em switches Cisco?
_______________________________________________________________________________________
Verifique a conectividade entre PC-A e PC-C. O seu ping foi bem-sucedido? ______________

2017 Cisco e/ou suas afiliadas. Todos os direitos reservados. Este documento contm informaes pblicas da Cisco. Pgina 3 de 9
Laboratrio Configurao de Rapid PVST+, de PortFast e de BPDU Guard

Se o ping no foi bem-sucedido, identifique e solucione os problemas de configurao at que o problema


seja resolvido.
Observao: pode ser necessrio desativar o firewall do PC para se obter xito em pings entre PCs.

Parte 3: Configurar a Bridge Raiz e Examinar a Convergncia do PVST+


Na Parte 3, voc determinar a raiz padro na rede, atribuir a raiz primria e secundria e usar o comando
debug para examinar a convergncia do PVST+.
Observao: os comandos necessrios para a Parte 3 so fornecidos no Apndice A. Para testar o
conhecimento, tente configurar a bridge raiz sem consultar o apndice.

Etapa 1: Determine a bridge raiz atual.


Que comando permite que o usurio determine o status do spanning tree de um switch Cisco Catalyst em
todas as VLANs? Escreva o comando no espao fornecido.
_______________________________________________________________________________________
Use o comando nos trs switches para determinar as respostas s seguintes perguntas:
Observao: h trs instncias do spanning tree em cada switch. A configurao padro do STP nos
switches Cisco PVST+, o que cria uma instncia separada do spanning tree para cada VLAN (VLAN 1 e
qualquer VLAN configurada pelo usurio).
Qual a prioridade da ponte do switch S1 para VLAN 1? ______________
Qual a prioridade da ponte do switch S2 para VLAN 1? ______________
Qual a prioridade da ponte do switch S3 para VLAN 1? ______________
Qual dos switches a bridge raiz? ______________
Por que esse switch foi escolhido como a bridge raiz?
_______________________________________________________________________________________

Etapa 2: Configure uma bridge raiz primria e secundria para todas as VLANs existentes.
Ter uma bridge raiz (switch) escolhida pelo endereo MAC pode resultar em uma configurao no ideal.
Neste laboratrio, voc ir configurar o switch S2 como a bridge raiz e o S1 como a bridge raiz secundria.
a. Configure o switch S2 para ser a bridge raiz primria para todas as VLANs existentes. Escreva o
comando no espao fornecido.
____________________________________________________________________________________
b. Configure o switch S1 para ser a bridge raiz secundria para todas as VLANs existentes. Escreva o
comando no espao fornecido.
____________________________________________________________________________________
Use o comando show spanning-tree para responder s seguintes perguntas:
Qual a prioridade da bridge do S1 para a VLAN 1? ______________
Qual a prioridade da bridge do S2 para a VLAN 1? ______________
Qual interface na rede est em estado blocking? _________________________________________

Etapa 3: Altere a topologia da camada 2 e examine a convergncia.


Para examinar a convergncia do PVST+, voc criar uma alterao de topologia da camada 2, ao mesmo
tempo que usa o comando debug para monitorar os eventos do spanning tree.

2017 Cisco e/ou suas afiliadas. Todos os direitos reservados. Este documento contm informaes pblicas da Cisco. Pgina 4 de 9
Laboratrio Configurao de Rapid PVST+, de PortFast e de BPDU Guard

a. Insira o comando debug spanning-tree events no modo EXEC privilegiado no switch S3.
S3# debug spanning-tree events
A depurao de evento da rvore de abrangncia est ligada
b. Crie uma alterao de topologia, desativando a interface F0/1 em S3.
S3(config)# interface f0/1
S3(config-if)# shutdown
*Mar 1 00:58:56.225: STP: VLAN0001 new root port Fa0/3, cost 38
*Mar 1 00:58:56.225: STP: VLAN0001 Fa0/3 -> listening
*Mar 1 00:58:56.225: STP[1]: Generating TC trap for port FastEthernet0/1
*Mar 1 00:58:56.225: STP: VLAN0010 new root port Fa0/3, cost 38
*Mar 1 00:58:56.225: STP: VLAN0010 Fa0/3 -> listening
*Mar 1 00:58:56.225: STP[10]: Generating TC trap for port FastEthernet0/1
*Mar 1 00:58:56.225: STP: VLAN0099 new root port Fa0/3, cost 38
*Mar 1 00:58:56.225: STP: VLAN0099 Fa0/3 -> listening
*Mar 1 00:58:56.225: STP[99]: Generating TC trap for port FastEthernet0/1
*Mar 1 0:58:56.242: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed
state to down
*Mar 1 00:58:56.242: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed
state to down
*Mar 1 00:58:58.214: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to
administratively down
*Mar 1 00:58:58.230: STP: VLAN0001 sent Topology Change Notice on Fa0/3
*Mar 1 00:58:58.230: STP: VLAN0010 sent Topology Change Notice on Fa0/3
*Mar 1 00:58:58.230: STP: VLAN0099 sent Topology Change Notice on Fa0/3
*Mar 1 0:58:59.220: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,
changed state to down
*Mar 1 00:59:11.233: STP: VLAN0001 Fa0/3 -> learning
*Mar 1 00:59:11.233: STP: VLAN0010 Fa0/3 -> learning
*Mar 1 00:59:11.233: STP: VLAN0099 Fa0/3 -> learning
*Mar 1 00:59:26.240: STP[1]: Generating TC trap for port FastEthernet0/3
*Mar 1 00:59:26.240: STP: VLAN0001 Fa0/3 -> forwarding
*Mar 1 00:59:26.240: STP[10]: Generating TC trap for port FastEthernet0/3
*Mar 1 00:59:26.240: STP: VLAN0010 sent Topology Change Notice on Fa0/3
*Mar 1 00:59:26.240: STP: VLAN0010 Fa0/3 -> forwarding
*Mar 1 00:59:26.240: STP[99]: Generating TC trap for port FastEthernet0/3
*Mar 1 00:59:26.240: STP: VLAN0099 Fa0/3 -> forwarding
*Mar 1 0:59:26.248: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed
state to up
*Mar 99 0:59:26.248: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed
state to up
Observao: antes de continuar, use a sada de dados de debug para verificar se todas as VLANs em
F0/3 alcanaram um estado forwarding; em seguida, utilize o comando no debug spanning-tree events
para interromper a sada de dados de debug.
Atravs de qual dos estados da porta cada VLAN em F0/3 prossegue durante a convergncia da rede?
____________________________________________________________________________________
Usando a data/hora da primeira e ltima mensagem de debug do STP, calcule o tempo (no segundo
mais prximo) que levou para a rede convergir. Dica: o formato de data/hora de depurao data
hh.mm.ss: ms.
____________________________________________________________________________________

2017 Cisco e/ou suas afiliadas. Todos os direitos reservados. Este documento contm informaes pblicas da Cisco. Pgina 5 de 9
Laboratrio Configurao de Rapid PVST+, de PortFast e de BPDU Guard

Parte 4: Configurar Rapid PVST+, PortFast, BPDU Guard e Examinar a


Convergncia
Na Parte 4, voc configurar o Rapid PVST+ em todos os switches. Voc configurar o PortFast e BPDU
guard em todas as portas de acesso e, em seguida, utilizar o comando debug para examinar a
convergncia do Rapid PVST+.
Observao: os comandos necessrios para a Parte 4 so fornecidos no Apndice A. Para testar o
conhecimento, tente configurar o Rapid PVST+, PortFast e o BPDU Guard sem consultar o apndice.

Etapa 1: Configure o Rapid PVST+.


a. Configure S1 para Rapid PVST+. Escreva o comando no espao fornecido.
____________________________________________________________________________________
b. Configure o S2 e S3 para o Rapid PVST+.
c. Verifique as configuraes com o comando show running-config | include spanning-tree mode.
S1# show running-config | include spanning-tree mode
spanning-tree mode rapid-pvst

S2# show running-config | include spanning-tree mode


spanning-tree mode rapid-pvst

S3# show running-config | include spanning-tree mode


spanning-tree mode rapid-pvst

Etapa 2: Configure PortFast e BPDU guard nas portas de acesso.


O PortFast um atributo do spanning tree que faz a transio de uma porta imediatamente para um estado
forwarding, assim que ela ligada. Isso til na conexo de hosts, de modo que eles possam comear a se
comunicar na VLAN instantaneamente, em vez de aguardar o spanning tree. Para evitar que as portas que esto
configuradas com o PortFast encaminhem BPDUs, o que poderia alterar a topologia do spanning tree, o BPDU
guard pode ser ativada. Ao receber um BPDU, o BPDU guard desativa uma porta configurada com PortFast.
a. Configure a interface F0/6 em S1 com PortFast. Escreva o comando no espao fornecido.
____________________________________________________________________________________
____________________________________________________________________________________
b. Configure a interface F0/6 em S1 com BPDU guard. Escreva o comando no espao fornecido.
____________________________________________________________________________________
____________________________________________________________________________________
c. Configure globalmente todas as portas de no trunking no switch S3 com PortFast. Escreva o comando
no espao fornecido.
____________________________________________________________________________________
____________________________________________________________________________________
d. Configure globalmente todas as portas PortFast de no trunking no switch S3 com BPDU guard. Escreva
o comando no espao fornecido.
____________________________________________________________________________________
____________________________________________________________________________________

2017 Cisco e/ou suas afiliadas. Todos os direitos reservados. Este documento contm informaes pblicas da Cisco. Pgina 6 de 9
Laboratrio Configurao de Rapid PVST+, de PortFast e de BPDU Guard

Etapa 3: Examine a convergncia do Rapid PVST+.


a. Insira o comando debug spanning-tree events no modo EXEC privilegiado no switch S3.
b. Crie uma alterao de topologia, ativando a interface F0/1 no switch S3.
S3(config)# interface f0/1
S3(config-if)# no shutdown
*Mar 1 01:28:34.946: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Mar 1 01:28:37.588: RSTP(1): initializing port Fa0/1
*Mar 1 01:28:37.588: RSTP(1): Fa0/1 is now designated
*Mar 1 01:28:37.588: RSTP(10): initializing port Fa0/1
*Mar 1 01:28:37.588: RSTP(10): Fa0/1 is now designated
*Mar 1 01:28:37.588: RSTP(99): initializing port Fa0/1
*Mar 1 01:28:37.588: RSTP(99): Fa0/1 is now designated
*Mar 1 01:28:37.597: RSTP(1): transmitting a proposal on Fa0/1
*Mar 1 01:28:37.597: RSTP(10): transmitting a proposal on Fa0/1
*Mar 1 01:28:37.597: RSTP(99): transmitting a proposal on Fa0/1
*Mar 1 01:28:37.597: RSTP(1): updt roles, received superior bpdu on Fa0/1
*Mar 1 01:28:37.597: RSTP(1): Fa0/1 is now root port
*Mar 1 01:28:37.597: RSTP(1): Fa0/3 blocked by re-root
*Mar 1 01:28:37.597: RSTP(1): synced Fa0/1
*Mar 1 01:28:37.597: RSTP(1): Fa0/3 is now alternate
*Mar 1 01:28:37.597: RSTP(10): updt roles, received superior bpdu on Fa0/1
*Mar 1 01:28:37.597: RSTP(10): Fa0/1 is now root port
*Mar 1 01:28:37.597: RSTP(10): Fa0/3 blocked by re-root
*Mar 1 01:28:37.597: RSTP(10): synced Fa0/1
*Mar 1 01:28:37.597: RSTP(10): Fa0/3 is now alternate
*Mar 1 01:28:37.597: RSTP(99): updt roles, received superior bpdu on Fa0/1
*Mar 1 01:28:37.605: RSTP(99): Fa0/1 is now root port
*Mar 1 01:28:37.605: RSTP(99): Fa0/3 blocked by re-root
*Mar 1 01:28:37.605: RSTP(99): synced Fa0/1
*Mar 1 01:28:37.605: RSTP(99): Fa0/3 is now alternate
*Mar 1 01:28:37.605: STP[1]: Generating TC trap for port FastEthernet0/1
*Mar 1 01:28:37.605: STP[10]: Generating TC trap for port FastEthernet0/1
*Mar 1 01:28:37.605: STP[99]: Generating TC trap for port FastEthernet0/1
*Mar 1 01:28:37.622: RSTP(1): transmitting an agreement on Fa0/1 as a response to a
proposal
*Mar 1 01:28:37.622: RSTP(10): transmitting an agreement on Fa0/1 as a response to a
proposal
*Mar 1 01:28:37.622: RSTP(99): transmitting an agreement on Fa0/1 as a response to a
proposal
*Mar 1 1:28:38.595: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1,
changed state to up
Usando a data/hora da primeira e ltima mensagem de debug do RSTP, calcule o tempo que levou para
a convergncia da rede.
____________________________________________________________________________________
____________________________________________________________________________________

2017 Cisco e/ou suas afiliadas. Todos os direitos reservados. Este documento contm informaes pblicas da Cisco. Pgina 7 de 9
Laboratrio Configurao de Rapid PVST+, de PortFast e de BPDU Guard

Reflexo
1. Qual a principal vantagem de usar o Rapid PVST+?
_______________________________________________________________________________________
2. De que maneira a configurao de uma porta com PortFast permite a convergncia mais rpida?
_______________________________________________________________________________________
_______________________________________________________________________________________
3. Que proteo o BPDU guard fornece?
_______________________________________________________________________________________
_______________________________________________________________________________________

Anexo A Comandos de Configurao do Switch

Switch S1
S1(config)# vlan 10
S1(config-vlan)# name User
S1(config-vlan)# vlan 99
S1(config-vlan)# name Management
S1(config-vlan)# exit
S1(config)# interface f0/6
S1(config-if)# no shutdown
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
S1(config-if)# interface f0/1
S1(config-if)# no shutdown
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 99
S1(config-if)# interface f0/3
S1(config-if)# no shutdown
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 99
S1(config-if)# interface vlan 99
S1(config-if)# ip address 192.168.1.11 255.255.255.0
S1(config-if)# exit
S1(config)# spanning-tree vlan 1,10,99 root secondary
S1(config)# spanning-tree mode rapid-pvst
S1(config)# interface f0/6
S1(config-if)# spanning-tree portfast
S1(config-if)# spanning-tree bpduguard enable

Switch S2
S2(config)# vlan 10
S2(config-vlan)# name User
S2(config-vlan)# vlan 99

2017 Cisco e/ou suas afiliadas. Todos os direitos reservados. Este documento contm informaes pblicas da Cisco. Pgina 8 de 9
Laboratrio Configurao de Rapid PVST+, de PortFast e de BPDU Guard

S2(config-vlan)# name Management


S2(config-vlan)# exit
S2(config)# interface f0/1
S2(config-if)# no shutdown
S2(config-if)# switchport mode trunk
S2(config-if)# switchport trunk native vlan 99
S2(config-if)# interface f0/3
S2(config-if)# no shutdown
S2(config-if)# switchport mode trunk
S2(config-if)# switchport trunk native vlan 99
S2(config-if)# interface vlan 99
S2(config-if)# ip address 192.168.1.12 255.255.255.0
S2(config-if)# exit
S2(config)# spanning-tree vlan 1,10,99 root primary
S2(config)# spanning-tree mode rapid-pvst

Switch S3
S3(config)# vlan 10
S3(config-vlan)# name User
S3(config-vlan)# vlan 99
S3(config-vlan)# name Management
S3(config-vlan)# exit
S3(config)# interface f0/18
S3(config-if)# no shutdown
S3(config-if)# switchport mode access
S3(config-if)# switchport access vlan 10
S3(config-if)# spanning-tree portfast
S3(config-if)# spanning-tree bpduguard enable
S3(config-if)# interface f0/1
S3(config-if)# no shutdown
S3(config-if)# switchport mode trunk
S3(config-if)# switchport trunk native vlan 99
S3(config-if)# interface f0/3
S3(config-if)# no shutdown
S3(config-if)# switchport mode trunk
S3(config-if)# switchport trunk native vlan 99
S3(config-if)# interface vlan 99
S3(config-if)# ip address 192.168.1.13 255.255.255.0
S3(config-if)# exit
S3(config)# spanning-tree mode rapid-pvst

2017 Cisco e/ou suas afiliadas. Todos os direitos reservados. Este documento contm informaes pblicas da Cisco. Pgina 9 de 9